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Welcome To Saola Animate
Have Fun Creating Interactive Web Content
Saola Animate is the complete solution for creating animated and interactive HTML5
animations for web, digital publishing, advertising, and more. The application’s focus is
twofold:

v
v

Make animation design as efficient and enjoyable as possible.
Enable users to produce the best possible animated content.

About This Documentation
This documentation is designed both as a course in using Saola Animate and as an ongoing
reference while you are working with the application. You can skim it quickly for reference,
and refer to it for additional information whenever you need.
Get Started - New Users

v
v

Study the Overview

5

to familiarize yourself with the basics of the application.

Visit the Q&A Community or email us to get help and more information about the
application.

Welcome To Saola Animate
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Chapter 1: Overview
Saola Animate is an advanced application for designing and building HTML5 web content
using an integrated visual and JavaScript source code interface. With Saola, you can create
smooth animations and impressive visual effects using many types of elements and
interactions. You can do almost everything in an intuitive editor with no coding required.
Once you are done creating your content, you can export your final document with clean
human-readable HTML5, CSS3, and JavaScript. Saola outputs have flexible layout that works
well on any platform or device. Saola also allows you to import and export packaged
elements as Symbols that are useful for sharing identical elements across multiple projects
or at different positions in the same project.

In this chapter, you will find the following:

v
v
v
v
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User Interface
Welcome Screen
The Welcome Screen is the first thing you see when launching Saola Animate. This screen
is also displayed when no project opens. The Welcome Screen allows quick access to a
number of common tasks and links to many useful samples, demos and other resources.

To the left side of the Welcome Screen, there are two sections: Quick Start and Recent
Projects (if any).

v

The Quick Start provides menus and buttons to perform tasks as follows:
·

Use the New command to create a new project.

·

Use the Open Project command to open an existing project.

·

Click Edit > Preferences to customize the default application settings.

·

Click View > Language to change the display language in Saola.

·

Click Help to open the documentation, access information about the current
version, check for updates, and open your account webpage where you can update
your profile and manage your subscriptions.

v

The Recent Projects shows a list of projects you have recently been working with.
You can do either of the following:
·

To open a project in the list, click a project or right-click and select Open.

Chapter 1: Overview
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·

To remove a project from the list, right-click it and select Remove from List.

·

To open the containing folder of a project, right-click it and select Show in Folder.

In the center of the Welcome Screen, there are three tabs: Home, Samples, and Resources.

v
v
v

The Home tab shows outstanding features which boost your creativity.
The Samples tab shows a list of Saola samples.
The Resources tab provides links to Saola Animate Homepage, YouTube Channel,
Q&A Community, and Online Demos.

Down in the bottom left corner, there are three buttons that take you directly to the
Homepage, YouTube Channel, and Facebook Fanpage of Saola Animate.
Workspace
Saola provides a customizable workspace with a large work area for editing content. The
central area is surrounded by a toolbar, a timeline, and a set of panes. The panes can be
grouped in tabs, and you can float any pane or pane group to a different location in the
workspace or to the desktop. Panes can also be resized both vertically and horizontally.

1. The Main Toolbar 118 provides quick access to tools for many of the most common
tasks in Saola Animate.
2. The Canvas 71 is the main work area in the center of the application. This area is not
only a place where you can add, modify, and arrange the elements of your projects
but it is also where you can view the results of your work.

Chapter 1: Overview
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3. The Scenes pane displays thumbnails of available scenes in the project. You can
click each of the scenes to view the scene individually and edit it if needed.
4. The Document pane provides quick access to view, enter, and edit document
properties.
5. The Timeline pane 72 contains information about your animations, as represented
over time. Each scene has a Main Timeline which automatically starts when the
scene loads. For more complex documents, scenes can have multiple timelines to
satisfy a large amount of elements, animations, and interactivity.
6. The Properties pane 76 displays the properties of the selected element and provides
editable text fields, lists, and other controls to adjust and fine-tune element properties.
If multiple elements are selected, you can adjust the mutual properties of the
elements.
7. The Elements pane displays all elements included in the project. You can select, lock
elements, or change their visibility in this pane. You can also use the pane to open the
Event Handlers dialog box for each element.
8. The Resources pane 91 displays all resource files in the project including those
which are in use and those which are not. The pane also holds any symbol you have
created, allowing you to edit existing symbols.
9. The Functions pane 94 displays all JavaScript functions in the project. You can add
and edit many JavaScript APIs to control various aspects of a document in this pane.
You can create a custom workspace by showing, hiding, moving, docking, floating, and
resizing all panes that best suits your preferences and working style. See Customizing User
Interface 132 for more details. The display language 131 and some other preferences
settings 133 are also customizable to fit your needs.

System Requirements
For Saola Animate, the following considerations apply:

v
v
v
v

Operating system: Windows 7/8/8.1/10 (64-bit only).
Processor: Intel Pentium 4 or later.
Memory: 4 GB or larger.
Internet connection: Required.

Chapter 1: Overview
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Common Editing Commands
You are probably familiar with several common editing commands (cut, copy, paste, delete,
undo, and redo) in Office or other applications. In Saola Animate, these editing commands
are also used, allowing you edit many types of items. These commands are available for
objects such as elements, scenes, keyframes, animation segments, and labels, etc.

Cut
The Cut command removes the selected items and places them on the Clipboard. Select
Edit > Cut from the context menu to remove the selected items.
Toolbar shortcut:

. Keyboard shortcut: CTRL+X.

Copy
While cutting a selection removes the selection from scene, copying a selection leaves the
original in place. To copy items, select one or more items, and then select Edit > Copy from
the menu bar to copy the selected items to the Clipboard.
Toolbar shortcut: . Keyboard shortcut: CTRL+C.
Paste
The Paste command inserts the contents of the Clipboard at the current location. You can
paste the Clipboard's contents back to any open Saola project by selecting Edit > Paste
from the menu bar.
Toolbar shortcut:

. Keyboard shortcut: CTRL+V.

Delete
Delete the currently selected items by selecting Edit > Delete from the menu bar.
Toolbar shortcut:

. Keyboard shortcut: DELETE.

The Undo command reverts the last change made to the document while the Redo reverts
the last Undo operation. In the Edit menu, these two commands are usually followed by the
name of the last command performed.

Chapter 1: Overview
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Undo
To undo the most recent action, select Edit > Undo from the menu bar. If you want to return
back to more than one action, click the down arrow next to the Undo button on the toolbar
and select the actions in the list.
Toolbar shortcut:

. Keyboard shortcut: CTRL+Z.

Redo
To redo the most recent action that you have already undone, select Edit > Redo from the
menu bar. If you want to redo several actions, click the down arrow next to the Redo button
on the toolbar and select the actions in the list. Note that the Redo button is only available
after you have undone an action.
Toolbar shortcut:

. Keyboard shortcut: CTRL+Y.

Quick Start Guide
After familiarizing yourself with the basics of the application, you can try to create your very
first project. This section walks you through common steps to make your lively and
interactive animation.
Suppose that it is your friend’s birthday and you want to surprise him with an online gift box.
The gift box gradually appears on screen, arousing his curiosity. Then he clicks the box and a
bunch of balloons flies in. At the same time, the melody of the Happy Birthday song starts
playing with joy. This must be an amazing birthday gift to your friend, and you can even
change the content to fit the gift to other special occasions.
(link)
To create a series of enjoyable animations like that, the first thing to do is to prepare the
content for your animation, namely images and audio, and then you create a Saola project.
After that, import the content into the project and create animations and interactions. The final
step is to preview and export your work. See below for details about each step.

Chapter 1: Overview
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Step 1: Prepare contents
Content
Name

Illustration

gift_box
240x180 px

balloons
800x600 px

hpbd_song

Chapter 1: Overview
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Step 2: Create a new project

1. Open Saola Animate.
2. Click the New button on the Welcome Screen or on the toolbar, or select File > New
from the menu bar.
3. Fill required information in the dialog box, and then click OK to submit.
4. Select a scene. In the Properties pane, notice Overflow property. Set the value to
Hidden.

Step 3: Import contents into project
1. In the Resources pane, click the Import

button.

2. Import all resource files into the pane.

Chapter 1: Overview
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Step 4: Create animations
1. Gift box
In the first 2 seconds, the gift box gradually appears on screen with the Opacity property
animated.
1. Drag the gift_box resource from the Resources pane onto the Canvas, position the
box in the center of the scene by using Canvas Snapping 71 .
2. In the Properties pane, add keyframes for the Opacity property, set the value to 0%
(when the Playhead is at 0:00).

3. On the Timeline, position the Playhead to 00:02.00, and add another keyframe for the
Opacity property, set the value to 100%.
Now move to the Width and Height properties.
1. Add two keyframes for the Width and Height properties.
2. Move the Playhead to 00:02.50.
3. Add two keyframes for the same properties, then enter a new width. The height of the
element will change accordingly as they are linked together.

Chapter 1: Overview
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4. Move the Playhead to 00:03 and make the element back to its original size.
The animation bar of the gift box element:

2. Balloons
In the first 3 seconds, a bunch of balloons is placed outside the scene. You cannot see it as
the Overflow property of the scene is set to Hidden. In the next 5 seconds, the balloons fly
into the screen from the bottom with the Top property animated, and then stand right in the
center of the screen, replacing the gift box which is hidden by the event and actions at that
time.
1. Drag the balloons resource from the Resources pane onto the Canvas, position the
balloons outside the scene with [left: 0px; top: 600px].

2. When the Playhead is at 00:03.00, add a keyframe for the Top property.
3. Move the Playhead to 00:08.00, add another keyframe for the Top property.
4. On the Canvas, position the balloons element in the center of the scene [left: 0px; top:
0px].
5. In the Timeline pane, click Easing > OutElastic. Easing method will smooth the
transition and make it more natural.

Chapter 1: Overview

14

Saola Animate

Version 1.0

The animation bar of the balloons element:

3. Happy Birthday Song
The player controls of the audio is hidden. The mouse click event at 00:03.00 triggers its
playback from start. Any mouse click on the balloons also toggles the playback of the audio
track.
1. Drag the hpbd_song resource from the Resources pane onto the Canvas.
2. Click Properties > Media, cancel the selection of the Controls attribute.

Step 5: Add a timeline trigger
Add a timeline trigger at 00:03.00 to pause the timeline so that all the animations beyond this
point of time will not be shown until a mouse click event is detected.
1. Position the Playhead to 00:03.00.
2. In the Timeline pane, click the Insert Trigger button.

3. In the Timeline Triggers dialog box, click Add Action > Timeline > Pause Timeline >
Main Timeline (as target).

Chapter 1: Overview
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Step 6: Add events & actions
When a mouse click on the gift box is detected, three actions will be provided as a response,
which are to hide the gift box, to continue the timeline, and to play the song. The second
event is a mouse click on the balloons. Chances are you want to pause the song for a while,
so you need to add event and action to toggle the playback of the audio.
1. Click the Open Event Handlers button of the gift box element.

2. In the Element Event Handlers dialog box, select Mouse Click event in the event list.
Click Add Action, add three actions as follows:
·

Hide/Show > Hide Element > gift_box (as target).

·

Timeline > Continue Timeline (as target).

·

Media > Start Media > hpbd_song (as target).

3. Click the Open Event Handlers button of the balloons element.
4. In the Element Event Handlers dialog box, select Mouse Click event. Click Add
Action, select Media > Toggle Play/Pause Media, leave hpbd_song as target.

Chapter 1: Overview
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Step 7: Preview & Export project
1. Preview
Do either of the following:

v
v

Click the Preview Current Scene in Browser
button on the toolbar, or select
File > Preview Current Scene in Browser from the menu bar.
Click the Preview Project in Browser
button on the toolbar, or select File >
Preview Project in Browser from the menu bar.

2. Export to HTML5
1. Click the Export to HTML5
HTML5 from the menu bar.

button on the toolbar, or select File > Export to

2. Click the Export button.

Chapter 1: Overview
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Chapter 2: Creating Projects
Creating a project is the first and most basic thing you need to do when working with Saola
Animate.

In this chapter, you will find the following:

v
v
v
v

Creating, Opening & Saving Projects
Flexible Layout

18

20

Working With Scenes

20

Project Backup & Recovery

22

Creating, Opening & Saving Projects
Saola Animate stores a project in a folder whose name is the name of the project itself. Saola
also supports packaging project files into a package file (*.saolapack) for faster and easier
sharing.
To create a new project
Click the New
button on the toolbar or select File > New from the menu bar. The New
Project dialog box appears as shown below. Fill required information, and then click OK to
submit.

Chapter 1: Overview
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Name: Name of the project.
Location: Location of the project. Once the project is successfully created, the
project folder will be named according to the project title. Enter a location where you
want to place your project, choose an existing location from the list, or navigate to a
location using the Browse
button. If you want to make a location to be default
every time you create a new project, check the Use as default location check box.

v

v

Width & Height: Size of the container in which the document is embedded. You can
click the Preset Sizes box and select any of the preset sizes in the drop-down list to
save time and ensure consistency when creating similar projects. The size is editable
afterward through the Document pane. See Updating Document Properties 67 for
more details.
Blank Scene: Number of blank scenes you would like to create. You can insert new
scenes at any time later. The scene size, by default, is the size of the abovementioned container.

Once the project is created, it will be stored in a folder with structure as shown below:

v
v

demo.saola: Manifest file that stores information and data of the project.
demo_res: Folder that contains all resource files (image, media...) that will be
inserted into project during editing.

To open a project

v

v

To open an existing project: Click the Open Project
button on the toolbar or
select File > Open Project from the menu bar, and then select the project file
(.saola). You can also open a project by double-clicking the manifest file. If a project
has already opened, Saola will switch to the tab showing this project.
To import project from a package file: Click the Open Project
button on the
toolbar or select File > Open Project from the menu bar, and then select the
package file (.saolapack). A dialog box appears to provide information of the project.

Chapter 2: Creating Projects
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To save a project

v
v
v

Save a project: Simply click the Save
Save from the menu bar.

button on the toolbar or select File >

Save a project as other project: Select File > Save As > Other Project from the
menu bar. Fill required information of a new project in the dialog box.
Save a project as package: Select File > Save As > Package from the menu bar.
Enter file name of a package file in the dialog box.

Flexible Layout
Saola Animate supports flexible layout. The size of a scene can be set to be relative to the
container size, which means that the change of the container size leads to that of the scene.
The size of an element can be relative to its parent size. The position of an element can also
be based on the top/bottom, or the left/right border of its parent element. To make the size of
the element/scene relative to its parent/container size, set percentage (%) as a size unit.
Otherwise, use pixel (px) as a fixed-size unit.

Working With Scenes
In Saola Animate, scenes are shown and managed in the Scenes pane. Commands for
managing scenes can be accessed from the Scene menu 122 , the toolbar, or from the
context menu as shown below. You can select to edit multiple scenes at once by holding
down the CTRL key while clicking the scenes.

Chapter 2: Creating Projects
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Inserting Scenes
To insert a new blank scene
Do either of the following to insert a new blank scene:

v
v
v

Click the Blank Scene

button on the toolbar.

Click Scene > Blank Scene from the menu bar.
Right-click a scene and select Bank Scene from the context menu.

A new scene will be inserted below the last selected scene. Its size and background property
will be inherited from the last selected scene.
You can customize the number and size of blank scenes when you create a new project.
See Creating, Opening & Saving Projects 18 for more details.
To duplicate a scene
You can duplicate a selected scene to create a copy. That way, the new scene copies all
aspects of the current one and will be inserted below it. This command is available when
there is only one selected scene. Right-click a scene and select Duplicate Scene from the
context menu, or select Scene > Duplicate Scene from the menu bar.
To copy & paste a scene
Scenes can be copied and pasted inside a current project or from/to another project. If
scenes are copied through projects, all resources and user-defined functions used in these
scenes will also be copied.
To cut, copy, paste, or delete scenes, use the buttons on the toolbar or in the context menu
of the selected scenes, or simply press keyboard shortcuts assigned to these commands.

Chapter 2: Creating Projects
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Note that you can use these commands for more than one selected scene at a time. In case
of pasting copied scenes, new scenes will be inserted below the last selected one.

Displaying Scene Thumbnails
You can select two different view modes, namely Column and Grid, to display scene
thumbnails.

v
v

Show in Column: Right-click any position in the Scenes pane, and select Show in
Column. When you resize the Scenes pane, the size of scene thumbnails also
changes to fit the available width.
Show in Grid: Right-click any position in the Scenes pane, and select Show in Gird.
The scene thumbnails are uniformly sized and displayed in grid.

Editing Scene Properties
Scene properties can be edited from the Properties pane as shown above. You can edit
properties of multiple scenes simultaneously; however, some unique properties such as
scene name are not allowed to edit when you select multiple scenes. Below is a list of scene
properties:

v
v
v
v
v

Name: Name of a scene that cannot be duplicated with other scenes of the same
project.
Size: Size of a scene that can be a fixed value (in pixels) or relative to the container
size (in percentages).
Overflow: Specify how content of a scene should be displayed if it extends beyond
the bounds of the scene.
Auto Advance: Jump to the next scene automatically when the current scene ends.
Transition Effects: Movements from one scene to another. A transition effect is
defined by type, duration, and timing function.

For more details about scene properties, see Scene section
section 90 .

89

& Transition Effects

Project Backup & Recovery
Saola supports Auto Backup feature. If the application closes unexpectedly and work has
not been saved, you will be asked to restore the unsaved project the next time you open it.
Saola also automatically creates backup for each project after a timeout. You can turn this

Chapter 2: Creating Projects
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feature on/off or change the backup timeout in the Preferences dialog box (See Customize
Preferences > General Tab 134 ).

When you open a project after an accidental closure or crash, a dialog box appears as
shown above. There are four options for you to choose:

v
v
v
v

Open Backup: The application will open the backup version of the project. When
editing this version, if you save your changes, this version will overwrite the last saved
version.
Open Last Saved: The application will open the last saved version of the project.
The backup version will be deleted immediately.
Open Both: Both backup and last saved version are opened to help you decide
which version will be used. The backup version will be opened as a temporary
project, meaning that it will be deleted if not saved.
Cancel: Cancel the pending action.

Chapter 3: Inserting & Editing Elements
Elements are objects in a scene. They can be div, text, image, audio, video, symbol, or
shape. See Elements 109 for details about each type of elements.

In this chapter, you will find the following:

v
v
v
v
v

Inserting Elements

24

Selecting Elements

25

Arranging Elements

26

Editing Element Properties
Adding Text To Elements
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Inserting Elements
To insert an element
Click the button of an element type on the toolbar to insert that element into a scene:

You can also insert elements by selecting element types from the Element menu:

After clicking the commands to insert elements:

v
v

v

For div/shape elements: Click and drag the mouse on the Canvas to define the
position and size of a new element. When you release the mouse button, a new
element will be inserted.
For image/audio/video/symbol elements: Select files from the dialog box and a new
element will be inserted. For these element types, you can insert elements by
dragging resource files directly from the file systems or from the Resources pane
onto the Canvas. Use playback animations 109 to control the playback of
audio/video/symbol elements.
For text elements: A text element is created in the center of the screen with a
placeholder text. The position and size of a text element can be modified afterward.

Chapter 3: Inserting & Editing Elements
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To copy & paste an element
Commands for cutting, copying, and pasting elements can be found in the Edit menu on the
menu bar, or on the toolbar, or from the context menu of the selected elements. You can also
use keyboard shortcuts 120 to edit faster.
Elements can also be copied and pasted across scenes or documents. To copy elements,
select one or more elements and select Copy from the context menu. To paste the copied
elements, right-click on the Canvas and select Paste from the context menu. There are three
options to paste elements:

v
v
v

Paste: Insert the copied elements without animation. New elements will be placed
near the position of the original elements or in the center of the viewport (if the original
elements are placed outside the viewport).
Paste Here: New elements will be placed at the position of the cursor.
Paste with Animation: Insert the copied elements with animation.

If elements are copied and pasted across documents, all of their resources and JavaScript
functions will also be copied and pasted to the target document. For example, if an image
element is copied from a document to another document, its image resource will also be
copied.

Selecting Elements
Elements of a scene can be selected in many ways from many panes with the selection
state synchronized among panes. Thus, if an element is selected on the Canvas, it is also
selected in the Elements pane and the Timeline pane.
To select an element on Canvas

v
v
v
v

Select a single element by clicking it.
Select multiple elements by a rubber-band selector: Click on scene, and then drag
mouse, a rubber-band selector appears. All elements that stay in or intersect with the
selector will be selected.
Select more elements: If you have already selected several elements and want to
select more, hold down the CTRL key, and then click elements you want. At the
same time, element selection is turned on. You can use this feature to cancel the
selection of one or more elements.
If elements stay in a group, select the group first, and then click child elements to
select them.

To select an element in Elements pane

Chapter 3: Inserting & Editing Elements
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Elements in the Elements pane are displayed in a tree view. You can select elements by
clicking the tree item, and cancel the selection by holding down the CTRL key and click each
of the items. If an element belongs to a group, when you select it, the group is selected too.
To select an element in Timeline pane
Selecting elements in the Timeline pane is the same as that in the Elements pane. In the
Timeline pane, you can also select an element by clicking its keyframes or animations. Note
that the Timeline pane only allows you to select and edit but not delete elements.

Arranging Elements
Saola Animate provides the Arrangement commands to help you refine the position and size
of elements relatively to each other. You can access these tools via toolbar, menu bar, or
from the context menu of the Canvas.

These Arrangement commands become available when you select two or more elements of
the same parent, that is, they must be contained in the same group (or scene). The last
selected element is the reference element. This element is specified by green handles rather
than by white handles like other elements. You can click one of the currently selected
elements (without holding the CTRL key) to set it as a reference element.

Aligning Elements With Reference Element
Saola provides a row of Alignment commands to align elements with a reference element.
There are both vertical and horizontal align options. All of the commands place the selected
elements with respect to the reference element. This element stays fixed at the same
position while all other elements move to align with it.
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To set alignment, select at least two elements that have the same parent, and then click an
Alignment tool on the toolbar, or select Edit > Alignment from the menu bar.
Command

Icon

Remark

Align Left

The left side of all elements will get aligned with the left of
the reference element. Their vertical position will not be
affected.

Align Right

The right side of all elements will get aligned with the right
of the reference element. Their vertical position will not be
affected.

Align Top

The top of all elements will get aligned vertically with the
top of the reference element. Their horizontal position will
not be affected.

Align Bottom

The bottom of all elements will get aligned vertically with
the bottom of the reference element. Their horizontal
position will not be affected.

Align Center

The center of all elements will get aligned vertically with
the center of the reference element. Their horizontal
position will not be affected.

Align Middle

The center of all elements will get aligned with the center
of the reference element. Their vertical position will not be
affected.

Resizing Elements To Reference Element
In addition to Alignment commands, Saola Animate offers Sizing commands to quickly resize
elements. These commands work on a group of elements and resize all other elements with
respect to the reference one. To use these commands, click Edit > Size from the menu bar,
or select Arrange > Size from the context menu.
Command
Make Same Width

Icon

Remark
The width of all other elements is adjusted to match the
width of the reference element.
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Icon

Remark

Make Same Height

The height of all other elements is adjusted to match the
height of the reference element.

Make Same Size

Both height and width of all other elements are adjusted to
match the height and width of the reference element,
respectively.

Setting Z-Order Of Elements
When elements overlap, z-order determines which one covers the other. In Saola Animate,
you can change the stacking order of elements by clicking the Display Order commands on
the toolbar, or selecting Edit > Display Order from the menu bar. These commands help
you set the z-order of elements even when they do not overlap each other. For example,
there are five shapes in the following order:

Change the z-order of the red shape by Display Order commands. Results are shown in the
following table:
Command

Icon

Remark

Bring to Front

Bring Forward
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Icon

Remark

Send to Back

Send Backward

Grouping Elements
Imagine you want to create a moving animated car with a body and four wheels, so you need
to make several elements moving simultaneously. The best way to animate multiple
elements at the same way together is to group them first. That way, selected elements act
as one element and you only have to apply your animation effect once.

To group elements
Select all the elements that you want to animate together then click the Group
button
on the toolbar, or right-click the selected elements and select Group from the context menu.
Grouped items appear under and at the next indent level compared to their group name in the
Elements pane. All moving animations of selected elements will be converted to new
coordinate systems of a new parent.
To ungroup a group
Select a group and then click the Ungroup
button on the toolbar, or right-click the group
and then select Ungroup from the context menu.
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Editing Element Properties
Properties of an element are all displayed on the Canvas, but not all of them could be edited
directly from here. The Properties pane shows values of all properties and users can edit
them here. Saola Animate allows editing multiple elements at the same time if they are all
selected.
From Canvas
An inserted element is often not the right size, or in the right position, so you may need to
resize or move it. To change the size, position, or rotation of an element, use the handles
surrounding this element. These handles appear when you click the element and disappear
when you click else where on the Canvas.

v
v
v

To resize an element: Use the sizing handles. Point the mouse to any sizing handle
so that the pointer turns into a bidirectional resize pointer (a two-way arrow). Click
and drag the sizing handle away from the center of the element to make it larger, or
toward the center of the element to make it smaller.
To rotate an element: Use the rotation handle. Point the mouse to the rotation
handle so that the pointer changes to a pointing hand. Click and drag the rotation
handle in the direction that you want to rotate the element.
To move an element: Point the mouse to the element or single-click the element so
that the pointer changes to a four-way arrow, indicating that you are about to move
the element. Drag the element to the new position and release the mouse button to
drop the element. You can repeat the action until you place the element right at your
desired spot.
When there are more than one selected element, if one element is resized, rotated,
or moved, all other elements are also be resized, rotated, or moved. Besides, be
careful not to double-click an element as this action enables you to edit the content of
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the element by opening the inline text editor. If this happens by mistake, click any
elsewhere on the Canvas to cancel the editing process and start over.
When you edit elements on the Canvas, elements can be snapped to a special
position or to the edge/center of other elements. To automatically align elements with
one another and the Canvas, use the Canvas Snapping tool. To turn Canvas
Snapping on/off, select View > Canvas Snapping from the menu bar. This tool can
be temporarily disabled by holding down the CTRL key when you resize or move
elements.

From Properties Pane
If an element is selected, its property values will be displayed in the Properties pane. The
Properties pane has many sections, and each section shows a group of properties. For
example, the Transform section displays geometric information for any selected element,
including values for position, size, shearing, and rotation.
Property values are shown in some UI control types (spin box, slider, text field, etc.)
depending on the type of properties. When multiple elements are selected, there are two
cases:

v
v

If a property is unique (e.g. name), the control shows that that property is disabled. It
will be enabled if there is only one selected element.
If a property is not unique, the control will be enabled, but it only displays a value if the
property values of elements are equal to each other. Otherwise, the control will not
display any value, but you can still focus and edit to make changes to the value (and
make it equal).

See Using Properties Pane

76

for details about each property.
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Adding Text To Elements
If an element can contain text, double-click its body or right-click it and select Edit Text from
the context menu to start editing text with the inline text editor. To stop editing text, click any
elsewhere outside or select Stop Editing from the context menu. Below is a list of element
types that can contain text:

v
v
v

Text element.
Div element.
Shape element.

Read more about editing text in Using Text Editor
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Chapter 4: Creating Animations
Saola Animate lets you create stunning HTML5 animations and interactive content. Creating
animations is the most important and exciting part of the application. In Saola Animate, you
mostly use three panes to create your animations: Elements, Timeline, and Properties.
You can add, view, and edit all animations on the Timeline. Think of it as a container for
animations and a ruler that measures time in your animations.

In this chapter, you will find the following:

v
v
v
v
v
v

Keyframes

34

Auto-Keyframe Mode
Animations
Easing

35

35

38

Motion Paths

52

Sprite Sheet Animations

56
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Keyframes
In Saola Animate, you can animate elements
keyframe is a diamond marker on the Timeline
time. Keyframes are used to set parameters for
that change over time. There are several ways
position of the Playhead.

by adding keyframes on the Timeline. A
that defines a property value at a specific
motion, effects, and many other properties
you can choose to add keyframes at the

To add a keyframe from Properties pane

In the Properties pane, you can use a small diamond next to most of the property values to
add keyframes. Select an element, position the Playhead to your desired point of time on the
Timeline, and click the keyframe diamond to manually insert a keyframe for that property.
Then position the Playhead to a different point of time, add another keyframe for the same
property, and change the property value. A bar between the two keyframes appears
indicating that the property is animated.
To add a keyframe from Timeline menu
Select an element, position the Playhead to your desired point of time on the Timeline, and
select Timeline > Add Keyframe from the menu bar. Select the type of keyframe you want
to add to the current Playhead position.
To add a keyframe with Add Keyframe button

In the Timeline pane, each element can have several properties animated which appear
grouped beneath an element name. Notice that next to any property there is always a
keyframe diamond representing the Add Keyframe button. You can click these buttons to
add new keyframes at the position of the Playhead for that specific property.
To add a keyframe from context menu
Select an element, position the Playhead to your desired point of time on the Timeline, and
select Add Keyframe from the context menu by right-clicking the element's Timeline.
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To add a keyframe in Auto-Keyframe mode
Turn Auto-Keyframe Mode on and Saola Animate with automatically add keyframes at the
current time when you modify a property. For more details about this feature, see AutoKeyframe Mode 35 .

Auto-Keyframe Mode
Auto-Keyframe Mode allows automatically generating keyframes when creating animations.
By default, this mode is turned off and you need to insert keyframes manually. To turn AutoKeyframe Mode on, choose Auto-Keyframe Mode from the Timeline pane menu or press
the K key.

When you work with elements on the Canvas, or change properties in the Properties pane,
the animations of elements will be changed or remain the same depending on the two
following cases:
On

Off

If there is no keyframe at the current time
cursor, a new keyframe is created
corresponding with the changed property on
the current Timeline at the current time.

If there is no keyframe at the current
timestamp, all the keyframes will be
changed as long as the value of the element
is changed.

If there exists a keyframe at the current
cursor, its value will be changed to one of
the corresponding changed properties.

If there exists a keyframe at current
timestamp, its value will be changed to the
one of the corresponding changed
properties.

Animations
Animations are composed of two keyframes which define the starting and ending values of a
property animation. There are two terms you need to mind:

v
v

An animation segment is the change between two keyframes - in other words, a
segment defines the way a certain property changes. A segment can have a
transition or not.
A transition allows an element to gradually change from one state to another over the
course of time. Hence, if there is no transition in an animation segment, there will be
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an instant change in the property value when the Playhead reaches the ending
keyframe of the animation segment.

Animation Segments
To adjust the timing of a segment
Drag an element animation bar or a property animation bar left and right along the Timeline. If
you want to change all the properties simultaneously, select the element animation bar to
select all properties of the element. Then, you can drag the bar along the Timeline to change
the timing.

To adjust the duration of a segment
You can change the length of the segment to run your animation effect at a speed that faster
or slower, that is, you need to create a longer segment to make a slower animation.

To adjust the duration of a segment, simply hover over the starting or ending keyframe of that
segment until the pointer changes to a pointing hand, indicating that adjustments are
possible. Then, click and drag the starting or ending keyframe along the Timeline to adjust
the duration. If an animation has the same starting and ending keyframes, the animation
duration is 0 and the animation is displayed as a special keyframe

on the Timeline.

To copy & paste a segment
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You can copy an animation segment and paste it on the Timeline of the same or of another
element. That way, you copy both the starting and ending keyframes and the transition
between them to the Clipboard.
1. Click an animation segment on the Timeline. An orange border appears to indicate
that that segment is selected. If you want to select multiple segments at the same
time, hold down the CTRL key and click the segments.
2. Select Edit > Copy from the menu bar or press CTRL+C to copy the segments to
the Clipboard. You can also cut the segments from the element by selecting Edit >
Cut from the menu bar or pressing CTRL+X. If you want to copy the segments to
another element, select that element on the Canvas or in the Timeline pane.
3. Move the Playhead to the position where you want the copied segments to start.
4. Select Edit > Paste from the menu bar or press CTRL+V to paste the segments on
the Timeline.

Transitions
Suppose that there is an element of which the Left property is animated. The Left property of
that element has an animation segment with a starting keyframe [time: 1s, value: 50px] and
an ending keyframe [time: 5s, value: 100px].
A transition between the two keyframes makes that element slowly move from one to another
position over the course of 5 seconds. Without any transition, the Left value will always be
50px at greater or equal 1s until the current time is greater or equal 5s, the Left value will
immediately change to 100px, meaning that the element instantly jumps to a new position
when the current time is equal 5s.
To create a transition
With any animation segment selected, right-click and select Create Transition from the
context menu to make an element gradually change from one state to another over the
course of time.
To remove a transition
With any animation segment selected, right-click and select Remove Transition from the
context menu to create an instant change in the property value when the Playhead reaches
the ending keyframe of the animation segment.
To invert an animation segment
With any animation segment selected, right-click and select Invert Animation Segment
from the context menu to swap the starting and ending keyframes of an animation segment.
This action puts the starting keyframe in the position of the ending keyframe and vice versa.

Chapter 4: Creating Animations

37

Saola Animate

Version 1.0

Easing
The motion in nature is rarely plain and linear from one point to another. In reality, when
moving, things almost never move at a constant speed, or in other words, they tend to
accelerate or decelerate. In Saola Animate, you can create a smooth transition effect by
adding the right easing method, which specifies the speed at which a transition progresses
over time. For example, you can use easing to create an animation showing a ball bouncing
down the stairs.

There is a wide range of easing methods within Saola Animate:

v
v
v
v
v

The default is Linear, which progresses at a constant speed throughout the
movement.
Some other families are smooth curves, such as Cubic, Circ, etc.
The Elastic family simulates inertia in the easing, making elastic curves.
The Back family starts by moving the object a little backward before moving it
forward.
The Bounce family simulates the motion of an object bouncing.

Each family, except Linear, has four variants: ease in, ease out, ease in-out, and ease outin.

v
v

Ease in and ease out are exact opposites. Ease in starts slow and accelerates at the
end while ease out starts fast and decelerates at the end.
Ease in-out and ease out-in are the two opposite combinations of ease in and ease
out. Ease in-out starts and ends slow, but it is fast in the middle, whereas ease out-in
starts and ends fast, but it is slow in the middle.
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Illustration

Remark

Linear

Easing curve for a linear(t)
function: velocity is constant.

InQuad

Easing curve for a quadratic (t^2)
function: accelerating from zero
velocity.

OutQuad

Easing curve for a quadratic (t^2)
function: decelerating to zero
velocity.
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Illustration

Remark

InOutQuad

Easing curve for a quadratic (t^2)
function: acceleration until halfway,
and then deceleration.

OutInQuad

Easing curve for a quadratic (t^2)
function: deceleration until halfway,
and then acceleration.

InCubic

Easing curve for a cubic (t^3)
function: accelerating from zero
velocity.
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Illustration

Remark

OutCubic

Easing curve for a cubic (t^3)
function: decelerating to zero
velocity.

InOutCubic

Easing curve for a cubic (t^3)
function: acceleration until halfway,
and then deceleration.

OutInCubic

Easing curve for a cubic (t^3)
function: deceleration until halfway,
then acceleration.
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Illustration

Remark

InQuart

Easing curve for a quartic (t^4)
function: accelerating from zero
velocity.

OutQuart

Easing curve for a quartic (t^4)
function: decelerating to zero
velocity.

InOutQuart

Easing curve for a quartic (t^4)
function: acceleration until halfway,
and then deceleration.
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Illustration

Remark

OutInQuart

Easing curve for a quartic (t^4)
function: deceleration until halfway,
and then acceleration.

InQuint

Easing curve for a quintic (t^5)
easing in: accelerating from zero
velocity.

OutQuint

Easing curve for a quintic (t^5)
function: decelerating to zero
velocity.
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Illustration

Remark

InOutQuint

Easing curve for a quintic (t^5)
function: acceleration until halfway,
and then deceleration.

OutInQuint

Easing curve for a quintic (t^5)
function: deceleration until halfway,
and then acceleration

InSine

Easing curve for a sinusoidal
(sin(t)) function: accelerating from
zero velocity.
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Illustration

Remark

OutSine

Easing curve for a sinusoidal
(sin(t)) function: decelerating from
zero velocity.

InOutSine

Easing curve for a sinusoidal
(sin(t)) function: acceleration until
halfway, and then deceleration.

OutInSine

Easing curve for a sinusoidal
(sin(t)) function: deceleration until
halfway, and then acceleration.
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Illustration

Remark

InExpo

Easing curve for an exponential
(2^t) function: accelerating from
zero velocity.

OutExpo

Easing curve for an exponential
(2^t) function: decelerating from
zero velocity.

InOutExpo

Easing curve for an exponential
(2^t) function: acceleration until
halfway, and then deceleration.
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Illustration

Remark

OutInExpo

Easing curve for an exponential
(2^t) function: deceleration until
halfway, and then acceleration.

InCirc

Easing curve for a circular (sqrt(1t^2)) function: accelerating from
zero velocity.

OutCirc

Easing curve for a circular (sqrt(1t^2)) function: decelerating from
zero velocity.
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Illustration

Remark

InOutCirc

Easing curve for a circular (sqrt(1t^2)) function: acceleration until
halfway, and then deceleration.

OutInCirc

Easing curve for a circular (sqrt(1t^2)) function: deceleration until
halfway, and then acceleration.

InElastic

Easing curve for an elastic
(exponentially decaying sine wave)
function: accelerating from zero
velocity. The peak amplitude can
be set with the
amplitude parameter, and the
period of decay by
the period parameter.
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Illustration

Remark

OutElastic

Easing curve for an elastic
(exponentially decaying sine wave)
function: decelerating from zero
velocity. The peak amplitude can
be set with the
amplitude parameter, and the
period of decay by
the period parameter.

InOutElastic

Easing curve for an elastic
(exponentially decaying sine wave)
function: acceleration until halfway,
and then deceleration.

OutInElastic

Easing curve for an elastic
(exponentially decaying sine wave)
function: deceleration until halfway,
and then acceleration.
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Illustration

Remark

InBack

Easing curve for a back
(overshooting cubic function: (s+1)
*t^3 - s*t^2) easing in: accelerating
from zero velocity.

OutBack

Easing curve for a back
(overshooting cubic function: (s+1)
*t^3 - s*t^2) easing out:
decelerating to zero velocity.

InOutBack

Easing curve for a back
(overshooting cubic function: (s+1)
*t^3 - s*t^2) easing in/out:
acceleration until halfway, and then
deceleration.
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Illustration

Remark

OutInBack

Easing curve for a back
(overshooting cubic easing: (s+1)
*t^3 - s*t^2) easing out/in:
deceleration until halfway, and then
acceleration.

InBounce

Easing curve for a bounce
(exponentially decaying parabolic
bounce) function: accelerating
from zero velocity.

OutBounce

Easing curve for a bounce
(exponentially decaying parabolic
bounce) function: decelerating
from zero velocity.
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Illustration

Remark

InOutBounce

Easing curve for a bounce
(exponentially decaying parabolic
bounce) function: decelerating
from zero velocity.

OutInBounce

Easing curve for a bounce
(exponentially decaying parabolic
bounce) function easing out/in:
deceleration until halfway, and then
acceleration.

Motion Paths
Elements can be animated moving along more complex curves than just a straight line by
using motion paths. Thus, motion paths allow you to imitate real movements that cannot be
achieved with linear motion.
A motion path is a curved animation between two or more points. You can modify a motion
path by changing existing keyframes or adding new ones.
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Creating Motion Paths
To animate element position using motion paths, in the Properties pane, switch from X, Y
Motion to Motion Paths. This action removes all animations of X/Y/Left/Top/Right/Bottom
property of an element.

To create a motion path, the first thing to do is to create a basic motion path with two
keyframes.
1. Add a Location keyframe at the desired starting time. A Location keyframe can be
added in many ways. See Keyframes 34 for more details.
2. Drag the Playhead to the desired ending time of your animation, and add another
Location keyframe with different value. You can repeat this step many times to create
a path with many points.
With these above steps, a motion path is created but it is still a straight line between points.
You can edit the motion path by adding and modifying its anchor points.
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Editing Motion Paths
Editing a motion path is actually working with its anchor points. Anchor points are circle
points on motion paths that define the path. There are two types of anchor points:

v
v

Key anchor points: Yellow points that have associated Location keyframes on the
Timeline.
Normal anchor points: Green points that do not have associated keyframes on the
Timeline. Normal anchor points define the path that element will move along between
key anchor points. Each normal anchor point has two blue handles with a control
point at their ends.

To create an anchor point

v
v

To create a key anchor point, add a Location keyframe to the animation segment at
your desired point of time. Location keyframes represent two separate motion paths.
You can add a Location keyframe to split a path into two, or delete a Location
keyframe between two paths to create a contiguous path.
To create a normal anchor point, hover over a motion path until the pointer turns into a
pointing hand, and then click and drag the path as desired.

To adjust a control point

v
v

With any anchor point selected, its control points appear to help you adjust the path
between two anchor points. Drag the control points to modify the motion path.
If the control point and the anchor point have the same position, when you click the
point, the anchor point will be selected. If you want to select the control point, hold
down the ALT key and then click the mouse.
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When dragging a single control point, the remaining control points will move to keep
the angle between them unchanged. If you want to change the selected point only,
hold down the ALT key and then select and drag the control point.

To delete an anchor point
Hold down the SHIFT key, and then click an anchor point to delete it. If you delete a key
anchor point, either of the following cases happens:

v
v

The key anchor point is the first/last point of the motion path: The associated Location
keyframe on the Timeline will be deleted if there is no anchor point between this point
and the next/previous key anchor point. Otherwise, the next/previous anchor point will
become the first/last key anchor point of the motion path.
The key anchor point is not the first/last point of the motion path: The associated
Location keyframe will be deleted.

To rotate a motion path
Hold down the ALT key; then click and drag any point on the path. The motion path will be
rotated around the element’s transformation-origin point.
To move a motion path
Hold down the CTRL key; then click and drag any point on the path.

Auto-Orientation
Imagine you want to create an animated car moving along a rough road. As the road is not a
straight line, you need to use a motion path to move the car along the road. However, even
with a motion path, the car's movement still sounds unnatural as it does not orient along the
direction of the path. To solve this problem, use the Auto-Orient attribute to make elements
automatically orient along the direction of the motion path.
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Sprite Sheet Animations
Sprite sheets are commonly used in games and storybooks. A sprite sheet is an image file
containing several smaller graphics in a tiled grid arrangement. By combining several
graphics into a single file, you can create an animated character representing one (or
several) animation sequence while only needing to load a single file.

To create sprite sheets, select an image on the Canvas, and then click Properties > Image
> Creating Sprite Sheets. Saola Animate offers two modes to define sprite types: Default
Sprite and Custom Sprite.

v
v

Use Default Sprite to generate frames automatically if you have a uniform sprite
sheet that is a grid of equally sized rectangles.
Use Custom Sprite to generate frames manually if you have a sprite sheet of which
images are packed together in different sizes.

Default Sprite
To use the Default Sprite mode, ensure that:

v
v

The images in the sprite sheet are of equal dimensions.
The padding between the images is uniform.
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1. Specify the number of rows and columns, sprite sheet margins [top, left, bottom,
right], and padding between sprites.
2. Specify the animation duration in milliseconds or at FPS. By default, FPS is set to 24.
3. Click Play Animation to preview.
4. Click OK to create frames.
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Custom Sprite
If the images in the sprite sheet are of different sizes, use the Custom Sprite mode to
manually define frames.

1. Click the Add Frame button to add a frame.
2. Specify frame properties (x, y, width, height), and then modify the position and size of
a frame in boxes, or drag and resize the frame rectangle in the preview window.
3. Specify the animation duration in milliseconds or at FPS. By default, FPS is set to 24.
4. Click Play Animation to preview.
5. Click OK to create frames.
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Chapter 5: Adding Interactivity
Saola Animate allows you to create HTML5 web content that is not only animated but also
interactive. You can make many things happen with a single mouse click or finger swipe.
Interactivity is a great way to gain and keep audience's attention and interest as it gives them
interactive control over their experience. With Saola Animate, you can use events, actions,
and triggers to add interactivity to your project.
Events are things that trigger actions - in other words, when an event is detected, one or
more actions are provided as a response. For example, when you click a menu button
(event), more options will expand in a drop-down list (action). Events are typically usergenerated, such as a mouse click or a key press; however, some events can occur
automatically without user actions. For example, the point when a preloader starts loading or
when it is completed. There are five types of events available in Saola Animate: element,
scene, document, timeline, and preloader events.
Actions are always paired with events, that is, they occur in response to events. For
example, when you click a link in a document, a new browser tab or window automatically
open or you jump to another part of the document. More than one action can be triggered
when an event occurs. Saola Animate offers users many types of actions: timeline, symbol,
media, visibility, etc.
Triggers are actions that are placed along the Timeline. Triggers are executed automatically
when the Playhead reaches them on the Timeline. One trigger can associate with many
different actions and you can have multiple triggers along the Timeline. Note that triggers
perform actions at specific point without user control.
For more details about types of events and actions, see Events - Actions

110
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In this chapter, you will find the following:

v
v

Event Handlers

60

Timeline Triggers

62
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Event Handlers
Saola Animate allows you to add and edit events and actions in the Event Handlers dialog
box. Element, scene, document, timeline, and preloader objects can have actions registered
with events. You can open the Event Handlers dialog box by clicking the Open Event
Handlers
button. This button can be found next to element/scene name in the Timeline
pane, in the first section of the Properties pane or in the context menu when you right-click a
scene or the Canvas.
The Event Handlers dialog box has user interface as shown below. The left side is a list of
event types associated with object types (element/scene/document...). The right side is a list
of all actions registered with the selected event. You can add an action, remove a single
action, or clear all actions by using three buttons at the top bar of the dialog box. Some
certain actions require a target object or parameters. Action type, target object, and
parameters can be adjusted by double-clicking the table cell.

To add an action
1. Select an event type in the Event Type list.
2. Click the Add Action button, select an action type.
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To change an action type
1. Double-click the action cell.
2. Select a new action type from the drop-down list.

To change a target object (scene, element or Timeline)
1. Double-click the target object cell.
2. Select a target object to change. An action can have no target object (e.g. “Go To
URL” action).
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To edit a parameter
1. Double-click the params cell.
2. Edit values in the Parameters editor. An action can have no parameters.

To remove an action
1. Select an action cell.
2. Click the Remove button to remove a single selected action.
To remove all actions
Click the Clear Actions button to remove all actions associated with an event.

Timeline Triggers
Timeline triggers automatically perform actions when the Playhead reach them on the
Timeline. When adding timeline triggers, you can immediately choosing an action to perform.
You can manage triggers through the Timeline Triggers dialog box. To open this dialog box,
do either of the following:

v
v

Click Timeline > Insert Trigger from the menu bar.
Click the Insert Trigger
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The Timeline Triggers dialog box has user interface as shown below. In general, this dialog
box is similar to the Even Handlers dialog box except the fact that it does not have the Event
Type list on the left side. You can add a trigger, remove a single trigger, or clear all triggers by
using three buttons at the top bar of the dialog box. Most of the actions to manage timeline
triggers such as changing action types, changing target objects, editing parameters of
actions, and removing actions are the same as those in the Event Handlers dialog box. See
Event Handlers 60 for more details.

To add a timeline trigger
1. Drag the Playhead along the Timeline to the point you want to add a trigger.
2. Select Timeline > Insert Trigger from the menu bar or click the Insert Trigger
button in the Timeline pane. A trigger appears as a red diamond at the position of the
Playhead.
To edit a timeline trigger
1. Double-click the trigger icon on the Timeline.
2. Edit the action type, target object, and parameters of an action (see Event
Handlers 60 for more details).
To move a timeline trigger
Click and drag the trigger icon along the Timeline to a new position. The actions registered
with that trigger will be executed when the Playhead reaches a new time.
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To copy & paste a timeline trigger
1. Select a trigger. You can select more than one trigger by holding down the CTRL key
while clicking.
2. Press CTRL+C or right-click and select Copy from the context menu.
3. Position the Playhead to the point you want to place the copied triggers.
4. Press CTRL+V or right-click and select Paste from the context menu.
To remove a timeline trigger
1. Select a trigger. You can select more than one trigger by holding down the CTRL key
while clicking.
2. Press the DELETE key or right-click and select Delete from the context menu.

Chapter 6: Using Symbols
Symbols are a powerful resource allowing you to easily reuse elements, scenes, timelines,
and animations. Symbols contain their own elements, scenes, timelines, and actions that
can be triggered independently from the scene. There are two concepts of symbol that you
need to mind: symbol and symbol element. Symbol elements are elements in which the
symbol is embedded. Thus, many symbol elements can use the same symbols, and if the
content of a symbol is changed, the content displayed by a symbol element is changed too.
Symbols are useful for sharing identical elements across multiple scenes or at different
positions in the same scene. For example, you can create a piece of animation, convert it to
a symbol, and then use it in a larger animation. To create a symbol, you can convert from
elements or import symbol files from the file system. You can also export symbols to files for
reusing or sharing.

In this chapter, you will find the following:

v
v
v

Converting Elements To Symbols
Editing Symbols
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Converting Elements To Symbols
To convert elements to symbols, do as follows:
1. Select one or many elements of the same parent.
2. Click the Convert to Symbol
menu.

button on the toolbar or select from the context

3. In the dialog box, type a unique name for the new symbol.

4. If you do not want to create the playback animation of the symbol at this time, clear
the Create Playback check box.

Editing Symbols
If a scene contains one symbol element of the symbol, simply double-click the element.
Otherwise, double-click the symbol in the Resources pane. Now the editor displays the
content of the symbol which resembles other documents with scenes, timelines, etc.

Take a look at the top of the Canvas. There is a stack of buttons displaying a stack of
symbols being edited. The first one is the main document while the last one is the symbol
you are working on. Click these buttons to navigate to the parent symbols.
To stop editing a symbol, double-click any elsewhere on the Canvas. This action stops
editing the symbol and navigate to the parent symbol. After you are done editing the symbol,
all symbol elements of the symbol will be changed.
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Importing & Exporting Symbols
To import a symbol file and create a symbol element on a scene, do either of the following:

v
v
v

Drag and drop symbol files onto the Canvas.
Click the Symbol

button on the toolbar and select a symbol file from Explorer.

Click Element > Symbol from the context menu of the Canvas, and then select a
symbol file from Explorer.

To import & export a symbol from the Resources pane, see Using Resources Pane

91
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Note that when importing a symbol from the Resources pane, all resources which are used
in this symbol will be imported into the current project. These resources become the
resources of the project, not that of the symbol.

Chapter 7: Previewing & Exporting
Projects
After creating and editing a project, it is important to preview your project before exporting it to
HTML5. This chapter covers previewing your Saola project on local browser and exporting
your project to the web.

In this chapter, you will find the following:

v
v
v
v

Updating Document Properties
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Previewing Scene & Project In Browser
Exporting Project To HTML5
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Updating Document Properties
A Saola document includes one or more scenes. Once property values of a document are
set, they will directly affect the appearance or behavior of scenes as well as their timelines or
elements. Document properties can be edited in the Document pane.

The following properties can be set in the Document pane:
1. Title exports its content in the <title> tag. The <title> tag is required in all HMTL
documents and it defines the title of the document. The <title> element:

v
v
v

Define a title in the browser toolbar.
Provide a title for the page when it is added to favorites.
Display a title for the page in search-engine results.

2. Description, keywords, and author describe metadata in HTML documents.
Metadata is often used in the content of the <meta> tag. Metadata will not be
displayed on the page but will be machine parable.
3. If the Autoplay option is turned on, the document will automatically start playing as
you open a web browser. Otherwise, it must be called to start via an event and an
action. You can edit the document events and actions by clicking the Event
Handlers button.
4. Alignment, container width and height of the document are all customizable.

Chapter 7: Previewing & Exporting Projects

67

Saola Animate

Version 1.0

5. If your project is complex and graphics-intensive with many resource files, it may take
a few seconds for the files to be transferred to the user's browser. It is when you
need to use a preloader to indicate that the content is being loaded. For more
details about preloader, see Customizing Preloader 116 .

Previewing Scene & Project In Browser
Previewing a project during and after the editing process allows you to review your work and
notice the changes that are required. That way, you can be sure of the final output that you
get. Saola supports two modes to preview your work before exporting a project.
To preview the current scene in default browser
Saola allows you to preview the current scene in default browser without having to export it.
Do either of the following:

v
v

Click the Preview Current Scene in Browser

button on the toolbar.

Click File > Preview Current Scene in Browser from the menu bar.

To preview the whole project in default browser
Do either of the following to preview the whole project:

v
v

Click the Preview Project in Browser

button on the toolbar.

Click File > Preview Project in Browser from the menu bar.

Exporting Project To HTML5
To export a project to HTML5
Once you have completed a project, the last step is to export it to HTML5. From that, you can
view your animations via browsers or embed it into websites or applications.
1. Click the Export to HTML5
HTML5 from the menu bar.

button on the toolbar or select File > Export to

2. Click the Export button.
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Once the project is exported to HTML5, it will be stored in a folder with structure as shown
below:

v
v
v
v
v

preloader_resources: Optional folder that contains all resource files (image/media...)
that are inserted into project to customize the preloader. If there is no custom
preloader or no resource file inserted to modify the custom preloader, this folder will
not appear.
resources: Folder that contains all resource files (image/media...) that are inserted
into project during editing.
demo.html: HTML document that is named after the project title. Open this file to play
the project on a webpage.
demo.js: Document data named after the project title that defines all scenes,
timelines, elements, and animations for the document.
slplayer.js: The main Saola Animate HTML5 Player.

Browser compatibility for HTML5 outputs
Saola Animate is compatible with:

v
v
v
v
v
v

Chrome 4+
Firefox 3.5+
IE 9+
Edge
Safari 3.1+
Opera 11.5+

Newer version of browsers are required for some features including:

v
v

Gradient Fill: Chrome 10+, Firefox 3.6+, IE 10+, Safari 5.1+, Opera 12.1+.
Audio/Video: Firefox 11+, Safari 4+ (Note that users still have to use compatible
formats that a browser supports.)

Saola Animate HTML5 Player checks if a browser supports a specific feature or not. In cases
where a browser does not support a feature, to keep the output compatible, it will fall back on
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less advanced options. For example, if a browser does not support Gradient Fill, it will
automatically use Solid Fill. If it cannot find a fallback, the feature will not work on that
browser.

Embedding HTML5 Output In Webpage
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Chapter 8: Using Canvas
The Canvas is the main work area in the center of the application. This area is not only a
place where you can add, modify, and arrange the elements of your projects but it is also
where you can view the results of your work. This is a WYSIWYG editor (what you see is
what you get), meaning that everything you see on the Canvas closely resembles its
appearance when previewed or exported to HTML5.

The Canvas has horizontal and vertical rulers and a scene editor. Canvas can be
customized to fit your needs with the following options:

v
v

Ruler: Rulers can help you precisely position elements on the Canvas. Select View >
Ruler from the menu bar or from the context menu of the Canvas to turn rulers
on/off. A check mark next to the option indicates that it is currently enabled.
Canvas Snapping: When you edit elements on the Canvas, elements can be
snapped to a special position on the Canvas or to the edge/center of other elements.
To automatically align elements with one another and with the Canvas, use the
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Canvas Snapping tool. This tool can be temporarily disabled by holding down the
CTRL key when you resize or move elements.

v
v

Zoom In/Out: Hold down the CTRL and scroll the mouse wheel or use the zoom
control to zoom the Canvas in or out. You can also select any zoom value you want in
the Zoom to box.
Fit on Screen: Click the
button to set the scene contents fit to the viewport size.
The Canvas will zoom in/out automatically to ensure that all scene contents appear in
the viewport window. Manually zooming the Canvas will turn off this feature.
You can also zoom the Canvas in or out using the buttons at the bottom right of the
application window.

Chapter 9: Using Timeline Pane
The Timeline shows a visual representation of the timing of all elements in a scene. Each
scene has a Main Timeline which automatically starts when the scene loads. For more
complex documents, scenes can have more than one timeline to satisfy a large amount of
elements, animations, and interactivity. Timelines can be made to play, pause, seek, or
change playback speed and direction to create rich and interactive animations.
For more details about commands and shortcuts in the Timeline pane, see Timeline
Menu 123 .

In this chapter, you will find the following:

v
v
v

Multiple Timelines
Timeline Lables

72

74

Visibility & Locking

75

Multiple Timelines
In Saola, each scene has at least one timeline - the Main Timeline which automatically starts
when the scene loads. You can create other timelines that are triggered by events and
actions. Multiple Timelines come in handy when you have a same set of elements within a
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scene but animate them on separate timelines and create interactivity to invoke those
timelines.
To add a timeline

1. Click the New Timeline

button.

2. Enter a unique name and click the OK button to finish.
3. Check the Set as Main Timeline check box if you want the new timeline to act as the
Main Timeline of a scene, indicating that it will automatically start when the scene
loads.
To remove a timeline
Click the Remove Timeline
button to remove the currently selected timeline. This
button only becomes available when there is more than one timeline of a scene.
To rename a timeline

1. Click the Rename Timeline

button.

2. Enter a unique name in the dialog and click the OK button to submit changes.
To set a timeline as Main Timeline
Click the Set as Main Timeline
button to set any timeline as the Main Timeline of a
scene. That way, the timeline's playback will start when the scene first loads.
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Timeline Lables
You can add labels to the timeline to mark important points that you want to refer to later.
Labels prove highly useful when you add triggers and actions to control your animation.
Labels appear below the time markers and right above the Actions bar, giving you the benefit
of both a word and a number.

To add a label
1. Drag the Playhead to a special point on the Timeline that you want to mark.
2. Click the Insert Label
button to add a label at the position of the Playhead. A label
appears with default name such as Label_1, Label_2, etc.
3. Rename a label right at that time or afterward.
To rename a label
1. Double-click a label.
2. Enter a new name.
To copy & paste a label
1. Select one or more labels by holding down the CTRL key while clicking.
2. Press CTRL+C to copy the selected labels.
3. Press CTRL+V to insert the copied labels into the current position of the Playhead.
To delete a label
1. Select one or more labels.
2. Once they are all highlighted, press the DELETE key or select Delete from the
context menu.
To move a label
Click and drag one or more labels to a new spot.
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Visibility & Locking
You can use the Visibility and Locking controls to hide or fix certain elements to focus on
others. These controls are accessible from the Timeline and Elements panes.
The visibility and locking state of elements are turned on by default, indicated by an open eye
and an open lock
buttons. These states are synchronized among panes, meaning
that if an element is invisible in the Timeline pane, it is also invisible in the Elements pane.

Visibility
The Visibility state decides whether or not to display elements in a scene while editing. Even
if you turn Visibility off and you cannot see an element on the Canvas, you can still select it
from the Timeline pane or the Elements pane and work on it. This control is best used to
help you focus on the target element without being distracted by other elements around it.

v
v
v

Turn Visibility state on/off by clicking the eye button next to the element name.
An open eye
means that an element is visible, whereas an eye with a slash
indicates that it is currently invisible.
You can turn on/off Visibility state of all elements in a scene at once by clicking the
master eye

button on the Actions bar.

Note that when you turn an element off, its child elements are also invisible.
Do not mistake the Visibility control with the Display property in the Properties pane. The
Display property decides whether or not to display elements in the browser, allowing you to
make an element suddenly appear or disappear during an animation. Meanwhile, the Visibility
control is only an interface feature within Saola that helps you work with many elements. It
does not affect the HTML5 output you get after you export the project.
Locking
When you work with multiple elements, chances are you move an element by accident and
need to hit the Undo button to revert the last change. In that case, use the Locking control to
fix individual elements so that you do not accidentally move or edit them, and they still remain
visible with the Visibility state on.
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Turn Locking state on/off by clicking the lock button next to the element name.
An open lock
suggests that you can edit an element, while a closed lock
indicates that you cannot select or edit it.
Click the master lock
button on the Actions bar if you want to lock/unlock all
elements in a scene at once.

Chapter 10: Using Properties Pane
The Properties pane displays the properties of selected elements and provides editable text
fields, lists, and other controls to adjust and fine-tune element properties. Located on the
right-hand side of the application, the Properties pane has many sections, and each section
shows a group of properties.
You can expand and collapse sections as needed by clicking on its title bar. When you
collapse a section, its contents are hidden but not deleted. Expand the section to see the
contents again. If multiple elements are selected, a section is only shown if all selected
elements have its properties.
The Properties pane constantly updates itself depending on the type of the selected
element. Some properties are consistent and appear despite what type of elements you
select, whereas other properties are specific to a certain type of elements. For example, the
Corner section is only available for Div elements.

In this chapter, you will find the following:

v
v
v
v
v
v
v

General Section

77

Position & Size Section
Transform Section
Fill Section

79

81

81

Border Section

84

Corner Section

85

Text Section

86
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General Section
The General section contains information about elements' name, title, and tab index. Here
you can animate the Display and Opacity properties of an element and set which type of
cursor is displayed when you point at the element.

Property

Remark

Animatable

Name

Name of the selected element. This property can be
changed but has to be unique.

No

Title

Title of the selected element. When you hover over
the element on the browser, the title will be shown.

No

Tab Index

Organize the Tab order of elements on browsers.
Four possible values:

No

v
v
v
v
Display

< -1: No focus.
= -1: The element is only focused if you click
it.
= 0: The element is focused after the browser
focuses everything which is not of the
document.
> 1: The element is focused in order when you
use the TAB key.

Set the visibility of the element.
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Property

Remark

v
v

Animatable

On: The element appears on the scene or in
export.
Off: The element does not appear on the
scene or in export.

In animations, display property is used to hide or
show an element instantly.
Overflow

Determine how the content of the selected element is
displayed if it overflows the element’s bounds, and
whether a scroll bar should appear.

v
v
v
v
Opacity

No

Visible: The overflow is not clipped; it renders
outside the element's box. This is default.
Hidden: The overflow is clipped; any content
that extends beyond the box will be hidden.
Scroll: The overflow is clipped, but a scroll bar
is added to view the rest of the content.
Auto: If overflow is clipped, a scroll bar should
be added to view the rest of the content.

Set opacity (also known as transparency) of the
element in the range [0, 100%]. A lower value makes
the element more transparent.

Yes

To change the opacity, drag the opacity slider to
increase or decrease opacity as you wish. Opacity
property is often used to create fade-in or face-out
effects.
Cursor

Set which type of cursor is displayed when you point
at the element. The default value is Auto.
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Property

Remark

Animatable

Position & Size Section
The Position & Size section controls elements' Position and Size properties.
Property
X, Y Motion

Remark
By default, the selected elements move in the X, Y
Motion mode with X and Y transition.

Animatable
Yes

Change element position & size by relative positions:

v
v
v
v

Relative to Top & Left (default).
Relative to Top & Right.
Relative to Bottom & Right.
Relative to Bottom & Left.
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Property

Remark

Animatable

If Relative to Top & Right or Relative to Bottom &
Right or Relative to Bottom & Left is chosen, Motion
Paths mode will be turned off.
Motion Paths

If the Motion Paths mode is selected, the Auto-Orient
check box will be enabled.

v
v
Width, Height

Yes

Auto-Orient: The element rotates with the
orientation of motion paths.
X, Y (px, %): Set the exact position for the
selected elements in motion paths.

Set the exact width and height for the selected
elements. To set width and height dependently, check
the Link width to height

Chapter 10: Using Properties Pane

Yes

button.

80

Saola Animate

Version 1.0

Transform Section
The Transform section displays geometric information for the selected element, including
values for position, size, shearing, and rotation.

Property

Remark

Animatable

Scale X, Y

Scale the selected elements horizontally or vertically
in the range [0, 100%].

Yes

Skew X, Y

Skew the selected elements horizontally or vertically.
The skew angle is in the range [-60, 60°].

Yes

Origin X, Y

Set the transformation-origin point around which the
selected elements rotate in the range [0, 100%].

Yes

Rotate

Rotate the selected elements. If this property has
negative value, the selected elements will rotate
counter-clockwise.

Yes

Fill Section
The Fill section shows the Fill property, which sets the background style of the selected
elements. Four Fill values are available:
Value
None

Remark
The background is transparent (alpha = 0).
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Value

Remark

Solid Fill

Fill the background with a color. The format of color is R, G, B, A. Default
alpha (A) = 255. The color can be animated.

Gradient Fill

Fill the background with two or more colors (with or without alpha
transparency) to create a multicolor fill in which one color gradually
changes into another color.

The actual controls adjusted to create this particular gradient are shown
below:

The Gradient Strip (2) is at the heart of the controls showing a “live”
sample of the gradient. You can make changes to the strip in a visual
manner.
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Value

Remark
Choose between Linear and Radial gradient using the Gradient Type
drop-down list (1).
In Linear gradient, the shades vary in a straight direction (horizontal or
vertical).
·

Position: Specify the position of a specific color along the gradient
strip.

·

Angle: Set the angle of diraction for the gradient. The angle is formed
between the horizontal line and the gradient line.

In Radial gradient, the shades are in concentric circles starting from a
central focal point.

·

Position: Specify the position of a specific color along the gradient
strip.

·

Shape: Define whether the shape is circle or ellipse. The default
value is ellipse.

·

Size Param: Define the size of the ending shape. Four possible
values:

§

Closest-side: The gradient's ending shape meets the side of the
box closest to its center (for circles) or meets both the vertical
and horizontal sides closest to the center (for ellipses).
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Value

Remark

§
§
§
·

Farthest-side: Similar to closest-side, except the ending shape is
sized to meet the side of the box farthest from its center (or
vertical and horizontal sides).
Closest-corner: The gradient's ending shape is sized so it exactly
meets the closest corner of the box from its center.
Farthest-corner: The gradient's ending shape is sized so it
exactly meets the farthest corner of the box from its center.

Origin X, Y: Adjust the location of the focal point such as top, bottom,
center, and left. For example, Origin X, Y [value: 50%, 50%] sets the
gradient at the center while Origin X, Y [value: 0%, 0%] sets the
gradient to start at the top left.

Image Fill

Images can be chosen from Resources (see Using Resources
Pane 91 ) or from the file system. Five position options are available:
Stretch, Center, Fit, Tile, and Fill.

Border Section
The Border section defines the border style of the selected elements.

Chapter 10: Using Properties Pane

84

Saola Animate

Version 1.0

Property
Style

Remark
Set the border style of the selected elements. Four
possible values:

v
v
v
v

Animatable
No

None
Solid
Dotted
Dashed

Width

Set the border width of the selected elements in pixels
(px).

Yes

Color

Set the border color of the selected elements.

Yes

Corner Section
The Corner section is used for only Div elements to define the shape of the Div elements'
border.

Property

Remark

Animatable

Top Left

Set the border top-left radius.

Yes

Top Right

Set the border top-right radius.

Yes

Bottom Left

Set the border bottom-left radius.

Yes

Bottom Right

Set the border bottom-right radius.

Yes
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Text Section
The Text section allows you to set and animate many text properties such as text size,
color, line height, etc. This section is available for all types of elements except media (audio
and video), symbol, and group elements.

Property

Remark

Animatable

Font

Font family of text elements.

No

Size

Font size of text elements, in pixels.

Yes

Color

Text color of text elements.

Yes

Highlight Color

Highlight color of text content.

Yes

Bold/ Italic/
Underline/
Strikethrough

Set the bold/ italic/ underline/ strikethrough style of
text content.

No

Horizontal
Alignment

Align text horizontally. Possible values: Left, Center,
Right, and Justify.

No

Vertical
Alignment

Align text vertically. Possible values: Top, Middle, and
Bottom.

No

Superscript/
Subscript

Format the selected text as superscript/subscript.

No

Word Spacing

Space between words, in pixels. Set to 0 by default.

Yes
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Property

Remark

Animatable

Letter Spacing

Space between letters, in pixels. Set to 0 by default.

Yes

Line Height

Space between lines, in percentages, relative to font
size value. Set to 120% by default.

Yes

Text Indent

The indent of each text block in pixels (paragraph).
Set to 0 by default.

Yes

Image Section
The Image section allows you to change the image within an image element, animate the
background image, and create sprite sheet animation.

Property

Remark

Animatable

File Name

Name of the image within the selected image
element.

No

From
Resources

Select another image resource from the Resources
pane to change the image within the selected image
element.

No

From File

Select another image file from the file system to
change the image within the selected image element.

No

Background
Image X, Y

Set the exact position for the background image within
the selected image element.

Yes
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Property

Remark

Animatable

Background
Image Width,
Height

Set the size for the background image within the
selected image element.

Yes

Create Sprite
Sheet

Click to create Sprite Sheet Animations

No

56

.

Media Section
The Media section displays information of the media file and allows you to define media
playback options.

Property

Remark

Animatable

Source

Name of the media file. This property cannot be
changed.

No

Duration

Duration of the media file in milliseconds. This
property cannot be changed.

No

Volume

Set the volume of the media in the range [0, 100%].

Yes

Autoplay

Allow the media file to automatically play on the
Timeline and desktop browsers.

No

Loop

Make the media file replay automatically from the
beginning after it finishes playing.

No
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Property

Remark

Animatable

Controls

Display the media controls for the media file. This
property is selected by default for audio file.

No

Preload

Preload the media file before the document loads.
This property is selected by default.

No

Scene Section
The Scene section appears when you select a scene. It shows several properties of scenes.

Property

Remark

Animatable

Name

Name of the selected scene. This property can be
changed but has to be unique.

No

Width, Height

Set the exact width and height for the selected
scenes. The size can be a fixed value (in pixels) or
relative to the container size (in percentages).

Yes

To set width and height dependently, check the Link
width to height
Over Flow

button.

Determine how the content of the selected scene is
displayed if it overflows the scene’s box, and whether
a scroll bar should appear.

v

No

Visible: The overflow is not clipped; it renders
outside the scene's box. This is default.
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Property

Remark

v
v
v

Animatable

Hidden: The overflow is clipped; any content
that extends beyond the box will be hidden.
Scroll: The overflow is clipped, but a scroll bar
is added to view the rest of the content.
Auto: If overflow is clipped, a scroll bar should
be added to view the rest of the content.

Auto Advance

Jump to the next scene automatically when the
current scene ends.

No

Event Handlers

Open the Scene Event Handlers dialog box.

No

Transition Effects Section
The Transition Effects section appears when you select a scene. It helps to define
transition effects between scenes.

Property

Remark

Animatable

Type

Type of the transition effect. Possible values: None
(default type, meaning that the scene simply goes
away and the next one appears), Fade, and Push.

No

Duration

Duration of the transition in milliseconds.

No

Easing

The timing function that updates the transition by time.
Set to Linear by default.

No
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Property
Direction

Remark
Direction of the Push transition effect. Possible
values: From Left, From Top, From Right, and From
Bottom.

Animatable
No

Chapter 11: Using Resources Pane
The Resources pane lists all resources that are available in the open project. To show the
pane, click View > Resources. The Resources pane has a toolbar with a view list to view
resources and common commands to manage resources.

To change view style of Resources pane
Click the View Style drop-down list, and then select the view style you want. Three view
styles are available:

v
v
v

List: Display resources as a list with small icons and text on the right of icons. Each
row contains only one resource file.
Small: Display resources as small icons and text under icons. Each row can contain
more than one resource file. This is the default view style.
Medium: Display resources as medium icons and text under icons. Each row can
contain more than one resource file.

To filter a specified resource type
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Click the Resource Type drop-down list, and then select the type you want. Currently, Saola
Animate supports the following resource types & extensions:

v
v
v
v

Image: jpg, jpeg, png, gif, bmp, svg.
Audio: mp3, wav, m4a, aac, oga, ogg.
Video: mp4, webm, ogv.
Symbol: sym.

In this chapter, you will find the following:

v
v

Managing Resources

92

Media Group Resource

93

Managing Resources
In the Resources pane, use buttons on the toolbar or in the context menu of selected
resources to manage resources. The states of commands on the toolbar or in the context
menu depend on the selected resources.
To import a file into Resources pane
In Saola Animate, you can prepare files in advance by importing files into the Resources
pane. Do either of the following:

v
v

Click the Import resources from files
button on the toolbar or select from the
context menu. Then select resource files from the dialog box, and click the Open
button.
Simply drag and drop files from the file system into the pane.

To delete a file from Resources pane
1. Select resource files that you want to delete. Make sure that they are not being used
by clicking the Selected unused resources
used cannot be deleted.

button. Any resource file that is in

2. Click the Delete
button on the toolbar or select from the context menu. You can
also press the DELETE key to get the same result.
To export a resource to file
1. Select resources that you want to export.
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2. Click the Export
button on the toolbar or in the context menu. If multiple
resource files are selected, you have to select the folder to export resources to.
Otherwise, you have to provide exported file name to export resource files.
To select unused resources
You can find unused resources by clicking the Select Unused Resources
button on
the toolbar or in the context menu. That way all resources that are not in use will be selected
(with an orange border). Then you can remove those unused resources if needed.
To preview a resource
Double-click the resource icon or select Preview from the context menu. A Preview window
appears allowing you to preview the resource file.
To add a resource to scene
Do either of the following:

v
v

Right-click one or more resources and select Add To Scene from the context menu.
Drag one or more resources from the pane onto a scene.

To rename a resource
1. Select a resource to rename.
2. Select Rename from the context menu or use keyboard shortcut. (The F2 key is
default.)
To edit a symbol resource
Double-click a symbol resource. Then you can edit the symbol as a normal project.

Media Group Resource
Saola Animate supports native HTML5 audio/video with the audio/video element, letting audio
and video tracks play with no plug-in required. However, as different browsers do not support
the same media formats, Saola also supports multiple source files feature for the best crossbrowser consistency. Users can group multiple audio/video files with different formats into a
media group.
Files in a media group can be managed in the widget appearing when users select a media
resource (audio/video). Users can add, remove, export, or preview media files by using tools
on the right side bar of the widget or in the context menu.
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To add a media file to group
1. Click the Add

button on the toolbar or in the context menu.

2. Select a media file from your computer. If the file format has already existed in the
group, you will be asked to overwrite it.
To remove a media file from group
1. Select a media file to remove.
2. Click the Remove
button on the toolbar or in the context menu. If a group
contains only one media file, it cannot be deleted.
To export a media file
1. Select a media file as desired.
2. Click the Export

button on the toolbar or in the context menu.

To preview a media file
Double-click a media file or click the Preview
button on the toolbar or in the context
menu. A Preview window appears allowing you to preview the media file.

Chapter 12: JavaScript
Saola Animate exports content to document using a combination of HTML5, CSS3, and
JavaScript. Users can register a JavaScript function with an event in the Event Handlers
dialog box. There are two main types of functions in Saola:

v

Normal functions: A normal JavaScript function that can be called in other functions.
Users can modify the parameters of this function type.
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Event handler functions: Functions that are registered with events and have fixed
parameters. Event handlers are separated into five types:
·

Document Event Handlers

·

Scene Event Handlers

·

Timeline Event Handlers

·

Element Event Handlers

·

Preloader Event Handlers

In this chapter, you will find the following:

v
v
v

Managing Functions
Editing Functions
JavaScript APIs

95

96

98

Managing Functions
Saola provides a pane to manage functions and a code editor to edit functions. Same as
resources, users can add, edit, remove, export, or rename functions. When exporting
functions, all selected functions will be exported into one file with a name provided by users.
The Functions pane has user interface as shown below:

To create a new function
1. Select the New Function

button on the toolbar or from the context menu.

2. Select the function type of the new function.
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To delete a function from library
1. Select one or more functions.
2. Select the Delete
DELETE key.

button on the toolbar or from the context menu, or press the

To export a function to JavaScript file
1. Select one or more functions, and then select the Export
or from the context menu.

button on the toolbar

2. Provide file name to export.
To edit a function
Double-click a function or select the Edit
menu.

button on the toolbar or from the context

To rename a function
1. Select a function, and then select Rename from the context menu.
2. Type a new name and press OK to submit change.

Editing Functions
To create or edit a function, Saola provides a powerful JavaScript editor. The editor supports
intelligent features that speed up the process of coding such as text highlighting, auto
suggestion, bracket matching, code folding, line number, and line wrap.
For normal functions, you can edit their name, content, and parameters. For event handler
functions which are registered with events, you can only edit there name and content as their
parameters are set to fixed.
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Auto suggestion is a remarkable feature of the code editor. When you turn this feature on, it
will predict the rest of a word or sentence while you are typing. You can press the TAB key to
accept a suggestion, or the DOWN ARROW key to select and accept one of the several
suggestions. To manually show suggestion, press the combination of CTRL and SPACE
when editing. You can also insert API from the JavaScript API Browser 98 of the code editor.

v
v
v
v
v
v
v

To clear function content: Select Function > Clear Content from the context menu.
To focus on function name: Select Function > Edit Name from the context menu.
To turn auto suggestion on/off: Select Editor > Code Suggestion from the context
menu or on the toolbar.
To show/hide line number: Select Editor > Show Line Number from the context
menu or on the toolbar.
To turn bracket matching on/off: Select Editor > Bracket Matching from the context
menu or on the toolbar.
To turn code folding on/off: Select Editor > Code Folding from the context menu or
on the toolbar.
To turn line wrap on/off: Select Editor > Line Wrap from the context menu or on the
toolbar.
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You can customize the code editor through Preferences > Code Editor, such as turning
features on/off or adjusting the color of components. There are two ways to access the
Code Editor dialog box:

v
v

Select Edit > Preferences from the menu bar, and then switch to the Code Editor
tab.
From the JavaScript Function dialog box, click the Options
More Options.

button and select

For details about customizing the Code Editor dialog box, see Code Editor Tab

136

.

Keyboard shortcuts are available when editing JavaScript code. See Shortcuts For Code
Editor 130 .

JavaScript APIs
Saola Animate publishes some methods and properties of common element types. These
methods are listed in the pane below the editing area in the JavaScript Function dialog box.
When selecting a method or property, its information is displayed on the right side of the
pane. The methods can be inserted into the editing area quickly by double-clicking it or
dragging and dropping it into the editing area.

Document
getElement(elementName)
Get the element of the current scene by name.
Params:
- elementName:

String. Element's name.

Return: Element object.

getScene()
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Get the current scene of the document.
Return: Scene object.

getSceneCount()
Get the number of the scenes.
Return: Number.

showScene(sceneName)
Show the scene by name.
Params:
- sceneName: String. Scene's name.
Return: Boolean. True if the scene was found, false otherwise.

showSceneAt(index)
Show the scene at the given index.
Params:
- index: Number. The index of the scene, the first scene has 0
index.
Return: Boolean. True if the scene was found, false otherwise.

showNextScene()
Show the next scene from the current scene.
Return: Boolean. True if the next scene exists, false otherwise.

showPreviousScene()
Show the previous scene from the current scene.
Return: Boolean. True if the previous exists, false otherwise.

getDuration()
Get the total duration (in milliseconds) of all Main Timelines of
all scenes and scene transitions.
Return: Number. Duration in milliseconds.

setSpeed(speed)
Set the playback speed of the document.
Params:
- speed: Number. The playback speed of the document
positive value (e.g. 0.5, 1). Normal speed: 1.

must

be

a

Return: undefined.

getSpeed()
Get the playback speed of the document.
Return: Number.
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setPlayBackward(backward)
Set the playback direction.
Params:
- backwards: Boolean. Set the playback to backward if undefined or
true, forward if false.
Return: undefined.

isPlayBackward()
Check if the playback direction is backward.
Return: Boolean. True if play backward, false if forward.

play()
Play the mainstream (Main Timeline or scene transition).
Return: undefined.

pause()
Pause the mainstream (Main Timeline or scene transition).
Return: undefined.

isPlaying()
Check if the mainstream is playing or paused.
Return:
paused.

Boolean.

True

if

the

mainstream

is

playing,

false

if

getTimeline(timelineName)
Get the timeline of the current scene by name. If timelineName is
undefined, the timeline is the Main Timeline.
Params:
- timelineName:

String. Timeline’s name.

Return: Timeline object.

Timeline
getDoc()
Get the current document.
Return: Document object.

getTimestamp()
Get the current timestamp
beginning of the timeline.

(in

milliseconds),

relative

to

the

Return: Number.
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getDuration()
Get the duration (in milliseconds) of the timeline. Do not take
media and symbols into account.
Return: Number.

play(timestamp, speed, backward)
Play the timeline at the given timestamp with speed and playback
direction.
Params:
- timestamp: Number/String. Timeline's timestamp
from the current position if not specified.

or

label.

Play

- speed: Number. Playback speed. Playback speed. Keep the current
speed if this speed is undefined or invalid (<= 0).
- backward: Playback direction. Keep the current direction
undefined, play backward if true, forward if false.

if

Return: undefined.

pause(timestamp)
Pause the timeline at the given timestamp
Params:
- timestamp: Number/String. Timeline's timestamp or label. Pause at
the current position if not specified.
Return: undefined.

isPlaying()
Check if the mainstream is playing or paused.
Return:
paused.

Boolean.

True

if

the

mainstream

is

playing,

false

if

seek(timestamp)
Seek timeline to timestamp.
Params:
- timestamp: Number/String. Timeline's timestamp or label.
Return: undefined.

setSpeed(speed)
Set the playback speed.
Params:
- speed: Number. Must be positive value, e.g. 0.5, 1, 2,...
Return: undefined.

getSpeed()
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Get the playback speed.
Return: Number.

setPlayBackward(backward)
Set the playback direction.
Params:
- backward: Boolean. Play backward if undefined or true, forward if
false.
Return: undefined.

isPlayBackward()
Check if the playback direction is backward.
Return: Boolean. True if play backward, false if forward.

Element
getScene()
Get the scene.
Return: Scene object.

getDoc()
Get the current document.
Return: Document object.

show(show)
Show/Hide the element.
Params:
- show: Boolean. Show if true or undefined, hide if false.
Return: undefined.

isVisible()
Get the visibility state.
Return: Boolean.

setCursor(cursor)
Set the cursor for the element, following CSS cursor.
Params:
- cursor: String. Follow CSS Cursor.
Return: undefined.

setPosition(left, top)
Set the position of the element.
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Params:
- left, top: Number/String. Value of left/top.
Return: undefined. The left/top can be number (e.g. 50) or string
(e.g. '50px', '50%'). If the left/top is number, the unit is
pixel.

setLeft(left)
Params:
- left: Number/String. Value of left.
Return: undefined. The left can be number (e.g. 50) or string
(e.g. '50px', '50%'). If the left is number, the unit is pixel.

setTop(top)
Params:
- top: Number/String. Value of right.
Return: undefined. The top can be number (e.g. 50) or string (e.g.
'50px', '50%'). If the top is number, the unit is pixel.

setRight(right)
Params:
- right: Number/String. Value of right.
Return: undefined. The right can be number (e.g. 50) or string
(e.g. '50px', '50%'). If the right is number, the unit is pixel.

setBottom(bottom)
Params:
- bottom: Number/String. Value of bottom.
Return: undefined. The bottom can be number (e.g. 50) or string
(e.g. '50px', '50%'). If the bottom is number, the unit is pixel.

setSize(width, height)
Params:
- width, height: Number/String. Width/Height of the element.
Return: undefined. The width/height can be number (e.g. 50) or
string (e.g. '50px', '50%'). If the width/height is number, the
unit is pixel.

setWidth(width)
Params:
- width: Number/String. Width of the element.
Return: undefined. The width can be number (e.g. 50) or string
(e.g. '50px', '50%'). If width is number, the unit is pixel.
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setHeight(height)
Params:
- height: Number/String. Height of the element.
Return: undefined. The height can be number (e.g. 50) or string
(e.g. '50px', '50%'). If the height is number, the unit is pixel.

setBorderStyle(border)
Set the border style of the element.
Params:
- border: CSS border style value. Possible values: 'none', 'solid',
'dotted', 'dashed'.
Return: undefined

setBorderWidth(width)
Set the border width of the element.
Params:
- width: Number/String. The width can be number (e.g. 10) or string
(e.g. '10px', '10%'). If the width is number, the unit is pixel.
Return: undefined.

setBorderColor(color)
Set the border color of the element.
Params:
- color: String. Name of
'red', 'rgb(255, 0, 0)'.

the

color,

following

CSS

color,

e.g.

following

CSS

color,

e.g.

Return: undefined.

fillSolid(color)
Fill the background with a solid color.
Params:
- color: String. Name of
'red', 'rgb(255, 0, 0)'.

the

color,

Return: undefined.

fillNone()
Set the fill style to nofill.
Return: undefined.

setTitle(title)
Set the tittle (tooltip) for the element.
Params:
- title: String. Title of the element.
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Return: undefined.

setText(htmlText)
Set html text. Do not call this method for elements that can't
have text, e.g. image, audio, video, symbol.
Params:
- htmlText: String. Text in html format.
Return: undefined.

Event
preventDefault()
Prevent default actions of the event.
Return: undefined.

stopPropagation()
Stop event propagation.
Return: undefined.

stopImmediatePropagation()
Stop event propagation immediately.
Return: undefined.

Preloader
getProgress()
Get the current loading progress, from 0 – 1.
Return: Number.
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Chapter 13: Using Text Editor
Saola Animate provides tools to help you edit rich text faster. These tools are always updated
with the current format of the text cursor and stay in two widgets: the Text Formatting
toolbar and the Properties pane.
With any selected element that can contain text, double-click an element to open the inline
text editor. The Text Formatting toolbar appears as shown below. For more details about
this toolbar, see Text Formatting Toolbar 128 .

There are some commands and options that you need to mind:

v

Insert Special Chars: To insert a special character, click the Insert Special Chars
button on the toolbar. A dialog box appears with a list of available special
characters. Click to select the character you want.

v

v

Insert Link: To insert a hyperlink into text, click the Insert Link
button on the
toolbar. In the dialog box, enter the address and display text of the hyperlink, and then
click the OK button to submit.

Edit HTML: You can directly edit the text element’s HTML by clicking the Edit HTML
button on the Text Formatting toolbar. A dialog box appears with basic styles for
HTML code. Edit HTML code and click the OK button to submit changes. Note that
the HTML code is filtered and only valid tags and styles could be used.
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Show/Hide Text Formatting toolbar: Click the Show/Hide Floating Tools
button
on the toolbar or select from the context menu. When editing text, you can also use
keyboard shortcuts 128 to edit faster.

Chapter 14: Using Color Picker
With the color picker, you can adjust strokes, fill shapes with color, change shapes’ color, or
highlight text. You can open the color picker by clicking the rectangle next to any Color or
Highlight Color property in the Properties pane or in the Text Formatting toolbar.
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1. Standard Colors: Include a color range from black to white and standard colors.
2. Themes Colors: Available colors that Saola Animate offers users to select. Users
could not make change to standard colors.
3. Customized Colors: If the value of the selected color does not equal that of the
standard color, it will be added to Customized Colors.
4. Opacity Slider: Allow users to change the opacity of the color. Opacity has value
from 0 to 1. If the value of Opacity Slider is 0, the selected color is transparent.
5. More Colors: Click to select more colors from a wide array of color choices. These
colors also are not changed even if you apply a different theme or color scheme to
the document.
6. Eyedropper: Click to pick a color from anywhere on the screen.
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Chapter 15: Elements
There are many types of elements that you can insert into a scene. All types of elements
have the same basic properties such as name, cursor, overflow, position, size,
transformation, etc. Some specific properties only belong to some element types. See Using
Properties Pane 76 for details about element properties and how to animate them.
Type

Remark

Property

Div

Elements that are displayed as a HTML <div>
element. There are three pre-defined shapes of div
elements that can be inserted directly into a scene:
Ellipse, Rounded Rectangle & Rectangle. The shape
of div is flexible and can be edited by adjusting the
Corner property 85 .

Fill, Border,
Corner, Text

Text

Elements that display text in a scene. Text can be
edited inline.

Fill, Border, Text

Image

Elements that show an image in a scene. You can
create a sprite sheet animation using an image
element.

Fill, Border,
Image

Audio & Video

Elements that show an audio/video in a scene. You
Media
can add playback animations to control media
playback. For audio, video, and symbol elements, five
playback animations are available:

v
v
v
v
v

Start: Plays the media file from the beginning.
Continue: Continues the media file from the
point it has already paused.
Continue From: Allows you to specify the time
point you want to play the media file from.
Pause: Allows you to pause the media file
from the current position of the Playhead.
Pause At: Allows you to jump to a certain time
point of the media file.
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Type

Remark

Shape

Elements that are the same as div, but have border
and background using SVG images. Shapes have
many types.

Symbol

Elements that display a symbol in a scene. Many
symbol elements can use the same symbol resource.
Symbols can have background or border. The size of
the element is the container size of the symbol
displayed inside it.

Group

Elements that contain other elements as children.

Property
Fill, Border, Text

Fill, Border

Chapter 16: Events – Actions
Events are occurrences that trigger actions. When an event is detected, you provide an
action as a response. The Event Handlers dialog box controls all events and actions you
add to your document. You can open this dialog box by clicking the Event Handlers
button. This button can be found next to element/scene name in the Timeline pane, in the
context menu of Scenes and Canvas, or in the Properties pane.

In this chapter, you will find the following:

v
v

Event List
Action List

111

113

Chapter 15: Elements

110

Saola Animate

Version 1.0

Events
Event Name

Remark
Element Events

Mouse Click

The event occurs when the user clicks an element.

Mouse Double Click

The event occurs when the user double-clicks an element.

Mouse Over

The event occurs when the pointer moves onto an element, or
onto one of its children.

Mouse Down

The event occurs when the user presses a mouse button over
an element.

Mouse Move

The event occurs when the pointer is moving while it is over an
element.

Mouse Up

The event occurs when the user releases a mouse button over
an element.

Mouse Out

The event occurs when the user moves the pointer out of an
element, or out of one of its children.

Mouse Enter

The event occurs when the pointer moves onto an element.

Mouse Leave

The event occurs when the pointer moves out of an element.

Focus

The event occurs when an element gets focused.

Swipe Left

The event occurs when the user swipes over an element in the
left direction.

Swipe Right

The event occurs when the user swipes over an element in the
right direction.
Scene Events

Scene Activate

The event occurs when the scene has been activated.

Scene Deactivate

The event occurs when the scene has been deactivated.
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Event Name

Remark

Scroll

The event occurs when the scroll bar of the scene is being
scrolled.

Key Down

The event occurs when the user presses a key.

Key Up

The event occurs when the user releases a key.

Orientation Change

The event occurs when the user rotates the mobile device
vertically or horizontally.

Resize

The event occurs when the scene is resized.

Events Inherited From
Elements

Scene has all events of an element: mouse click, mouse enter,
etc.
Document Events

Create

The event occurs when the document has been created.

Ready

The event occurs when the document is ready.

Destroy

The event occurs when the document has been destroyed.

Scene Events

Document has all events of mouse, keyboard, orientation...
same as scene.
Timeline Events

Update

The event occurs when the Timeline is updating.

Play

The event occurs when the Timeline changes state from pause
to play.

Complete

The event occurs when the Timeline plays until the end and
stops.

Speed Change

The event occurs when the Timeline speed changes.

Pause

The event occurs when the Timeline changes state from play
to pause.
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Event Name

Remark

Seek

The event occurs when the Timeline is sought.

Reverse

The event occurs when the Timeline direction changes
(forward and backward).
Preloader Events

Start

The event occurs when the preloader starts.

Progress

The event occurs when the preloader is in progress.

Complete

The event occurs when the preloader is completed.

Item Start

The event occurs when a resource of the preloader starts
loading.

Item Complete

The event occurs when a resource of the preloader has
finished loading or a load error happens.

Actions
Action Name

Target Object

Parameter

Timeline Actions
Start Timeline

Timeline

Direction (Forward, Backward), Speed
(%)

Continue Timeline

Timeline

Direction (Forward, Backward), Speed
(%)

Continue Timeline From

Timeline

Direction (Forward, Backward), Time or
Timeline Label, Speed (%)

Pause Timeline

Timeline

Pause Timeline At

Timeline
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Toggle Play/Pause
Timeline

Timeline

Seek Timeline

Timeline

Time or Timeline Label
Symbol Actions

Start Symbol

Symbol

Direction (Forward, Backward), Speed
(%)

Continue Symbol

Symbol

Direction (Forward, Backward), Speed
(%)

Continue Symbol From

Symbol

Direction (Forward, Backward), Time or
Timeline Label, Speed (%)

Pause Symbol

Symbol

Pause Symbol At

Symbol

Toggle Play/Pause
Symbol

Symbol

Seek Symbol

Symbol

Time or Timeline Label

Time or Timeline Label
Media Actions

Start Media

Audio, Video

Speed (%)

Continue Media

Audio, Video

Speed (%)

Continue Media From

Audio, Video

Time, Speed (%)

Pause Media

Audio, Video

Pause Media At

Audio, Video

Mute Media

Audio, Video

Media Volume

Audio, Video

Toggle Mute Media

Audio, Video
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Mute All Media

None

Toggle Play/Pause Media

Audio, Video

Seek Media

Audio, Video

Play Video Full Screen

Video

Time

Visibility Actions
Hide Element

All Element Types

Show Element

All Element Types

Toggle Hide/Show
Element

All Element Types

Other Actions
Jump To Scene

Scene

Transition Type, Duration (ms), Easing
Type, Direction

Go To URL

None

URL, New Window (True, False)

Change Text

Div, Shape, Text

Text

Run JavaScript

None

Function (see JavaScript
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Chapter 17: Customizing Preloader
When your animation loads from a web server, images, media files, and all other
components will need to be transferred to the user's browser. If your project is complex and
graphics-intensive, it may take a few seconds to download. It is when you need to use a
preloader to indicate that the content is being loaded.

By default, Saola documents use a default loader that contains only a loading indicator
shown when resources are being loaded. To edit the loading indicator, click the Edit button to
open the Preloader dialog box. You can modify many attributes of the loading indicator, all
changes are immediately reflected in the preview pane.
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Diameter: Set the diameter of the loader. The default value is 60 pixels.
Density: Set the number of shapes drawn on the loader. The default value is 9.
Range: Set the amount of the modified shapes in percent. With this value the user
can set what range of the shapes should be scaled and/or faded. The shapes that
are out of this range will be scaled and/or faded with a minimum amount only. This
minimum amount is 0.1 which means every shape which is out of the range is
scaled and/or faded to 10% of the original values. The visually acceptable range
value should be between 0.4 and 1.5. The default value is 1.0.
Speed: Set the speed of the loader animation. This value tells the loader how many
shapes to skip by each tick. The default value is 1.
Color: Set the color of the loader in RGB. The default value is blue.
Shape: Set the type of the loader shapes. The acceptable values are oval, spiral,
square, rectangle, and rounded rectangle. The default value is oval.

If the default loader does not meet your needs, that is, you want to add text, images, audio, or
animations to customize it, select Custom from the Preloader drop-down list.
A custom preloader is a project, so you can edit it like any normal Saola project. Custom
preloader project will be closed if you close the main project or if you switch from Custom
loader to Default loader.
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The loading indicator is turned on by default, but you can turn it off if you want. To turn the
loading indicator on/off, select/clear the Loading Indicator check box.

Chapter 18: Menus, Toolbars & Shortcuts
In this Appendix, the menus, toolbar buttons, and default keyboard shortcuts are listed. Note
that Saola Animate allows you to customize all keyboard shortcuts.
In Saola Animate, Main Menu is a set of menus at the top of the application window
containing seven drop-down menus. These menus allow you to interact with the content of
the application in many different ways. For example, the File menu provides commands to
create a new project, open an existing one, etc.

In this chapter, you will find the following:

v
v
v
v
v
v
v
v
v

File Menu

119

Edit Menu

120

Scene Menu

122

Element Menu

122

Timeline Menu

123

View Menu

126

Help Menu

127

Text Formatting Toolbar

128

Shortcuts For Code Editor

130
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File Menu
The File menu controls major events such as creating a new project, opening an existing
project, previewing scene and project in browser, etc.
Command

Icon

Default
Shortcut

Remark

New

CTRL+N

Create a new project.

Open Project

CTRL+O

Open an existing project.

Open Recent
Projects
Save

List of recently open projects.

CTRL+S

Save As Other
Project

Save the current project.
Save the project under a new name.

Save As Package

CTRL+SHIFT+P Save the project to a package.

Close

CTRL+F4

Close the current project.

Preview Current
Scene In Browser

CTRL+ALT+S

Preview the current scene in default
browser.

Preview Project In
Browser

CTRL+ALT+P

Preview the current project in default
browser.

Export to HTML5

CTRL+ALT+E

Export the current project to HTML5.

Exit
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Edit Menu
The Edit menu allows you to arrange elements on the Canvas. From here, you can also
create new symbols.
Command

Icon

Default
Shortcut

Remark

Undo

CTRL+Z

Reverse the last actions.

Redo

CTRL+Y

Reverse the last “undo” actions.

Cut

CTRL+X

Cut the selected objects.

Copy

CTRL+C

Copy the selected objects.

Paste

CTRL+V

Paste the selected objects.

Paste with Animation

Paste elements with animation.

Delete

DELETE

Delete the selected objects.

Select All

CTRL+A

Select all objects.

Group

CTRL+G

Group selected elements to be children
of a new created element (the group
element).

Ungroup

CTRL+SHIFT+G Ungroup the grouped elements.

Convert to Symbol

Convert the selected elements to
symbol.

Size > Make Same
Width

Make the width of all other objects
match the width of the reference object.

Size > Make Same
Height

Make the height of all other objects
match the height of the reference
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Icon

Default
Shortcut

Remark

object.
Size > Make Same
Size

Make the size of all other objects match
the size of the reference object,
respectively.

Alignment > Alight
Left

SHIFT+L

The left side of all objects will get
aligned with the left of the reference
object. Their vertical position will not be
affected.

Alignment > Alight
Right

SHIFT+R

The right side of all objects will get
aligned with the right of the reference
object. Their vertical position will not be
affected.

Alignment > Alight
Top

SHIFT+T

The top of all objects will get aligned
vertically with the top of the reference
object. Their horizontal position will not
be affected.

Alignment > Alight
Bottom

SHIFT+B

The bottom of all objects will get aligned
vertically with the bottom of the
reference object. Their horizontal
position will not be affected.

Alignment > Alight
Center

SHIFT+E

The center of all objects will get aligned
vertically with the center of the
reference object. Their horizontal
position will not be affected.

Alignment > Alight
Middle

SHIFT+M

The center of all objects will get aligned
with the center of the reference object.
Their vertical position will not be
affected.

Display Order >
Bring to Front
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Place the selected object at the very top
of the stack.
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Icon

Default
Shortcut

Remark

Display Order >
Bring Forward

Send the selected object higher by one
level in the stack.

Display Order >
Send to Back

Place the selected object at the very
bottom of the stack.

Display Order >
Send Backward

Send the selected object lower by one
level in the stack.

Preferences

View and edit the global settings.

Scene Menu
The Scene menu helps you insert a new blank scene or duplicate a selected scene.
Command

Icon

Default
Shortcut

Remark

Blank Scene

Insert a blank scene.

Duplicate Scene

Duplicate the selected scene to new
scene.

Element Menu
The Element menu lists all types of elements you can insert into a Saola project.
Command

Icon

Default
Shortcut

Remark

Rectangle Div

Insert a rectangle div.

Rounded Rectangle
Div

Insert a rounded rectangle div.

Chapter 18: Menus, Toolbars & Shortcuts

122

Saola Animate

Command

Version 1.0

Icon

Default
Shortcut

Remark

Ellipse Div

Insert an ellipse div.

Text

Insert a text.

HTML widget

Insert a HTML widget.

Image

Insert an image.

Audio

Insert an audio.

Video

Insert a video.

Symbol

Insert a symbol.

Shape

Insert a shape.

Timeline Menu
The Timeline menu lets you control the timeline and animations while working in Saola.
From here, you can play/stop animation playback, add keyframes, animations, triggers, and
lables, etc.
Command

Icon

Default
Shortcut

Remark

Play/Stop

SPACE

Switch the control to play or stop the
selected action on the Timeline, starting
from the current position of the
Playhead.

Go to Start

HOME

Restore the Playhead to the beginning
position on the Timeline.
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Icon

Default
Shortcut
END

Loop Playback

Auto-Keyframe Mode

Remark

Bring the Playhead to the ending
position of the range on the Timeline.
The range will be played endlessly (in a
loop). When the Playhead reaches the
end of the range, it will return to the
beginning and continue playing.

K

Add Keyframe

Automatically generate keyframes when
creating animations.
Add a keyframe corresponding to the
selected object.

Insert Label

ALT+L

Insert a label at the Playhead position
on the Timeline.

Insert Trigger

ALT+T

Insert a trigger at the Playhead position
on the Timeline.

Open Event Handlers

Open the Event Handlers form
corresponding to the selected object.

Create Transition

CTRL+SHIFT+T Create new property transition for an
animation segment that does not have
transition.

Remove Transition

SHIFT+DEL

Remove property transition of an
animation segment.

Invert Animation
Segment

Swap the starting and ending
keyframes of animation segments.

Only Show Animated
Element

Show/Hide elements which does not
have property animation.

Snapping

ALT+;
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Icon

Default
Shortcut

Remark

on the Timeline ruler or jumps to a
keyframe. You may want to change
multiple properties at a single point in
time, meaning that you should turn
Snap To option on most of the time. To
fine-tune snapping behaviors, you can
choose what the Playhead snaps to.
Three choices available: Grid,
Playhead, and Keyframes, Labels,
Triggers.
Snap To > Grid

The Playhead, keyframes, labels,
triggers snap to the grid lines displayed
when you turn on the grid.

Snap To > Playhead

The keyframes, labels, triggers snap to
Playhead position on the Timeline.

Snap To >
Keyframes, Labels,
Triggers

The keyframes, labels, triggers snap to
their own position on the Timeline or the
Playhead snaps to items' position.

Show Grid

Show/Hide grid lines on the Timeline.
Grid is used to help users divide time
into little pieces by displaying subtle
vertical lines along the Timeline at
regular intervals.

Grid

Use the Grid submenu to set the time
increments. You can choose many
increments such as half-second,
quarter second, or 24 frames per
second.

Zoom Out

-

Reduce the time scale of the Timeline.

Zoom In

=

Expand the time scale and see more
details.
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Icon

Default
Shortcut

Remark

Zoom to Fit

\

Animation bars is fitted based on the
Timeline view horizontal size.

Expand/Collapse
Lanes

CTRL+SHIFT+.

Show/Hide all properties under all
elements.

View Menu
The View menu gives you access to customize the workspace. From here, you can change
the display language, show/hide various toolbars and panes, etc.
Command

Icon

Default
Shortcut

Remark

Language

Choose the language of the user
interface.

Ruler

Show/Hide the rulers.

Canvas Snap

Turn canvas snapping on/off.

Zoom > Zoom In

Expand the Canvas scale.

Zoom > Zoom Out

Reduce the Canvas scale.

Zoom > Zoom Level

Set the zoom level for the Canvas.

Zoom > Fit on
Screen

Set the scene content fit to the viewport
size.

Toolbars > Files

Show/Hide icons of the Files group on
the toolbar.

Toolbars > Edit

Show/Hide icons of the Edit group on
the toolbar.
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Icon

Default
Shortcut

Remark

Toolbars > Insert

Show/Hide icons of the Insert group on
the toolbar.

Toolbars > Modify

Show/Hide icons of the Modify group on
the toolbar.

Properties

Show/Hide the Properties pane.

Scenes

Show/Hide the Scenes pane.

Document

Show/Hide the Document pane.

Timeline

Show/Hide the Timeline pane.

Elements

Show/Hide the Elements pane.

Resources

Show/Hide the Resources pane.

Functions

Show/Hide the Functions pane.

Help Menu
The Help menu allows you to access the Saola documentation and provides information
about the current version.
Command

Help Contents

Icon

Default
Shortcut
F1

Remark

Launch the Help file.

About

Provide information about the current
version.

Check Updates...

Saola will periodically check for updates
when started. This feature is selected
by default. To turn this feature on/off, go
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Icon

Default
Shortcut

Remark

to Preferences > General > Auto
Updates.
My Account

Open your account webpage where you
can update your profile, manage your
subscriptions, etc.

Sign Out

Sign out of your account.

Text Formatting Toolbar
The Text Formatting toolbar appears when you insert or edit text with the inline text editor.
The toolbar provides necessary commands to format text style, insert special characters,
hyperlink, etc.
Command

Icon

Default
Shortcut

Remark

Font Name

Change the font of the selected text or
objects.

Font Size

Change the size of the selected text or
objects.

Align Text Left

CTRL+L

Align the selected text, or the text in the
selected objects left.

Align Text Center

CTRL+E

Align the selected text, or the text in the
selected objects center.

Align Text Right

CTRL+R

Align the selected text, or the text in the
selected objects right.

Align Text Justify

CTRL+J

Align the selected text, or the text in the
selected objects justified.

Bold

CTRL+B

Make the selected text, or the text in the
selected objects bold.
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Icon

Default
Shortcut

Remark

Italic

CTRL+I

Make the selected text, or the text in the
selected objects italic.

Underline

CTRL+U

Underline the selected text, or the text in
the selected objects.

Strikethrough

Strikethrough the selected text, or the
text in the selected objects.

Superscript

CTRL+SHIFT+= Format the selected text as superscript.

Subscript

CTRL+=

Format the selected text as subscript.

Outdent

Increase the indent of the selected text.

Indent

Decrease the indent of the selected
text.

Insert Unordered List

Create a bulleted list.

Insert Ordered List

Create a numbered list.

Foreground Color

Change the text color of the selected
text or objects.

Highlight Color

Highlight the selected text, or the text in
the selected objects.

Insert Special Chars

Insert special characters to the text.

Insert Link

Link the selected text to a webpage.

Edit HTML

Edit the content of HTML to the text.
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Icon

Default
Shortcut

Show/Hide Floating
Tools

Remark

Show/Hide the Text Formatting toolbar
when editing text.

Shortcuts For Code Editor
Command

Icon

Default
Shortcut

Remark

Undo

CTRL+Z

Reverse the last actions.

Redo

CTRL+Y

Reverse the last “undo” actions.

Copy

CTRL+C

Copy the selected text.

Cut

CTRL+X

Cut the selected text.

Paste

CTRL+V

Paste the selected text.

Delete

DELETE

Delete the selected text.

Export To File

Export the current function to file.

Search

CTRL+F

Display the Find search box. If there is
no current Find criteria, place the word
under your cursor in the Find box.

Replace

CTRL+H

Display the Find search box where you
can replace the specified text.

Zoom In/Out

CTRL+Mouse
Expand/Reduce the text size.
Wheel Up/Down
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Icon

Default
Shortcut

Options

Remark

Show/Hide editor features and access
the Code Editor settings.

Chapter 19: Customizing Saola Animate
You can customize some aspects of Saola Animate to suit your particular needs.

In this chapter, you will find the following:

v
v
v

Changing Language

131

Customizing User Interface
Customizing Preferences

132

133

Changing Language
By default, the display language in Saola Animate is set to English (United States). If you
want to choose another language, click View > Language, and then select your desired
language from the drop-down list. Your change will be applied the next time you open the
application.

Another way to customize the display language is to use the Preferences dialog box. Do the
following steps:
1. Click Edit > Preferences

to open the Preferences dialog box.

2. In the General tab, select the appropriate language in the Language drop-down list.
3. Click Apply to submit changes.
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Customizing User Interface
To show/hide panes & toolbar
Though the View menu

v
v

126

, you can make the following changes:

View/hide toolbars (File, Edit, Insert, and Modify).
View/hide various panes (Properties, Scenes, Document, etc.).

Saola saves the project settings when you close the project. The next time you open the
application, the settings of the last saved project will be automatically applied to the new one.
To change pane location
In Saola, the location and size of all panes are customizable. Each pane has two small
buttons in the top right corner. Use the Undock

button to move panes and the Close

button to close panes when needed.
You can dock panes together, move them into or out of groups, and undock them so that
they float above the application window. Drag a pane from its current location by its title bar
or its Undock button. Note that for the Timeline pane, you can only undock it by clicking the
Undock button.
As you drag a pane, a highlighted drop zone appears indicating that you can dock the pane
onto that area. Remember not to release the mouse button until you find the location you
want to place the pane.
As you drag the pane, you have three available options:

v
v

Dock the pane in the highlighted drop zones that appear on screen. By choosing a
drop zone, you determine not only where the pane is inserted but also whether it
docks or groups with other panes.
Drag the pane at the top, bottom, or in between other panes so that they stand
together on one edge of the Canvas. If two or more panes are placed in the same
drop zone, they will be stacked into a tabbed group.
To change the tab order, drag a pane left or right by its tab. To remove a pane from
the group and make it free-floating, drag it outside the group by its title bar or its
Undock button.

v

Make the pane free-floating by dragging it to an area that is not a drop zone. The
floating pane allows you to position it anywhere on the screen, even outside the
application window.

To change pane size
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You can change the size of the panes that appear in Saola. This is useful when you want to
make your work area larger by reducing the pane size, or when you want to view more of the
information that appears in a pane by increasing its size.

v
v

To resize a docked pane, move the pointer over the left or right edge of the pane (for
vertical panes) or over the top edge of the pane (for horizontal panes). When the
pointer turns into a bidirectional resize pointer, drag the boundary to resize the pane
to the dimensions you want.
To resize a floating pane, hover over any edge or corner of the pane until the pointer
turns into a bidirectional resize pointer, and then drag the boundary until the pane is
the width/height you want.

Customizing Preferences
Use the Preferences dialog box to set how you want Saola Animate to operate. To open this
dialog box, select Edit > Preferences

from the menu bar.

The Preferences dialog box appears having three tabs, and each serves a different
category. Select the relevant tab to customize the relevant settings.
Tab

Category

General

General options applicable to the entire application.

Shortcuts

Shortcuts used for various operations.

Code Editor

Features and colors in the JavaScript Function form.
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General Tab
The General tab is the first tab in the Preferences dialog box. In this tab, you can set a few
preferences for how Saola Animate works.

Language & Theme
By default, the display language in Saola is set to English (United States). To change the
language, select a new language from the Language drop-down list. The language change
will be applied the next time the application starts.
In terms of Theme, in this version Saola Animate only offers a Dark theme. Other theme
options will be updated in the next versions.
Project Location
The default project location is your Documents folder; however, you can always choose
where to save your Saola projects at any time. To change the default project location, enter
your desired location in the Default Location box, or navigate to a location using the
Browse

button.

Note that no matter which default location you choose, you still can select the project location
you want each time you create a project. See Creating, Opening & Saving Projects 18 for
more details.
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Backup
Auto Backup feature allows you to recover your work if anything happens when you are
working with Saola Animate. To turn this feature on/off, select/clear the Enable Auto Backup
check box.
By default, backup is made available and set to automatically save changes to your work
every 2 minutes. You can shorten or lengthen this interval as desired by simply entering a
new interval (in minutes) in the text box.
Auto Updates
Saola will periodically check for updates when started. This feature is selected by default. To
turn this feature on/off, select/clear the Auto Check for Updates check box.

Shortcuts Tab
The Shortcuts tab shows all keyboard shortcuts in Saola Animate. You can assign keyboard
shortcuts to commands or remove any keyboard shortcuts you do not want.

All major commands in Saola are grouped functionally in a hierarchical tree. The tree
consists of nodes; each node contains a group of related commands. To expand any node to
list the commands or other items that it contains, click the arrow on the left of it. Any
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keyboard shortcuts that are currently assigned to a command or item will be shown in the
Shortcut column.
To assign keyboard shortcuts
1. Select a command or item that you want to assign a keyboard shortcut.
2. Click inside the New Shortcut box, and then press the combination of keys that you
want to assign.
3. Look at the Current used by box to see if the combination of keys is already
assigned to a command or item. If the combination is already used, press a different
combination.
4. Click Assign to assign the new keyboard shortcut.
5. Click Apply to submit changes.
To remove keyboard shortcuts
1. Select a command or item that you want to remove a keyboard shortcut.
2. Click the Remove button.
3. Click Apply to submit changes.
When you assign keyboard shortcuts, you can reassign a combination of keys if you want;
however, in that case you can no longer use the combination for its original purpose.
Example: Select the Copy command in the tree view, and then press CTRL+A in the New
Shortcut box. The combination of CTRL and A is automatically captured and displayed. In
fact, Saola Animate detects that this keyboard shortcut is currently used by the Select All
command.
Now you have two options: Either try another keyboard shortcut (and repeat the cycle), or
press the Assign button to reassign the CTRL+A keyboard shortcut to the Copy command.
If you choose the second option, this keyboard shortcut will no longer be assigned to the
Select All command. You can restore the default settings by clicking the Reset All button.

Code Editor Tab
Saola Animate offers you a feature-rich editor for code writing and editing. To customize the
code editor’s features and component colors, in the Preferences dialog box, switch to the
Code Editor tab.
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Features

v
v
v
v
v
v

To show/hide auto suggestion: Select the Suggestion check box.
To turn bracket matching on/off: Select the Bracket Matching check box.
To turn code folding on/off: Select the Code Folding check box.
To turn line number on/off: Select the Line Number check box.
To turn line wrap on/off: Select the Line Wrap check box.
To show/hide API: Select the Show API check box.

Colors

v

v
v

To change the color of the editor components:
·

Click the color rectangle next to the component in the component list, and then
select a color in the color picker.

·

All changes you make are immediately reflected in the preview editor on the right
side.
To reset the code editor to its default settings, click the Reset All button.
Click Apply to submit changes.
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