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Introduction to ActivePresenter
ActivePresenter is a leading authoring software to simplify your eLearning design experience.
ActivePresenter stands out from the rest as a feature-rich and easy-to-use tool for multiple
scenarios, including:
• Design high-quality interactive courses for school and workplace learning.
• Build interactive software simulations with smart screen capture technology.
• Develop assessments and educational games.
• Create or record videos with screencasting and editing tools.
• Convert existing PowerPoint presentations to eLearning courses.
Leverage from high-level responsive support, HTML5, SCORM, and xAPI, content created with
ActivePresenter can run perfectly on any device and integrate with almost all learning
management systems (LMS). The video output (MP4, WebM, MVK, WMV, AVI) can also be
uploaded to video-sharing websites.

ActivePresenter User Interface
UI Theme
ActivePresenter supports both light theme and dark theme for your liking, which lets you
customize your look and feel. On the first launch, after you successfully installed
ActivePresenter, this dialog will appear:

Introduction to ActivePresenter > ActivePresenter User Interface
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You can choose either the light theme or the dark theme that you want to work on within your
projects. Then, the chosen theme will be the default theme whenever you launch the program.
However, you can switch between two themes in the current working project later by going to the
View tab > UI Theme > Light or Dark.

Start Page
The Start Page will appear as soon as you launch the app. It allows you to quickly start new
projects as well as access useful resources such as templates and samples. During the editing
phase, you can open the Start Page by clicking the ActivePresenter button at the top-left corner
and selecting Start Page .
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The Start Page has many components that are grouped into two main areas: the left pane and
the central part.

On the left are two sections:
●

The Quick Start provides buttons to create new projects and open existing ones.
o

Click Blank Project to create a new project using the blank theme.

o

Click Record Screen as Video to record screen as video.

o

Click Record Interactive Simulation to record a software simulation.

o

Click Responsive Project to create a new responsive project.

o

Click Import PowerPoint to convert a PowerPoint presentation into an
ActivePresenter project.

Introduction to ActivePresenter > ActivePresenter User Interface
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Click Open to open an existing project, a slide template, a theme, an object template,
or a video file.

The Recent shows a list of recently opened projects.
o

Click a project or right-click it > Open to open a project in the list.

o

Right-click a project > Remove to remove a project from the list.

o

Right-click a project > Open Folder to open the folder containing the project.

In the center are three tabs:
●

The Templates tab shows all the built-in and custom themes/templates that you can click
to create a new project using this theme/template.

●

The Samples tab contains useful ActivePresenter samples.

●

The Help tab provides access to the User Manual, Product Homepage, Support Center,
Activation/Deactivation, Check Updates, and information about the current version.

Workspace
ActivePresenter workspace also comes up with the theme that you’ve chosen. To change the
look of the workspace from light to dark and vice versa, click the View tab > UI Theme.

The workspace of ActivePresenter contains three main sections: Tabbed Toolbar (1), Document
Window (2), and Status Bar (3).

Introduction to ActivePresenter > ActivePresenter User Interface
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Tabbed Toolbar
Located at the top of the application window, the tabbed toolbar contains almost all the tools for
creating and editing content. There are ten core tabs always present and some contextual tabs
that appear only when a particular object is selected. In each tab, related commands are grouped
into groups. When you point to a command, a tooltip appears explaining the command and giving
the hotkey (if any).

At the top-left of the tabbed toolbar is the ActivePresenter button. This button opens the
ActivePresenter main menu that provides access to all common file operations, configuration
settings, and a list of recently opened projects.

Introduction to ActivePresenter > ActivePresenter User Interface
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at its right corner. You

Document Window
You can open more than one project at the same time. Then, the document window will display
projects in tabs for easy navigation. The document window has components as follows:
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1. The Quick Access Toolbar contains commands for creating new projects, opening and
saving projects, and undoing and redoing recent actions.
2. The Document tab enables you to navigate between open documents. You can also hover
over this tab to view the project location, or right-click the tab to open the project folder.
3. The Slides pane displays thumbnail views of all slides in your project.
4. The Canvas is the central area of the document window. It displays slide contents and
allows all spatial editing.
5. The Timeline allows you to manage the timing and animations of all objects, as well as
their relationship to each other on a slide. Besides, it also provides you with many tools
for editing audio and video objects. You can record your voice in real-time and create
multiple timelines for more enhanced projects.
6. The Properties pane lets you edit almost all physical and behavioral properties of the
selected objects.
7. The Resources pane displays all the resources in your project.
8. The Selection pane displays all the objects included in a slide. It allows you to view,
reorder, change the selection, lock, and toggle the visibility state of objects.
9. The Slide Pools pane contains slide pools that are used to randomize slides and create
dynamic quizzes.
10. The Object States pane contains the states of objects. Object states allow you to change
the appearance of an object in response to user interaction.
11. The Object Templates pane contains object templates that are useful to save and reuse
objects across slides in the same project or across projects.

Introduction to ActivePresenter > ActivePresenter User Interface
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You can customize the workspace by showing, hiding, repositioning, and resizing panes. After
customizing, if you want to go back to the original window layout, just click the View tab > Reset
Pane Layout . Your change will be applied the next time you open the application.

Status Bar
Located at the bottom of the application window, the status bar displays the indicator about the
current project. It may vary from what slide you are on to the current status of a project. You can
quickly preview your project in HTML5 format. Besides, ActivePresenter makes it easy to adjust
the zoom level of the Canvas through the tools at the right corner of the project.

The Status Bar also includes the Check Spelling function.

Once the spelling check is turned on, the spelling errors will be marked with a red line. You can
right-click an error and do some commands such as correcting it or adding it to the dictionary.

Introduction to ActivePresenter > ActivePresenter User Interface
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If you don’t want to use this function, you can click it in the Status Bar again, then uncheck to
turn it off.

ActivePresenter Editions
ActivePresenter offers three editions: Free, Standard, and Pro.
1. Free edition is designed for those who want to create video demonstrations. This edition
allows several screen recording and video editing features. Projects can be exported to
several video formats, namely MP4, AVI, WMV, WebM, and MKV. However, the outputs
cannot be used for commercial purposes.
2. Standard edition provides all the features available in the Free edition plus some
advanced audio and video editing features and the capability to export a project to many
document formats, namely PDF Document, Microsoft Word, Microsoft Excel, and
Microsoft PowerPoint. The outputs can be used for commercial purposes.

Introduction to ActivePresenter > ActivePresenter Editions
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3. Pro edition is the most powerful one that allows creating interactive eLearning content.
This edition is highly suitable for online learning designers, trainers, educators, technical
supporters, and anyone who wants to create professional content. Besides document
formats, it allows exporting to HTML5, SCORM, and xAPI. Content exported to these
formats can run perfectly on any device and integrate with almost all learning management
systems (LMS). You can try all the features of the Pro version in the Free version. The
watermark will be added to the outputs of non-free features until the license is activated.
The following table compares the features of the three editions. The features which are available
in all three editions aren’t listed.
Feature

Free

Standard

Pro

Edition

Edition

Edition

Commercial Use
Report & Tracking in LMS (SCORM, xAPI)
Export To HTML5
Export To Microsoft PowerPoint
Export To Microsoft Excel
Export To Microsoft Word
Export To PDF Document
Export To Video
Export To Images
Audio Fade In/Fade Out
Audio Noise Reduction
Audio Normalization
Video Blur Effect
Video Green Screen Effect
Cloud Text-to-Speech (Amazon Polly,
Google Cloud, Microsoft Azure)
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System Requirements
Here are the system requirements for running ActivePresenter 9 on Windows and macOS:
Windows 8.1, Windows 10, Windows 11 (only 64-bit (x64) is supported).
macOS 10.15, macOS 11, macOS 12.
Environment

The following features are only available on Windows: Microsoft Word
Export, Microsoft Excel Export, Microsoft PowerPoint Export.
Note that administrative privilege is required to install ActivePresenter.
CPU: 2 GHz multi-core processor or higher.
4 GB of RAM or better (>8 GB recommended).

Hardware

4 GB of available hard-disk space for installation.
Sound card and microphone for audio recording.
Webcam for webcam video recording.
Browsers and mobile OS versions for viewing HTML5 courses:
Windows:
+ Mozilla Firefox (latest)
+ Google Chrome (latest)
+ Microsoft Edge (latest)
Mac:
+ Safari (latest)
+ Google Chrome (latest)
iOS:

Software

+ iOS 13 or later
+ Safari (latest)
Android
+ Android 6 or later
+ Chrome (latest)
For Microsoft Word Export: Microsoft Word 2016 (or later) on Windows.
For Microsoft Excel Export: Microsoft Excel 2016 (or later) on Windows.
For Microsoft PowerPoint Export: Microsoft PowerPoint 2016 (or later) on
Windows.
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For recording system audio on OS X or macOS: Background Music is
required.

Installing ActivePresenter

Installing

Windows: After downloading the installer, double-click it and follow the
instructions. To install ActivePresenter silently from the command line, you
can use the /VERYSILENT flag. For example, call
ActivePresenter_v9.0.0_setup.exe /VERYSILENT /NORESTART from
scripts.
macOS: After downloading the installer, double-click it and follow the
instructions.

Activating

Updating

Upgrading

The Free edition doesn’t need activation. To activate Standard and Pro
editions, on the Start Page, or in the open project window, click the Help
tab > Activate Product.
To update an existing version, just download the latest version of the
installer and double-click to run. There is no need to uninstall the older
version first.
You can also click the Help tab > Check Updates to have
ActivePresenter check if there are new updates and do the update
automatically.
To upgrade your license, please contact the support group.
Windows: The standard way to uninstall ActivePresenter from your
computer is to use the Control Panel > Programs and Features >
ActivePresenter, and follow the instructions. To uninstall ActivePresenter
silently from the command line, call <installation_folder>\unins000.exe
/SILENT from scripts.

Uninstalling

Alternatively, open the folder in which you’ve installed the application,
double-click the unins000.exe file, and follow the instructions.
macOS: In the Finder sidebar, click Applications, drag the app from the
Applications folder to the Trash (located at the end of the Dock), then
choose Finder > Empty Trash.

Activating and Deactivating ActivePresenter
Activating ActivePresenter
While the Free edition needs no activation, you must activate the Standard and Pro editions using
product keys. There are two ways to activate ActivePresenter: direct (automatic) and web
(manual) activation.
You can purchase a product key here.
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Direct Activation
Direct activation requires an active internet connection. Do the following:
1. Click Activate Product at the top-right corner of the application window. Alternatively, in
the open project window, click the Help tab > Activate Product .
2. In the dialog that appears, enter a product key in the Product Key text box.
3. The default activation method is direct. Click Activate to activate the application.

Note: Click Connection Settings to configure the network connection if your computer is behind
a proxy.

Web Activation
To manually activate ActivePresenter, perform the first two steps above, then do the following:
1. In the Method section, open the Web tab.
2. Click Get Confirmation Code to open a web page that gives you the code.
3. Click Enter Confirmation Code to paste the code into the text box that appears.
4. Click Activate. Note that this button is dimmed until you enter the confirmation code.
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Silent Activation
To activate ActivePresenter silently from the command line, call
<installation_folder>\rlactivator.exe -activate -pkey=<product_key> -silent from scripts.

Deactivating ActivePresenter
There is a chance you want to launch ActivePresenter on another computer. In that case, you
need to deactivate the application on the current computer before using the same product key on
a new computer.
To deactivate the application, on the Start Page or in the open project window, click the Help tab
> Deactivate Product. In the dialog that appears, select Director Web in the Method section >
Deactivate. This deactivates the application instantly. Alternatively, to deactivate ActivePresenter
silently from the command line, call <installation_folder>\rlactivator.Exe -deactivate -silent from
scripts.
You can manage the activations yourself using the portal at:
https://atomisystems.com/selfhelp/activepresenter/
You need to use the email associated with your license (the email used for purchasing by default)
to get access to this portal.

The Multi-tier System of Support
ActivePresenter has a multi-tier system of support, as described below:
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Tooltips

A tooltip system explains the purpose of all the toolbar buttons. Hover the
mouse over any button to show a short description.

User Manual

A user manual (PDF file) contains extensive references to all topics.
Press F1 to open it.

Demos

The best way to learn about a product is to watch someone using it. The
website provides many excellent demos.

Tutorials

A large number of written and video tutorials are available to help.

FAQ

The user community answers all your queries. But it is always better to
first check whether your query is already listed in the FAQ section. If you
have any features in mind, you can also post a new feature request.

Email Support

If you need any help or further information about ActivePresenter, you
can send an email to the support team.

Phone Support

For urgent support needs, contact +8424-3755-8373.
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Creating Projects
Creating Blank Projects
A blank project is one of the built-in projects in Start Page. When opening, it contains one Title
slide. In the same way as other slides, you can add new slides and content such as images,
video/audio clips, and slides from ActivePresenter projects or PowerPoint presentations. You can
also add newly recorded slides to a project by recording the screen as video or as interactive
simulations.
To create a blank project, on the Start Page > Blank Project. Alternatively, in the open project
window, click the ActivePresenter button > Blank Project. ActivePresenter will launch a new
project with the default theme. Another way to do that is in the Quick Access Toolbar, click the
Create blank project button

.

By default, the new project will have one blank slide with the layout corresponding to the theme.
You can add more slides by clicking the Home tab > New Slide , or in the Insert tab > New
Slide . The new slide will be inserted after the slide that you are selecting.
If you want to create a new slide with a different layout, click the arrow on the New Slide button
and select a slide layout from the drop-down list.

Changing Slide Size
The new project that you’ve created has the default slide size (1280x720), and you can change it
if needed. Note that you cannot change the slide size for a responsive project.
In ActivePresenter, you can see the project size and change its size. To do that, click the
ActivePresenter button > Project > Properties. You can see and change the current size of the
project. Click the Change Size button to change the slide size.

Alternatively, in the Design tab > click Slide Size
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1. Preset Size: You can choose to quickly apply one of the preset sizes from the Preset Size
drop-down list. The list contains different sizes ranging from small to large. You can also specify
the new size by entering values in the Width and Height spin boxes, or clicking the up/down
arrow to increase/decrease the size respectively.
2. Lock Aspect Ratio: By selecting this checkbox, ActivePresenter will automatically change the
height according to the width, and vice versa so that the aspect ratio can be maintained.
The new slide size that you select can be either smaller or larger than the previous size, so you
have further options to adjust the contents of the slides. Two cases are described in detail in the
next parts.
3. If the new size is smaller than the current slide size, do one of the following:
o

Select Scale to Fit to scale the contents to fit the new slide size. If you select Scale All
Objects, all the objects in slides will be scaled to fit the new slide size, including
placeholders in slides and slide masters. Otherwise, objects will keep their original sizes
which are sometimes too large in comparison with the new slide size. However, you can
adjust their sizes after that.

o

Select Crop > Next to crop the contents. The following dialog will appear:
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To crop a slide, drag the orange frame to the desired position. You can crop each slide individually
or all of them at once:
Crop each slide individually: Select the slide from the Slide list box or click the
buttons, then drag the orange frame to the desired position.

and

Crop all slides at once: Select any slide of the project, drag the orange frame to the desired
position, then click Apply to All Slides. All slides will be cropped at the same position.
Note: When you choose to crop the slide in any position, objects and placeholders of the slide or
slide master will not be cut. They keep their original sizes and you can manually drag their
handles to fit the new slide size.
4. If the new size is larger than the current slide size, do one of the following:
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Select Scale to Fit to scale the contents to fit the new slide size. This is similar to the
Scale to Fit command mentioned above when the new slide size is smaller than the
previous slide size.

If you select Scale All Objects, all the objects in slides will be scaled to fit the new slide size,
including placeholders in slides and slide masters. Otherwise, objects will keep their original
sizes which are sometimes too small in comparison with the new slide size. However, you can
adjust their sizes after that.
o

Select Fill Background, then select the slide position where the contents will fill in from
the Slide Position drop-down list, then click OK.

Creating Responsive Projects
Responsive design in ActivePresenter allows you to create a single project which displays
perfectly on any device which has different screen sizes. ActivePresenter defines five default
responsive layouts which correspond to the most popular device screen sizes:
●

Desktop with a viewport of 1280x620

●

Tablet Landscape with a viewport of 1024x674

●

Tablet Portrait with a viewport of 768x930

●

Mobile Landscape with a viewport of 667x345

●

Mobile Portrait with a viewport of 375x522

Note that the above layout sizes are not the device viewport sizes. They are chosen to make sure
that the content displays best on popular devices. You can add a responsive layout to support
Creating Projects > Creating Responsive Projects
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a particular device if you want. Besides, in the responsive mode, ActivePresenter also supports
a flexible coordinate system with percentage, pixel, and auto units so the content still looks good
with other screen sizes that are not in the list of responsive layouts of the project.
To create a responsive project, launch ActivePresenter and click Responsive Project on the
Start Page.
Alternatively, in the open project window, click the ActivePresenter button > Responsive
Project. ActivePresenter will create a project with five different layouts which are Desktop, Tablet
Landscape, Tablet Portrait, Mobile Landscape, and Mobile Portrait, their corresponding
viewports, and a responsive bar.
A newly created responsive project looks like this:

Responsive Bar

The responsive bar is placed at the top of the document window. This bar allows you to change
the layout size by whether choosing one out of five default layouts or adding a new custom layout.
The currently selected layout is orange. Dragging the handle along the responsive bar to change
the width of the current layout as well as of the viewport. Additionally, it also allows you to
show/hide the layout height, or set the largest layout to the project.

Viewport of Responsive Layout
Screen size
Creating Projects > Creating Responsive Projects
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The screen size is the physical measurement diagonally of the screen in inches.
Resolution
The resolution is the number of pixels on the screen often displayed as width by height (i.e.
1024×768).
Viewport
Because devices with the same screen size can have very different resolutions, we use viewports
when creating mobile-friendly content. Viewports are scaled-down versions of resolutions that
allow sites to be viewed more consistently across different devices. You can find the viewport
sizes of popular devices at https://material.io/devices (in the column with dp unit).
How is the size of a responsive layout calculated in ActivePresenter?
The viewport of the responsive layout is the actual visible area of the content when displaying in
the browser excluding the HTML5 player toolbar if any.
For example, the Mobile Portrait is based on the viewport of iPhone 6, 7, or 8 (375x667). After
excluding the Safari browser title and navigation bars and the HTML5 player toolbar (width: 100%,
height: 30), the layout size is 375x522. But with Mobile Landscape, the Safari browser
automatically hides the title and navigation bars so the layout size is 667x345.

Managing Responsive Layouts
Adding Layouts
To add a new layout, click the drop-down button on the Responsive bar (on the top of the
document window) and select Add New.
You can select one of the layouts provided or have a custom size by clicking Custom... and
adjusting the size for the new layout.
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Removing Layouts
To remove a layout, select it and click the drop-down button on the Responsive bar > Remove...

Changing Layout Name
To rename a layout, select it and click the drop-down button on the Responsive bar > Rename...
> type the new name in the Name text box > OK.

Changing the Current Layout
To switch between layouts, click the drop-down button on the Responsive bar > select a layout
from the drop-down list. Alternatively, you can click directly on one of those layouts on the
Responsive bar. The current layout is in orange.

Changing Layout Width
You can drag the handle on the Responsive bar to the left or right to change the layout width,
which is previewed in the Viewport. The layout width can be in a range from 1 to 5000 depending
on your division. A project can contain one or more breakpoints. By default, there are 5
breakpoints which are 375, 667, 768, 1024, 1280 with 5 corresponding layouts [1, 375], [376,
667], [668, 768], [769, 1024], [1025, 1280], respectively. Once the handle exceeds a specific
layout, it will jump to another layout range.
Furthermore, if you want the slide's width to full the device's width, select Expand Largest
Layout.
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Changing Layout Height

The layout height (1) is used as the standard size for slide height (2) when previewing on the Canvas.
To show and change the layout height, do the following:
1. Tick the Layout Height Control checkbox (4) on the Responsive bar. Then, a blue
bordered rectangle appears. It matches with the slide.
2. Drag the layout height control (3) up or down or click the up/down arrow of the Layout
Height spin box (5) to increase or decrease the height respectively. Or, enter a new value
in the box.

Changing Slide Height
In common cases, you place the content inside the area which is limited layout width and layout
height. However, for devices with small viewports, you may want to have more space to place
content. In that case, you can increase the slide height.
To change the slide height, navigate to the Properties pane > Slide Properties tab > Slide
Height section.
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Here, you have three options to adjust the slide height:
•
•
•

100% Device Height: Check the radio button if you want the slide height to fully match
with the device height.
100% Layout Height: Check this button then the slide height will 100% fit to the layout height.
Custom: Enter a value in the spin box, or click the up/down arrow to increase/decrease
the slide height. It specifies the slide height independently from layout height.

Note:

•
•

If the slide height is bigger than the device height (in case you select 100% Layout Height or
Custom), users can view the contents beyond the layout by scrolling the bar on their devices.
The slide width is always the same as the layout width.

Inherit Properties of Layouts
By default, a layout will inherit properties from a larger layout, which is called layout inheritance
behavior in a responsive project. That is to say, the properties of each layout will be the same
since the smaller layout will inherit properties from its larger layout except for properties that you
already changed in that smaller layout.
Due to the layout inheritance, if you want to change any properties, you should make changes to the
largest layout first. If you are satisfied with it, then just make changes to any smaller layouts if needed.
However, after making changes to these properties of a smaller layout, if you are not satisfied
with these changes, you can reset it by right-clicking the Canvas > Reset Layout Inheritance.
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Changing Object Position Mode
Position Mode is the exact specification of the object position in a slide of a project. To change
this value of an object, select that object > Properties pane > Size & Properties > Transform >
select one from four modes (Top-Left, Top-Right, Bottom-Left, or Bottom-Right) (6).
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Changing Object Position and Size
These values define the object’s position in a slide. To change those values, in the Properties
pane > Size & Properties > Transform > adjust values of Left, Top, Width, and Height (in
percentages or pixels) by entering values in those spin boxes. You can also click up/down arrows
next to the spin boxes to increase/decrease values. (7)
The values (Top, Left, Right, and Bottom) displayed in this section depend on the Position Mode
type you select. For example, if you select the Bottom-Right mode, this section will show the
Bottom and Right values instead of showing the Top and Left values when you select the TopLeft mode.
If you want to keep the height-to-width ratio when changing the object width, select Auto from the
Unit combo box next to the Height spin box. This option automatically changes the height
according to the width and vice versa.
To rotate the object, along with dragging the rotation handle of the object, you can enter a value
in the Rotation spin box.
Tick the Exclude from Container Layout (11). It defines whether an object can be excluded from
the container layout or not. See more about this feature at Excluding Objects from Slide
Container Layout.

Changing Object Position Value Unit
You can change the unit of object position value between percentages (%) and pixels (px). To do
that, in the Properties pane > Size & Properties > Transform > Unit combo box next to the Size
spin boxes > select %, px, or Auto. (8)
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●

Choose the % unit if you want the object position to be a percentage of
left/top/width/height.

●

Choose the px unit if you want the object position to be pixels of left/top/width/height.

●

Choose Auto for the height or the width unit to retain the aspect ratio.

Either the unit you choose, the size and position of the object should remain unchanged.

Aligning Horizontal/Vertical Center
You can align objects in the center of the slide in all layouts of responsive projects. To do that, in
the Properties pane > Size & Properties > Transform > Align Horizontal Center or Align
Vertical Center. (9)
If you select both checkboxes, objects will be aligned to both the horizontal and vertical center of
the slide and you cannot move the object either in the horizontal or vertical direction.
●

Align Horizontal Center: The object will be aligned to the horizontal center and you can
move the object only in the vertical direction of the slide. You cannot move it horizontally.

●

Align Vertical Center: The object will be aligned to the vertical center and you can move
the object only in the horizontal direction of the slide. You cannot move it vertically.

Showing/Hiding Objects in Individual Responsive Layout
ActivePresenter allows showing or hiding the object in each layout individually. To do that, in the
layout that you want to hide the object, select that object > Properties pane > Size & Properties
> Transform > Hidden in Current Layout. (10)

Scaling Text
With the Text Scale feature, ActivePresenter allows you to reduce the text size on smaller devices.
You can scale the text to a specified percentage of its original size. For that to happen, select the
text > Properties pane > Size & Properties > Text Box > Text Scale.
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Creating Projects from PowerPoint Presentation
This is a content-generation method where slides from a PowerPoint presentation are used
instead of recording a target application or creating a blank project. ActivePresenter enables you
to import PowerPoint slides directly even if you do not have Microsoft PowerPoint installed on
your system.
To create a new project from PowerPoint slides, on the Start Page > Import PowerPoint > select
the PowerPoint file from your computer. Alternatively, in the open project window, click the
ActivePresenter button > Import PowerPoint > select the PowerPoint file from your computer.
Note: ActivePresenter cannot handle the *.odp files created by OpenOffice and LibreOffice. You
have to convert these files to pptx files first, then import them into ActivePresenter.
After that, all the objects in each PowerPoint slide are imported into the corresponding
ActivePresenter slide. You can manipulate those objects and annotate the slides in
ActivePresenter.

Creating Projects from Themes or Templates
Creating projects from themes or templates can save you a lot of time in designing content
because you can reuse the project preferences (e.g., slide layouts, object properties) across
multiple projects. It also ensures workflow consistency especially when multiple authors are
working on similar projects.
An ActivePresenter theme or template contains the following:
●

Slide master which includes predefined slide layouts. Each layout may have additional
decoration content.

●

Predefined colors and fonts.

●

Object settings if any (otherwise, default program settings will be used).

●

For the template, there are some pre-created slides with content.

To create a template-based project, on the Start Page > Templates tab > select a theme or
template.
In the Templates tab, you can right-click any theme to open the context menu:
●

Preview: Preview the theme.

●

Blank Project: Create a blank project with the theme you are currently selecting.

●

Record Screen as Video: Record a video demonstration.

●

Record Interactive Simulation: Capture all actions on the screen and then convert them
into a slide-based project.

●

Responsive Project: Create a responsive project with the theme that you are currently
selecting.

●

Set as Default Theme: Set the theme as the default theme.

Creating Projects > Creating Projects from PowerPoint Presentation
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Creating Projects from Video Files
ActivePresenter allows you to create projects from video files, in which your desired video will be
opened in a completely new ActivePresenter project. That new project will have the same size as
the video size.
To create a project from a video, do the following:
1. On the Start Page, click Open. Or, in the open project window, click the
ActivePresenter button > Open Project…
2. In the File name combo box, select All Types or Video Files.
3. Browse the video files on your computer and select one.
4. Click Open.
After that, you can still resize and reposition the video as a normal object.

Converting Projects
Converting from Non-Responsive to Responsive Projects
This feature allows you to convert from a non-responsive project to a responsive project having
up to five default responsive layouts. To get it done, click the ActivePresenter button > Project
> Convert to Responsive Project… The following dialog will appear:
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●

Current Project Size: Show the slide size of the current working project.

●

Add Layouts: Choose which device layouts to insert into the new responsive project.

●

Convert Size & Position to Percentage: Convert unit from pixels to percentages.

●

Scale Content: Choose to scale the content in width, height, or both dimensions.

●

Maintain Aspect Ratio: ActivePresenter will maintain the height-to-width ratio of the slide
size and scale the contents.

●

Scale Text Size: Scale the text to a specified percentage of its original size.

Converting from Responsive to Non-Responsive Projects
ActivePresenter allows you to convert from responsive to non-responsive projects. To get it done,
click the ActivePresenter button > Project > Convert to Non-Responsive Project... > select
one of the layouts. The project will be converted to a non-responsive project having the layout
that you have chosen, without affecting object positions.
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44

ActivePresenter User Manual

Version 9.0

Saving Projects
Saving Projects
After creating and editing a project, you can save it easily by clicking Save changes
in the
Quick Access Toolbar, or by using the CTRL+S hotkey. You can also click the ActivePresenter
button > Save to get the same result.
Alternatively, you can right-click the name of the project that you want to save on the document
tab, then click Save.
Note that when you save a project created with an older version, ActivePresenter will
automatically save it in the new format, and those files cannot be opened with the older versions
anymore. In such a case, ActivePresenter will warn you with a dialog.

Saving Projects as Different Types
ActivePresenter allows you to save existing projects into four types: Project, slide template, object
template, and theme so that you can reuse them as the basis for other projects.
To do that, in the open project window, click the ActivePresenter button > Save As… > select a
type from the Save as type drop-down list. You can also right-click the name of the project that
you want to save on the document tab, and click Save As… > select a type from the Save as
type drop-down list.

●

ActivePresenter Projects (*.approj): Save existing projects as normal projects with all
editings you’ve made. To know how to open an ActivePresenter project, see Opening
Existing Projects.

●

ActivePresenter Slide Template (*.apslide): Save existing projects as slide templates.
If you save templates in the location C:\Users\<user_name>\Documents\ActivePresenter
Templates folder (for Windows) or /Users/<user_name>/Documents/ActivePresenter
Templates folder (for macOS), they will be shown as custom themes on the Start Page.

●

ActivePresenter Object Template (*.apobject): Save existing projects as object
templates.
If
you
save
templates
in
the
location
C:\Users\<user_name>\Documents\ActivePresenter Templates folder (for Windows) or
/Users/<user_name>/Documents/ActivePresenter Templates folder (for macOS), they will
be shown in the Object Templates pane.

●

ActivePresenter Theme (*.aptheme): Save existing projects as themes. If you save
themes in the location C:\Users\<user_name>\Documents\ActivePresenter Templates
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folder (for Windows) or /Users/<user_name>/Documents/ActivePresenter Templates folder
(for macOS), they will be shown as custom themes in the Design tab and Start Page.
To open any type of project, do one of the following:
●

On the Start Page > Open > select one project type from the File name drop-down list >
select a project.

●

In the open project window > ActivePresenter button > Open Project… > select one
project type from the File name drop-down list > select one project.

●

In the open project window > click the
button in the Quick Access Toolbar > select
one project type from the File name drop-down list > select one project.

●

Use the CTRL+O hotkey. ActivePresenter will open the folder containing ActivePresenter
projects for you to select. Now you can select one project type from the File name dropdown list.

Shrinking Projects
A project containing unused resources can be increased in size. Its size can also be increased
after some editing operations. You can choose to reduce the size by shrinking your project.
To get it done, click the ActivePresenter button > Project > Shrink.... ActivePresenter will
display the following dialog:

To remove all unused resources, select the Delete All Unused Resources checkbox > Shrink.
You can also manually choose which resources to remove by clicking the Delete Manually
button. The Project Resources dialog will appear having three tabs. While the Images tab
contains all images of the project, the Audio & Video tab contains all audio and video files of the
project, the Other Resources tab contains other types of resources of the project.
Click the items that you want to remove, then click the Delete icon
You can click the Select Unused Items button
resources for you, then click the Delete icon .

at the top of the dialog.

to let ActivePresenter select all unused

Opening Existing Projects
When you have existing ActivePresenter projects, you can open them again easily.
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Do one of the following:
●

In the open project window, click the ActivePresenter button > Recent Projects > select
a project, or click the
button in the Quick Access Toolbar > select a project.

●

Use the CTRL+O hotkey. ActivePresenter opens the folder containing ActivePresenter
projects for you to select.

●

On the Start Page, select one project from the Recent list to open it.
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Recording Projects
Recording Screen as Videos
You can use ActivePresenter to record the computer screen to create a video demo to show how
your products or services look like. A recorded project captures truthfully all live actions on the
screen along with mouse and keyboard actions while you are interacting with the target
application.
To record a new project, do one of the following:
●

On the Start Page, click Record Screen as Video.

●

In the open project window, click the ActivePresenter button > Record Screen as Video.

After that, the following dialog will appear:

Recording Area Section
This section allows you to specify the region on the computer screen to capture.

●

Full Screen: Allow you to capture the entire computer screen. When you select this mode,
the entire screen will be treated as the recording window and the blue rectangle is invisible.
Besides, ActivePresenter will temporarily change the screen resolution before capturing
and automatically revert to the previous setting when you finish capturing.

●

Custom: Allow you to customize the captured screen in any size and direction by dragging
the floating blue rectangle. ActivePresenter will capture anything that happens inside this
blue rectangle while ignoring the rest of the screen. The fancy cross-hair in the middle is
just a visual reminder that this is a target-seeker window.
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Alternatively, you can specify the captured frame size by entering the width and height value in
the Size spin boxes. Besides, ActivePresenter provides some popular preset video sizes. You
can quickly apply them by using the Preset Sizes button next to the spin boxes (the down arrow
next to the Size spin boxes).
Click Lock to application to select a running application window to snap into the captured area.
The Change Lock Mode button next to the list-of-application combo box provides two options to
define the snap behavior. The Fit To Boundary option will resize the window of the selected
application to fit the recording area. On the other hand, the Fit To Application option will resize
the recording area to fit the window of the selected application.
Note: If the custom size is odd, when you click the Record button, a dialog will appear.

You are asked if you want to continue recording the screen with the custom size, which may
decrease the quality. In case it isn't essential, click Yes.

Audio and Webcam Section
This section provides options for recording audio and webcam during the recording screen. You
can record system audio, audio from the microphone, and webcam simultaneously, which is
common in the practice.
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Audio Section
Click the

button to enable audio recording. The following options become available:

●

Input Devices: Select the input device such as a microphone. If you don’t want to record
any input device, select Do not record microphone.

●

System Audio: Select the system audio (also speaker sound). If you don’t want to record
any system audio, select Do not record system audio.

●

The Volume slider displays the input audio signal level for the audio input device. Before
actual recording, you can speak something into the microphone to test the sound.

The system audio volume can be changed by using the adjust volume tool on your computer.

Webcam Section
Recording screen and webcam video simultaneously come in handy for instructional purposes
such as presentations or game streaming.
To record webcam video, do the following:
1. In the Record Screen as a Video Project dialog, click the
button to enable webcam
recording. A live preview of the camera appears next to the button.
2. Click the arrow on the

button to select the webcam.

3. Click the Format Settings to fine-tune video format if you wish.
4. Click Record to start a capture session.
After capturing, you will get a slide that displays a screencast and the webcam video at the bottomright corner of it. You can reposition, resize, and edit the webcam video the same way as you do
with a normal video.
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Record Button and Settings
The Record button is a big red button that you can click to start recording. After clicking this
button, there will be an ActivePresenter icon appearing in the system tray .

The gear icon at the top-right corner of the dialog allows you to adjust the following options:

●

Recording Settings…: Launch the Recording Settings for Video dialog where you can
change the settings for audio and video, cursor, and hotkeys.

●

Show Recording Area: Show the blue rectangle which indicates the recorded screen area.
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Show Recording Toolbar: Display a toolbar with all necessary controls for the recording.
You can click the gear icon at the top-right corner of the toolbar to toggle its sections.

The Statistics section shows the following project statistics:

●

o

Mode: Show the current recording project mode (Video).

o

Frames: Show the current frame number of the recording project.

o

Dropped: Show the number of missed frames of the recorded video.

Calibrate Audio Input…: Open the Calibrate Audio Input dialog which allows you to
calibrate automatically the audio input.

When you finish the recording, click the Stop Recording button, ActivePresenter will end the
recording and enter the edit mode with an intuitive interface. You can also use the hotkey
CTRL+END to stop the recording.
Note: Some software uses OpenGL for rendering which may not be recorded by ActivePresenter.
Disabling Open GL in the target app may resolve the problem.

Recording Interactive Simulations
Creating interactive simulations is a great way to show others how you practice an application or
software engagingly and lively. Using this feature, you will have a project containing a series of
slides describing how to achieve a specified purpose with the application you are capturing.
To capture a new project, do one of the following:
●

On the Start Page, click Record Interactive Simulation.

●

In the open project window, click the ActivePresenter button > Record Interactive
Simulation.

The following dialog will appear:

Recording Projects > Recording Interactive Simulations

52

ActivePresenter User Manual

Version 9.0

Recording Area Section
This section allows you to specify the region on the computer screen to capture. It has the same
properties and functions as the Recording Area section when you record a video project.

Audio Section
This section provides the option for audio recording. You can record system audio and audio
from the microphone simultaneously. For creating software simulations, a recording webcam isn’t
available.

Record Button and Settings
This section is the same as that of the Record Screen as a Video Project dialog, except for the
following two differences:
●

When you click the gear icon > Recording Settings…, you open the Recording Settings
for Software Simulation dialog where you can change the settings for audio and video,
cursor, annotation, and hotkeys.

●

The mode of the recording can be either Video or Slide. Whenever you scroll the mouse
or carry a drag-n-drop action, ActivePresenter will automatically switch to the Full Motion
Recording mode (Video). Otherwise, it will switch back to the previous capture mode
(Slide). The recording mode is shown in the Recording toolbar.

Stopping the Recording
When you’re done with recording a project, stop the recording and start to edit it. Press
CTRL+END on your keyboard to end the recording.
Alternatively, you can stop the recording using the Recording toolbar. On the system tray of your
computer, click the ActivePresenter icon to show the toolbar. If the Recording toolbar is
currently shown on the screen, skip this step.
●

Click the Pause button
to pause the recording for a while. Click on it again to continue
recording. You can also press SPACE BAR to pause and resume the recording.

●

Click the Stop button

●

Click the Discard button
to discard the recording. In this case, ActivePresenter will
offer you three further options:

to end the recording and step into the editing process.

o

Discard: Abort the current recording without saving the recorded project.

o

Re-capture: Abort the current recording without saving the recorded project and start
a new recording project with previous settings.

o

Continue: Resume the current recording.
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Working with Themes
Using Themes
A theme is a set of design elements, including colors, fonts, background styles, and layouts. Using
themes is a quick way to give your slides a consistent and attractive look and feel.
A design theme consists of:
●

A set of theme colors that contains four text and background colors and eight accent
colors for objects.

●

A set of theme fonts that contains fonts for the heading and body text.

●

A set of twelve preset background styles that define the color of the slide background.

●

A slide master that defines the formatting and placement of text and objects in a slide.
Each slide master has a master layout and a set of custom layouts. If you use more than
one theme in your project, that project will have more than one slide master (and sets of
layouts).

Available themes are displayed on the Start Page. From here, you can click a theme to create a
new project using it. In the open project window, you can view thumbnails of available themes in
the Design tab. In this tab, just click the arrow at the bottom-right corner of the theme gallery to
expand the list.
The theme applied to the current slide will be displayed with a gray outline in the This Project
section. Below this section are two sections for any Custom themes you’ve created and the Builtin themes of ActivePresenter. You can hover the mouse over each thumbnail to see a live preview
before applying a theme.

Working with Themes > Using Themes

54

ActivePresenter User Manual

Version 9.0

Applying Themes
ActivePresenter lets you apply different themes to different slides in your project. To apply a theme
to the current slide, in the Design tab, click a theme thumbnail. The selected theme is also applied
to any other slides using the same theme as the current slide.
You can also right-click a thumbnail and choose the following options:
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●

Apply to Matching Slides: This applies the theme to all slides that use the same slide
master as the current slide. Slides using other slide masters remain unchanged. This
option has the same effect as you left-click a theme thumbnail.

●

Apply to Selected Slides: This applies the theme to the selected slides only.

●

Apply to All Slides: This applies the theme to all slides in your project.

●

Delete...: This removes the selected custom theme. (This option isn’t available for built-in
themes.)

●

Set as Default Theme: This sets the theme as the default for new projects.

Note: If your desired theme (*.aptheme) doesn’t appear in the theme gallery, do one of the following:
●

Copy
the
theme
file
to
the
ActivePresenter
Templates
folder
in
C:\Users\<user_name>\Documents\ActivePresenter Templates (for Windows) or
/Users/<user_name>/Documents/ActivePresenter Templates (for macOS)). Then, restart
the app to see the theme appear in the theme gallery.

●

Click the Design tab > theme gallery > Browse for Themes… to look for this theme and
select it.

Customizing Built-In Themes and Saving as Custom Themes
You can make the following changes to a built-in theme:
●

Changing the theme colors.

●

Changing the theme fonts.

●

Changing the preset background styles.

●

Changing items in the slide master.

Changes you make to a theme will be saved within the current project. If you want to reuse the
custom theme for other projects, do the following:
1. Click the Design tab.
2. Expand the theme gallery by clicking the arrow at its bottom-right corner.
3. Click Save Current Theme….
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This will save the current theme as a custom one. When you open another project, in the Design
tab, custom themes are available in the Custom section of the theme gallery. If you don’t want a
custom theme anymore, right-click it > Delete.

Working with Theme Colors
ActivePresenter includes sets of built-in theme colors that determine the default color choices for
text, background, fill styles and outlines. You can use built-in theme colors or set up your own
sets to fit your needs.
To see available theme colors, in the Design tab, click the Colors button . This opens the
theme color gallery that contains both Custom and Built-in theme colors. Each set of theme
colors contains four colors for text and background and eight accent colors for objects. The theme
colors in use are shown with a gray outline. You can hover the mouse over a set of theme colors
to see a live preview before applying it.
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Applying Theme Colors
To apply a set of theme colors, do the following:
1. Click the Design tab > Colors

to open the theme color gallery.

2. Click a theme color set to apply it to the current slide and any other slides sharing the
same slide master with the current one.
You can also right-click a theme color set and choose the following options:
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●

Apply to Matching Slides: This applies the theme colors to all slides that use the same
slide master as the current slide. This option has the same effect as you left-click a set of
theme colors.

●

Apply to Selected Slides: This applies the theme colors to the selected slides only. If the
change doesn’t satisfy you, click Reset Slide Theme Colors to restore the original colors.

●

Apply to All Slides: This applies the theme colors to all slides in your project.

●

Edit…: This lets you modify the selected custom theme colors. This option isn’t available
for built-in theme colors.

●

Delete...: This removes the selected custom theme colors. This option isn’t available for
built-in theme colors.

Creating Custom Theme Colors
To create a set of custom theme colors, do the following:
1. Click the Design tab > Colors

to open the theme color gallery.

2. Click Create New Theme Colors….
3. In the dialog that appears, assign a color to each item. If you don’t see the color you want
in the color picker, click More Colors... You can also click Eyedropper… to sample a
color from within the application window.
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4. If you want to discard all changes and start over, click Reset.
5. In the Name text box, enter a name for your new theme colors.
6. Click OK to save changes. The custom theme colors are now available in all projects.
After that, in the theme color gallery, you can right-click a set of custom theme colors > Edit… to
modify it. If you don’t want a set of custom theme colors anymore, right-click it > Delete….

Working with Theme Fonts
You can apply a consistent set of theme fonts to an entire project. Theme fonts allow you to
quickly change the fonts used for all the objects in a slide, including slide titles, shapes, text
captions, text boxes, buttons as well as text in questions and answer choices. You can use builtin theme fonts or create your theme fonts as you wish.
To see available theme fonts, in the Design tab, click the Fonts button . This opens the theme
font gallery that contains both Custom and Built-in theme fonts. Each set of theme fonts contains
a heading font for slide titles and a body font for body text. The theme fonts in use are shown with
a gray outline. You can hover the mouse over a set of theme fonts to see a live preview before
applying it.
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Applying Theme Fonts
To apply a set of theme fonts, do the following:
1. Click the Design tab > Fonts

to open the theme font gallery.

2. Click a theme font set to apply it to the current slide and any other slides sharing the same
slide master with the current one.
You can also right-click a theme font set and choose the following options:

●

Apply to Matching Slides: This applies the theme fonts to all slides that use the same
slide master as the current slide. This option has the same effect as you left-click a set of
theme fonts.

●

Apply to Selected Slides: This applies the theme fonts to the selected slides only. If the
change doesn’t satisfy you, click Reset Slide Theme Fonts to restore the original fonts.

●

Apply to All Slides: This applies the theme fonts to all slides in your project.

●

Edit…: This lets you modify the selected custom theme fonts. This option isn’t available
for built-in theme fonts.

●

Delete...: This removes the selected custom theme fonts. This option isn’t available for
built-in theme fonts.

Creating Custom Theme Fonts
To create a set of custom theme fonts, do the following:
1. Click the Design tab > Fonts

to open the theme font gallery.

2. Click Create New Theme Fonts….
3. In the dialog that appears, specify the heading and body fonts. You can preview the
fonts in the Sample box.

Working with Themes > Using Themes

62

ActivePresenter User Manual

Version 9.0

4. In the Name text box, enter a name for your new theme fonts.
5. Click OK to save changes. The custom theme fonts are now available in all projects.
After that, in the theme font gallery, you can right-click a set of custom theme fonts > Edit… to
modify it. If you don’t want a set of custom theme fonts anymore, right-click it > Delete….

Working with Preset Background Styles
Each theme comes with a set of twelve preset background styles that can be used to quickly
change the background fill in a slide. You can also customize the preset background styles as
you wish.
To see the preset background styles, click the Design tab > Background Styles . This opens
the preset background gallery that contains twelve styles. The colors of these styles depend on
the theme colors of the project. The background style in use is shown with a gray outline. You
can hover the mouse over a style to see a live preview before applying it.
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Applying Preset Background Styles
To apply a preset background style, do the following:
1. Click the Design tab > Background Styles

to open the preset background gallery.

2. Click a style to apply it to the current slide and any other slides sharing the same slide
master with the current one.
You can also right-click a style and choose the following options:

●

Apply to Matching Slides: This applies the style to all slides that use the same slide
master as the current slide. This option has the same effect as you left-click a style.

●

Apply to Selected Slides: This applies the style to the selected slides only. If the change
doesn’t satisfy you, click Reset Slide Background to restore the original background style.

●

Apply to All Slides: This applies the style to all slides in your project.

Note: In a slide, you can hide the background graphics originating from the slide master. Just
select Hide Background Graphics.

Customizing Preset Background Styles
You can customize the preset background styles in the slide master view. Do the following:
1. Select the slide that you want to modify its preset background style.
2. Click the View tab > Slide Master to open the slide master view. In the left pane, the
layout used by the current slide is selected.
3. Click the Properties pane > Slide Properties > Background Fill. Use options in this
section to modify the background style.
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4. To hide the background graphics originating from the slide master, select Hide
Background Objects.
5. If you want to discard all changes and start over, click Reset Background.
6. Click Apply to Preset and select a preset background you wish to change. The new style
will be applied immediately.

Using Slide Masters
Slide masters allow you to easily design the default themes, colors, fonts, background styles,
text, and objects for slides. Besides formatting, slide masters let you determine the placement of
objects in slides. Thus, you can use slide masters to apply the same look and feel to multiple
slides in your project.

Opening and Closing Slide Master View
To view and customize slide masters, you need to switch to the slide master view. Click the View
tab > Slide Master
to open the slide master view where any slide master previously set up for
the project appears in the left pane. If you create a blank project or haven’t designed any slide
master yet, you will see a default slide master.
A slide master consists of a master layout and a set of built-in layouts. In the left pane, the master
layout is the first thumbnail which appears slightly larger than all other thumbnails of built-in
layouts below it.
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Title Slide Layout appears by default when you open a blank project. There are two text
placeholders: presentation title and subtitle.
Title and Content Layout consists of a title placeholder and a content placeholder. The
content placeholder allows you to add some annotation & media objects, interactive
questions, and report control.
Two Content Layout as a title placeholder and two content placeholders.
Question Layout includes a title placeholder and a question placeholder. The latter allows
you to add one of the questions that are available in the Question tab.
Question with Media Layout provides you with 3 placeholders. They are Title, Question,
and Media. While the Question layout contains questions, the Media allows you to insert
an image, a video, and a 3D model.
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Report Slide Layout has a title placeholder, a Report placeholder, and the Review
Course button.
Title Only Layout has only a title placeholder.
Blank Layout is just a blank slide without any placeholders.

The built-in layouts inherit all the properties from the master layout. However, you can make
changes to each of them as you wish. All changed properties will no longer be inherited from the
master layout. You can create a new slide master or add more custom layouts to a slide master
if you want.
In the tabbed toolbar, the Slide Master tab appears with a set of commands for customizing slide
masters. When you’re done, click the Close Master View button to switch to the normal view and
edit slides. Changes you make to slide masters and their layouts will be automatically applied to
slides based on them.

Adding Slide Masters and Layouts
To add a new slide master, click the Slide Master tab > Insert Slide Master . Alternatively,
right-click in the left pane > Insert Slide Master. The new slide master will be inserted below the
selected slide master.
To add more custom layouts to a slide master, do the following:
1. In the left pane, select the slide master to which you want to add more layouts.
2. Click the Slide Master tab > Insert Layout
Insert Layout.

. You can also right-click in the pane >

The new custom layout will be inserted below the selected layout. It has a default title placeholder
and three footer placeholders.
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Managing Slide Masters and Layouts
Duplicating Slide Master and Layouts
You can duplicate a slide master or layout to create a similar one. In the left pane, right-click the
master layout or a custom one > Duplicate Master/Layout .

Copying Slide Masters and Layouts
To copy a slide master or layout, in the left pane, select them respectively and follow any step
below:
•
•
•

In the Home tab > click Copy.
Press CTRL+C.
Right-click them > Copy .

When pasting the selected slide masters or layouts, do one of the following:
•
•
•

In the Home tab > click Paste.
Press CTRL+V.
Right-click them > Paste
or Paste (Keep Source Formatting)

.

Note:
•

•

The Paste and CTRL+V commands work the same way as Paste (Use Destination
Theme) . It is to take the theme of the destination presentation. This will adapt the
copied slide to match the destination theme.
The Paste (Keep Source Formatting) is to maintain the theme of the presentation you
are copying from.

Removing Slide Masters and Layouts
If you no longer need a slide master or a custom layout, just remove it. Note that you cannot
remove any slide master or layout that is currently used by any slide in your project.
To delete a slide master and all of its layouts, select the master layout and press DELETE.
Alternatively, click the Slide Master tab > Delete
or select Delete Master from the context
menu.
To delete a custom layout, select it and press DELETE. You can also click the Slide Master tab
> Delete or select Delete Layout from the context menu.

Renaming Slide Masters and Layouts
If there are many similar slide masters or layouts within your project, you should give them
descriptive names to easily select and apply them later. Just select the master layout or a custom
one and click the Slide Master tab > Rename . In the dialog that appears, enter the desired
name and click OK. Alternatively, you can right-click the master layout or a custom one > Rename
Master/Layout.

Preserving Slide Masters
A slide master that is not in use will be deleted automatically. If you want to keep it in your project
for later use, just preserve it. In the left pane, select the master layout of the slide master you want

Working with Themes > Using Slide Masters

68

ActivePresenter User Manual

Version 9.0

to preserve and click the Slide Master tab > Preserve . Alternatively, right-click the master layout
> Preserve Master. Then, a pushpin icon appears at the top-left corner of the master layout.

If you don’t want to preserve a slide master anymore, click the Preserve button again. In that
case, if the slide master isn’t used by any slide, a confirmation dialog will appear asking whether
you want to delete it.
Keep in mind that a newly added slide master is automatically preserved.

Designing Slide Masters and Layouts
A layout consists of one or more placeholders. Placeholders are containers that hold different
types of content such as text, images, videos, and questions. They provide a quick and easy way
to insert different types of content into slides. In addition, using placeholders is a good way to
consistently define the formatting and positioning of slide contents across slides in your project.
To design a layout, you can add or remove placeholders as well as apply themes, theme colors,
theme fonts, and preset background styles. Use commands in both the Slide Master tab and the
Home, Insert, Transitions, and Animations tabs to design slide master and layouts.

Inserting Placeholders
You can modify custom layouts by adding any of twelve placeholder types.
●

Content : Hold any one type of the following content: images, videos, 3D models,
charts, tables, 13 types of questions, and report controls.

●

Text , Image , Video , Report
controls, and buttons, respectively.

●

Media

●

Question

●

Flex Box
, Grid Box : Hold items such as objects and questions which can be
vertically and/or horizontally aligned within a container.

●

Chart

, Button

: Hold text, images, videos, report

: Hold either images, videos, or 3D models.
: Hold any one type of question.

, Table

: Hold either charts or tables.

Do the following to add placeholders to a custom layout (not the master layout):
1. In the left pane, select the custom layout to which you want to add a placeholder.
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3. Reposition and resize the placeholder as you want.
4. If you add a text placeholder, you can modify the text style.

Removing Placeholders
To remove placeholders from the master layout and its corresponding custom layouts, do the
following:
1. Click the master layout.
2. Select a placeholder and press DELETE. Alternatively, click the Slide Master tab >
Master Layout > clear any checkbox.
To remove a placeholder from a custom layout, select it and press DELETE. In the case of title
and footer, you can clear the Title and Footers checkboxes in the Slide Master tab.

Applying Themes to Slide Masters
Using themes allows you to apply a consistent design to a slide master and its layouts. Just select
a slide master and click the Slide Master tab > Themes
> click a thumbnail. The selected
theme will be applied to all slides in your project.
You can also right-click a thumbnail and choose Apply to Selected Slide Master or Apply as
New Slide Master.

These two options work as follows:
●

If the selected slide master is in use or not preserved, this theme will be applied to it.

●

If the selected slide master is preserved, a new slide master based on this theme will be
added.

●

If there are multiple selected slide masters, this theme will be applied to any slide master
that is in use or preserved. Other selected slide masters will be removed completely.

If your desired theme (*.aptheme) doesn’t appear in the theme gallery, click Browse for
Themes… to look for this theme and select it. You can also customize a built-in theme and save
it as a custom theme. To learn more about themes, see Using Themes.

Applying Theme Colors to Slide Masters
Using theme colors allows you to apply a consistent color scheme to a slide master and its layouts.
You can preview a theme color set by clicking the Slide Master tab > Colors
and hovering
over it.
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●

To apply a theme color set to one or more selected slide masters, just click the set or rightclick it > Apply to Selected Slide Masters.

●

To apply a theme color set to all slide masters, right-click it > Apply to All Slide Masters.

●

To apply a theme color set to one or more selected layouts, right-click it > Apply to
Selected Layouts. If the change doesn’t satisfy you, click Reset Slide Theme Colors to
restore the original colors.

●

To create a set of custom theme colors, click Create New Theme Colors….

●

To learn more about theme colors, see Working with Theme Colors.

Applying Theme Fonts to Slide Masters
Using theme fonts allows you to apply consistent fonts to a slide master and its layouts. You can
preview a theme font set by clicking the Slide Master tab > Fonts
and hovering over it.

●

To apply a theme font set to one or more selected slide masters, just click the set or rightclick it > Apply to Selected Slide Masters.

●

To apply a theme font set to all slide masters, right-click it > Apply to All Slide Masters.

●

To apply a theme font set to one or more selected layouts, right-click it > Apply to
Selected Layouts. If the change doesn’t satisfy you, click Reset Slide Theme Fonts to
restore the original fonts.

●

To create a set of custom theme fonts, click Create New Theme Fonts....

●

To learn more about theme fonts, see Working with Theme Fonts.

Applying Preset Background Styles to Slide Masters
Using preset background styles allows you to apply a consistent background to a slide master
and its layouts. You can preview a preset background style by clicking the Slide Master tab >
Background Styles
and hovering over it.
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●

To apply a preset background style to one or more selected slide masters, just click the
style or right-click it > Apply to Selected Slide Masters.

●

To apply a preset background style to all slide masters, right-click it > Apply to All Slide
Masters.

●

To apply a preset background style to one or more selected layouts, right-click it > Apply
to Selected Layouts. If the change doesn’t satisfy you, click Reset Slide Background
to restore the original background style.

●

To hide the background graphics originating from the slide master, select Hide
Background Graphics. This option is only available for custom layouts.

●

To customize a preset background style, use options in the Properties pane >
Background Fill.

●

To learn more about preset background styles, see Working with Preset Background
Styles.

Changing Slide Size
The size of layouts in the slide master view is the same as that of slides in the normal view. If you
want to change the slide size as well as the layout size, do one of the following:
●

In the slide master view, click the Slide Master tab > Slide Size

.

●

In the normal view, click the Design tab > Slide Size. Alternatively, click the
ActivePresenter button > Project > Properties > Properties pane > General section >
click Change Size.

●

To change the default slide size when creating new projects, click the ActivePresenter
button > Preferences > General > Default Project Size.

Note: Slide size doesn’t apply to responsive projects.

Applying Slide Layouts to Slides
There is more than one way to apply layouts to slides in your project. You can insert a new slide
using the layout you’ve designed or change the layout of an existing slide.

Applying Layouts to New Slides
To apply layouts to new slides, in the normal view, do the following:
1. In the Home tab or the Insert tab, click the arrow on the New Slide button

.

2. Choose a layout.
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A new slide using the selected layout will be inserted below the current one.

Changing Layouts of Existing Slides
To change the layout of an existing slide, in the normal view, do the following:
1. Select one or more slides whose layouts you want to change.
2. Click the Home tab > Layout

. Select a layout from the gallery.

The selected layout will be applied to all the selected slides. Alternatively, in the Slides pane, you
can right-click slides > Layout and choose a layout.

Using Feedback Masters
Feedback Master Overview
The Feedback Master feature allows you to create and edit feedback layers. These layers are
shown as popups on the slide when users finish questions. With this feature, you can easily
customize complex feedback messages.
Feedback Master consists of a Feedback Master Layout and feedback layers. The Feedback
Master Layout is the base layer that other layers inherited from. Its layout and style can be
applied to all below feedback layers.
In general, one Feedback Layer contains 3 placeholders, namely Title (1), Text (2), and Button
(3). The Title and Text provide users with feedback on their results. The Button allows users to
decide what to do next. You can edit their styles, add more objects like buttons or images to the
layers to give users more information or details.

The feedback message now is isolated from slides or slide masters so users can freely edit and
customize it.
1. Generally, the feedback master is almost like the slide master, except for some differences:
●

The feedback layers are used directly in the Show/Hide Feedback Layer action. You can
select which layer to show or hide from the list when adding events and actions to objects.
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The placeholders in the feedback layer are treated as normal objects. You can customize
them the way you want. Besides, you can change the background style for the feedback
layer. The style will be inherited from the feedback master layout.

2. A feedback layer is almost the same as a slide. So, users can add objects, animations, or
transitions to them.
3. The On Correct, On Incorrect, On Complete, On Incomplete, and On Timeout events have
the default action which is showing the feedback layer. For example, the default action of the On
Correct event is showing the Correct Feedback layer.

4. A Show Feedback Layer action has three options:

●

Variable: Checking this option to use variable to show feedback layer.

●

Hide After: The feedback layer automatically hides after a while that you set in the spin box.

●

Blocking: Checking this option will block the main timeline when the feedback layer is
showing.

Opening and Closing Feedback Master View
To open the feedback master view and edit the default feedback master, click the View tab >
Feedback Master . Then, the feedback master will appear in the left pane. If there is no custom
feedback master yet, you will see the default feedback master.
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By default, a feedback master includes at least 1 master feedback layout and built-in feedback
layers. These feedback layers are used in question events. However, you are free to customize
them to meet your needs. You can also add more feedback layers.

●

Correct Feedback: Used in the On Correct event to let users know that their answer is correct.

●

Incorrect Feedback: Used in the On Incorrect event if the current attempt is the last
attempt, letting users know that their answer is not correct.

●

Try Again Feedback: Used in the On Incorrect event if the current attempt is not the last.
The message lets users know that their answer is not correct and they can try it again.

●

Complete Feedback: Used in the On Complete event to let users know that they have
completed the answer.

●

Incomplete Feedback: Used in the On Incomplete event. The message lets users know
that they have to complete answering the task before moving to the next one.

●

Timeout Feedback: Used in the Timeout event. The message appears to let users know
that the time to do the task is run out.

●

Resume Feedback: This feedback layer appears if the last session is incomplete. It is
triggered in the On Load event of the project. You have to use the
apLastSessionIncomplete variable to check if the presentation is complete or not. There
are two buttons (Resume and Restart) in this layer to let users resume or restart the
presentation.
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●

Review Feedback: This feedback layer is used in the review mode. It is triggered in the
On Load event of the project. You have to use the apReviewMode variable to check if
the presentation is in the review mode or not. There are two buttons (Previous and Next)
in this layer. They let users navigate the presentation when reviewing a course.

●

Blank Feedback: A preserved feedback layer.

ActivePresenter provides you with the Feedback Master tab with tools allowing you to adjust the
feedback messages.

With this tab, you can:
●

Insert new layers. The newly inserted layers will have the same style as the feedback
master layout.

●

Delete or rename the selected layers.

●

Define which placeholders will be included in the selected layout (title, text, and button).

●

Style the layer’s background.

To close the feedback master view, click Close Master View
in the Feedback Master tab. All
the changes you made will be applied to the feedback messages.

Adding New Layers
ActivePresenter allows adding as many new feedback layers as you want.
To insert a new layer into a feedback master, do one of the following:
●

In the Feedback Master tab, click Insert Layer

.

●

Right-click any thumbnail in the left pane and select Insert Layer

.

Note that each slide master can have only one Feedback Master Layout and you cannot add
more. You can only add more feedback layers.

Managing Feedback Masters and Layers
Duplicating Feedback Layers
ActivePresenter allows you to duplicate the feedback layers, making it easier for you to create
similar layers when needed. You cannot duplicate the feedback master layout.
To do that, right-click any layer on the left pane > Duplicate Layer

.

Copying Feedback Layers
To copy a layer, select the layer > press CTRL+C or right-click it > Copy. You cannot copy the
Feedback Master Layout. Then, do one of the following:
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Press CTRL+V
Right-click > Paste or Paste (Keep Source Formatting). The copied layer is
duplicated in both commands since there is only one format applied in one Feedback
Master.

Removing Layers
If there are any layers that you don’t want to use, just remove them. Note that you cannot delete
the feedback master layout.
To delete feedback layers, select them then do either of the following:
•
•
•

Feedback Master tab > Delete.
Press the DELETE key.
Right-click > Delete Layer.

Renaming Layouts and Layers
Do any of the following to rename the layouts and layers:
●

Select the layout or layers > Feedback Master tab > Rename

.

●

Right-click the layout or layers > Rename Master/Rename Layer.

Inserting and Removing Placeholders
To show or hide the placeholders on the feedback message, simply select/clear the checkboxes
of corresponding properties in the Feedback Master tab.

Styling Feedback Messages
You are free to style the background and the placeholders of the feedback layers. Every change
in the layout will be applied to all the corresponding layers.
•

To change the background style of the feedback message, in the Feedback Master
Layout, select the message on the Canvas > Format tab > change the shape, style, fill,
line, and shadow the way you want. This can be changed in the Properties pane > Style
& Effects tab > Fill/ Line/ Shadow section too. You can also change the size of the
feedback layers by dragging their border. But, keep in mind that, these changes can only
be done in Feedback Master Layout.
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●

To style the text (font, size, and color...) > select them > then use the buttons and
commands in the Home tab or the inline text editor that appears.

●

To design the Button of the message, select the button > Format tab > change the shape,
style, etc.
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Working with Slides
Inserting Slides
ActivePresenter provides you several ways to insert slides, from inserting a new slide to copying
slides from other projects.

Inserting Slides
Inserting New Slides
To insert a new slide, in the Home tab or the Insert tab, click the arrow on the New Slide button
and select a slide from the slide gallery.

You can also simply click the New Slide button or right-click the Slides pane > New Slide to
insert a new slide that uses the same layout as the current slide. The new slide will be inserted
below the current one.
Slides always come with layouts. You can do the following:
●

Change layouts: Click the Home tab > Layout
> select a layout. Alternatively, in the
Slides pane, right-click a slide > Layout > choose another layout.
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●

Restore original layouts: Click the Home tab > Reset
> Reset.

. You can also right-click a slide

●

Modify and create new layouts: Click the View tab > Slide Master
view. Then you can customize the layout the way you want.

to open the master

Inserting Slides from Recording Screen
ActivePresenter allows you to record a screencast or a software simulation and insert them as
new slides in your project. These two methods are similar to recording projects, but instead of
creating new projects, they just create new slides in the current project.
To add a recording screen slide, in the Home tab or Insert tab, click the arrow on the New Slide
button > Record Screen as Video or Record Interactive Simulation. Alternatively, you can
access the Home tab > Record Screen
> Record Screen as Video
or Record Interactive
Simulation .

Inserting Slides from Templates
Besides themes, you can use slide templates (also templates) to quickly create new projects with
ready-made slide layouts and contents. Everything you’ve added to a slide is reusable when you
use slide templates.
To insert slides from a slide template, do the following:
1. In the Home tab or the Insert tab, click the arrow on the New Slide button
from Templates... .

> Slides

2. In the window that appears, select the desired template in Template.
3. In the Slides section, there are several options:
•
•
•

Select All: Click the button if you want to select all slides.
Deselect All: Click the button to deselect all slides.
Drag the Zoom slider to zoom in or zoom out the slides.

4. Click Insert Slide to insert the selected slides into the current project.
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Note: Slide templates appear in the window only when they are stored in the ActivePresenter
Templates folder (C:\Users\<user_name>\Documents\ActivePresenter Templates (for Windows)
or /Users/<user_name>/Documents/ActivePresenter Templates (for macOS)).

Inserting Slides from Images
You may have a collection of pictures and want to import them into ActivePresenter as slides.
Supported image input formats include BMP, PNG, JPG, JPEG, JPE, GIF, ICO, CUR, ANI, XPM,
and SVG.
To insert images as slides, in the Home tab or the Insert tab, click the arrow on the New Slide
button
> Slides from Images… .

Working with Slides > Inserting Slides

81

ActivePresenter User Manual

Version 9.0

In the dialog that appears, do the following:
●

Add images from file: Click

●

Remove selected images: Click

●

Reorder images: Click
pane.

or

●

Flip images: Click

to flip images horizontally or vertically.

●

Rotate images: Click

●

Select Use images as objects if you want each image to be inserted into each slide as a
slide object. Otherwise, images will be treated as the background of each slide.

or
or

to import images from your computer.
if you no longer want an image.

. The image order will be the slide order in the Slides

to rotate images 900 right or left.

Note: Images will be clipped if their size is larger than the slide size. In this case, you can change
the slide size so that the images are displayed properly.

Inserting Slides from PowerPoint Presentations
You can convert PowerPoint slides to new slides in the current project. This method is similar to
creating a new project by converting PowerPoint presentations. However, instead of creating new
projects, it just creates new slides in the current project.
To insert slides from PowerPoint presentations, in the Home tab or the Insert tab, click the arrow
on the New Slide button
> Slides from PowerPoint... .
Depending on the size of the current slides and of the PowerPoint slides, there will be a dialog
that appears for you to customize. It works the same way as when you change slide size.
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Inserting Slides from ActivePresenter Projects
You can reuse slides from another ActivePresenter project. Do the following
1. In the Home tab or the Insert tab, click the arrow on the New Slide button
from ActivePresenter… .

> Slides

2. Select an ActivePresenter project.
3. In the dialog that appears, select the slides you want to reuse.
4. Click OK to import slides.

You can also copy slides across projects. However, bear in mind that different projects may have
different slide sizes. Thus, importing or copying slides may make the slide content clipped or
distorted. Therefore, always check the slide size of both the source and destination projects
beforehand.

Copying Slides
You can copy slides in the same project or across different projects. To copy slides, do the following:
1. Select one or more slides.
2. Press CTRL+C or right-click > Copy. Alternatively, click the Home tab > Copy.
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3. You can paste the copied slides into the same project or another project. The copied slides
will be inserted below the current slide:
●

To take the theme of the current slide: Press CTRL+V or right-click > Paste or click
the Home tab > Paste (Use Destination Theme)
to match the destination theme.

●

. This will adapt the copied slides

To maintain the theme of the slides you are copying, right-click > Paste (Keep Source
Formatting)
or click the Home tab > Paste (Keep Source Formatting). This will
make the copied slides keep their original theme format.

Duplicate Slides
To reuse one or more slides, rather than manually copying and pasting, you can duplicate them.
Follow these steps to achieve it:
1. Select the slide(s) that you want to duplicate.
2. Right-click them and select Duplicate or press CTRL+D.
The duplicated slide(s) will then appear under the last slide that you selected. For example, you
selected slide 3 and 1 orderly, then duplicated them. The duplicated slides will be added under
slide 1.

Removing Slides
If you no longer want a slide, select it and press DELETE. Alternatively, right-click it > Delete.
You can hold down CTRL while clicking slides to select more than one slide and remove them at
the same time.

Changing Slide Properties
Naming Slides
It’s always a good idea to give slides recognizable names, so it makes it easier for you to find
them later.
To name a slide, click the Properties pane > Slide Properties > General. Give the slide name
and description using the corresponding text boxes. You can further edit the slide name and
description by clicking the Edit buttons
next to the text boxes.
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In the Slides pane, if the view mode is Slides In titles (right-click Slides pane > Slides In Titles),
you can double-click each entry or right-click an entry > Edit Name to name a slide.

Another way to name slides is by using a batch operation that generates a slide name from the
first shape in each slide. This is useful when you want to name slides in a software simulation.
Do the following:
1. Click the ActivePresenter button > Project > Batch Operations > Generate Slide Name
From First Shape.
2. In the dialog that appears, the Current Name column shows the current name of slides
while the New Name column shows the text inside the first shape in each slide. To rename
a slide, double-click a name in the New Name column or click a row > Edit Name.

3. Select the slides you want to name by selecting their corresponding checkboxes.
4. Click OK to apply changes.

Ordering Slides
It’s easy to reorder slides. In the Slides pane, just drag a slide to the order you want. Keep in
mind that you cannot drag slides when the view mode is Slides In Titles.
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Advancing Slides
By default, the presentation jumps to the next slide immediately when the current slide ends
thanks to the Auto Advance option. You can find this option in the Transition tab or Properties
pane of a slide > General section.
You can disable this option and use actions, such as Continue Presentation, Go Forward, or
Go to Slide to advance slides.

Changing Slide Background Fill Styles
You can fill the slide background with a solid color, a gradient, or an image. Get this done using
the Background Fill section in the Properties pane.

Besides, you can:
●

Hide Background Objects: Hide the background objects originating from the slide masters.

●

Apply to All: Apply the background fill style of the current slide to all slides in your project.

●

Reset Background: Restore the default background fill style of the current slide.

Adding Background Images to Slides
Apart from background fill styles, you can add background images to slides. Do the following:
1. Select one or more slides.
2. Click the Properties pane > Slide Properties > Background Image.
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or your computer

.

4. Specify the position and size using the Left, Top, Width, and Height spin boxes.
5. If you want to revert the image to its original size, click Restore Original Size.
6. If you want to stretch the image so that it fits into the background, click Fit To
Background.
7. If you no longer want a background image, click Remove

.

To further edit the background image, on the Canvas, right-click a slide > Edit Background Image.
This opens the Image editor and the Drawing tab, which helps you edit the image as you wish.

While editing the background image, once you click Save in the Quick Access Toolbar, all your
changes to the image will be applied and reflected in the slide. When you’re done, close the Image
editor and go back to editing the slide.

Changing Slide Container Layout
ActivePresenter supports two different layouts for a slide, which are Grid and Flex. They can be
found in the Properties pane of a slide > Size & Properties > Container Layout.

When you create a new blank project or insert a new slide, the default slide container layout is
None. This layout allows you to change the size and position of any object on the slide freely.
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Using the Flex layout or Grid layout makes it easy to align and distribute the spacing of objects
in a slide efficiently.

Using Container Layout (Flex & Grid)
ActivePresenter also supports 14 built-in layouts for a slide. To insert layouts into a slide, go to
the Home tab or the Insert tab > Container > Preset Slide Layouts.

Immediately, the slide will, by default, include flex boxes with a flex layout. You can change the
layout of these boxes to a grid layout by going to the Properties pane, and then adding more
layouts and objects to them. To work with flex box and grid box, see Container for more details.

Excluding Objects from Slide Container Layout
Once you select either Flex or Grid for any container layout, the Container Snapping mode will
be enabled by default. That is to say, when you move objects into a slide container layout, objects
will be automatically snapped to that layout (the slide turns orange). Besides, any object in a slide
can be included in or excluded from the slide container layout. If an object is excluded from the
layout, you are free to place them anywhere on the slide. To make one or more objects excluded
from the slide container layout, you can select them first and then do either of the following:
●

Right-click the objects > Exclude from Container Layout.

●

Go to the Properties pane > Size & Properties > Transform > select the Exclude from
Container Layout checkbox.

●

You can temporarily disable the snap behavior by holding down ALT while moving objects.
Or turn off this mode by clicking the View tab > Container Snapping.

Changing Slide Operation Modes
ActivePresenter allows you to choose operation modes for a slide to determine if it appears in a
certain mode in the output when creating HTML5 content.
You can determine operation modes for one or more slides as follows:
1. Select one or more slides.
2. Click the Properties pane > Size & Properties > Show in Mode > choose the modes
you want.

Working with Slides > Changing Slide Properties

88

ActivePresenter User Manual

Version 9.0

Adding Transition Effects
While presenting, slide transitions are visual effects that appear when you move from slide to
slide. You can control the style and speed of transition effects and apply different effects to
different slides in your project.

Adding Transition Effects
To apply a slide transition effect, do the following:
1. In the Slides pane, select one or more slides.
2. Click the Transitions tab > select an effect from the gallery.

3. Specify the effect option (if any) and duration of the effect.
4. In the Timeline pane, the transition effect is represented by a blue diamond. Click the
Preview button
or press SPACE BAR to preview.
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Slide transition effects can also be applied to slide masters.

Removing Transition Effects
To remove slide transition effects, select a slide, then do one of the following:
●

In the timeline, drag the blue diamond downward until it turns gray, then release the mouse
button.

●

Click the Transitions tab > None from the gallery.

Managing Slides
Splitting and Merging Slides
When a slide is rather long with many contents, you may want to split it into two or more slides.
To split a slide, do the following:
1. In the timeline, choose a timestamp where you want to split the slide.
2. Click Split Slide

on the toolbar of the Timeline pane.

Then, your slide will be split into two slides at the Playhead position. The new slide contains all
the objects and other properties on the right side of the Playhead and is inserted right below the
current one.
If the Playhead lies in the middle of an object time bar, the time bar will be split and the latter part
will be transferred to the new slide.
If you want to merge slides into one, hold down CTRL or SHIFT to select multiple slides and rightclick them > Merge Slides.

Changing Slide View Modes
The Slides pane displays slide thumbnails in the following three modes:
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●

Slides in Column
(1): Slide thumbnails expand their size to fit into the pane. This is
the default view mode.

●

Slides in Grid

●

Slides in Titles

(2): Slide thumbnails are arranged into multiple columns and rows.
(3): Only slide titles are displayed.

To change the view mode, right-click the Slides pane > choose the mode you want. You can also
click the View tab > Slides View > choose the view mode.

Saving Slides as Images
ActivePresenter allows you to export your project to images. That way, each slide will be exported
to an image. If you want to save just one slide to an image, the app gives you another feature. On
the Canvas, right-click a slide > Save Slide As Image... . Alternatively, you can right-click the
selected slide in the Slides pane to get the same result. Supported formats include PNG, JPG,
and BMP.
This feature is useful when you have a particular slide that you want to use in different projects.
It also lets you save a particular scene in a video to an image so that you can use it in the written
tutorial, for example.

Saving Slides as Videos
The Save Slide As Video feature comes in handy when you want to export one or more the
selected slide as a video, instead of exporting the whole project.
•

To save a slide as video: you can right-click a slide on the Canvas or in the Slides pane
> Save Slide As Video… .

•

To save selected slides as video: you select multiple slides (press and hold SHIFT for
multiple sequential slides, CTRL for multiple non-sequential slides). Then, right-click
selected slides and click Save Selected Slides As Video…

.

After that, you are enabled to further adjust the output options in the Export To Video dialog.
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Inserting and Managing Objects
Inserting Objects
There are two types of objects in ActivePresenter:
Annotation objects: container, shapes, text caption, spotlight, equation, icons, gesture
effects, footer, chart, table, image, screenshot, audio, video, YouTube video, web object,
3D model, cursor path, zoom-n-pan, and closed caption.
Interaction objects: mouse click, key stroke, text entry, drop area, button, checkbox, radio
button, slider, dropdown, animated timer, and questions.

Inserting and Removing Objects
To insert an object, click the Insert tab and choose the object you want (click the Questions tab to
insert a question). The object will be inserted into the current slide. After that, you can rename the
object by clicking the Properties pane > Interactivity > General or going to the Selection pane.
If you no longer want an object, select it on the Canvas, in the Timeline pane or the Selection
pane, then press DELETE. Alternatively, right-click the object > Delete. The same steps are
applied to remove more than one object in a single slide.

Inserting and Removing Objects in Multiple Slides
ActivePresenter makes it easy to insert objects into multiple slides as well as remove multiple
objects from multiple slides.

Inserting Objects into Multiple Slides
If you want to do a batch operation to insert an object into multiple slides, do the following:
1. Click the ActivePresenter button > Project > Batch Operations > Insert Objects…
2. In the dialog that appears, select the object type that you want to insert.

3. Specify the slides into which you want to insert the object. If you choose Specified Slides,
separate the ordering numbers of slides by commas. Otherwise, use hyphens to indicate
ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, and 6th slides.
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4. Click OK to apply.
Once the batch processing finishes, the selected object will appear in all specified slides with the
same properties. Then, you can edit each of these objects individually or style all of them in the
same way. See Changing Style and Effects for details.
Note: You might want to make a single object appear in all slides in the presentation. This is
useful when the object is a corporate logo or background music. To do that, right-click the object
> Show over Multiple Slides. Then, you can choose to place the object in the top layer or bottom
layer of the stack order of slide objects. In the Timeline pane, there is an icon that appears next
to the object name to indicate that object is showing over multiple slides.

After that, you can click the All Slides button
the objects that span across multiple slides.

to view all slides in the current project as well as

Removing Multiple Objects from Multiple Slides
If you want to do a batch operation to remove objects from multiple slides, do the following:
1. Click the ActivePresenter button > Project > Batch Operations > Delete Objects….
2. In the dialog that appears, select the object types that you want to remove.
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3. Specify the slides where you want the mass destruction to happen. If you choose Specified
Slides, separate the ordering numbers of slides by commas. Otherwise, use hyphens to
indicate ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, and 6th slides.
4. Select Include objects shown over multiple slides if you want to remove any objects
shown over multiple slides.
5. Click OK to apply. All selected objects will be removed from the specified slides.

Copying Objects
To copy objects, do the following:
1. Select one or more objects in a slide.
2. Press CTRL+C or right-click > Copy. Alternatively, click the Home tab > Copy.
3. You can paste the copied objects into the same slide or another slide. In case of the latter,
do either of the following:
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. This will adapt the copied

To maintain the theme of the slide you are copying from Right-click > Paste (Keep
Source Formatting)
or click the Home tab > Paste (Keep Source Formatting).
This will make the copied objects keep their original theme format.

Duplicating Objects
To duplicate objects, do as follows:
1. Select one or more objects in a slide.
2. Take either of the following:
•
•
•

Press CTRL+D.
Right-click > Duplicate
in the context menu.
Click the Duplicate
command in the Home tab.

Changing Object Properties
Repositioning, Resizing and Rotating Objects
After inserting an object into a slide, you often want to change its position, size, and rotation. Do
that on the Canvas or in the Properties pane. Do one of the following:

●

On the Canvas, drag the object to a new position. You can also use the ARROW keys to
move objects.

●

On the Canvas, select the object that you want to resize. Then, drag the resizing handles
(green dots) to change the object’s size. You can also use SHIFT+ ARROW keys to resize
objects.

●

On the Canvas, select the object that you want to rotate. Then, drag the rotation handles
to rotate it.

●

Select the object > Properties pane > Size & Properties > Transform. Specify the
position, size, and rotation value as you wish.

Note:
●

To reposition, resize, or rotate objects in responsive projects, see Changing Object
Position and Size.
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For images and videos, by default, the aspect ratio is locked to keep them proportional
while being resized. To change the ratio, clear the Lock Aspect Ratio checkbox in the
Properties pane > Size & Properties > Transform. Or right-click an image or a video >
uncheck the Lock Aspect Ratio option from the context menu.

If you want to revert these objects to their original size, just click the Restore Original
Size button. Alternatively, right-click them > Restore Original Size.
●

To lock the size and position of an object on the Canvas, just right-click that object > Lock
Size and Position or press CTRL+SHIFT+K.

Changing Style and Effects
You can change the style and effects of more than one object in the Format tab, Home tab, and
the Properties pane > Style & Effects.
Quick styles are a useful way to quickly change an object’s fill, line, shadow, and opacity. To
apply a quick style, do the following:
1. Select one or more objects.
2. Click the Format tab or Home tab > Quick Style
> choose the style you want. The
color choices will depend on the theme you are using for your project.
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If your project has many objects of the same type and you want them to have the same animation
effects or formatting style, do the following:
1. Animate an object or format it the way you want.
2. Apply the animation and style of the object to all other existing objects of the same type.
To do that, right-click the object > Apply to All Objects > Animation and/or Style.
Besides, you can quickly apply the formatting style (fill, line, shadow, opacity, and text style) of an
object to one or more objects of the same or different types in the same project or across projects.
Do as follows:
1. Select an object that has the formatting style you want to copy.
2. Click the Format Painter
command in the Home tab. After that, the mouse cursor will
appear with a paint roller.
3. Click on any object you want to apply the copied style. If you want to apply to multiple
objects, simply hold down ALT while selecting the desired objects.
Note:
●

The Apply to All Objects and Format Painter options affect existing objects only. They
have nothing to do with objects that haven’t been inserted yet. If you want the newly added
objects to use the same style as those existing ones, you must use the Object Settings.

●

If you want to restore all the default objects which come with ActivePresenter, click the View
tab > Object Settings > Reset All Object Settings . You can also restore the default
settings of one object type by right-clicking it on the Canvas > Reset Default Settings.

Inserting and Managing Objects > Changing Object Properties

97

ActivePresenter User Manual

Version 9.0

Object Operation Modes
When creating HTML5 content, you have to choose operation modes for objects to determine if
objects appear in a certain mode in the output. For example, by default, the operation modes for
mouse clicks are Demonstration and Tutorial. This means these objects only appear in these two
modes. They don’t appear in the Practice and Test modes.
You can determine operation modes for objects in the current slide as follows:
1. Select one or more objects.
2. Click the Properties pane > Size & Properties > Show in Mode > choose the modes
you want.

You can also apply mode to show to all the objects of the same type in your project. To do that,
choose operation mode(s) to one object, then on the Canvas, right-click the object > Apply to All
Objects > Show in Mode.

Animating Objects
Animation is a great tool to engage your audience. ActivePresenter allows you to animate objects
with four types of animation effects: entrance, exit, emphasis, and motion path. In the Animations
tab, entrance effects are colored green, exit effects are colored orange, emphasis effects are
colored yellow, and motion paths are pre-made paths or custom paths that you draw by yourself.
ActivePresenter 9 now offers you up to 80 effects of all types, helping bring your content to life
effortlessly.

Entrance effects control how an object appears. These effects start at the start point of an object
(the left edge of the object time bar). For example, an object moves slowly into a slide using the
Float effect.
Exit effects control how an object disappears. These effects end at the end point of an object (the
right edge of the object time bar). For example, using the Zoom Out effect, an object gradually
scales down and disappears.
Emphasis effects add highlights or movement to draw attention to an object already in a slide.
For example, you can make an object shake using the Teeter effect.
Motion paths move objects already in a slide along a predetermined path, like a line, circle, or
star. You can also draw your own paths.
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You can set all the animations to play in turn or simultaneously. For example, apply the Fly In
entrance together with the Spin emphasis to make a shape fly in while rotating. However, keep in
mind that always use animations for a purpose. Don’t overuse animations as they can distract
your audience.
The Timeline contains animations. As ActivePresenter supports multiple timelines and the Click
Sequence timeline, a single object can hold different animations in different timelines. So, make
sure you add the right animation effect in the right timeline.
Note: In the Main Timeline, you can apply only one entrance or exit effect but multiple emphasis
effects and motion paths to an object. However, interactive timelines and the Click Sequence
timeline allow you to add multiple effects of all types to a single object.
To apply animations to objects, do the following (skip unnecessary steps, if any):
1. Select one or more objects that you want to animate.
2. Click the Animations tab.
3. To add an entrance or exit effect, click the Entrance Effects or Exit Effects button >
choose an effect.

4. To add an emphasis effect or a motion path, click the arrow at the bottom-right corner of
the emphasis & motion path gallery to expand the gallery, then choose an effect.
Emphasis effects and motion paths will be added at the Playhead position, so remember
to specify the Playhead position beforehand.

5. Specify the effect option to tweak the effect. Some effects have effect options that
determine their direction or a shape that the object moves long. For example, the Spin
effect can rotate an object clockwise or counterclockwise.
6. Specify the start time and duration of the effect.
7. Preview the effect by pressing the SPACE BAR or clicking the Preview button
Timeline pane.

in the

Note: When you apply animation effects to text or flex child, some effects such as the Peek,
Wipe, and Shape effects are not working as expected in IE and Edge browsers.
In the timeline, entrance effects are colored green, exit effects are colored red, both emphasis
effects and motion paths are colored yellow. To expand animation effects as in the below figure,
in the timeline, right-click an object time bar > Expand Animations.
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When you add a motion path, you will see the path on the Canvas. It appears as a dotted line with
a green arrow indicating the path’s start and a red arrow indicating its end.

Adding Multiple Effects
You can apply more than one emphasis effect or motion path to an object in the main timeline.
Meanwhile, in interactive timelines and the Click Sequence timeline, you can apply multiple
effects of all types, including more than one entrance and exit effects. Do the following:
1. Select one or more objects that you want to animate.
2. Specify the timestamp where you want the effect to start.
3. Click the Animations tab > Add Animation > choose an effect.
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4. Specify the effect option (if any), start time, and duration of the effect.
5. Preview the effect by pressing the SPACE BAR or clicking the Preview button
Timeline pane.

in the

Note:
●

If you try to add more effects by using the effect gallery, you won’t add an additional effect.
Instead, you’ll replace the existing effect with the one you’re adding.

●

Multiple effects can have the same start time or play simultaneously, making it hard to
select and manipulate them in the timeline. In that case, right-click the object time bar >
Expand Animations to expand the animation time bars.

Editing Animation Effects
After applying an animation effect, you may want to change its timing, direction, etc. You may
also want to replace it with another one. Do the following to modify an effect:
●

Change timing: Drag the effect time bar along the timeline ruler or select the object >
Animations tab > Start Time.
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●

Change duration: Lengthen or shorten the effect time bar in the timeline or select the
object > Animations tab > Duration.

●

Change effect options: Select the object > Animations tab > Effect Options.

●

Replace effects: Select the object > Animations tab. For entrance and exit effects, click
the Entrance Effects or Exit Effects button and choose an effect to replace the existing
one. For emphasis effects and motion paths, choose an effect from the emphasis & motion
path gallery.

In the timeline, you can also double-click the effect time bar or right-click it > Effect Settings.
Both ways open the dialog which allows you to modify the effect.

Note:
●

For emphasis effects and motion paths, you can make an effect repeat automatically when
it ends using the Repeat option. An effect can be repeated a specific number of times or
until the end of the slide. If you want a motion path to repeat end-to-start, select the Autoreverse checkbox.

●

For details about motion paths, see Adding and Editing Motion Paths.

●

You can apply an animation effect to all the objects of the same type in your project. To
do that, apply the effect to one object, then on the Canvas, right-click the object > Apply
to All Objects > Animation.
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Adding Animation Effects to Text
For text-based objects, ActivePresenter makes it possible to animate texts inside them. After
adding an animation to that object, double-click the effect time bar or right-click it > Effect
Settings to open the effect setting dialog. There is a Text Animation section.

To animate text, do the following:
1. In the Animate Text spin box, select either By Letter or By Word options.
2. Set the delay value for the time between letters or words appearing by the percent of
animation duration of the object. Except for effects which have no duration such as Appear
and Disappear effects, their delay time for a text is set in seconds. Do one of the following:
●

Click the up or down arrow in the delay box to increase/decrease the delay time.

●

Enter a new value in the delay box.

Note:
After clicking OK to apply the effect, you can change the delay time by dragging the text
effect time bar (the transparent bar) in the Timeline.

Removing Animation Effects
To remove an animation effect, do one of the following:
●

In the timeline, drag the effect time bar downward until it turns gray, then release the
mouse button to delete the effect.

●

In the timeline, right-click the effect time bar > Remove Effect.

●

Select the object > Animations tab > None from the effect galleries.

●

For motion paths, you can also select the path on the Canvas > DELETE.

Adding and Editing Motion Paths
Adding Motion Paths
To add a motion path to an object, select the object and do the following:
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1. Select one or more objects that you want to animate.
2. Specify the timestamp where you want the effect to start.
3. In the Animations tab, click the arrow at the bottom-right corner of the emphasis & motion
path gallery to expand the gallery, then choose a motion path.
●

If you choose a predefined path, the path will appear on the Canvas immediately.

●

If you choose the Custom Path option, you will draw your own path. Drawing a custom
path is the same as drawing a freeform shape.

4. Specify the path option, start time, and duration of the effect.
5. On the Canvas, select the path and resize it or move it to the position you want.
6. Preview the effect by pressing SPACE BAR or clicking the Preview button
Timeline pane.

in the

Locking Motion Paths
By default, a motion path follows an object when you move the object. That’s thanks to the
unlocked state where the path and the object move together. You can choose to lock the path so
that it remains in the same position when you move the object.
To lock or unlock a path, select it on the Canvas > Animations tab > Effect Options > Lock Origin.

Opening and Closing Paths
For closed paths like Shapes, Loops, and Stars, right-click the path > Open Path to separate the
start and end point.

For open paths like Lines, Arcs, and Turns, right-click the path > Close Path to make the path
return to its start point. A linear path is added from the previous end point to the start point.
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Changing Path Shape
To change the shape of a path, double-click the path or right-click it > Edit Points to enter the
edit mode. In this mode, you can modify the path shape by moving, adding, or removing the
anchor points (black squares) that appear. For more details, see Editing Freeform.

Reversing Path Direction
To exchange the start point and end point of a path, right-click the path > Reverse Path Direction.

Arranging Objects
Ordering Objects
A slide may have numerous objects, such as shapes, text captions, images, and videos. When
being inserted into a slide, new objects are placed in front of others and may cover them partly or
fully. This stack order of objects is called z-order.
ActivePresenter gives you the ability to arrange objects in z-order. You can move an object to the
front or the back of the slide even when they do not overlap each other. Do the following:
1. Select one or more objects.
2. Click the Format tab > Order
or the Home tab > Arrange > Order. Alternatively, on
the Canvas or in the timeline, right-click objects (time bars) > Display Order.
3. Choose the desired display order option.
4. You can go to the Selection pane and drag an object up or down to change its position in
the stack order. Moving an object higher means that you bring it to the front of the stack.
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Hotkey

Function
Place the object at the very top of the
stack.

Bring to Front

CTRL+HOME

Bring Forward

CTRL+PAGE UP

Send the object higher by one level in the
stack.

Send to Back

CTRL+END

Place the object at the very bottom of the
stack.

CTRL+PAGE DOWN

Send the object lower by one level in the
stack.

Send Backward

Grouping Objects
ActivePresenter lets you group multiple objects into a group so that you can edit and manage
them easily.
Note that you cannot group closed captions, spotlights, zoom-n-pans and objects which belong
to different layers.

Grouping Objects
ActivePresenter lets you group objects of several types: shapes, images, text captions, audio
tracks, videos, questions, etc. Note that object grouping is unavailable to some objects including
closed captions, spotlights, and zoom-n-pans.
Do the following:
1. Hold down CTRL while selecting all the objects that you want to include in a group.
2. Right-click objects > Group > Group . Alternatively, click the Format tab > Group >
Group or the Home tab > Arrange > Group. You can also quickly make a group by
pressing the CTRL+G hotkey.
The selected objects are grouped. A single box with resizing handles appears around the entire group.

At the same time, in the Timeline pane, all the child objects’ time bars are merged into the only
time bar of the group. The Selection pane lists all the child objects under and at the next indent
level compared to their group. Click the +/- button to expand or collapse these child objects.

Inserting and Managing Objects > Arranging Objects

106

ActivePresenter User Manual

Version 9.0

3. Rename the group to make it easier to find and work with. Click the Properties pane >
Interactivity > General or double-click the group name in the Selection pane.
Note:
●

Another way to select multiple objects is to drag the mouse across them. In other words,
use a rubber-band selector. Click on a slide and drag the mouse, a rubber-band selector
appears. All the objects that stay in or intersect with the selector will be selected.

●

If you’ve already selected several objects and want to select more, hold down CTRL and
click them. If you accidentally select some objects you don’t want, hold down CTRL and
click redundant objects to clear the selection.

●

After you make a group, you can still work with child objects in that group. Select the
group, then click an object to select it.

●

A group and its child objects are mutually exclusive when it comes to converting objects
into drag sources/drop targets. That is, you can only convert either a group or its child
objects into drag sources/drop targets.

●

Some features are not available to child objects, namely Attached audio, Show to the
end of slide, and Pause presentation to wait for user input.

Adding Objects to a Group
ActivePresenter lets you add objects to an existing group. Do the following:
1. Select a group and one or more objects that you want to add to the group.
2. Right-click > Group > Add to Group . Alternatively, click the Format tab > Group >
Add to Group or the Home tab > Arrange > Add to Group.
In the Timeline pane, the time bars of the extra objects are merged into the time bar of the group.
In the Selection pane, extra objects are listed as child objects of the group.
Note: You can nest groups within groups. Simply put, groups can contain groups as members.
To nest a group in another group, use the same techniques for grouping objects. Just select all
the objects/groups you want, right-click > Group > Group. A new group is created containing all
the selected objects/groups as members.

Removing Objects from Group
ActivePresenter lets you remove some objects out of a group without ungrouping entire that
group. Do the following:
1. Select objects that you want to remove.
2. Right-click > Group > Remove from Group . Alternatively, click the Format tab >
Group > Remove from Group or the Home tab > Arrange > Remove from Group.
In the Timeline pane, the time bars of the removed objects are placed in separate lines.

Ungrouping Objects
Sometimes, you no longer need a group. You want to break it apart so that you can more easily
select and format each individual object. To ungroup a group, first select the group. Then, right-
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click it > Group > Ungroup . Alternatively, click the Format tab > Group > Ungroup or the
Home tab > Arrange > Ungroup. You can also quickly ungroup objects by pressing the
CTRL+SHIFT+ G hotkey.

Changing Group Layout
ActivePresenter also supports flex layout and grid layout for a group. To change the group
layout, do as follows:
1. Select a group.
2. Go to the Properties pane > Size & Properties > Container Layout > select a layout.
Note: After changing the container layout to Grid or Flex, if the selected container contains less
than 2 children, you cannot remove its group layout. That said, you cannot re-switch the container
layout to None. In that case, ActivePresenter will warn you with a dialog.

Aligning Objects
ActivePresenter helps you to align objects quickly and perfectly as you want. There are two
available tools to support you to do that. They are grid and guides and alignment commands.

Aligning Objects Using Grid and Guides
Grid and guides help you place objects precisely in a flash. In the View tab, you will realize the
Canvas Snapping section which includes three checkboxes: Gridlines, Guides, and Smart
Guides:

Select or deselect the corresponding checkbox to turn on or off these functions. Besides, if you
click on the dialog box launcher at the bottom right corner of this section, the Grid and Guides
dialog will pop up. Alternatively, right-click on the Canvas, select Grid and Guides…

The dialog has two sections including Grid settings and Snap to:
Inserting and Managing Objects > Arranging Objects
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Grid settings: Gridlines are horizontal and vertical dotted lines. Enter a specific number
in the range of [10-10000] in this spin box to adjust the spacing between gridlines.
Snap to: This section allows you to show/hide gridlines or guides and enable snapping
objects to grid or guides.
o Snap objects to grid: This checkbox functions similarly to the Gridlines checkbox in
the View tab. Select this checkbox to show gridlines and align objects to grid.
o Snap objects to guides: This checkbox is equivalent to the Guides checkbox in the
View tab. Select this checkbox to show drawing guides and align objects to guides.
By default, drawing guides include two lines, one is horizontal and the other is vertical.
These two lines intersect at the center of the Canvas. They can float over objects.
o Snap objects to other objects (smart guides): This checkbox works the same as
the Smart Guides checkbox in the View tab. Select this checkbox to show smart
guides. Smart guides are orange lines that only appear when you drag or reshape
objects. They are vertical or horizontal lines through the edge/center of an object or
the Canvas. Use them to align an object relative to another object. Or, you can align
an object relative to the center/edge of a slide:

You can temporarily disable this function by holding down ALT when resizing or moving objects.
Click the Set as default button to apply the changes you’ve made for the next projects.
Note that ActivePresenter supports you in customizing guides. Select a guide, then right-click,
you will see the context menu below:
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You can change its color by selecting a color from the built-in list. Besides, you can add more
vertical or horizontal guides. And drag them to a new position. Alternatively, there is another way
to insert additional guides. Just right-click at any position you want on the Canvas and select Add
Vertical Guide or Add Horizontal Guide. The newly added one will appear at the position of the
mouse pointer.

Aligning Objects with Anchor Objects
Sometimes, you have an object’s position set perfectly and you want to align other objects with
that specific object. To do that, use the Alignment options and an anchor object.
An anchor object (also a reference object) is the one with which all other objects align. It is the
last object you select with green resizing handles rather than white handles like others. To define
a different anchor object, click any of the currently selected objects without holding CTRL.

You have many options for aligning objects both vertically and horizontally. Do the following:
1. Hold down CTRL while selecting all the objects that you want to align with.
2. Define an anchor object.
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. Alternatively, click the Home tab > Arrange or the Format tab

Command

Function

Align Left

Align the left side of all the selected objects with the left of the
anchor object.

Align Center

Align the center of all the selected objects with the vertical center
of the anchor object.

Align Right

Align the right side of all the selected objects with the right of the
anchor object.

Align Top

Align the top of all the selected objects with the top of the anchor
object.

Align Middle

Align the center of all the selected objects with the horizontal
center of the anchor object.

Align Bottom

Align the bottom of all the selected objects with the bottom of the
anchor object.

Aligning Objects to the Canvas
You can align one or more objects to the center of the Canvas. Do the same steps to align objects
as mentioned above, but choose either of the following:
Icon

Command

Function

Center Horizontally

Move all the selected objects to the horizontal center of the
Canvas.

Center Vertically

Move all the selected objects to the vertical center of the
Canvas.

Distributing Objects
If you arrange objects in a row or column, you may want them to be an equal distance from one
another for a neater appearance. Do that by distributing the objects horizontally or vertically.
Perform the same steps to align objects as mentioned above, but choose either of the following:
Icon

Command

Function

Distribute
Horizontally

Make the horizontal spacing equal between the selected objects.

Distribute Vertically

Make the vertical spacing equal between the selected objects.

Note: These commands work only when you select more than two objects.
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Resizing Objects to Anchor Objects
If you have multiple objects that you want to size equally, use the following alignment options:
Icon

Command

Function

Make Same Width

Match the width of all the selected objects with that of the anchor
object.

Make Same Height

Match the height of all the selected objects with that of the
anchor object.

Make Same Size

Match the height and width of all the selected objects with those
of the anchor object, respectively.

Rotating Objects
ActivePresenter lets you rotate objects quickly to any angle, to an exact angle or 90 degrees,
depending on your needs.

Rotate Objects to Any Angle
To rotate objects to any angle, do as follows:
1. Select one or more objects.
2. Select the rotating handle, then feel free to rotate it clockwise or counterclockwise.
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Rotate Objects to an Exact Angle by Degrees
To rotate objects to an exact angle by degrees, do as follows:
1. Select one or more objects.
2. Navigate to the Properties pane > Size & Properties > Transform > enter new value to
the Rotation spin box.

Rotating Objects 90 Degrees
ActivePresenter allows you to rotate objects 90 degrees clockwise or 90 degrees
counterclockwise by using rotate commands.
Note: The Rotate commands are not applicable for spotlight, gesture effects, cursor paths, zoomn-pan, closed captions and child objects in the grid layout group.
To rotate objects 90 degrees, do as follows:
1. Select one or more objects.
2. Right-click objects > Rotate
either of the following:
Icon

. Alternatively, click the Format tab > Rotate. Then, select

Command

Function

Rotate Right 900

Rotate the selected objects 90 degrees to the right.

Rotate Left 900

Rotate the selected objects 90 degrees to the left.
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Flipping Objects
ActivePresenter lets you flip objects vertically or horizontally. When flipping objects vertically, you
can see their reversion. Meanwhile, flipping objects horizontally brings a mirror image.
Note: The Flip commands are not applicable for text inside the objects, groups, gesture effects,
charts, tables, cursor paths, zoom-n-pans, and closed captions.
To flip objects, do the following:
1. Select one or more objects.
2. Right-click objects > Rotate
either of the following:
Icon

. Alternatively, click the Format tab > Rotate. Then, select

Command

Function

Flip Vertical

Flip the selected objects vertically 180 degrees.

Flip Horizontal

Flip the selected objects horizontally 180 degrees.

Using Object States
Object states allow you to change the appearance of an object in response to user interaction. A
state is a collection of visual elements that define the look of an object. You can add states to
many types of objects such as shapes, text captions, images, or buttons. Using actions, you can
shake an image on hover and make it appear disabled after being clicked.
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Besides adding new custom states, you can apply several built-in states to objects.
ActivePresenter also adds built-in states to some types of objects by default, such as buttons,
checkboxes, and radio buttons, so that you can use these multi-state objects right away.
There are four types of states, including:
●

Normal state: Each object always has a neutral state that cannot be deleted and
renamed. By default, it’s the initial state (default state) of an object.

●

Default state: This is the initial state of an object, in other words, this is how an object
looks when it first appears. By default, the normal state is the default state of an object,
but you can change the default state to any other state.

●

Custom state: You can create many custom states for an object.

●

Built-in state: ActivePresenter provides several built-in states that you can apply to
objects. The normal state is a built-in state.

Built-In States
The built-in states of objects are as follows:
●

Normal: This is the neutral state of an object. By default, it’s how an object looks when it
first appears.

●

Hover: This is how an object looks when being hovered. This state is available for buttons,
checkboxes, and radio buttons and is added by default. You don’t need to use an action
to trigger it.

●

Pressed: This is how an object looks when being clicked. This state is available for
buttons, checkboxes, and radio buttons and is added by default. You don’t need to use an
action to trigger it.

●

Disabled: This is the state you use when you want to disable an object. A disabled object
is visible but cannot respond to any user action. Unless this state is added to an object by
default, you need to use an action to trigger it.

●

Normal/hover/pressed/disabled checked: These are the states of the selected
checkbox or radio button. They are added to checkboxes and radio buttons by default, so
you don’t need to trigger them using actions.

There are several built-in drag-n-drop states that you can apply to drag sources and drop areas.
As you add these states to a drag source or drop area, they will be automatically displayed when
the corresponding events occur, in other words, when you interact with the drag source or drop
area.
●

Drag start: This is how a drag source looks when it’s dragged from its location.

●

Drag end: This is how a drag source looks when you release the mouse button while
dragging it.

●

Drag enter: This is how a drop area looks when a drag source enters it.

●

Drag leave: This is how a drop area looks when a drag source leaves it.
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●

Drop correct: This is how a drag source or drop area looks when all drag sources are
dropped onto the correct drop areas.

●

Drop incorrect: This is how a drag source or drop area looks when a drag source is
dropped onto the incorrect drop area.

●

Drop accept: This is how a drag source or drop area looks when any accepted drag
source is dropped onto the drop area.

●

Drop reject: This is how a drag source or drop area looks when any rejected drag source
is dropped onto the drop area.

Opening Object States Pane
You use the Object States pane to manage states. To open this pane, click the View tab > Object
States.
Alternatively, you can select an object that you want to manage its states and click the Properties
pane > Interactivity > General > State View, or right-click the object > Object States.

Adding States
An object may have one or several states by default. However, you can add more states to it
using the following steps:
1. Select an object.
2. In the Object States pane, click Edit States . This enters the state edit mode where all
other objects except the selected one are grayed out and unclickable.
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3. Click Add State
or right-click the pane > Add State to add a built-in state or a custom
state. A custom state will inherit all visual properties from the normal state.
4. Assign a name to the new custom state and click OK.
5. If you want to change the appearance of the newly added state, follow the steps in the
next part.
6. If you want to add states to another object in a slide, switch to that object using the States
of combo box.
7. When you’re done adding and editing states, click Done Editing States
state edit mode.

to exit the

Editing States
You can change the appearance of any state, including its size, position, shape type, text, color,
border, etc. Just enter the state edit mode, select a state, and make an edit.
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●

To change the state of an image, access the Properties pane > Size & Properties >
Image > choose another image from the current project or your computer.

●

To change the background image of a state, access the Properties pane > Style &
Effects > Fill > Image Fill.

●

To change the fill, mark, and border of Checkbox and Radio Button, go to the Format tab.

All your changes will be saved when you click the Done Editing States

button.

As mentioned earlier, if you want to edit the states of multiple objects in a slide, use the States of
combo box to switch between objects. Take note of the following:
Property
Size, position,
and rotation
Other visual
properties

State editing mode
When the active state is the
normal state, your changes will be
applied to all other states which
inherit from the normal state.
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changes will be applied to all other states
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Otherwise, the changed property
will no longer inherit from the
normal state.

which inherit from the normal state.
Otherwise, your changes will be applied to
the default state only.

Managing States
To manage states, first enter the state edit mode by clicking the Edit States button. Then, use
the buttons in the toolbar of the Object States pane or right-click a state and select an option in
the context menu. Be aware that you cannot rename, remove, or reset the normal state.
●

Rename State

: Rename the active state.

●

Remove State

: Remove the active state.

●

Reset State : Restore the original appearance of the active state. Use this option when
you aren’t satisfied after editing a state.

●

Duplicate State

●

Set as Default State
state of an object.

: Create a copy of the active state.
: Make the active state the default state, in other words, the initial

Triggering States Using Actions
Use actions to display a state based on the user’s interaction with the content. While the event
depends, you will use the Change Object State action to invoke a state. For more details, see
Adding Events - Actions.

Using Object Templates
Object template is a good way to reuse objects across slides in the same project or across
different projects. By adding objects to an object template, you save not only the objects
themselves but also the animations and event actions attached to them.
ActivePresenter uses the ActivePresenter Templates folder and the Object Templates pane to
help you manage object templates. Your object templates (*.apobject) are stored in the
ActivePresenter
Templates
folder
(C:\Users\<user_name>\Documents\ActivePresenter
Templates (for Windows) or /Users/<user_name>/Documents/ActivePresenter Templates (for
macOS)). Any object templates stored in that folder will appear in the Object Templates pane.
This pane is where you add and manage template items in an object template.

Opening Object Templates Pane
The Object Templates pane contains object templates. Each object template includes one or
more object template items. These items can be annotation or interaction objects. By default,
ActivePresenter gives you a Default object template. You can add objects to this template or
create other object templates to use.
The Object Templates pane automatically opens when you add objects to a template. When you
want to open this pane, click the View tab > Object Templates.
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Adding Objects to Object Templates
You can add any object to object templates, except cursor path, zoom-n-pan, and closed caption.
To add an object to the object template, do the following:
1. Right-click the object > Add to Template. Then, the object will appear as a template item
in the current object template.

2. Right-click the object template item > Rename

to rename it.
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3. If you don’t want a template item anymore, click it and press DELETE or right-click it >
Delete .
Note:
●

When you add multiple objects to the object template at once, all the selected objects will
be treated as a single template item. That said, this doesn’t group the selected objects or
make them a single object. When you insert that template item into a slide, the objects are
still separate ones.

●

An object template item can hold the event actions attached to it. However, if the action
involves other objects and you don’t add those objects to the same template, the action
will be removed. Otherwise, if you add all the objects to the same template, the actions
will remain. For example, if you have the object A with the action Show object B when
clicked. If you add these objects to the object template simultaneously, the action will
remain. Otherwise, if you just add object A to the object template, the action will be
removed.

Using Object Template Items
To insert an object template item into a slide, in the Object Templates pane, do one of the
following:
●

Double-click a template item.

●

Drag and drop a template item onto the Canvas.

●

Right-click a template item > Insert.

By default, object template items added to slides will maintain their original theme thanks to the
Keep Source Formatting checkbox at the bottom of the pane. If you want the template items to
adapt to the theme of the destination slide, clear this checkbox.

Saving and Sharing Object Templates
You can save a project as an object template and reuse it for other projects.
To save a project as an object template, click the ActivePresenter button > Save or Save As….
Next, select ActivePresenter Object Template (*.apobject) from the Save as type drop-down list.

Then, save file in C:\Users\<user_name>\Documents\ActivePresenter Templates (for Windows)
or /Users/<user_name>/Documents/ActivePresenter Templates (for macOS). That way, the
object template will appear in the Object Templates pane.
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Note: If you save the project in other folders on your computer, the object template will not appear
in the Object Templates pane.
After that, you can rename or delete the object template file in the same way as you normally do.
You can also share the template file with others.
If you have any *.apobject file and want to import it into ActivePresenter as an object template,
just copy the file and paste it into the ActivePresenter Templates folder. Then, in the Object
Templates pane, click Reload
to refresh the Templates folder, making the new object
template appear in the pane.

Setting Default Objects
You can format a certain object and set it as the default. After that, the same properties will be
applied to all newly inserted objects of the same type in the same project. Do either of the
following:
●

Right-clicking the object > Set as Default.

●

Go to the View tab > Object Settings. All changes made to objects in this Object Setting
View will be the default settings of all newly inserted objects of that object type in the
current project.

You can also export and reuse the object settings across projects. Do the following:
1. Save the current project as a slide template (*.apslide) or theme (*.aptheme).
2. Navigate to the location where you want to save the file > Save.
If you save files in C:\Users\<user_name>\Documents\ActivePresenter Templates (for Windows)
or /Users/<user_name>/Documents/ActivePresenter Templates (for macOS), the template or
theme will appear on the Start Page. Then, use this template or theme to start a new project.
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Container
In responsive projects, you can make objects respond to different viewports using the Transform
properties (go to the Properties pane > Size & Properties > Transform). However, this way may
take a lot of effort to make even a simple responsive project as you have to do it manually. In
ActivePresenter, there is another way to make it easier is by using a container (flex box or grid
box). Objects inserted in a container can be laid out and aligned automatically to adapt to different
viewport sizes. Thanks to that, you don’t need to change their size and position manually.

Flex Box Overview
Flex Box
Flex box is a flex container that can hold objects. It is designed as a one-dimensional layout
model, which means objects in a flex container can be laid out either horizontally or vertically, but
not both.

Flex box offers space distribution among objects. In detail, it allows aligning and distributing space
within a container by expanding objects to fill the available space (growing) or shrinking them to
prevent the overflow.
Container > Flex Box Overview
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Differences between Flex Box and Grid Box
●

Flex box is one-dimensional, grid box is two-dimensional.

●

Flex box is content-based, and grid box is container-based. Objects in the flex box can
have different sizes within a single row/column but their sizes are predefined in the grid
box. That’s why flex box is more flexible than grid box and also more complicated.

Using Flex Box/ Grid Box
Inserting Flex Box/ Grid Box
To insert a flex box or a grid box, access the Home tab or the Insert tab > Container
Box

or Grid Box

> Flex

.

Alternatively, you can group objects (see Grouping Objects), then navigate to the Properties
pane > Size & Properties > Container Layout > Flex or Grid.

Adding Child Container to Flex Box/ Grid Box
To add more child containers to a flex box or a grid box, firstly, select it > click the plus button
> Child Container. Then, insert one of 14 Preset Layouts, or click Flex Box or Grid Box to
insert it manually.

Adding Objects to Flex Box/ Grid Box
Do one of the following ways to add objects to a flex or grid box:
●

Select the box > click the plus button > Objects or Questions > choose any object or
question type from the drop-down list that you want to add.

●

Drag any object on the Canvas and drop it into a flex box or a grid box.

When an object is added to a flex box or grid box, its height will be automatically adjusted to be
equal to the box height by default.

Container > Using Flex Box/ Grid Box
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Using Flex Layout
Flex layout is one type of container layout, which is available for a flex box, a slide, or a group of
objects. Flex container layout properties can be set differently for different layouts of a responsive
project. By default, these properties of each layout in a responsive project are the same and the
smaller layout will inherit properties from its larger layout.
However, after making changes to these properties of a small layout, if you are not satisfied with these
changes, you can reset it by selecting the container and right-clicking > Reset Inheritance Layout.
Look at the following image to see all properties of a flex container layout:

●

Direction: Flex layout will keep objects displaying along a row (in the horizontal direction)
or a column (in the vertical direction). Select the direction (either Horizontal or Vertical)
that you want objects to be aligned.

●

Wrap: Select No Wrap or Wrap to specify whether objects should be forced into one line
or wrapped onto multiple lines.
Note that the wrapping behavior only happens when items in a flex box are too large to
display all in one line. In this case, when you select Wrap, they will be wrapped onto
another line.
Let’s look at the below image:
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In this example, a flex container holds four shapes (four squares). The width of each
square is 100 px, which means the total width of four squares is 400 px. Meanwhile, the
width of the flex container holding four squares is only 300 px. As you can see, the total
width of four squares is larger than the flex container width. In this case, if you select
Wrap, four squares will be wrapped onto two lines.
●

Vertical Align/Horizontal Align: Select one of the following commands for aligning items
vertically/horizontally:

Vertical Align

Horizontal Align

Function

Top

Left

Align items to the top/left of the container if the direction
is vertical/horizontal.

Middle

Center

Align objects to the middle/center of the container if the
direction is vertical/horizontal.

Bottom

Right

Align objects to the bottom/right of the container if the
direction is vertical/horizontal.

Space
Between

Space
Between

Align the flex items evenly with equal space among
rows/columns if the direction is vertical/horizontal. There is no
space before the first flex item and after the last flex item.

Space
Around

Space
Around

Align the flex items evenly with equal space among
rows/columns.

●

Align Columns/Align Rows: When the Wrap option is selected, the flex box allows
breaking objects into multiple lines. Use the following properties to align those lines:

Align Columns

Left

Align Rows

Top

Container > Using Flex Box/ Grid Box
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Center

Middle

Align objects to the center/middle of column/row if the
direction is vertical/horizontal.

Right

Bottom

Align objects to the right/bottom of column/row if the
direction is vertical/horizontal.

Stretch

Stretch

Stretch the flex items to fill the maximum size of
column/row if the direction is vertical/horizontal.

Space
Between

Space
Between

Space
Around
●

Space Around

Align the flex items evenly with equal space among
rows/columns if the direction is vertical/horizontal. There is no
space before the first flex item and after the last flex item.
Align the flex items evenly with equal space among
rows/columns.

Overflow: Determine how the content in a flex container is displayed if it overflows the
container and whether a scroll bar should appear:
o

Visible: The overflow isn't clipped; it renders outside the container. This is the
default.

o

Hidden: The overflow is clipped; any content that extends beyond the container
will be hidden.

o

Auto: If the overflow is clipped, a scroll bar will appear and help you view the rest
of the content. Note that the scroll bar is scrolled from left to right and from top to
bottom in the flex box. Therefore, all items that overflow the left and/or top position
of the flex box couldn’t be shown.

Customizing Flex Child in Flex Container
An object or a container added to a flex box is called a flex item or flex child. As its name implies,
a flex child can adjust itself to fit the container. In detail, it can grow to fill unused space or shrink
to avoid overflowing. Flex child properties are only available for flex container layout. Grid
container layout doesn’t have those properties.
Flex child properties can be set differently for different layouts of a responsive project. By default,
these properties of each layout in a responsive project are the same and the smaller layout will
inherit properties from its larger layout. However, after making changes to these properties of a
small layout, if you are not satisfied with these changes, you can reset it by selecting the container
and right-clicking > Reset Layout Inheritance.
To set the properties of a flex child, select it, then navigate to the Properties pane > Size &
Properties > Flex Child, you can see its properties as below:

Container > Using Flex Box/ Grid Box

127

ActivePresenter User Manual

Version 9.0

●

Width: Define the base width of a flex child by percentage, pixel, or auto. Auto means that
the base width is based on the object content. The content can be either text if the object
is a shape or the total base width of children if the object is a nested flex box.

●

Height: Define the base height of a flex child by percentage, pixel, or auto. Auto means
that the base height is based on the object content. The content can be either text if the
object is a shape or the total base height of children if the object is a nested flex box.

●

Lock Aspect Ratio: Select Width or Height to maintain the aspect ratio of a flex child
according to its width or height respectively. In case you select None, its aspect ratio isn’t
locked, which means you can freely resize both the width and the height.

●

Grow: Define how the free space of the flex box is distributed to its children. Specify the
value from 0 - 100. If the value is equal to 0, a flex child keeps its base size. If the value
is greater than 0, depending on the Direction set in its flex container, a flex child will be
grown in width or height to occupy the free space in the flex container. The higher value
the Grow property has, the more space the object will occupy. Check out the below image:
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In this example, the Grow value of all squares in the first image is equal to 1, therefore they
have the same space. Meanwhile, in the second image, the Grow value of the orange square
is equal to 2, hence, it has double space in comparison to the blue and green squares.
●

Shrink: When the total base size of objects is greater than the container size, objects
should be shrunk to fit the container. Specify the value from 0 - 100. If the value is equal
to 0, a flex child keeps its base size. If the value is greater than 0, depending on the
Direction set in its flex container, a flex child will be shrunk in width or height to fit the
container. The higher value the Shrink property has, the more the object will be shrunk.

●

Horizontal Align: This property only appears when the Direction in a flex container is set
to Vertical. Select one of four options (Left , Center , Right , Stretch ) to align
a flex child horizontally.

●

Vertical Align: This property only appears when the Direction in a flex container is set to
Horizontal. Select one of four options (Top , Middle , Bottom , Stretch ) to
align a flex child vertically.

●

Left Margin: Adjust the margin on the left side.

●

Right Margin: Adjust the margin on the right side.

●

Top Margin: Adjust the margin on the top.

●

Bottom Margin: Adjust the margin on the bottom.

Some Tips for Using Flex Box
●

In some browsers, for example, Safari, the height using percentage is not working very
well, therefore, try to use grow/shrink if you can.

●

As mentioned above, the flex box deals with the layout in one dimension at a time.
Therefore, if you want to create a two-dimensional layout, you can nest a flex container
inside another one (which is known as a nested flexbox).

●

The Auto unit may cause the width or height of objects to be 0, which may be quite hard
to edit. In this case, you can fix object size by pixel then change it to auto later.

●

If you want to separate the container into equal parts, change flex child width/height to 0%
then adjust the Grow property as you want.

Using Grid Layout
Grid layout is one type of container layout, which is available for a grid box, a slide, and a group. If the
container layout is set to Grid, objects in that layout will be arranged in a grid pattern. The grid layout
ignores the original size of all the objects in a box and assigns a fixed size to all of them.
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The grid size is defined by the number of columns, horizontal spacing between columns, and
vertical spacing between rows. Change the values for these parameters if needed. The number
of rows will be automatically counted based on the number of child objects and columns.

For further modification, click Advanced Settings…. A dialog appears, allowing you to define the
width ratio between columns or the height ratio between rows. If the value is 0, the minimum size
of objects will be used.
For example, the group below has two columns (width ratio 1:2) and two rows (height ratio 1:3).
As you can see, the width of the blue rectangle is one-half of the orange one. Meanwhile, the
height of the blue rectangle is one-third of the green one.
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Annotation Objects
Annotation objects are objects commonly used to add further notes, comments, explanations, or
information. Annotation objects in ActivePresenter can be shapes, text captions, videos, audio,
and more.
Take a look at the following table to see all types of annotation objects:
Object

Icon

Usage

Shapes

Insert a shape on/around a point of interest.

Text Caption

Insert text to explain content.

Spotlight

Overlay a display area with a dark screen, allowing only a
certain area to be fully visible.

Equation

Insert common math equations or build up your own
equations using a library of symbols and structures.

Icons

Insert an icon into a slide.

Gesture Effects

Insert a widget that shows how users interact with a target
object on a touch screen.

Footer

Insert date, slide number, and text into the bottom of a slide.

Chart

Insert a chart type into a slide to illustrate your data.

Table

Insert a table into a slide.

Image

Insert an image into a slide.

Audio

Insert an audio track into a slide.

Video

Insert a video or a webcam recording into a slide.

YouTube Video

Embed a YouTube video within a slide.

Web Object

Embed a webpage within a slide.
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3D Model

Insert a 3D model into a slide.

Cursor Path

Handle mouse movements and clicks to simulate user actions.

Zoom-n-Pan

Zoom in a virtual camera on a specific part of the screen to
show it in more detail.

Closed Caption

Insert a closed caption into a slide. Users can control whether
to show or hide closed captions on the screen.

Shapes
In ActivePresenter, shapes are divided into five groups, including Basic Shapes, Callouts, Lines
and Arrows, Block Arrows, and Stars.

Inserting Shapes
To insert a shape, click the Insert tab or the Home tab > Shapes > select one shape.

As soon as you select a shape, the cursor turns into a crosshair . Click anywhere on the Canvas
to insert that shape, or drag the mouse to draw that shape on the Canvas.
The initial format of a shape is determined by the theme you are using for your project. To change
its default format, open the Format tab, the Home tab, or the Style & Effects tab in the
Properties pane. See Changing Style and Effects for more details.
Besides, you can customize shapes in your own way. For example, you can reposition, resize,
edit, add text to shapes, or even switch from one shape to another. Do as follows:
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●

Reposition: Simply drag a shape to a new position on a slide. Or, select a shape and click
the Properties pane > Size & Properties > Transform > enter specific values in the Left
and the Top spin boxes.

●

Resize: Drag the resizing handles to resize a shape. Alternatively, select a shape and
click the Properties pane > Size & Properties > Transform > enter specific values in the
Width and Height spin box.
If a shape contains a pointer, you can make it point anywhere by dragging the diamond
symbol . Note that if you scale down a shape too much, some text within it may be
clipped or hidden, so be careful when resizing the frame.

●

Edit: Right-click on a shape > Edit Points
you edit a freeform drawing.

. Then, you can edit it in the same way as

●

Add text: Click inside a shape to add text. You can also right-click on a shape > Edit Text.
Or, click on a shape and press F2 on your keyboard. After adding text to a shape, you can
use commands in the Home tab or in the inline text editor to format text.

●

Switch to another shape: Select a shape, click the Format tab > Change Shape > select
a new shape type. Keep in mind that once you edit points of a shape, then it becomes a
freeform. At that time, you cannot change to another shape in the Format tab anymore.

After customizing a shape, if you want to apply its current format to all new shapes in the same
project, just select the shape and right-click on it > Set as Default Shape. That way, the format
of the selected shape will be set as default. That means each time you insert a new shape in the
current project, a new shape will inherit the format from the default shape.

Drawing Freeform
Instead of using ready-made shapes, you can draw your own ones using the following drawing
tools: Line, Curve, Freeform: Shape, or Freeform: Scribble.

Lines
To draw a straight line, click the Insert tab or the Home tab > Shapes > Lines & Arrows > Line
. As soon as you select Line, the cursor changes into a crosshair . Click anywhere on the
Canvas to set the start point. Then, move the mouse without releasing the mouse button to form
a line. Finally, to set the end point for a line, simply release the mouse button.
Note that ActivePresenter allows you to draw a 0, 30, 45, 60, 90, 120, 135, 150, or 180-degree
line precisely. To do that, just hold down SHIFT when moving the mouse. Note that this action
must be performed before releasing the mouse button. Otherwise, it will not work.

Curves
To draw a curve, click the Insert tab or the Home tab > Shapes > Lines & Arrows > Curve .
As soon as you select Curve, the cursor changes into a crosshair . Click anywhere on the
Canvas to set the start point. Then, move the mouse to a different position to form a line.
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To curve the line, just click the mouse button, then continue moving the mouse to form a curve.
Note that each click adds a new turn to the curve.
Finally, to set the end point for a curve, simply double-click or right-click on a desired position on
the Canvas.

Note that a curve can be open or closed. If you want to form a closed curve, move the mouse to
the start point and click to set the end point.

Freeform Shapes
The Freeform: Shape tool has a dual capability as it allows drawing both straight and freeform lines.
To use this tool, click the Insert tab or the Home tab > Shapes > Lines & Arrows > Freeform:
Shape . As soon as you select it, the cursor changes into a crosshair . Click anywhere on
the Canvas to set the start point.
Next, release the mouse button, move the mouse, then click elsewhere on the Canvas if you wish
to draw a straight segment. Otherwise, keep holding down the mouse button when moving the
mouse, then click, you can draw a freeform segment. You can alternate between straight and
freeform segments within a shape.

Similar to a curve, a freeform shape can be open or closed. If you want a closed freeform shape,
move the mouse to the start point, then click to set the end point.
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Freeform Scribbles
The Freeform: Scribble tool is almost similar to the Freeform: Shape tool. However, there is
one distinct difference between them. That is, once you start drawing a scribble, you have to keep
holding down the mouse button until you finish. The point where you release the mouse button
will be the end point of your drawing.
To use this tool, click the Insert tab or the Home tab > Shapes > Lines & Arrows > Freeform:
Scribble . As soon as you select it, the cursor changes into a crosshair . Click anywhere on
the Canvas to set the start point. Then, move the mouse without releasing the mouse button to
draw the shape. The point where you release the mouse button will be the end point of your
drawing.

If you want an open scribble, just release the mouse button at any time. Otherwise, move the
mouse to the start point and release it to get a closed scribble.

Editing Freeform
To edit a freeform drawing, right-click on it > Edit Points
to enter the edit mode. In the edit mode,
the shape is outlined by a red dashed line containing multiple black squares. These black squares
are anchor points, which indicate the start and the end of each line segment. When you select an
anchor point, two blue handles appear with two control points (white squares) at their ends.
You can click and drag an anchor point to sharpen or smooth a corner or a curve. Alternatively,
simply drag a control point. A red dashed line will appear immediately to indicate the change.
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Adding and Removing Anchor Points
Right-click on a freeform shape > Edit Points to enter the edit mode:
●

Adding an anchor point: Click on anywhere in the red dashed line then drag it to the
desired position. Or right-click a segment between two existing anchor points > Add Point.

●

Removing an anchor point: Hold down CTRL and click an anchor point to remove it.
Alternatively, right-click an anchor point > Delete Point. The selected anchor point will
disappear, making the shape change accordingly.

Opening and Closing Paths
In the edit mode of an open shape, right-click on an anchor point > Close Path to close the shape.
A linear path is added from the end point to the start point.

Otherwise, select Open Path to open a closed shape right at the selected point.
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Changing Point Types
In the edit mode, right-click on an anchor point and select one of the following options: Corner
Point, Straight Point, or Smooth Point.

●

Corner Point: The two blue handles with control points go in different directions. This is
the default mode.

●

Straight Point: The two blue handles with control points go in the opposite direction (180
degrees) from each other.

●

Smooth Point: The two blue handles with control points go in the opposite direction (180
degrees) from each other. Also, two control points are positioned at the same distance
away from the anchor point.

Making Straight Segments
If you want to straighten a curved segment between two anchor points, in the edit mode, rightclick on the segment > Straight Segment.

Ending Edit Point
Once you finish editing, click outside a shape to exit the edit mode. Or, right-click anywhere in the
red dashed line and select Exit Edit Point.

Text Caption
Text caption is a rectangle shape that can contain multiple lines of text. You can use text captions
to provide extra information or explain important concepts.
To insert a text caption, click the Insert tab > Text Caption . To add text to text caption, click
on the default text to open the inline text editor, then enter text.

Text caption is a variant of shapes in which only text is seen while its Fill and Line properties are
invisible by default. Therefore, all properties of shapes are applied to text captions. You can also
customize the text caption in the same way you customize shapes.
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Spotlight
Spotlight retains the original brightness of a particular area and darkens the rest of the screen. It
helps to create an effect like you are watching a dark screen while a searchlight is sweeping
through a particular area of the screen. Therefore, the spotlight comes in handy to draw the
audience's attention to even a tiny part of the screen.
To insert a spotlight, click the Insert tab > Spotlight . By default, only the oval shape maintains
the original brightness while the rest of the slide is darkened.

In ActivePresenter, the spotlight is also a shape, hence, all properties of shapes are applied to
the spotlight. You can customize the spotlight in the same way as you customize shapes.
However, there are two exceptions:
●

In the Properties pane, the Fill section in the Style & Effects tab shows the fill properties
of the outside area (outside the oval shape).

●

Spotlight object doesn’t have the rotation property.

Equation
Built-in equations in ActivePresenter allow you to insert them into a slide quickly. Besides, with a
rich library of symbols and structures, you can create a new equation easily as well as edit builtin equations in the way you want. It’s also possible to copy equations from Microsoft Office and
paste them into ActivePresenter.

Inserting Built-In Equations
To insert a built-in equation, in the Insert tab or the Home tab, click the drop-down arrow of the
Equation button, then select an equation you want from the list.
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After that, the equation will be inserted into a slide. At the same time, the Equation tab appears
in the tabbed toolbar. This tab contains symbols and structures that you can use to customize
your equation.

Writing and Editing Equations
Apart from the ability to insert built-in equations, ActivePresenter assists you in writing a brand
new equation from scratch. To do that, in the Insert tab, click the Equation button . Then, a
placeholder where you can build up a new equation is inserted into a slide. At the same time, the
Equation tab appears in the tabbed toolbar.

Do one of the following:
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●

Click the Equation button
customize it as you want.

at the top-left corner to insert a built-in equation and

●

Insert math-related symbols from the Symbols group into the placeholder. To see more
symbols, click the arrow at the bottom-right corner of the gallery.

●

Insert built-in structures from the Structures group into the placeholder. Then, replace
small dotted-line boxes with symbols selected from the Symbols group.

●

To edit an equation on a slide, just click the equation, open the Equation tab, then replace
the current structures or symbols with new ones.

Icons
Using icons is a good way to add visuals to your presentation. Icons are illustrative vector files
that can be resized without pixelation. Once you’ve inserted an icon into a slide, you can move,
resize, rotate, or style it the way you want.
To insert an icon, click the Insert tab > Icons
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Note that some icons are actually groups of freeform shapes, so you can edit them in the same
way as how you edit groups. An icon is also a variant of shapes. Hence, all properties of shapes
are applied to icons. You can also customize icons in the same way you customize shapes.

Gesture Effects
Gesture effects are mostly used in the demonstration mode to simulate how users interact with a
target object on a touch screen. A gesture effect looks like an animated GIF image.
To insert a gesture effect, click the Insert tab > Gesture Effects
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To change a gesture effect, click the Properties pane > Size & Properties > Gesture Effects >
select a new gesture effect from the Type drop-down list.
Note that gesture effect objects don’t have the rotation property.

Footer
Footer allows you to add dates, slide numbers, and text to the bottom of a slide. To insert a footer,
click the Insert tab > Footer . A Slide Footer dialog appears as follows:
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Date: Add the date to the bottom-left corner of a slide.
o

Update Automatically: Automatically add the current date each time you open or print
the project.

o

Fixed: Add a fixed date.

●

Slide Number: Add slide numbers to the bottom-right corner of a slide.

●

Footer: Add text to the bottom center of a slide.

●

Don’t show on title slide: Don’t show the footer on the title slide.

●

Click Apply to add a footer to the current slide. Click Apply to All to add a footer to all
slides in a project.

Chart
Using charts is a great way to illustrate your numerical or statistical data visually. That makes it
easier to interpret data, hence retaining viewers’ interests. You can represent your data through
symbols such as columns, lines, bars, and more.

Chart Overview
ActivePresenter supports up to 10 major chart types with variations on each type for you to choose
from.

Column Charts
Column charts can be used to illustrate data changes over time or comparisons among items or
categories. A column chart presents data in rectangular vertical bars whose heights are
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proportional to the values. In which, categories and values are correspondingly distributed on the
horizontal axis and the vertical axis.
There are two types of column charts: Column and Stacked Column.

●

The Column chart type: Compares individual data values in the same category or
across categories, and displays them vertically.

●

The Stacked Column chart type: Compares the total of data values across categories as
well as shows the relative contribution of each data value to the total by displaying values
in vertical stacks.

Bubble Charts
Bubble charts are used to visualize data in three dimensions simultaneously, and present data points
with bubbles. The first two dimensions correspond to horizontal (X) and vertical (Y) axes that define
the location of bubbles. Meanwhile, the third dimension is reflected in the bubbles' sizes.
There is one type of bubble chart: Bubble.
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Doughnut Charts
Doughnut charts can help compare proportions between categorical data as well as express the
“part-to-whole” relationship. A doughnut chart displays data arranged in rings where each ring
represents a dataset counting 100% in total. Each segment’s size in a ring corresponds to the
proportion of each category. Note that a doughnut chart can contain more than one dataset.
There is one type of doughnut chart: Doughnut.

Bar Charts
Bar charts are ideal for showing trend data or comparisons among items or categories when there
are a great number of categories. A bar chart plots data in rectangular horizontal bars whose
lengths are proportional to the values. In which, categories are organized along the vertical axis
and the values along the horizontal axis.
There are two types of bar charts: Bar and Stacked Bar.

●

The Bar chart type: Compares individual data values in the same category or across
categories, and displays them horizontally.
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The Stacked Bar chart type: Compares the total of data values across categories as well
as shows the relative contribution of each data value to the total by displaying values in
horizontal stacks.

Line Charts
Line charts are best to track data changes over periods. A line chart shows data points connected
by straight lines or curve lines. In which, categories and values are distributed evenly along the
horizontal and vertical axes respectively.
There are six types of line charts: Line, Stacked Line, Line with Markers, Stacked Line with
Markers, Stepped, and Stepped with Markers.
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●

The Line chart type: Presents values over time across evenly spaced categories on
straight lines or curve lines.

●

The Stacked Line chart type: Shows values that are cumulative at each category on
straight lines or curves.

●

The Line with Markers chart type: Plots the Line chart type with markers. Markers are
used to visually indicate individual data values.
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●

The Stacked Line with Markers chart type: Plots the Stacked Line chart type with
markers. Markers are used to visually indicate individual data values.

●

The Stepped chart type: Depicts data values on horizontal baselines connected with
vertical lines to form a series of steps.

●

The Stepped with Markers chart type: Plots the Stepped chart type with markers.
Markers are used to visually indicate individual data values.

Polar Area Charts
Polar Area charts are often used when you want to plot cyclic data (eg. average monthly
temperature). A polar area chart presents data in a circular graphic, but each segment has the
same angle and the radius varies with value. In other words, this chart type represents data along
angular and radial axes.
There is one type of polar area chart: Polar Area.

Pie Charts
Pie charts are excellent at showing each data item's distribution relative to the total value
(represented as a pie). A pie chart depicts data in a circular graph divided into slices. Each slice
represents a numerical value and may be bigger or smaller depending on the value. Be aware
that this chart type supports only one dataset.
There is one type of pie chart: Pie.
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Radar Charts
Radar charts are often a good choice if you want to visualize multivariate data. A radar chart
shows two-dimensional data in angular and radial axes. The number of angular axes is
determined by the number of categories. They are spaced evenly around a central point.
There are four types of radar charts: Radar, Radar with Markers, Filled Radar, and Filled Radar
with Markers.
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●

The Radar chart type: Presents the changes in values from the center point across
multiple angular axes (categories).

●

The Radar with Markers chart type: Plots the Radar chart type with markers. Markers
are used to visually indicate individual data values.

●

The Filled Radar chart type: Fills the area covered by data values with colors.

●

The Filled Radar with Markers chart type: Plots the Filled Radar chart type with markers.
Markers are used to visually indicate individual data values.

Scatter Charts
Scatter charts can be effective in showing the relationship between two numerical variables by
markers. The position of each marker on the horizontal and vertical axis indicates values for an
individual data point.
There are five types of scatter charts: Scatter, Scatter with Smooth Lines, Scatter with Smooth
Lines and Markers, Scatter with Straight Lines, and Scatter with Straight Lines and
Markers.
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●

The Scatter chart type: Depicts data points to compare pairs of values.

●

The Scatter with Smooth Lines chart type: Connects data points by a smooth curve.

●

The Scatter with Smooth Lines and Markers chart type: Connects data points by a
smooth curve in which data points are visually shown as markers.

●

The Scatter with Straight Lines chart type: Connects data points by straight lines.
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The Scatter with Straight Lines and Markers chart type: Connects data points by
straight lines in which data points are visually shown as markers.

Combo Column - Line Charts
A Combo Column-Line chart is a variation of combination charts. It’s an ideal choice when you
want to display and distinguish measures of different scales on a single graph. In this chart type,
some data values can be presented as columns and some are shown as lines in the same chart.
There are two types of combo column-line charts: Combo Column-Line and Combo Stacked
Column-Line.

●

The Combo Column-Line chart type: Shows data values in a combination of columns
and lines.

●

The Combo Stacked Column-Line chart type: Shows data values in a combination of
stacked columns and lines.

Inserting Charts
To insert a chart on a slide, take the following:
1. Click the Insert tab > Chart
. The Insert Chart dialog appears, letting you choose
one out of 10 major chart types from the left pane.
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2. Select and preview any available variations of each type at the top of the dialog.
3. Click OK to finish.

Editing Chart Data
After inserting a chart, a window pops up, allowing you to edit the chart data. If you do not see
the Chart Data window, make sure you click the chart to make the window show up. Otherwise,
you can right-click the chart > Edit Chart Data
> Style > click the Edit Chart Data button.

. Or go to the chart Properties pane > Chart

Working with data cells is quite similar to working with cells in Excel spreadsheets. Do as follows:
●

Select an individual cell and change or add content to it.

●

Select one or more labels of columns/rows to manipulate multiple cells at once. Then, you
can right-click them and choose the following options:
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o

Insert: Insert a new column/row to the left/above the selected column/row.

o

Delete: Delete the selected column/row. Note that you can select multiple
columns/rows and delete them at once.

o

Clear Contents: Clear all cell content in the selected column/row. Alternatively, you
can press the DELETE key on your keyboard.

All the changes you made will be reflected in the chart immediately.

Modifying Charts
There are several ways to modify and customize your charts. ActivePresenter lets you change
chart size, adjust chart container layout, and show/hide chart elements. Do the following:
●

Resize chart: Select a chart and drag its resizing handles to change its size. Or, in the
Properties pane > Size & Properties > Transform > enter specific values in the Width
and Height spin boxes.

●

Adjust chart container layout: An inserted chart on the Canvas has 3 parts: chart title
(1), chart area (2), and chart legends (3).
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By default, the chart container has a flex layout. You can find its properties by selecting
the chart > Properties pane > Size & Properties > Container Layout. Chart parts in the
flex container layout can be laid out and aligned automatically. You cannot manually adjust
them. Instead, just select each chart part (flex child) and make changes in the Flex Child
section. For more information, please refer to Using Flex Layout and Customizing Flex
Child in Flex Container.
●

Show/hide chart elements: Select a chart > click on the plus button > choose to
show/hide the chart Title, Legends, Tick Labels, Axis Labels, Gridlines, as well as
Point Labels and Angle Lines (in the Polar Area and Radar chart types).
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Customizing Chart Styles
To change styles for a chart, you first select it > Properties pane > Chart > Style. You are free
to customize styles of chart datasets, scale options, markers, lines, and so on. Chart style
properties may vary from type to type.
Annotation Objects > Chart

156

ActivePresenter User Manual

Version 9.0

Customizing the Column, Bubble, Bar, and Combo Column-Line Chart Styles
The Column, Bubble, Bar, and Combo Column-Line charts share the same style properties.
You can adjust their chart datasets and scale options.
a. Dataset
The Dataset means data values presented in colored vertical/horizontal bars/bubbles. Click the
drop-down Dataset list to switch to any dataset you want to style.

●

●

Fill: Customize the background fill of the dataset.
o

No Fill: The dataset becomes transparent.

o

Solid Fill: Fill a dataset with a single color. To do that, click the color picker > select
a color > change the color Opacity by dragging the slider or entering a number in the
Opacity spin box.

Line: Customize the line border of the dataset.
o

No Line: There is no outline for the dataset at all.

o

Solid Line: Draw the dataset’s line border with a single color. To do that, click the
color picker > select a color > change the color Opacity by dragging the slider or
entering a number in the Opacity spin box. Moreover, you can set the line width the
way you want.
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Plot Dataset On: Choose between Primary Axis and Secondary Axis to plot a dataset
on. In vertically oriented charts, the primary axis runs along the left side and the secondary
axis runs along the right side of the chart. Meanwhile, horizontally oriented charts have the
primary axis and secondary axis distributed at the bottom/top of the chart, respectively. You
can use a secondary axis when data values vary greatly between one another without the
need for additional charts. Note that you cannot plot all the datasets in the secondary axis.
For example, in the chart below, Dataset 1 is plotted on the Secondary axis while Dataset
2 and Dataset 3 are plotted on the Primary axis.

b. Scale Option
Click the drop-down Axis list to choose one of the chart axes to customize its properties. There
are four types of axes: Primary Horizontal, Primary Vertical, Secondary Horizontal, and
Secondary Vertical.
Note that the properties for the Secondary Horizontal and Secondary Vertical options are only
available when there is at least one dataset plotted on the Secondary axis.
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Gridlines: You can set the following properties for gridlines:
o

No Line: Do not draw gridlines on the chart area.

o

Solid Line: Draw gridlines with a single color. To do that, click the color picker > select
a color > change the color Opacity by dragging the slider or entering a number in the
Opacity spin box. Moreover, you can set the gridlines’ width the way you want.

o

Dash Pattern: You can change the pattern of gridlines. Select either of two types:
Solid and Dash.

o

Draw On Chart Area: Tick the checkbox to draw horizontal/vertical gridlines on the
chart area. Drawing gridlines helps viewers understand what values are represented
by unlabeled data points.

o

Draw Tick Mark: Tick the checkbox to draw lines which are the extension of the
gridlines from the axis border to the tick labels.
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Draw Border: Tick the checkbox to draw a line border at the edge intersecting with
the corresponding axis.

Tick Labels: This section lets you customize the tick labels of the corresponding axis.
o

Text No Fill: The corresponding axis has no tick labels.

o

Text Solid Fill: Fill the tick labels of the corresponding axis with a single color. To do
that, click the color picker > select a color > change the color Opacity by dragging the
slider or entering a number in the Opacity spin box.

o

Font Name: Change the font of the tick labels.

o

Font Size: Change the font size of the tick labels.
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Bold: Tick the checkbox to make the tick labels bold.

o

Italic: Tick the checkbox to make the tick labels italic.
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Axis Label: In this section, you can customize the axis label of the corresponding axis.
o

Text No Fill: The corresponding axis has no axis label.

o

Text Solid Fill: Fill the axis label of the corresponding axis with a single color. To do
that, click the color picker > select a color > change the color Opacity by dragging the
slider or entering a number in the Opacity spin box.

o

Text: Change the text of the axis label.

o

Font Name: Change the font of the axis label.

o

Font Size: Change the font size of the axis label.

o

Bold: Tick the checkbox to make the axis label bold.

o

Italic: Tick the checkbox to make the axis label italic.

Note: In the Combo Column-Line chart, you can choose the Type for each dataset, either
Column or Line, to customize. The Column type has properties similar to those of Column charts,
while the Line type is similar to Line charts.

Customizing the Doughnut, Pie, and Polar Area Chart Styles
Data values in the Doughnut, Pie, and Polar Area charts all are shown in circular graphics. With
these chart types, you are enabled to edit styles for the chart datasets and categories. Besides,
the Polar Area charts have extra scaling options.
a. Dataset
In the Doughnut charts, a dataset is represented as a ring. You can add additional datasets to
this chart type through the Chart Data window. However, the Pie and Polar Area charts just have
only one dataset. The Dataset section allows you to set the line border of each dataset and the
border of categories in that dataset.
For the Doughnut charts, you can click the drop-down Dataset list to switch to any dataset you
want to edit.
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●

No Line: Do not draw line borders of datasets and categories.

●

Solid Line: Draw line borders of datasets and categories with a single color. To do that,
click the color picker > select a color > change the color Opacity by dragging the slider or
entering a number in the Opacity spin box. Moreover, you can set the line borders’ width
the way you want.

b. Category
The Category means data values depicted in colored segments. In this section, you can
customize the background fill of each category. Click the drop-down Category list to choose one
of the categories to restyle.
●

No Fill: The category becomes transparent.

●

Solid Fill: Fill a category with a single color. To do that, click the color picker > select a
color > change the color Opacity by dragging the slider or entering a number in the
Opacity spin box.

c. Scale Option
The Polar Area charts have the same Dataset and Category sections above. It is also
customizable with scaling options.
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Gridlines: Gridlines in the Polar Area charts are drawn in the polar coordinate system.
o

No Line: Do not draw gridlines on the chart area.

o

Solid Line: Draw gridlines with a single color. To do that, click the color picker > select
a color > change the color Opacity by dragging the slider or entering a number in the
Opacity spin box. Moreover, you can set the gridlines’ width the way you want.

o

Dash Pattern: You can change the pattern of gridlines. Select either of two types:
Solid and Dash.

Angle Lines: Angle lines are line borders of angles, which extend from the center point to
the maximum magnitude of the gridlines.
o

No Line: Do not draw angle lines on the chart area.

o

Solid Line: Draw angle lines with a single color. To do that, click the color picker > select
a color > change the color Opacity by dragging the slider or entering a number in the
Opacity spin box. Moreover, you can set the angle lines width the way you want.

o

Dash Pattern: You can change the pattern of angle lines. Select either of two types:
Solid and Dash.

Tick Labels: This section lets you customize the tick labels of the chart.
o

Text No Fill: The chart has no tick labels.

o

Text Solid Fill: Fill the tick labels with a single color. To do that, click the color picker
> select a color > change the color Opacity by dragging the slider or entering a number
in the Opacity spin box.

o

Font Name: Change the font of the tick labels.

o

Font Size: Change the font size of the tick labels.

o

Bold: Tick the checkbox to make the tick labels bold.

o

Italic: Tick the checkbox to make the tick labels italic.

Point Labels: In this section, you can customize the point labels of the chart.
o

Text No Fill: The chart has no point labels.

o

Text Solid Fill: Fill the point labels with a single color. To do that, click the color picker
> select a color > change the color Opacity by dragging the slider or entering a number
in the Opacity spin box.

o

Font Name: Change the font of the point labels.

o

Font Size: Change the font size of the point labels.

o

Bold: Tick the checkbox to make the point labels bold.

o

Italic: Tick the checkbox to make the point labels italic.
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Customizing the Line, Scatter, and Radar Chart Styles
The Line, Scatter, and Radar charts can show data values with or without markers. Apart from
the customization of the background fill of markers, you can also edit styles for interpolation lines.
a. Dataset
Click the drop-down Dataset list to switch to any dataset you want to make changes to.

●

●

Fill: Customize the background fill of markers of the dataset for charts plotted with
markers. For the Filled Radar/Filled Radar with Markers, and Line with Area Fill chart
types, this option applies to the area covered by data values and markers.
o

No Fill: The area covered by data values and/or markers becomes transparent.

o

Solid Fill: Fill the area covered by data values and/or markers with a single color. To
do that, click the color picker > select a color > change the color Opacity by dragging
the slider or entering a number in the Opacity spin box.

Line: Customize the interpolation lines/line borders of the dataset.
o

No Line: Do not draw the dataset's interpolation lines/line borders.
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o

Solid Line: Draw the dataset’s interpolation lines/line borders with a single color. To
do that, click the color picker > select a color > change the color Opacity by dragging
the slider or entering a number in the Opacity spin box. Moreover, you can set the line
width the way you want.

o

Cap Type: You can let the ends of the dataset’s interpolation lines/line borders have
either a square or round cap type.

o

▪

Square: A square end cap is added to each end of the line.

▪

Round: A rounded end cap is added to each end of the line.

Join Type: You can change the type of the join where two lines intersect with each other.
▪

Round: The corners where two lines connect are rounded.

▪

Bevel: The corners where two lines connect are cut off at a 45-degree angle.

▪

Miter: The corners where two lines connect are squared off.

o

Dash Pattern: You can change the pattern of the dataset’s interpolation lines/line
borders. Select either of four types: Solid, Dot, Dot Dash, and Dash.

o

Area Fill: You can fill the area between the dataset’s interpolation lines and the origin,
start, or end boundary with a solid color. This option is available for the Line charts only.
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▪

None: The dataset area has no background fill.

▪

Origin: Fill the area from the dataset’s lines to the gridline at the origin.

▪

Start: Fill the area from the dataset’s lines to the gridline at the min value.

▪

End: Fill the area from the dataset’s lines to the gridline at the max value.

Plot Dataset On: Choose between Primary Axis and Secondary Axis to plot a dataset
on. This option is available for the Line and Scatter charts. Please refer to the Dataset
section of the Column charts for more information.

b. Line Mode
You can plot the Line/Stacked Line with or without Markers charts or the Scatter charts with
straight lines or smooth lines.

●

Linear: Data points are joined by straight lines.

●

Curve: Data points are joined by curve lines resulting in smooth transitions between points.

c. Stepped
This option is only added to the Stepped/Stepped with Markers charts. It lets you adjust the
step in the interpolation line between two data points of the dataset.
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●

Before: The step is formed at the value of the second data point. It is enabled by default.

●

Middle: The step is formed at the value in the middle of two data points.

●

After: The step is formed at the value of the first data point.

d. Marker
This section allows you to adjust the type and size of markers.

●

None: Plot the chart without markers.

●

Built-in: Plot the chart with built-in markers.
o

Type: Change the markers’ type. Choose either of five types: Circle, Triangle, Rect,
RectRounded, and RectRot.
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Size: Change the size of markers (in pixel). Click the up/down arrows to
increase/decrease the value respectively. Alternatively, directly enter a value into the
spin box.

e. Scale Option
The scaling properties of the Line and Scatter charts are similar to those of the Column charts.
Meanwhile, for the Radar charts, you can reference the Scale Option section of the Polar Area
charts for more information. The only difference is the gridlines in the Radar charts can be drawn
as either circles or a spider web. Check the Circular checkbox to draw the gridlines as circles.
Otherwise, they can be like a spider web.

Changing Chart Type
To replace the existing chart type with another one, you select that chart first, and click the Insert
tab > Chart. Or, right-click the existing chart > Change Chart Type. Notice that ActivePresenter
builds a preview for each type using the data you have specified in the existing chart. When it
comes to changing chart types, there are some differences in the data, datasets’ styles, and chart
elements’ styles among chart types.
●

Regarding data and datasets’ styles changing, charts are divided into 2 groups. The first
group includes the Column, Bubble, Bar, Line, Radar, Scatter, and Combo ColumnLine charts. The second group contains the Doughnut, Polar Area, and Pie charts. When
you change a chart type to others of the same group, it will keep the data and dataset
styles unchanged. Otherwise, they will be reset.
However, in the first group, the Column, Bar, Line, Radar, and Combo Column-Line
chart types plot only one dimension of the datasets. Meanwhile, the Bubble and Scatter
chart types plot more than one dimension. Therefore, there is one thing to be considered
in data change.
For instance, if you switch between a Column chart type and a Scatter chart type, the
data values in the Column chart type will be converted to the (Y) values of the
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corresponding datasets in the Scatter chart type, and vice versa. The (X) values (Scatter
and Bubble charts) and the (Size) values (Bubble charts) will be the defaults.

●

About the chart elements’ styles such as Tick Labels or Gridlines when changing chart
type, you should take notice of charts plotted with different elements (eg. the Radar and
Column chart types) or with the same elements (eg. the Radar and Polar Area chart
types).
For example, if you switch from a Radar chart type to a Column chart type, the styles of
the Tick Labels/ Point Label/ Gridlines in the Radar chart will correspondingly convert
to those of the Primary Vertical Tick Labels/ Primary Horizontal Tick Labels/
Horizontal and Vertical Gridlines in the Column chart.
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On the contrary, if you change from a Column chart type to a Radar chart type, the styles
of the Tick Labels and Point Label work the same way as above; however, the styles of
the Gridlines in the Radar chart will be inherited only from the styles of the Primary
Horizontal Gridlines in the Column chart.

Because the Radar and Polar Area chart types are plotted with the same elements,
switching between these two chart types will maintain the elements' styles.

Annotating and Labeling Charts
Charts in ActivePresenter can be annotated and labeled in HTML5 output. Viewers can hover
the mouse over each dataset to see the data values.
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Table
Tables allow you to store and organize data in rows and columns.

Inserting Tables
To insert a table, click the Insert tab > Table

. The Insert Table dialog appears as follows:

Do either of the following to specify the number of columns and rows:
●
●

Click the up/down arrow to select the number of columns and rows that you want.
Enter a number in the range of 1 – 50 in the Number Of Columns and Number of Rows
combo boxes.

Click OK. Then, the cursor turns into a crosshair. Drag the mouse to draw the table on the Canvas
or click anywhere on the Canvas to insert the table.
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Modifying Tables, Columns, Rows, and Cells
As soon as you insert a table, you can modify the table the way you want:
●

●

●

●

●

Change table size: Drag the resizing handles to resize a table. Alternatively, select a
table and click the Properties pane > Size & Properties > Transform > enter specific
values in the Width and Height spin box.
Change table position: Drag a table to a new position on the Canvas. Or, select a table
and click the Properties pane > Size & Properties > Transform > enter specific values
in the Left and the Top spin box.
Insert, delete rows/columns and merge/split cells: Select one or more adjacent cells
and do these manipulations in the contextual Table Tools tab that appears after inserting
a table. Or right-click a cell/table > Table > select the desired option. Alternatively, you
can click the green plus button and select the desired option.

Resize columns, rows, cells: Rest the mouse on the line inside the table until it turns
into a bidirectional arrow, then drag the table line until it is the desired size. Alternatively,
select the column/row/cell and click the Properties pane > Table > Cell Size > enter
specific values in the Width and Height spin box. To make multiple rows or columns the
same size, select the columns or rows and click Distribute Columns or Distribute Rows.
Add text: Click a cell, then enter your text. After adding text to a cell, you can use the
buttons and commands in the Home tab or in the inline text editor to format text.
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●

Change table style: Select a table and click the Properties pane > Table > Style
Options to toggle table elements such as Header Row, Total Row, Banded Rows, First
Column, Last Column, and Banded Columns. You can also access the Table Tools
tab to change the quick style.

●

Change background fill: You can add or change the background color for the whole
table. The background color appears underneath any fill color that is applied to the table
cells. Select a table or any cell, click the Properties pane > Table > Table Background
> select the fill color option you want, or to choose no color, click No Fill.
Change shading: Select a table, columns, rows, or cells that you want to change their
shading, click the Properties pane > Table > Shading > select the fill color option you
want, or to choose no color, click No Fill.
Change border: Select a table, columns, rows, or cells that you want to change their
borders, click the Properties pane > Table > Border > select the border type, width, and
color you want.

●

●

Image
Images can be technical drawings, paintings, landscape pictures, photographs, or screenshots.
ActivePresenter currently supports six image file formats, including PNG, JPG, JPEG, BMP, GIF,
and SVG.

Inserting Images
To insert an image, do the following:
●

Click the Insert tab > Image
> select an image. Alternatively, you can drag an image
directly from your computer onto the Canvas.

●

Click the Insert tab > Screenshot

to take a screenshot of anything on the screen.

Taking Screenshots
A typical application has a top-level window, which may consist of many child-level windows that
appear to accomplish different tasks. Besides, a window at any level, either a top-level or a childlevel, may include many objects such as menus, panes, toolbars, controls, etc. In case you want
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to capture a window or an object of that application perfectly, ActivePresenter offers a great
feature to do that quickly and easily. Just open the Insert tab > Screenshot
> select a
screenshot mode:

Window
Select the Window mode
to capture a screenshot of the target window or any object in it. You
can capture a window at any level of the application. Do as follows:
1. Move the mouse to select a window or its object (toolbars, panes, menus, etc.). As you
move the mouse over different parts of the screen, a red dashed outline
appears
around areas that can be captured. Note that you can click on screen and the target
application as usual because this action doesn’t trigger a screenshot.
2. When you find the correct area to be captured, press PRINT SCREEN or CTRL+Click. A
screenshot is captured and placed on the current slide.
Note: ActivePresenter cannot detect some objects in certain target applications. This is because
those applications don’t provide MSAA interface for those controls. ActivePresenter typically
captures the whole toolbar because it is usually the lowest child level window.

Object
Select the Object mode

to capture a screenshot of any object in any window.

1. As you move the mouse over different parts of the screen, a red dashed outline
appears around areas that can be captured.
2. When you find the correct area to be captured, press PRINT SCREEN or CTRL+Click. A
screenshot is captured and placed on the current slide.
Note: ActivePresenter cannot detect some objects in certain target applications. This is because
those applications don’t provide MSAA interface for those controls. Typically, ActivePresenter
can capture individual tools in any toolbar, depending on the accessibility support level of the
target application.

Full Screen
Select the Full Screen mode
to capture a screenshot of the entire screen of your PC.
ActivePresenter will minimize its own window, and automatically capture whatever visible on your
computer screen.
A screenshot will be placed on the current slide. Normally, it is very likely to be larger than your
slide. If you resize it to fit the slide size, the details in the screenshot may get blurred and users
may not be able to read specific details.
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Application or Region
Select the Application or Region mode
to capture a screenshot of the top-level window of
the target application or a rectangular area on the screen. Immediately, a blue rectangle and the
Take Screenshot window appear. You can resize the blue rectangle, drag it, then place it in any
area on the screen.

To set the properties for the Take Screenshot dialog, do as follows:

1. Screenshot Usage:
o

Insert as image to current slide: Insert a screenshot as an image into the current slide.

o

Insert as new slide next to current slide: Insert a screenshot as a background
image into a new slide (The new slide will be inserted below the current slide).

2. Screenshot Size: Specify screenshot’s sizes by entering specific values in the Width and
the Height spin box. Alternatively, click the Preset Sizes button to select one predefined
size from the drop-down list.
3. Application: Provide a list of all running applications that have a visible window on your
computer.
o

Fit To Application: Resize the blue rectangle to fit into the application window.

o

Fit To Boundary: Resize the application window to fit into the blue rectangle.
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4. Wait for: Specify a time delay (in seconds). Use this delay to quickly interact with the
target application and capture its response.
5. Take Screenshot: Click the button to take a screenshot.

Screenshot Options
To change screenshot settings, click the Insert tab > Screenshot > Options.

●

Capture Window Shadow: When an application window is in non-maximized state, the
Windows OS casts a drop-shadow around its border. Select this option to capture the
shadow while taking a screenshot of the target window.
Note that the drop-shadow is treated as a part of the image but not the shadow property
of the screenshot. In other words, you can add one more shadow to this captured image
with a different set of parameters (color, distance, angle, etc.)

●

Process Rounded Corners: When an application window is in non-maximized state, the
Windows OS offers an option to display rounded corners. Select this option to capture those
rounded corners. If you turn off this option, the captured image will have sharp corners.

●

Use Opaque Background: Windows 8.1 and later have an option to use Aero theme, in
which the border of windows appears semi-transparent. With this theme, while the
windows look great, they mess up the screenshot because any text/image in the
background will also show up through the border. Select this option to replace this
transparency in the screenshot with opaque border.

●

Show Usage Guide: Show a text box that describes how to capture a screenshot while
taking screenshots of windows or objects. If you are apt to forget the shortcuts, leave this
display on.

Note that the first three options only work when you capture a window at any level. They will not
work when you capture a region or an object.

Editing Images
After inserting an image, you can make changes to it as follows:

● Resize images: Select an image and simply drag its resizing handles to change its sizes.
Or, in the Properties pane > Size & Properties > Transform > enter specific values in
the Width and Height spin boxes.

● Restore image’s original size: If you want to revert to the image’s original size, in the

Properties pane > Size & Properties > Transform > Restore Original Size.
Alternatively, right-click on an image > Restore Original Size.

●

Crop images: Select an image, access its Properties pane > Size & Properties > Crop.
Then, adjust the Left, Right, Top and Bottom sides to be cropped (in %) the way you
want. You can click the up/down arrow to increase/decrease the value respectively, or
enter a value in the spin box. All the changes will be immediately reflected in the image
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on the Canvas. Alternatively, clicking the Crop button in the Properties pane will enable
you to drag the red frames on the Canvas to specify the cropped area. You can also
navigate to the Format tab > Crop or right-click the image > Crop to get the same result.
Once you click the Crop button again or click outside the image, it will be cropped instantly.

● Replace images: Select an image, then in the Properties pane > Size & Properties >

Image > From Project… or From File… > select another image from the current project
or from your computer respectively. Note that if the new image has a different size or ratio
compared to the selected image, it will be adjusted to fit into the selected image object.

● Further edit images: Right-click an image > Edit Image... to open the Image editor and

the Drawing tab. While editing an image, once you click Save in the Quick Access
Toolbar, all changes you made to an image will be applied and reflected on the slide.
When you’re done, close the Image editor and go back to the slide.

Exporting Images
ActivePresenter allows you to export images to 3 supported file formats, which are PNG, JPG,
and BMP.
To export images, follow these steps:
1. Select an image on the Canvas.
2. Right-click on it > Export To File….
3. Specify the file name, file format, and file location, then click Save to export.

YouTube Video
YouTube video is an effective tool to make your presentation more informative. Do the following
steps to embed a YouTube video on a slide:
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. A dialog appears, letting you add a video.

2. Enter the URL of a YouTube video into the Link text box.
3. Click Preview or press ENTER on the keyboard to load and preview the video within the
dialog.
4. Specify playback options for the video.
●

Autoplay: Make the video start playing automatically as soon as the slide’s
timeline reaches the start of the video object.

●

Hide Annotations: Hide annotations in the video such as notes, labels, or titles.

●

Hide Controls: Hide video player controls. Note that without the controls, you can
still play or pause the video by simply clicking it.

●

Disable Scaling: Keep embedded content the same when scaling a slide/ a
presentation, for example, when zooming and panning in the AutoFit mode of a
presentation. This option is turned on by default.

●

Play Specific Part: Embed just a specific part of a video. Select this option and
enter the start time and end time (in seconds) in the spin boxes.
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For example, you have a two-minute video but you just want to show its content from the 20th
second to the 60th second. To do that, simply select the Play Specific Part box, then enter 20
and 60 in the Start Time and the End Time spin boxes, respectively.
5. Click OK to finish.
After embedding a YouTube video on a slide, you can resize it. In case you want to bring back its
original size, right-click on it > Restore Original Size.
You can also update a video thumbnail to the latest one by right-clicking on it > Update Thumbnail.
To make changes for a YouTube video, right-click it on the Canvas > YouTube Properties. This
will take you to the Properties pane. Or you can directly access the Properties pane > Size &
Properties > YouTube > Edit.
Note:
●

A YouTube video only works in HTML5 output. In other outputs, it is exported as an image.

●

Due to technical limitations, there is no warranty that the playback of a YouTube video will
always synchronize with the playback of the project.

●

On mobile devices, only user-initiated playback is acceptable. So, users need to click a
YouTube video to play it even when the Autoplay option is selected. For this reason, you
should not select the Hide Controls option when creating content for mobile devices.

Web Object
Web objects allow you to embed a website or an HTML package directly in a slide. They can help
enhance your project with web-based resources such as websites, games, social media, and
reference material. Embedding web objects helps increase the interactivity level of your project.
For example, when you embed a website in your eLearning course, learners can interact directly
with the website in the course as they normally do when they visit the website.
In ActivePresenter, both full, absolute, and relative URLs are supported for web objects. A web
object only works in HTML5 output. In other output, it is exported as images.

Address & Embed Code
To insert webpage or embed code, do the following:
1. Click the Insert tab > Web Object

. A dialog appears, letting you add a web object.

2. Select Address or Embed Code from the Type drop-down list to embed a webpage or a
piece of code respectively.
3. Enter the URL of a webpage into the URL text box or type a piece of code in the Code
text box.
4. Click Preview or press ENTER to load and preview the web object within the dialog.
5. Click OK to finish.
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HTML Package
To insert an HTML package, do as follows:
1. Click the Insert tab > Web Object

.

2. Select HTML Package from the Type drop-down list.
3. Click
to select a package from your project or click
computer.

to select a folder from your

4. Select Entry Point from the drop-down list.
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4. Click OK to embed your HTML package.
Specify scrolling and scaling behaviors for web objects as follows:
●

Scrolling: Allow scrolling the content of a webpage. You can see how this scrolling
behavior works when previewing your project.

●

Disable Scaling: Keep the embedded content the same when scaling a slide/ a
presentation. For example, when zooming and panning in the AutoFit mode of a
presentation.

After embedding a web object on a slide, you can resize it. In case you want to bring back its
original size, right-click on it > Restore Original Size.
You can also update a web object thumbnail to the latest one by right-clicking on it > Update Thumbnail.
To change a web object, right-click it on the Canvas > Web Object Properties. This will take you
to the Properties pane. Or you can directly access the Properties pane > Size & Properties >
Web Object > Edit.
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3D Model
3D models help to provide a real-world environment for your projects. This feature comes in handy
when you want to visualize scenes that are hard to imagine by using 3-dimensional objects.

Inserting 3D Models
To insert a 3D model, open the Insert tab, click 3D Model
and select a file from your computer.
Currently, ActivePresenter supports six 3D model formats, including *.fbx, *.obj, *.3mf, *.ply, *.stl,
and *.glb. However, regardless of the format you choose, it will be converted into *.glb format
when being imported into ActivePresenter. Keep in mind that you can also drag 3D models directly
from your computer into the app. Besides, when you import a PowerPoint presentation
containing 3D models, they will be imported into your current ActivePresenter project.
The imported 3D models can be found in the Resources pane > Other Resources tab. From
here, you can drag them to any slide in your project for further editing. You can also export them
to files with *.glb format. Just right-click a 3D model and select Export to File… Or, select one or
multiple 3D models and click the Export to File button:

If you want to replace a 3D model with another one, you can select that 3D model. Then, in the
Properties pane > 3D Model tab > 3D Model section > Source > select another 3D model from
the current project or from your computer respectively.

Customizing 3D Models
Select a 3D model, then, navigate to the Properties pane > 3D Model tab. ActivePresenter allows
you to customize model rotation, camera position, look-at point, and field-of-view. Besides, with
animated 3D models, you can explore their multiple scenes.
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Model Rotation
After inserting 3D models, feel free to rotate them 360 degrees on the desired axis:
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X Rotation: Rotate a model on the horizontal axis (the X-axis).
Y Rotation: Rotate a model on the vertical axis (the Y-axis).
Z Rotation: Rotate a model on the Z-axis.

Just enter any integer value in the corresponding spin boxes and then it will automatically convert
to a value in the range [0;359].
Take a look at the following examples:
•

If X Rotation = 90, the model will be rotated 90 degrees downwards:

•

If Y Rotation = 30, the model will be rotated 30 degrees to the right:
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If Z Rotation = 180, the model will be rotated 180 degrees on the Z axis. As a result, it
turns upside down:

Camera Position
As its name implies, the camera position defines the location (the X, Y, Z coordinates) of the
camera. When you import a 3D model into ActivePresenter, the camera always takes up an initial
position to point to the model. Normally, it is located on the Z-axis, its X and Y coordinates are
equal to 0. It points directly to the center of the model.
Enter a number value from -50 to 50 in the corresponding spin boxes to change the X, Y, Z
coordinates of the camera:
•

•

•

X Position: Change the X coordinate of the camera.
o X<0: The camera moves to the left (with respect to the origin) along the X-axis. As
a result, the camera points to the left of the model. The smaller the value is, the
smaller the model becomes.
o X>0: The camera moves to the right (with respect to the origin) along the Xaxis. Subsequently, the camera points to the right of the model. The greater the
value is, the smaller the model becomes.
Y Position: Change the Y coordinate of the camera.
o Y<0: The camera moves downward (with respect to the origin) along the Y-axis.
As a result, the camera points to the lower part of the model. The smaller the value
is, the smaller the model becomes.
o Y>0: The camera moves upward (with respect to the origin) along the Y-axis.
Subsequently, the camera points to the upper part of the model. The greater the
value is, the smaller the model becomes.
Z Position: Change the Z coordinate of the camera.
o Z<0: The smaller the value is, the farther the camera moves from the model along
the Z-axis and the smaller the model becomes. You will see the back of the model.
o Z=0: The camera and the model are in the same position. In other words, they
have the same coordinates (0,0,0). Therefore, you cannot see the model if this
value is 0.
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Z>0: The greater the value is, the farther the camera moves from the model along
the Z-axis and the smaller the model becomes. You will see the front of the model.

See the images below:
•

X Position = -1:

•

Y Position = 1:

•

Z Position = -1.7:

Camera Look-at Point
In the previous section, you learn the definition of the camera position. It is a point that sets the
camera position in space. In other words, it is a “from” point. If the camera position is the “from”
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point, you can refer to the camera look-at point as the “to” point. This point has the same
coordinates as the model. Panning the camera will move its look-at point.

Enter a number value from -50 to 50 in the corresponding spin boxes to change the X, Y, Z
coordinates of the look-at point. Note that the Z value of the look-at point should be smaller than
the Z value of the camera position. Otherwise, you will not see the model.
•

X Position: Change the X coordinate of the look-at point.
o If X<0, the look-at point will move to the left side of the model. When this value
decreases to a certain limit, the model will no longer appear in the field-of-view.
o If X>0, the look-at point will move to the right side of the model. When this value
increases to a certain limit, the model will no longer appear in the field-of-view.

•

Y Position: Change the Y coordinate of the look-at point.
o
o

•

If Y<0, the look-at point will move to the lower part of the model. When this value
decreases to a certain limit, the model will no longer appear in the field-of-view.
If Y>0, the look-at point will move to the upper part of the model. When this value
increases to a certain limit, the model will no longer appear in the field-of-view.

Z Position: Change the Z coordinate of the look-at point.
o

Z >=0
If the Z value of the look-at point is smaller than the Z value of the camera position:
The look-at point will move along the Z-axis in front of the camera. Hence, the model
will appear in the field-of-view. You will see the front of the model.
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If the Z value of the look-at point is greater than the Z value of the camera position:
The look-at point will move along the Z-axis behind the camera. So, the model will no
longer appear in the field-of-view.
Z <0
If the Z value of the look-at point is greater than the Z value of the camera position:
The look-at point will move along the Z-axis in front of the camera. Hence, the model
will appear in the field-of-view. You will see the back of the model.
If the Z value of the look-at point is smaller than the Z value of the camera position:
The look-at point will move along the Z-axis behind the camera. So, the model will no
longer appear in the field-of-view.

Take a look at the following images:
•

X Position = -0.3:

•

Y Position = 0.2:

Camera Field-of-view
Field-of-view is the observable range of a camera that allows it to capture all objects that appear
in the range. When you import 3D models into ActivePresenter, the field-of-view value is
predefined in degrees. Enter a value from 0.1 to 179.9 degrees in the corresponding spin box:
•
•

The smaller the value, the narrower the viewing angle and the higher the magnification.
Hence, the larger the model is zoomed in.
The greater the value, the wider the viewing angle and the lower the magnification. As a
result, the smaller the model is zoomed out.
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Take a look at the example below. When this model is imported, its default field-of-view (FOV)
value is 18:

When you adjust other values such as X, Y, Z coordinates of the look-at point, sometimes, you
realize that the model no longer appears in the field-of-view. In this case, you should adjust the
field-of-view value properly to make the model appear again.
Note: After customizations, if the changes do not satisfy you, you can reset all the properties to
the initial values. To do that, access the Format tab > Reset 3D Model. Or, navigate to the
Properties pane > 3D Model tab > click the Reset 3D Model button.

3D Model Scenes
Some 3D models may include multiple scenes for animation. To explore their available animation
scenes, select the model and navigate to the Format tab > Scenes. Alternatively, you can access
the Properties pane > 3D Model tab > 3D Model section > Scenes.

Previewing 3D Models
When you preview your projects which include 3D models in HTML5, you can use the mouse to
rotate them as you wish. Simply drag the mouse left, right, upward, downward, or in a circular
movement to view the model from different perspectives. Note that these movements are not
applicable to 3d models which are set as drag sources.

Cursor Path
Cursor path enables you to simulate mouse movements and clicks, which is extremely useful for
software training. A cursor path has a start point (1), an end point (2) and a dotted line (3)
presenting the movement of the pointer between these two points.
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●

The red arrow shows the direction of the cursor movement.

●

Half of the dotted line toward the start point is green in color, and its remaining half
gradually turns red toward the end point.

●

The spacing between dots indicates the speed of the cursor on screen. That is, the faster
the cursor moves across the screen, the farther are the dots. On the contrary, closely
spaced dots mean slower speeds.

●

When you click the start point, a square appears to denote that the start point is currently
selected. ActivePresenter shows a control point (4) associated with the end point. The line
between the control point and the end point is tangent to the path at the end point. Move
the control point to change the shape of the path.

In practice, cursor path objects are generated in two different ways:
●

During the capture phase, ActivePresenter records your mouse movements and converts
them into cursor paths. You can edit these paths by adding mouse click sounds and effects
in the edit phase.

●

During the edit phase, you can insert your own cursor path and style the path the way you
want. In general, the idea is to insert a cursor path, then add points to the path and place
them over buttons or other clickable objects. Optionally, you can add click points, where
ActivePresenter produces the click sound in the rendered project.

Adding Cursor Paths
You can insert only one path to a slide. Do the following:
1. Click the Insert tab > Cursor Path

. This inserts a cursor path into the current slide.

2. Add points to the path. Hover anywhere over the dotted line, the pointer changes to a
pencil (1). Click to add a point (2) and drag that point (3) to the position you want (4).
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3. Any path segment can be made a curve or a straight line. Just right-click on the start point >
Straight/Curved Cursor Path. Another way to change the path is to move the control point.
Tip:
●

Highlight the mouse cursor so that users follow it more easily. To do that, select one point
on the path > Properties pane > Size & Properties > Cursor Path > Highlight.

●

In the Cursor Path section, select Show to end to show the path until the end of the slide.

Changing Cursor Styles
To add a cursor image to a point or replace the original pointer with another shape. Do the
following:
1. Right-click a point > Change Cursor. This will take you to the Properties pane. Or you
can click a point and directly access the Properties pane > Size & Properties > Cursor
> Cursor Image.
2. Select the cursor image you want from the gallery. You can even use your own image by
clicking the From Project or From File button.
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In the following example, several points are added to the original path. The cursor for each of
those interim points is also changed. When rendered, this path will keep changing the cursor
shape along the way.

Note: If you want all the Cursor Path objects in the current project to have the same cursor
shape/image, just click the Apply Style To All Cursors button.
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Changing Timing and Speed of Mouse Movements
Take a look at the cursor movement in time. The cursor path has four segments in total.

The figure shows the 3rd segment with four instants 1-4 marked on both the Canvas and the
timeline. From the timeline, you can see that:
●

The gray vertical line (1) starts the life of the segment.

●

The instant when the cursor starts moving is marked with a red vertical line (2).

●

During the 1→2 gap, the cursor is at rest (there is no movement). This is the start duration
of the cursor.

●

The instant when the cursor stops moving is marked with a second red vertical line (3).

●

During the 3→4 gap, the cursor is at rest (there is no movement). This is the stop duration
of the cursor.

●

The green horizontal line indicates the moving duration of the cursor.

●

The second gray vertical line (4) denotes the end of the segment.

●

The yellow diamond
represents a click point. This is where ActivePresenter simulates
a click by creating a click sound and click effect.

You can drag the lines above to change where the movements of the cursor begin and how long
they last. Alternatively, click the Properties pane > Cursor > Timing to adjust the timing and
speed of the mouse movement.
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Adding Click Points
You can convert any point along the path into a click point by doing the following:
1. Click a point.
2. Click the Properties pane > Size & Properties > Cursor > Click Point.

3. Select the desired type of click point from the Type drop-down list. Select None if you
don’t want to add a click point.
4. Set the click time which is the duration from the time the cursor appears until it starts
moving. If the cursor is the last one, it is the cursor’s showing time. To do that, you should
drag the click point (a yellow diamond icon) in the Timeline.
5. Click Apply To All to apply changes to all click points of the same type.
Take a look at the table below. It summarizes all properties that you can adjust in the Cursor
section:
Properties

Function

Cursor Image

Change the cursor shape or cursor image (from the project or your computer).

Apply Style To
All Cursors

Apply the style of the selected cursor path to all cursor path objects in the
current project.

Position

Change the position of each dot on the dotted line of the cursor path.

Timing

Change the timing of the cursor movement.

Start Duration

The duration which is counted from the beginning point of the cursor
segment (the time when the cursor appears) to the point when the cursor
starts moving. During this time, the cursor has no movement.

Stop Duration

The duration which is counted from the point when the cursor stops moving
to the end point of the cursor segment. During this time, the cursor has no
movement.

Moving Duration

The duration in which the cursor has movement.

Speed

The speed of the cursor movement.

Fixed Speed

The movement speed is fixed. Select this checkbox to disable the option to
set the moving duration.
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Click Point

Change the click point’s timing.

Type

Select the click type to add and customize it (Left-click, Right-click, and Left
double-click).

Click Time

The duration from the time that the cursor appears to the time it starts
moving. If that cursor is the last one, it is the cursor’s showing time.

Apply To All

Apply the click time to all clicks of that type.

Adding Cursor Graphics and Click Effects
You are able to further customize the cursor graphics, click sound and effects if you wish by going
to the Properties pane > Size & Properties > Cursor Path.
Properties

Function
Type of the highlight effect.

Highlight

You can select from: None, Circle, and Square.
Size of the highlight effect.
Size

Color
Opacity
Left-Click/ RightClick/ Left
Double-Click
Effects
Click Sound
Click Effect
Size
Color
Opacity

It is the radius of the circle in the Circle Highlight or half of the square width
in the Square Highlight.
The color is used to draw the highlight.
The opacity is used to draw the highlight.

Customize sound and effects for clicks.

The sound is played when a mouse button is pressed.
The animation effect is rendered when a mouse button is pressed. You can
select from: None, Circle, Concentric Circles, and Square.
Size of click effect.
The color is used to draw the click effect.
The opacity which is used to draw the click effect.

Show to end

Show the last Cursor to the end of the slide.

Apply To All

Apply the click sound and effect to all clicks.
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Continuation of Cursor Paths between Slides
Normally, when you drag the start or end point of a cursor path, ActivePresenter also moves the
corresponding point in the previous/next slide to ensure a smooth mouse movement. That’s
thanks to the Cursor Snapping tool in the View tab.
If you don’t want the cursor path to move continuously between slides, click the View tab and turn
off Cursor Snapping .
Let us explain this with an example. In the following figure, the end point of the cursor path (1) on
a slide has the same coordinates as the start point of the cursor path (2) in the next slide. As a
result, when the rendered presentation transitions from the first slide to the next one, the
movement of the cursor appears to be continuous (without any jerks). If you move the end point
(or the start point) in any slide, ActivePresenter automatically moves the corresponding point in
the other slide to match their coordinates.

In rare cases, the cursor path can be out of sync. For example, when you delete a slide that is in
the middle, or delete the cursor path in that slide. This results in an abrupt movement of the mouse
cursor in the rendered presentation when the slide changes. To avoid this, you can again stitch
the ends of cursor paths of adjoining slides together. Do the following:
●

Right-click on the start point > Snap to Previous

●

Right-click on the end point > Snap to Next

.

.

Tips to Compose Cursor Paths
Here are a few tips for composing a realistic-looking cursor path:
●

Avoid showing the mouse all the time. It is OK if the mouse vanishes from the scene for a
while.
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●

Remove aimless wandering of the mouse to prevent distraction.

●

Avoid using the mouse as a presentation pointer. Instead, use shapes, zoom-n-pan
effects, spotlights, or other types of annotations.

●

The resting periods are important in realistic depiction of the mouse movement. In fact,
they contain the click points (you cannot click while the mouse is moving).

●

When you are narrating something, keep the mouse at rest.

●

Before clicking any important control, first prepare users, by (a) describing which control
you are going to click, and (b) what will be the consequence of that action. That way, users
will be able to observe the action closely and correlate the happenings on screen. It is a
poor practice to first do something and then tell users about what you did. While users
struggle to make sense of what you said, they would lose track of what you will say next.

Zoom-n-Pan
Zoom-n-pan allows you to zoom in a specific area of a slide during playback. This is useful when
you want your audience to focus on a specific part instead of the entire screen.
Consider this object with an example. In the following screenshot, the image of the Taj Mahal
occupies the entire screen. Now imagine you were standing on the right minaret. You would like
to zoom in that minaret.

Creating Zoom-In Effects
To insert a zoom-n-pan object, do the following:
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1. In the timeline, position the Playhead where you want the effect to start.
2. Click the Insert tab > Zoom-n-Pan . The zoom area appears on the Canvas. This
resizable rectangle must always have the same aspect ratio as slides.
Change the size and position of the zoom area directly on the Canvas or in the Properties
pane > Size & Properties > Position & Zoom Scale.
3. Change the timing and speed of the effect in the timeline or in the Properties pane > Size &
Properties > Timing. The effect should not be too fast, otherwise it becomes nauseating.
4. By default, zoom-n-pan objects only appear in the Demonstration and Tutorial modes. To
change the operation modes for showing them, click the Properties pane > Sizes &
Properties > Show In Mode.
When the slide is rendered, the camera shows the entire scene, then zooms in and simultaneously
pans sideways to the minaret.

Creating Panning Effects Using Multiple Zoom Areas
You can create a continuous panning effect using multiple zoom areas. Just position the zoom
areas at different places on a slide. In the timeline, place the zoom time bars so that the effect
occurs as desired.

Zooming Back to Normal View
The zoom-n-pan object has a one-way effect. When it ends, it doesn’t restore the zoom to normal.
So, in the above example, the camera will keep looking at the minaret till the slide ends. To go
back to the normal view, you have to use another zoom-n-pan object to zoom out. Just resize the
zoom area so that it covers the entire slide.

Closed Caption
Closed captions (CC) are the text version of a spoken part of televisions, movies, videos, or
presentations. The qualifier term “closed” means that users have the power to display or hide
closed captions.

A closed caption object is quite different from other object types:
●

Each time you insert a new closed caption, a new CC node will be automatically added to
the Closed Caption object of the Timeline pane.

●

A closed caption object may have one or multiple CC nodes. You can only toggle the lock
and visibility state of all CC nodes at a time by clicking the
and
icons on the left side
of the timeline.
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●

If you format closed captions in one slide, the new format will be applied to all closed
captions in other slides of the same project.

●

CC nodes are arranged in chronological order and there is no overlap between two CC
nodes. That means only one closed caption can be displayed at a time.

●

You cannot switch the order of CC nodes.

●

When being converted into speech, all nodes of a CC object produce a combined single
audio object.

Adding and Importing Closed Captions
You can either insert closed captions on your own or import closed captions from a caption file
with the *.srt file extension.
To insert closed captions, do the following:
1. In the timeline, place the Playhead at the timestamp that you want to add a closed caption.
2. Open the Insert tab > Closed Caption
Timeline pane.

or click the Insert Caption button in the

Immediately, in the Timeline pane, a CC node (1) appears in the Closed Caption object.
Meanwhile, on the Canvas, a CC editor (2) also appears, allowing you to type text.

3. Type your text in the CC editor. Then, position the Playhead to another timestamp and
repeat the cycle to add more closed captions if you want.
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4. Drag either side of a CC node to change its timing and duration.
5. To remove one or more CC nodes, select them and press DELETE. To remove all closed
captions, click the Closed Caption object to select all CC nodes and press DELETE.
On the other hand, if you have a caption file created in ActivePresenter or another software, you
can import it into a single slide or multiple slides. Note that ActivePresenter supports only *.srt file
format for closed caption files.
1. In the Insert tab, click the arrow on the Closed Caption button > From File > Import To
Single Slide or Import To Multiple Slides > select the file that you want to import.
2. Closed captions will be added to the timeline from the beginning. Click the Preview button
to review.

Formatting Closed Captions
To format closed captions, do the following:
1. In the timeline, place the Playhead at a timestamp that a CC node appears. That makes
its CC editor visible on the Canvas.
2. Select the CC node on the timeline or its CC editor on the Canvas.
3. Use commands and options available in the Home tab, Format tab, or the Properties
pane to format closed captions in the way you want.
Note that if you format closed captions in one slide, the new changes will be applied to all closed
captions in other slides of the same project.

Adjusting Closed Captions in Timeline
If you annotate a slide with shapes and zoom-n-pan effects, your closed captions and text to
speech (TTS) audio must refer to the feature that is being highlighted at that particular moment.
However, this doesn’t happen automatically. There may be several sync problems:
●

The CC may run into the subsequent scene which has no relation to what the CC is talking
about.

●

The converted audio may interfere with an audio embedded within the slide during the
capture phase.

●

The converted audio may overlap with TTS audio of other objects (shapes, for example).

●

The converted audio may overlap with other stand-alone audio/video objects. You have
to check the project for these problems and sort them out.

To synchronize the CC with your annotations, go back to the slide and look at the timeline. Look
at its relationship with other objects in the timeline, and adjust CC nodes.
●

Display each CC for adequate time so that your audience can read it comfortably. The
longer the CC is, the more time it needs to be shown.

●

If you have used TTS narration, it needs to be read fully while the corresponding feature
is still highlighted.

●

In case of videos, you can freeze the frame for a few moments until the narration and CC
play out. After that, resume the playback.

When you adjust CC nodes in the timeline, changes are reflected in the CC editor on the Canvas.
Consider the following example:
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The following screenshot shows the Taj Mahal project. It shows three CC nodes, which means
there are three captions.

Three CC nodes in the timeline are adjusted as follows:
●

The first CC (1) introduces the Taj Mahal. It should start a couple of seconds after the slide
starts. Its duration is adjusted so that the audience can read the text comfortably.

●

The intent is to zoom in on a minaret (2) and reveal an amazing fact that the minarets are
intentionally built tilted so that from afar, they actually look perfectly vertical. So, the zoomn-pan (2’) takes the audience to the minaret.

●

Once the view is zoomed in, the second CC (3) is displayed. Since this is a longer
sentence, more time is given to it.

●

Another zoom-n-pan (4) brings the view back to normal. This is intentionally done at a
faster pace because it only reverts to the full view that was already there. After that, a
small gap is allowed so that the audience can reorient themselves.

●

Finally, the third CC (5) starts. Adequate time is given so that the audience can read it
comfortably.

Here are some tips for manipulating closed captions that can help you position CC nodes correctly
(for example, to synchronize with the audio):
●

You can select multiple CC nodes by pressing SHIFT+Click (to select all adjoining CC
nodes) and/or CTRL+Click (to select all non-adjoining CC nodes).
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You can shift multiple selected CC nodes simultaneously by dragging the mouse.

Adding Multiple Languages for Closed Captions
ActivePresenter now supports adding multiple languages for a closed caption. It can be useful
when the content is conveyed in different languages other than just the default language. After
adding the closed captions, you can add further languages to them, do the following:
1. Go to the Insert tab > click the drop-down arrow next to the Closed Caption button >
Multiple Languages.
Alternatively, in the Properties pane > Size & Properties > General >

Edit Language.

2. In the Edit Language dialog that appears, in the Current Language section:

Click the Add New Language
button to add a new language. In the pop-up Add
Language dialog, choose one from the drop-down list. Then click OK to apply.

To manage the new language, you can:
●

Remove Language

: Remove the current language.

●

Rename Language

: Rename the current language.

●

Set As Default Language

: Save the current language as the default language.

3. In the Caption Editor section, type closed captions of the new language in the Text field.
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●

Show Original: Select this checkbox to show CC of the default language.

●

Insert Original: Add the CC of the original language into the CC of the new language.
Thereby, both of them will be simultaneously shown in the same CC.

●

Revert: Revert CC of the new language to the original one.

●

Add Line Break: Add the <br> tag to a text to break it into different lines.

Exporting Closed Captions to File
It’s so easy and quick if you wish to just export closed captions to *.srt files without exporting with
the whole video. To get it done, you simply right-click a CC node in the Timeline pane > Export
Closed Captions To File. Alternatively, click the drop-down arrow next to the Closed Caption
button in the Insert tab > Export Closed Caption To File. Thereby, all the closed captions with
timing included in the current project will be exported to an *srt file, accordingly. Then, you are
free to edit this file as you want.

Converting Closed Captions to Speech
ActivePresenter lets you convert closed captions to speech using the Text to Speech feature (also
TTS). When converted, all CC nodes in the Timeline produce a single audio object. This audio object
works just like other audio objects, meaning that you can use the built-in audio tools to edit it.
ActivePresenter also allows you to use different voices, speeds, and volumes for each CC node.
This is useful when you want to make conversations, for example. Besides, you’re enabled to do
a batch operation to generate audio from closed captions in some specified slides or all slides in
your project.
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Converting Closed Captions in a Single Slide
You can apply different settings to each closed caption on a slide, then convert all of them into
audio. To do that, select a closed caption and do the following:
1. Click the Properties pane > Size & Properties > Caption.

2. In the Text To Speech part, specify the voice, speed, and volume for the closed caption.
ActivePresenter allows you to get more voices for text to speech. Click More Voices... to
see other available voices. See Getting More Text-to-Speech Voices for more details.
Note that when selecting a voice from third parties, the Speed and Volume options are
disabled, so you cannot edit them. However, you can use SSML tags to customize the
text-to-speech voice.
3. Click Speak to listen to the voice and click Stop to stop listening.
4. Optionally, click Apply To All to apply the same settings to all other existing CC nodes in
the current project.
Besides, you can click Set As Default to apply the new default TTS settings to all newly
added closed captions.
5. After adjusting each closed caption, in the timeline, right-click on a CC node > Convert
Closed Caption to Audio. Alternatively, click the drop-down arrow on the Closed
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Caption button in the Insert tab > Convert Closed Caption to Audio. This converts all
closed captions on a slide into speech.
6. After the conversion, you’re asked whether to extend the duration of the CC object to
match the duration of the converted speech. If you select Always do this from now on,
ActivePresenter will remember your preferences.

Regardless of your choice, the TTS audio will be generated and placed right below the CC object
in the timeline.
Note: It’s possible to adjust the speed and/or volume of a closed caption and apply the same
settings to other ones. To do that, right-click on a CC > Apply Speed For All Caption Nodes/
Apply Volume For All Caption Nodes.

Converting Closed Captions in Multiple Slides
ActivePresenter also provides a batch operation to convert closed captions in some specified
slides or all slides in your project. Do the following:
Click the ActivePresenter button > Project > Batch Operations > Convert Closed Captions
To Audio. A dialog appears as follows:

Specify the slides where you want to convert closed captions to audio. If you choose Specified
Slides, separate the ordering numbers of slides by commas. Otherwise, use hyphens to indicate
ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, and 6th slides.
Select Extend caption duration to match the duration of generated audio if needed. This may
cause sync problems, so you have to check out the project carefully.
Note: Even when you have already converted many CC objects, you can still launch this batch
operation safely, without any adverse effects.
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Getting More Text-to-Speech Voices from the Third Parties
ActivePresenter allows you to access external voices from voice providers, including Amazon
Polly, Google Cloud, and Microsoft Azure. These providers provide you with more text-to-speech
voices to choose from. However, you need to have a registered account to get authentication
keys from the corresponding provider.
To access external voices, click on the More Voices button:

Then, the Cloud Voices dialog will appear. You need to click on the Authentication Settings
button to open the Cloud Text-to-Speech Authentication dialog to do some settings before you
can select a favorite voice from the list:
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In this dialog, select the voice provider(s), then enter authentication information (such as key,
region) to get authentication from the voice provider. After that, click the Test Authentication
button to check whether your keys are valid or not. When the authentication is successful, click
OK and Save to get the provider’s voices.
Now, you can select one or all voice providers from the Provider drop-down list. Then, select a
language that you want from the Language list:
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You can preview the voice by typing the text in the Preview text box and clicking Speak to listen
to that voice:
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If this voice satisfies you, click the Add button to make that voice appear in the Added Voices
section. Note that if you want to apply the current settings for future projects, remember to select
Apply to global settings.
When you click OK, those added voices will be shown in the Voice drop-down list of the Text to
Speech section in the Properties pane:
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After selecting a voice from this list, you can select either Use Caption Text (for closed caption
objects)/ Use Object Text (for other types of objects), or SSML. With Use Caption Text/ Use
Object Text, it allows you to convert closed captions or text of an object to speech as normal.
You can also enter the plain text in the box to convert them to speech. Meanwhile, SSML (Speech
Synthesis Markup Language) allows you to use SSML tags to edit the text-to-speech to speed it
up; slow it down; control volume, speaking rate, and pitch; add emphasis;… and customize it as
you wish:
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For more information about how to use supported SSML tags, you can take a look at this link.

Miscellaneous Tips
Here are some general tips for using closed captions:
●

Always ensure correct spellings.

●

Use words that match the actual voice narration. Do not try to paraphrase; otherwise, the
audience may find it hard to read the CC.

●

Use punctuation to clarify the meaning. If a sentence ends normally, use the appropriate mark
(.?!) at the end. However, a sentence that is left unfinished should end with an ellipsis (…).

●

Translate foreign words in parenthesis ( ).

●

Use italics (or ALLCAPS) to denote a new word or a heavily emphasized part of speech.

●

Show music or other sound effects in square brackets, such as [music], [door slams],
[crowd at the bar], or [laughter].

●

Use square brackets to describe any mood conveyed through voice modulation, such as
[whispers], [shouts], [menacingly], [croons], [sobs]. Always use the appropriate word to
convey the degree of intensity of action. For example, chuckles, smiles, laughs, and guffaws
are all different. Similarly, a door closes and door slams convey entirely different moods.

●

When the speaker is off-screen, identify him/her by name.

●

When more than one person is on screen, identify the speaker by name.

●

As a rule, show only one line of closed captions at a time. An exception is when multiple
people speak simultaneously. In that case, it is OK to show their sentences together; but
always maintain the correct sequence (a sentence that starts first should be listed at the
top of the CC stack). Another exception is when one person is interrupted by another.
Here, end the first (interrupted) sentence with a dash “–”; and place the second
(interrupting) sentence in the second line.
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Audio and Videos
Inserting Audio and Videos
You can insert audio and video tracks into a slide to engage the audience. ActivePresenter
currently supports audio/video formats as follows:
●

Supported audio formats: MP3, OGG, WMA, WAV, M4A, and AAC.

●

Supported video formats: MP4, MKV, WMV, FLV, AVI, WebM, M4V, and MOV.

Inserting Audio
An audio object is displayed on the Canvas as the
icon and its time bar is displayed in the
timeline. The
icon is just a visual indicator to remind you that there is an audio object on a
slide. Its placement on the Canvas doesn’t matter as this icon isn’t visually rendered in the final
output. You can right-click on the icon > Audio Properties to open the Audio section in the
Properties pane where you can edit your audio.
In a recorded project, audio objects are created when you narrate the operation of a target
software and record system audio.
ActivePresenter allows you to insert audio objects into a slide in many different ways including
inserting audio from files, inserting built-in audio, recording audio, and converting text to speech.
Depending on how audio objects are created, they are displayed in three different ways:
●

When an audio object is inserted into a slide, the Canvas displays the
icon (only in the
edit mode; not in the output). The timeline displays the time bar of the audio object.

●

When an audio track is attached to an object (for example, the audio attached to a shape),
the timeline displays its waveform bar within the target object's time bar. There is no
icon on the Canvas.

●

When a closed caption is converted into audio, a separate audio object is created. The
timeline shows a separate time bar of the audio object.

In all cases, the time bar of the audio object in the timeline shows the actual audio waveform,
which facilitates editing.

Inserting Audio from Files
To insert audio into a slide, click the Insert tab > Audio
> From File… and choose an audio
file. You can also drag an existing audio file from your computer onto the Canvas.

Inserting Built-In Audio
ActivePresenter provides you with some useful built-in audio for mouse clicks and questions. To
insert built-in audio, click the Insert tab > Audio
> Built-in and choose an audio file.

Recording Audio
There are two ways to record audio. First, use the Record Narration button in the Timeline pane
to record and create a new audio object. Do the following:
1. Click the down arrow next to the Record Narration button > Recording Options.
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2. In the dialog that appears, select an input device, adjust input volume, and calibrate input
volume, then click the Close button to close the dialog.
3. Place the Playhead at the timestamp you want to add audio recording.
4. Click Record Narration to start recording your voice.
5. Click Pause/Resume to pause/resume the recording.
6. Click Stop to stop the recording. Your narration is recorded as an audio object.
Note: It’s good to reduce noise after recording narration.
The second way to record audio is to insert empty audio which will be later used for recording or
converting text to speech. Do the following:
1. Click the Insert tab > Audio > Create New to create an empty audio object.
2. Navigate to the Properties pane > Media > Audio. From here, you can record your voice
using the Recording part or generate TTS voice using the Text To Speech part.

Converting Text to Speech
You can generate audio from a text for audio objects and other objects with attached audio. For
audio objects, click the Properties pane > Media > Audio. For objects with attached audio, click
the Properties pane > Audio tab. For more details, see Text to Speech.

Inserting Videos
There are three ways to insert videos into your project: insert videos from files, insert videos by
recording screen, or insert videos by recording webcam. When a video object is inserted into a
slide, its time bar is displayed in the timeline, and its frames are shown by default. To toggle video
frames, right-click the video object or anywhere in the Timeline pane and select Show Video
Frames. This feature is useful when you want to split videos into frames and edit one or more
frames exactly. To do that, zoom in on the video time bar until you see red lines. Red lines are
the time stamps which frames appear. Two red lines define a frame. Then, you drag the Playhead
on the Timeline pane until it snaps to the red line. You can now perform the steps to cut or split
video as mentioned in the sections below.

Inserting Videos from Files
To insert a video into a slide, click the Insert tab > Video
> From File… and select a video
file. You can also drag an existing video file from your computer onto the Canvas.
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After that, you can resize the video to the size you want. If you want to revert to the original size,
right-click on the video > Restore Original Size.

Inserting Videos by Recording Screen
You can record the screen and insert the recorded video as a video object into the next slide
below the current slide. Just click the Home tab > Record Screen > Record Screen as Video.
For more details, see Recording Screen as Videos.

Inserting Videos by Recording Webcam
To record a video from webcam, click the Insert tab > Video
appears, allowing you to record your webcam.

> Webcam Recording. A dialog

1. Select a webcam device from the (Webcam) Device list. You can click Refresh to detect
new webcam devices. Besides, click Settings to fine-tune video format and compression.
2. Select an audio recording device from the (Audio) Device list. You can click Volume to
adjust input volume and Calibrate Input… to change recording sensitivity levels.
3. Click Record to start recording.
4. Click Stop to stop recording.

Cropping Videos
In ActivePresenter, you now can directly crop videos on the Canvas to remove any unwanted
part. Just select a video, do either of the following:
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Right-click the video > Crop.
Access the Format tab > Crop.
Navigate to its Properties pane > Size & Properties > Crop.

Then, adjust the Left, Right, Top, and Bottom sides to be cropped (in %). You can click the
up/down arrow to increase/decrease the value respectively, or enter a value in the spin box. All
the changes will be immediately reflected in the video on the Canvas. Alternatively, clicking the
Crop button will enable you to drag the red frames on the Canvas to specify the cropped area.

Once you click the Crop button again or click outside the video, it will be cropped instantly.

Converting Videos to Author Videos
For instructional purposes or presentations, you may want to record screen and webcam at the
same time. At run time, users often see a webcam video appear at a corner of the screencast and
cover a portion of it. While this may be useful to instruct users, both the presenter and users may
experience potential disadvantages. For example, the webcam video may block the user's view
of some important information that the screencast conveys. As for users, chances are that they
will find a webcam video unnecessary or even distracting. They may not want to watch it but have
no way to turn it off.
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Taking that into account, ActivePresenter provides the author video feature, which turns a normal
video into an author video. An author video appears in the side bar of the player instead of
covering the content. Thus, users can choose to watch the author video and the content
simultaneously or hide it by hiding the side bar. The Show/Hide Side Bar button is enabled by
default and appears at the bottom-right corner of the player toolbar.

To convert a video to an author video, on the Canvas, right-click on it > Convert To Author
Video. This will play the video over multiple slides in the project and place the video in the side
bar of the player.
Note:
●

A single project can have more than one author videos. To adjust the timing and duration
of author videos, in the Timeline pane, click the All Slides button
to view objects that
span across slides. Then, drag the time bars of the author videos as you wish.

●

If you don’t want an author video anymore, on the Canvas, right-click on it > Remove
Author Video.

●

To display the author video in the side bar of the player, click the Export tab > Player Settings
> General > General Parameters > Side Bar > select the Author Video checkbox.

Changing Playback Options
ActivePresenter lets you control how an audio/video plays using several playback options. On the
Canvas, just right-click on an audio/video object > Audio Properties/Video Properties to open
the Audio or Video section in the Media tab of the Properties pane. In these sections, you can
view some information about an audio/video, replace it, and control playback options.
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There are three generic options:
●

Loop: Make an audio/video replay continuously.

●

Autoplay: Make an audio/video start playing as soon as an object starts showing.

●

Show Media Controls: Display the media controls that allow users to control an
audio/video playback in HTML5 output.

For audio objects, there is one specific option named Background Music. Select this option to
set an audio object as the background music of the presentation. See Background Music for
more details.

Exporting Audio and Videos
You can export both audio/video you’ve created within your project and imported audio/video to
files. These are the supported file formats:
●

Audio: WAV, MP3, M4A, and OGG.

●

Video: MP4, MKV, WMV, AVI, and WebM.

To export audio/video objects, do the following:
1. Select an audio/video object.
2. Right-click on it > Export To File….
Specify the file name, file format, and file location, then click Save to export.

Basic Audio and Video Editing
Range-Editing
Before you start editing audio and video, it’s necessary to understand what is a range and how
you can define or select a range in ActivePresenter.

Defining a Range
The Timeline pane has four range-editing commands
that only can be used
when a range is defined first. If you haven’t selected a range, these buttons are disabled, you
cannot click them.
Let’s take a look at the following image:

•
•
•

Start Marker: The green marker represents the starting point of the selected range.
Playhead: The blue line indicates the timestamp that you are currently selecting.
End Marker: The orange marker indicates the ending point of the selected range.
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The Start Marker and the End Marker help to define a range. Just click to place the Playhead
at any position in the Timeline pane. Then, you can select a range by either dragging the Start
Marker or the End Marker. When you drag a marker, the Playhead will stick with it. The selected
range is highlighted in blue color to help you easily recognize it.
Note that you can use some keyboard shortcuts to manipulate the markers. For example, you can
use SHIFT+LEFT ARROW to move the Start Marker to the left (in case no object is selected).
Similarly, press SHIFT+RIGHT ARROW to move the End Marker to the right. Please refer to
Timeline Toolbar and Productivity Tips for more information.
The following sections will show you how to cut, copy, delete, and crop a range. Consider these
commands with the following examples, in which each command is used in two different
circumstances: (a) when none of objects are selected, and (b) when some objects are selected.
Each set has three figures: (1) the original objects, (2) the result when none of the objects are
selected, and (3) the result when some objects are selected.

Cutting Ranges
Click the Cut Range button
to remove the range and place it on the clipboard. You can paste
the cut content into the current slide or the new one.
The following example shows the effect of the command when no objects are selected on the
slide:
Original slide

No objects selected
The slide and all objects are
edited. The entire slice of the
range (with the parts of objects
enclosed in it) is cut away. Thus,
the slide duration is reduced by
the duration of the range.
If an object spans both sides of
the range, its remaining parts are
joined. (Shape_1).
Shape_4 is deleted because it is
completely inside the range.
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When some objects are selected, the command behaves differently, as shown in the following
example:
Original slide
There are two identical sets of
objects (1-6; 7-12).
Only one of the two sets is
selected to show the difference.

At least one object selected
Only selected objects are
edited. The slide itself and
unselected objects (7-12) aren’t
affected at all.
For the selected objects only:
The range is folded up and
removed. Any object parts that
lie in the range are deleted
(Shape_5). Shape_4 is deleted
because it is completely inside
the range.
Objects/parts that follow the
range are shifted to the left by
the duration of the range
(Shape_2 & 3).
If the selected object spans both
sides of the range, its remaining
parts are joined (Shape_1).

Copying Ranges
Click the Copy Range button
on the clipboard.

to copy parts of objects that fall inside the range and put them
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●

If there is no selected object, the command checks all the objects on the slide.

●

If there is at least one selected object, the command checks only these selected objects.

●

If an object doesn’t have any part inside the range, it isn’t copied.

The following figure illustrates these conditions:
No object selected

Some objects selected

All the objects’ paths falling inside the range are
pasted at the Playhead position.

Only parts of selected objects falling inside the range
are pasted at the Playhead position.

Note: The lower figures show fresh slides into which the clipboard content is pasted. Just imagine
that a slice is taken out of the original slide, and placed at the Playhead position in the current or
another slide.
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Deleting Ranges
The Delete Range button
works just like the Cut Range button, except for one difference:
While the former is used to delete the content inside the range, the latter “cuts” the content from
the range and places it on the clipboard, then you can paste it where you want.
In short, deleting stands for removing while cutting stands for reallocating.
Note: You can also press CTRL+DELETE to delete a range.

Cropping to Ranges
The Crop to Range command

simply deletes everything outside the range.
Original slide

No object selected
Only the content falling inside
the range is retained while
the rest is deleted. Thus, the
slide duration is reduced to
the duration of the range.
If an object doesn’t have any
part inside the range, it is
dropped. (Shape_6).
When there are some selected objects, the Crop to Range command behaves differently, as
shown in the following example:
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Original slide
There are two identical
sets of objects (1-6; 7-12).
Only one of the two sets
is selected to show the
difference.

At least one object
selected
Only selected objects are
edited. The slide itself and
unselected objects (7-12)
aren’t affected at all.
The parts of the selected
objects that lie inside the
range are retained.
If the selected object
doesn’t have any part
inside the range, it is
deleted entirely from the
slide. (Shape_6).

Freezing the Frame
Sometimes, a video contains a significant scene, which lasts only for a few seconds. The scene
is over before the audience has enough time to absorb the important information. If this were a
live lecture, you would pause the video and explain various parts of the frozen scene to your
audience. However, that is impossible in a self-running video.
This is where the freeze-frame control comes in handy. It allows you to pause a video for a certain
duration. You can extend this pause as long as you want and add a commentary track or
annotations to analyze the frozen video frame.
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Freeze-frame also works on audio objects. Normally you would only apply this control to a
significant audio track that needs to be synchronized with the visual part of the presentation. A
typical example is to re-sync a stand-alone commentary track with the rest of the slide by holding
it off for a few seconds.

Inserting Freeze-Frames
To insert a freeze-frame, do the following:
1. Select one or more audio/video tracks.
2. Place the Playhead where you want to pause the track.
3. In the Timeline pane, click the Insert Time button

.

4. In the dialog that appears, specify the duration of the control and click OK to finish.

A yellow bar will get superimposed on the time bar of the audio/video object. It represents the
pause you’ve inserted into the audio/video object.

Note:
●

If you have defined the freeze-frame duration in the fourth step, the yellow bar is adjusted
to this duration. However, the usual practice is to drag the left and right-side edge of the
yellow bar to change the start time and duration of the control.

●

Each freeze-frame extends the host track by its duration. In other words, if you insert an
n-second pause in an audio/video track, its total duration will be increased by n seconds.

●

You can insert any number of pauses in any selected track. The only condition is that two
pauses cannot overlap.

●

Freeze-frame also works on other types of objects. Basically, it inserts an interval of time
into the selected object at the position of the Playhead. For example, if the duration of a
shape is 3 seconds (3000 ms) and you insert 2 seconds (2000 ms) into its duration, then
the total duration of the shape will be 5 seconds (5000 ms).

●

If there is no selected object on a slide, the control will insert an interval of silence into the
entire slide and all the objects that appear at the Playhead position. Other objects that
don’t intersect with the Playhead will not be affected at all.
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Removing Freeze-Frames
To remove a freeze-frame from the host track, in the timeline, click the yellow bar and drag it
downward till it turns gray, then release the mouse button. Alternatively, drag the right-side edge
of the yellow bar toward the left-side one till the yellow bar disappears. After that, the duration of
the host track will be reduced by the duration of the yellow bar.

Splitting and Joining
Splitting Audio Track from Video
In ActivePresenter, you can split audio track from video with a few clicks. To get it done, rightclick the video on the Canvas or Timeline pane > Split Audio Track.

Splitting Audio and Videos
Sometimes, it’s necessary to split one video into several parts, for example, to save each of them
as a single file and use it for different purposes. In that case, just select the audio/video object
and click the Split Audio/Video Objects button
in the Timeline pane to split the object at the
Playhead position.
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●

The timeline shows the latter part as a new object but still places it in the same object line
as the other one. If you want to move the latter part to a new object line, right-click on it >
Move Up/Down into a New Line.

●

The split parts are treated as new project-level resources (which appear in the Resources
pane) and can be further used in any slide within the project.

●

In case of audio objects, each split part is shown as a separate
icon on the Canvas.
However, all these icons are stacked together, so you can only distinguish between them
when you drag them apart.

Joining Audio and Videos
To join multiple audio or video objects, click the Join Audio/Video Objects button
in the
Timeline pane. You can join an audio object with other audio objects; and a video object with
other video objects, but cannot join an audio object with a video object.
When you join audio/video, all selected audio/video objects will merge based on ascending order
of their start times. It means that the object with the smaller start time will play first in the combined
object. A red mark appears showing where the objects join.
Some cases you may encounter:
●

If audio/video objects have the same start time, ActivePresenter will sort them by their zorders in ascending order. The object with a lower stack order will appear before the one
with a greater stack order.

●

If audio/video objects don’t have identical properties such as width, height, or resolution,
the combined object will use all the properties of the first object that plays. In other words,
the output object will apply all the properties of the object having the smallest start time.

Changing Playback Speed
Changing the speed of a video or audio can be useful in many different situations. For example,
you are creating a tutorial showing how to export videos in ActivePresenter. The wait time for the
exporting process to complete should be speeded up to shorten the duration of your tutorial.
In that case, you can change the playback speed to make that part of the video run faster. That
way, you will save the duration and the file size of your video and provide a better user experience.
You can also use this command to slow down your video, thus making it look professional like the
slow-motion scene on TV.
The command is only active when you select an entire audio/video object or just a part of it. In the
Timeline pane, click the Change Playback Speed button
and the following dialog appears:
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The input is a relative value in the range of 10-1000%. ActivePresenter will scale the current
speed of the selected range using this value. In case you want to quickly reset to the original
speed of the selected range, select Reset to original speed.

Adjusting Volume
If a slide has multiple concurrent audio tracks, you will have to ensure that only one of those tracks
is dominant at a time, and the other tracks are either muted or with lowered volume. This balance
keeps changing. In other parts of the slide, you may have to give dominance to other tracks. This
is where the adjust volume control in the Timeline pane comes in handy.
You can adjust the volume of the entire audio or just a part of it. Just select the audio object/range
and click the Adjust Volume button . This opens a dialog containing a relative volume scale with
a default value of 100% (the original volume). Use this scale to adjust the volume from 0 (mute) to
500% (original volume x 5). You can also select the Mute checkbox to quickly silence the track.

Note:
●

When you adjust the volume of a range, the start and end points of the range are marked
with red vertical marker lines. These markers cannot be moved within the time bar
because they actually denote the range in which the volume is altered.

●

When you adjust the volume, the original track isn’t affected at all. You can bring back the
original volume at any time. Just select an object/range and click the arrow next to the
Adjust Volume button > Restore Original Volume.

●

If this control is used to mute a track, it doesn’t affect the original duration of the track, because
unlike the freeze-frame control, this control doesn’t insert an additional period of silence.

Advanced Audio Effects
Advanced audio effects let you improve your audio quality in general and audio recording quality
in particular. Advanced audio effects, including audio fade in , audio fade out , audio noise
reduction , and audio normalization , are accessible from the Timeline pane.

Audio Fade In/Out
When you add an audio track to a slide, you may often end up with a sudden start or end that can
be rough on the ears. Audio fade in and audio fade out come in handy to smooth the beginning
and end of an audio track. Fade in (1) begins with silence and gradually becomes louder until full
volume while fade out (2) makes audio progressively softer until it can no longer be
heard.
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You can apply fade in and fade out effects several times to strengthen the fade. Do the following
to apply audio fade in or fade out to an audio track:
1. Specify the audio range you want to apply the effect.
2. In the Timeline pane, click Audio Fade In
several times if needed.

or Audio Fade Out

. Apply the effects

3. To remove the effect, select the faded range and click the arrow next to the Adjust
Volume button > Restore Original Volume.

Audio Noise Reduction
Your recordings often have some background noise, regardless of the microphone quality. Audio
noise reduction can reduce constant background noise such as tape hiss, electric fans or hums.
This effect doesn't work well with inconstant noise like talking or music and is often best done by
trial and error. You may have to try the effect several times until getting the best result.
To apply audio noise reduction, do the following:
Step 1. Get a noise profile.
1. Specify the range that contains only background noise.
2. In the Timeline pane, click the arrow next to the Audio Noise Reduction button
Noise Profile.

> Get

Step 2. Reduce noise. After getting a noise profile, you can apply noise reduction to a certain
range in an audio track or the entire track. You can even apply the effect to multiple tracks
simultaneously.
1. Specify the ranges or the audio tracks you want to apply the effect.
2. In the Timeline pane, click the Audio Noise Reduction button
offering necessary controls to reduce noise.

○

. A dialog appears

Noise reduction (dB): Control the amount of volume reduction (0 - 48 dB) applied to
the identified noise. Higher values reduce higher amount of volume reduction, making
the noise quieter, but can distort the audio track. Keep this control as low as possible.
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○

Sensitivity: Control how much of the audio will be considered noise, on a scale from
0 (off) to 24 (maximum). Greater sensitivity will remove more noise but can damage
the track. Keep this control as low as possible.

○

Frequency smoothing (bands): Spread the noise reduction into the specified number of
neighboring bands. Smoothing can make the desired audio less clear, so set the value to
0 if your desired signal is strong and of wide frequency range and the noise is low.

Step 3. Click OK to apply the effect to the selected audio ranges/objects.
Step 4. If the effect doesn’t work as you expect, click Restore Defaults and try the effect again
with different settings.
Tip:
●

The noise profile you got will be stored in the application. It will be lost if you close the
application or be replaced by another noise profile when you get a noise profile again.
Therefore, if there are different types of noise in different positions in the audio track, you
should repeat the following process several times. Pick the profile for the first type of noise,
reduce the noise for it, then pick the next type and reduce that until you get your desired result.

●

When getting a noise profile, you shouldn’t choose a very short range because a longer
selection is better to get a more accurate picture of the noise. A selection of 2 - 4 seconds
of only noise is recommended. You must select a minimum 2048 samples or about 0.05
seconds at 44100 Hz sample rate.

●

Sometimes a recording has no noise sample available because no part contains only
background noise. In that case, you can create a recording made in identical conditions
that contain silence only, then use a noise sample from that to reduce noise from the target
recording.

Audio Normalization
Audio normalization applies a certain amount of gain to an audio track to bring the amplitude to a
target level (the norm). This is useful when you have a group of audio objects at different volumes
and want them to have a consistent volume level. This is also helpful when you cannot speak at
the same volume level in a recording session.
In ActivePresenter, you can normalize every audio in your project, including narrations, recorded
system audio, and imported audio, for consistent volume across slides. You can apply the effect
to the entire object or just a part of it, or to multiple objects at the same time.
Do the following:
1. Select one or more audio objects/ranges.
2. In the Timeline pane, click the Audio Normalization button . This opens the following
dialog. Adjust the settings and click OK to normalize the selected track.
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○

Remove DC offset: DC offset is an offsetting of a signal from zero. The problem can
be seen from the waveform as it appears above or below the 0.0 horizontal line. DC
offset is mostly a hardware problem that can cause clicks, distortion, or loss of audio
volume, which can limit the possible loudness. Thus, removing DC offset is required
when normalizing audio as it centers the waveform on the 0.0 amplitude level. Note
that if you are sure your audio has no offset, you should clear this option to speed up
the normalization.

○

Normalize maximum amplitude to (peak normalization): Peak normalization brings
the highest peak to the norm. You can enter a new value in the range of [-145.0; 0.0].
The level of -1.00 dB (the initial default setting) is just below the maximum amplitude
(0 dB) possible without clipping but gives a little headroom for effects and distortionfree playback on all equipment. For this option, enter zero or a negative value for the
maximum amplitude you would like the selected track to have. A more negative value
means you normalize the selected track to lower amplitudes.

○

Normalize stereo channels independently: Normalization can work on the left and
right channels of a stereo track as a pair or independently. When you select this option,
normalization adjusts the amplitude of the channels separately to the same peak level.
This is useful for correcting stereo imbalances. Otherwise, when you don’t select this
option, normalization adjusts the level of both channels by the same amount, which is
practical if your audio is already balanced.

If you want to discard all changes, click Restore Defaults to go back to the original settings.

Background Music
ActivePresenter makes background music possible. Background music plays across slides in the
background of the slide show. You can insert audio from your computer or record a track and
make it the background music of your project.
To set an audio track as background music, do the following:
1. Right-click on an audio object > Play over Multiple Slides > Top/Bottom Layer to make
the background music play continuously throughout all. Both options create the same
effect when you don’t show the player controls for the audio. However, the layer you place
the audio object affects the stack order of objects on a slide. To show which object that is
playing over multiple slides in the Timeline pane, there is an icon that appears next to the
object name.
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2. Click the Properties pane > Media > Audio > Playback Options > Loop to make the
track replay automatically when it finishes. After that, you can drag the end point of the
audio time bar to the duration you want. You can also right-click on the audio time bar >
Play to the End of Slide to make the audio duration equal to the slide duration.

Regarding HTML5 output, consider two other playback options in the Properties pane > Media
> Audio > Playback Options:
●

Background Music: Make the track continue playing when the presentation is paused.
That way, in an interactive presentation, while the presentation pauses to wait for user
input, background music still plays.

●

Autoplay: Make the audio play automatically when the slide loads.

Video Blur Effects
Blur effect is used to hide sensitive information such as identity or private information. You can
apply blur effects to a recorded or imported video to blur both moving and static objects.

Applying Blur Effects
To apply a blur effect, select a video object and do the following:
1. In the timeline, specify where you want the effect to start.
2. Click the Insert Blur Area button . In the dialog that appears, specify the effect duration
and click OK. You can change the duration later, so don’t worry too much about the choice
you make at this moment.

3. On the Canvas, change the size and position of the blur area so that it covers what you want
to hide. You can drag the resizing handles or use the ARROW keys on your keyboard.
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4. Click the Properties pane > Media > Blur Effect to make further adjustments to the blur
area. Later, if you want to change these properties, select the blur area on the Canvas or
the blur time bar in the timeline to open the section.
○

Blurriness: Specify the amount of blur. The higher the value, the more the blur.

○

Blur Orientation: Specify the orientation of the blur (horizontal and vertical, horizontal,
or vertical).

○

Mask Type: Specify the shape of the blur area (rectangle or ellipse).

5. Change the effect duration by lengthening or shortening the blur time bar in the timeline. You
can also drag the blur time bar to another position to change the start time of the effect.

Blurring Moving Objects
The above steps are enough if the area you want to blur maintains the same size and position. If
the target area is moving, you need to do further steps to cover it precisely.
Blur effect uses keyframes to mark specific areas in the video. The size and position of the blur
area at any timestamp are interpolated from the values of the nearest keyframes on the left and
right of the timestamp. The more keyframes you insert, the more exactly the blur area covers the
moving object.

To add more keyframes, do the following:
1. In the timeline, select the blur time bar. This enables you to change the blur area on the
Canvas.
2. Seek the Playhead along the timeline, then change the size and/or position of the blur
area on the Canvas. ActivePresenter will automatically insert a new keyframe each time
you make changes. You can also add new keyframes by clicking the Add/Remove
Keyframe button
in the Timeline pane, then edit the blur area on the Canvas.
3. From the position of the Playhead, to navigate between keyframes, click the Go to Next
Keyframe button
or the Go to Previous Keyframe button .
4. To remove a keyframe you don’t want, drag it downward until it grays out and release the
mouse button. Alternatively, place the Playhead at the keyframe > Add/Remove
Keyframe .
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Removing Blur Effects
To remove the blur effect, in the timeline, drag the blur time bar downward until it grays out and
release the mouse button. Note that if you select the blur area on the Canvas and try to delete it
by pressing DELETE, you will end up deleting the video.

Video Green Screen Effects
Green screen, technically known as chroma-key, is the technique of masking a video by keying
out a background of a consistent color, so you can put one video on top of another. You often see
this technique in movie stunts or in weather forecast where a presenter stands in front of a moving
weather map.
Basically, the green screen works as your tool chooses a specific color and makes it transparent
- all pixels having that color become transparent. Although it’s called green screen, you don’t have
to use a green screen all the time. In fact, any solid color can be used theoretically, but green is
the most commonly used because it provides a good contrast and luminescence and rarely occurs
on the human body.
To apply a green screen effect, do the following:

1. Select a video object.
2. Click the Properties pane > Media > Green Screen Effect.
3. Specify a color you want to key out.
4. Move the Tolerance slider to adjust the range of color to key out. Higher values key out a
wider range of color near the key color.
5. If you aren't satisfied with the result, click the Reset Color button to discard all changes.

Picture-In-Picture Effects
The picture-in-picture effect (also called video overlay) lets you place a video clip in a small frame
on top of another so that they play at the same time. You often see this effect in instructional
videos where webcam videos are placed at the corner of the tutorial ones.
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ActivePresenter allows you to use picture-in-picture effect in video editing. Do the following:
1. Insert the picture-in-picture (PIP) video (the smaller video clip placed on top of another)
into a slide.
2. Resize and reposition the video and change its timing. You can also add animation
effects to the video to make it more engaging.
3. Optionally, create a zoom-n-pan effect to zoom in the PIP video. That way, the audience
can focus on the PIP video instead of the entire screen.
Note:
●

ActivePresenter enables you to record screen and webcam at the same time. What you
get is a slide that displays both your screencast and webcam as two separate videos. The
webcam video is smaller and placed at the bottom-right corner of the screencast, making
a PIP effect.

●

Alternatively, you can record your webcam separately and insert the webcam video into
a slide.

●

It’s practical to combine the video overlay effect with the green screen effect. Use the
latter to key out the background of the superimposed video to integrate two videos.

Cursor Effects in Recorded Video
When you record a screencast, you can record the mouse cursor and edit the cursor effects of the
recorded video after that. To enable this feature, select the two options Record Mouse Cursor and
Make Cursor Editable for Full Motion Recording in the Cursor tab of the Recording Settings dialog.
To change the cursor effects of a recorded video, select the video and click the Properties pane
> Media > Cursor Effects. The cursor effects have the following options:
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●

Render Cursor: Display the cursor, highlight effect, click effects, and play the clicking
sounds when playing the video. If you don’t select this option, the cursor will not appear in
the recorded video.

●

Cursor Highlight: Highlight the cursor.

●

○

Type: Type of the highlight effect (none, circle, square).

○

Size: Size of the highlight effect. It is the radius of the circle in the circle highlight or
half of the width of the square in the square highlight.

○

Color: Color of the highlight.

○

Opacity: Transparency of the highlight.

Left-Click/Right-Click/Left Double-Click Effects: Play a sound and render an animation
when the mouse is left-clicked, right-clicked, or left double-clicked.
○

Click Sound: The sound which is played when a mouse button is pressed.

○

Click Effect: The animation effect which is rendered when a mouse button is pressed
(none, circle, concentric circles, square).

○

Size, Color, Opacity: The same as those of the cursor highlight.

If your project contains multiple recorded videos, you can edit the cursor effects of one video, then
click the Apply To All button to apply the changes to others.

HTML5 Closed Caption
ActivePresenter supports embedding/attaching closed captions files into a video for displaying in
the HTML5 output. Note that only .vtt files are applicable.

1. Add an HTML5 closed caption file: To add an HTML5 closed caption file to a video, select
the video > Properties pane > Media tab > Video > HTML5 Closed Caption. Then, select a
*.vtt file from the current project , or import one from your computer . Right after that, the
Choose Language dialog will appear and allow you to select a suitable language.
You can add multiple closed caption files in different languages to a video. To set a
language as default, select it and click this button .
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Besides, if the Show Media Controls option (Properties pane > Media tab > Video >
Playback Options) is selected, users can toggle the subtitles or change language by
clicking the CC button.
2. Remove an HTML5 closed caption file: If you no longer need an HTML5 closed
caption file, select it and click this button to remove it.
3. Customize an HTML5 closed caption’s appearance: You are free to customize how
closed captions are displayed in the output (font, font size, color, background color, and
opacity). Once you change, all closed caption files have the same appearance in the
output.
4. Preview & Export: When adding an HTML5 closed caption file to a video, closed
captions will not be shown in the editor. To preview them in the browser, open the
Export tab > HTML5 Preview.
When you add an HTML5 closed caption file, it will be displayed by default. To make it
hidden, uncheck the Show By Default checkbox.
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Interaction Objects
Interaction objects are designed to respond to user input in a predefined manner. Users can
interact with them using keyboards, mouses, or other input devices. Interaction objects not only
change the course or the presentation based on user input but also keep track of user activities
(for example, assessing user performance in a test).
Interaction objects are listed as follows:
Object

Icon

Usage

Mouse Click

Respond when users click in a predefined area. Use of
modifier keys (ALT, CTRL, SHIFT) is also allowed.

Key Stroke

Respond when users press an individual key on the
keyboard or a hotkey (such as CTRL+SHIFT+P).

Text Entry

Respond when users enter specific text (string).

Drop Area

Respond when users drop a drag source on it.

Button

Respond when users click it.

Checkbox

Respond when users click it.

Radio Button

Respond when users click it.

Slider

Respond when users slide it.

Dropdown

Respond when users select one option from the dropdown
list.

Animated Timer

Count up the elapsed time or count down the remaining time
in a running presentation.

Questions

There are thirteen types of questions, namely True/False,
Multiple Choice, Multiple Response, Fill in Text Entry,
Fill in Text Entries, Fill in Blanks, Sequence, Drag-nDrop, Hotspot, Essay, Select in Dropdown, Select in
Dropdowns, and Rating Scale (Likert).
When you insert a question, the question and its answer
options appear on the screen. Users are expected to
respond within a predefined time. ActivePresenter can be
programmed to take different actions depending on whether
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the response is correct or incorrect; or if users fail to
respond within the time limit.

Mouse Click
Mouse clicks are interaction objects placed at any area on a slide where users must click to trigger
the next action. They are often used in software simulations to teach the use of applications. For
example, place a mouse click object on a button or a menu where users must click to perform a
certain task in an application. When you record software simulations, ActivePresenter
automatically inserts mouse clicks wherever and whenever you make a click.
Mouse clicks use the On Click event to trigger actions, just like buttons, but they are designed
to assess user knowledge of a target application. Mouse clicks validate mouse actions as correct
and incorrect and can give users points for correct actions.

Inserting Mouse Clicks
To insert a mouse click, click the Insert tab > Mouse Click
> Interactions
> Mouse Click .

. Alternatively, click the Home tab

By default, a mouse click consists of three separate elements: (1) a target area, (2) a Correct
message, and (3) an Incorrect message.

When the interactive presentation is played, it displays only the target area (1) and waits for users
to click anywhere on the slide. If users click the target area, the Correct message (2) appears,
otherwise the Incorrect message (3) appears. You can prompt users to click on a specific area by
inserting a shape with some guidance.
Note:
●

You can add Timeout and Hint messages by selecting the target area > Questions tab >
Message. To remove any message you don’t want, select the message and press
DELETE.

●

For score and reporting settings, see Score & Reporting.

●

To add event - actions, click the Properties pane > Interactivity > Events - Actions.
By default, mouse clicks have four events, namely On Click, On Correct, On Incorrect,
and On Timeout. You can add two other events, namely On Rollover and On Rollout.
These events are helpful when you want to create hover effects for a mouse click object.
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You can make the target area invisible so that users cannot see the correct click area. To
do that, set the outline of the target area to No Line (Properties pane > Style & Effects
tab > Line > No Line). However, this is not recommended. Instead, you should use the
Show In Mode property of objects. You can show the click area in some modes (for
example, Demonstration and Tutorial) but hide it in other modes (for example, Practice
and Test).

Setting Correct Values
Mouse click objects accept three types of mouse clicks (left-click, right-click, and left double-click)
with or without modifier keys (SHIFT, CTRL, and ALT).
To define a correct action, do the following:
1. Select the target area.
2. Click the Properties pane > Interactivity > General > Correct Values > Add Value.
3. Place the cursor over the Correct Value text box and click the mouse button with or
without the modifier keys.
4. Click the Remove button

to remove a value you don’t want.

Note: It’s great to let users know there is a clickable area on the screen. For this reason, change
the cursor for the target area to a hand cursor (Properties pane > Interactivity > General >
Cursor). That way, the mouse pointer will turn to a hand cursor when it’s over the correct area in
the output.

Key Stroke
In software simulations, you often want to simulate a single action of pressing a key on your
keyboard to interact with a target software. Key strokes are interaction objects that help you do
that by responding when users press a key or combination of keys. When you record software
simulations, key strokes are automatically inserted whenever you press a keyboard shortcut.

Inserting Key Strokes
To insert a key stroke, click the Insert tab > Key Stroke
Interactions
> Key Stroke .

. Alternatively, click the Home tab >

By default, a key stroke consists of three separate elements: (1) a target area, (2) a Correct
message, and (3) an Incorrect message.
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When the interactive presentation is played, initially the key stroke displays nothing. It just waits
for users to enter a shortcut (such as CTRL+SHIFT+P) while ignoring any text string. If the entered
shortcut matches the reference, the Correct message (2) appears, otherwise the Incorrect
message (3) appears.
For example, if the predefined value is CTRL+SHIFT+P, but users just press CTRL+P without
holding down the SHIFT key, the Incorrect message appears.
Note:
●

You can add Timeout and Hint messages by selecting the target area > Questions tab >
Message. To remove any message you don’t want, select the message and press
DELETE.

●

For score and reporting settings, see Score & Reporting.

●

To add event - actions, click the Properties pane > Interactivity > Events - Actions.
By default, key strokes have three events, namely On Correct, On Incorrect, and On
Timeout. You can add three other events, namely On Key Press (occurs when each key
or combination of keys is pressed), On Rollover, and On Rollout.

Setting Correct Values
Key strokes accept all keys or combinations of keys on the keyboard except the WINDOWS key.
Be sure to fully test your key stroke in your published output to avoid any unexpected behavior.
Don’t use keys or key combinations that are common in browsers (CTRL+F, ALT+D, etc.).
To define a correct action, do the following:
1. Select the target area.
2. Click the Properties pane > Interactivity > General > Correct Values > Add Value.
3. Click inside the Correct Value text box and press a key with or without the modifier keys
(SHIFT, CTRL, and ALT).
4. Click the Remove button
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Text Entry
Text entries are interactive text fields into which users can enter text. Text entries provide a great
way to test user knowledge and collect information from users. When you record software
simulations, ActivePresenter inserts text entries automatically whenever you enter a text string.

Inserting Text Entries
To insert a text entry, click the Insert tab > Text Entry
Interactions
> Text Entry .

. Alternatively, click the Home tab >

By default, a text box consists of three separate elements: (1) a target area, (2) a Correct
message, and (3) an Incorrect message.

When the interactive presentation is played, the text entry object displays only the target area (1)
and waits for users to enter text strings. If the entered text matches the correct value, the Correct
message (2) appears, otherwise, the Incorrect message (3) appears.
Note:
●

When users enter a text string, it appears in real-time in the target area.

●

If the entered text exceeds the area, the text is shifted so that the insertion point is always
visible. You should resize the target area to an appropriate size so that all text can be
visible.

●

By default, text entries use the Graded mode which validates learner input as a correct or
incorrect action. To disable the validation, set the mode to Survey. (Properties pane >
Interactivity tab> Score & Reporting > Mode > Survey). The Survey mode is useful
when you want to collect learner names or other information.

●

There are two ways to submit the entered text: Press Key (the Submit key) and Auto.
(The Survey mode only accepts the Submit key.) The former validates the entered text
after learners press the Submit key. Meanwhile, the latter validates the entered text
whenever learners press any key. As long as the entered text partially matches the correct
value, the presentation will wait for learners to input more text. The moment the last
entered character is found to be different, it will be deemed incorrect.

●

You can add Incomplete, Timeout, and Hint messages by selecting the target area >
Questions tab > Message. To remove any message you don’t want, select the message
and press DELETE.
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To add event - actions, click the Properties pane > Interactivity > Events - Actions.
By default, text entries have three events, namely On Correct, On Incorrect, and On
Timeout. You can add four other events, namely On Text Enter (occurs when an entered
value is submitted), On Incomplete, On Rollover, and On Rollout.

Setting Correct Values
To define a correct value, do the following:
1. Select the target area.
2. Click the Properties pane > Interactivity > General > Correct Values > Add Value.
3. Type a text string in the Correct Value text box.
4. Click the Remove button

to remove a value you don’t want.

Drop Area
A drag-and-drop interaction involves a drag source and a drop target. It allows you to drag a drag
source and drop it onto a drop target. A drop area is a special drop target that can assess, score,
and keep track of users’ responses instantly when they drop a drag source onto a drop target.
Each drop area can accept multiple drag sources, many of which can be set as correct values.
However, a drop area can hold only one drag source at a time. That means when you drop another
accepted drag source onto it, the current drag source will replace the previous one while the
previous one is sent back to its original place. Meanwhile, a normal drop target can hold multiple
accepted drag sources at once.

Inserting Drop Areas
To insert a drop area, click the Insert tab > Drop Area
Interactions
> Drop Area .

. Alternatively, click the Home tab >

By default, a Drop Area object includes five default elements: (1) a drop area (with a light red
marker), (2) a drag source (with a light green marker), (3) a drag-n-drop connector (an orange
arrow), (4) a Correct message, and (5) an Incorrect message. Note that you can make the markers
and the drag-n-drop connector shown or hidden by clicking the Drag-n-Drop button in the View
tab. You can also customize these elements and add as many drag sources as you want.
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When the interactive presentation is played, users can drag any drag source from its original
place. When he drops a drag source onto a drop area, one of the following cases will happen:
●

If the drag source is rejected, it will be sent back to its original place.

●

If the drag source is accepted but not correct, it will lie on the drop area while the Incorrect
message appears.

●

If the drag source is accepted and correct, it will lie on the drop area while the Correct
message appears.

●

If users drop another accepted drag source onto the drop area, the current drag source
will replace the previous one while the previous one is sent back to its original place. At
the same time, the Correct or Incorrect message will appear depending on whether the
current drag source is correct or not.

Note:
●

You can add Timeout, Hint, Accept or Reject messages by selecting the target area >
Questions tab > Message. To remove any message you don’t want, select the message
and press DELETE.

●

For score and reporting settings, see Score & Reporting.

●

To add event - actions, click the Properties pane > Interactivity > Events - Actions.
By default, drop areas have three events, namely On Correct, On Incorrect, and On
Timeout. You can add 7 other events, namely On Accept, On Reject, On Drag Out, On
Drag Enter, On Drag Leave, On Rollover, and On Rollout.

●

You can make the drop area invisible by setting its outline to No Line (Properties pane >
Style & Effects > Line > No Line). However, this is not recommended. Instead, you
should use the Show In Mode property of objects. You can show the drop area in some
modes (for example, Demonstration and Tutorial) but hide it in other modes (for
example, Practice and Test).

●

To hide drag-n-drop markers and connectors, click the View tab > Drag-n-Drop.

Setting Correct Values
A drop area can accept multiple drag sources, many of which can be set as correct values. To
define a correct drag source, do the following:
Interaction Objects > Drop Area
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1. Select the drop area.
2. Click the Properties pane > Interactivity > Drag-n-Drop > Accept List.
3. In the dialog that appears, define accepted drag sources by selecting checkboxes in the
Accept column. Select Accept All to make the drop area accept all the drag sources on
a slide.

4. Define correct drag sources by selecting checkboxes in the Correct column. Note that an
accepted drag source may not be the correct one.
5. Click OK to save changes.
Another way to set correct drag sources is to use the drag-n-drop connector. Just click the marker
in the middle of a drag source and drag the mouse to the drop area. This creates a drag-n-drop
connector that connects the two items.
To remove a drag source as a correct value, you can click the connector and press DELETE or
right-click on it > Delete. You can also get the same result by using the Accept List dialog.

Setting Drop Area Properties
To set up properties for a drop area, click the Properties pane > Interactivity > Drag-n-Drop.
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●

Effect: Specify the effect that appears when users drag any drag source over the drop area.

●

Snap Behavior: Specify properties of a drag source after it is dropped onto a drop area.
○

Size (%): Resize the drag source.

○

Opacity: Change the opacity for the drag source.

○

Position: Define the position of the drag source.
▪

Absolute: Keep the drag source at the same position as where users drop it.

▪

Anchor: Snap the drag source to an anchor point of the drop area. Choose one
from nine anchor points in the Direction list.

▪

Tile: Arrange the drag source so that it lies on the drop area without covering each
other. Choose one from eight tiling directions in the Direction list.

Converting Objects to Drag Sources
You may want to convert objects on a slide, such as images and shapes, to drag sources so that
you can drag and drop them onto drop areas (or drop targets). ActivePresenter allows you to
convert multiple objects to drag sources at the same time.
Do the following:
1. Select an object.
2. Click the Properties pane > Interactivity > Drag-n-Drop > Drag Source.

3. Specify properties for a drag source.
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○

Effect: Specify the effect that appears when users drag the drag source (None, Zoom,
or Highlight).

○

Revert: Determine whether the drag source is sent back to its original place if it’s
dropped outside the drop area.

Button
Interactive buttons allow you to do certain tasks when users click them. For example, clicking the
Next button takes users to the next slide in the presentation.
When you insert a button into a slide, it comes with four built-in states which control the look of
the button when users hover, click, or otherwise interact with it.

Inserting Buttons
To insert a button, click the Insert tab > Button
Interactions
> Button .

. Alternatively, click the Home tab >

A button appears on the Canvas with default text. Give it a descriptive name by clicking the default
text and entering your text. You can modify the text attributes in the same way that you normally
modify text captions.
Note:
●
●

You can modify the look of a button in the same way that you normally modify a shape.
Use commands and options in the Format tab
or the Properties pane > Style & Effects.

●

After modifying a button, you can set it as the default style for all newly added buttons in
the same project. To do that, right-click on the button > Set as Default Button, or set the
new style for a button object in the View tab > Object Settings. In case you want the new
default style to take effect on existing buttons in the same project, right-click on a button
> Apply to All Button Objects > Style.

●

Buttons don’t validate user input as correct or incorrect. When users click a button, actions
registered with the On Click event are executed.

●

Buttons have no Report ID and score settings so they don’t appear in the report.

Working with Button States
Buttons include four built-in states, namely Normal (Default), Hover, Pressed, and Disabled.
These states are added to buttons by default, so you don’t need to use actions to trigger them.
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●

Normal: This is the neutral state of a button. By default, it’s how a button looks when it
first appears.

●

Hover: This is how a button looks when being hovered.

●

Pressed: This is how a button looks when being clicked.

●

Disabled: This is the state you use when you want to disable a button. A disabled button
is visible but cannot respond to any user action.

You can modify built-in states and create additional states if needed. For more details about
states, see Using Object States.

Making Buttons Work
To add event - actions, click the Properties pane > Interactivity > Events - Actions. Add
events and actions as you wish. Buttons can respond to both mouse and touch events. Normally,
you want to add an On Click event to create actions when users click the button. Besides, other
events that you can add for a button are On Timeout, On Rollover, On Rollout, On Swipe Left,
On Swipe Right, On Swipe Up, and On Swipe Down.

Checkbox and Radio Button
ActivePresenter comes with a variety of ready-made checkboxes and radio buttons to help you
create interactions in your course.

Inserting Checkboxes and Radio Buttons
To insert a checkbox or a radio button, click the Insert tab > Checkbox
or Radio Button
Alternatively, click the Home tab > Interactions
> Checkbox
or Radio Button .

.

A checkbox/radio button appears on the Canvas with default text. Give it a descriptive name by
clicking the default text and entering your text. You can modify its text attributes in the same way
that you normally modify text captions.
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Setting Correct Answers
Double-click the checkbox/radio button to set it as the correct answer. Alternatively, right-click it
> Set As Correct.
To set a checkbox as incorrect, right-click it > Set As Incorrect.

Working with Checkbox/Radio Button States
Checkboxes and radio buttons include eight built-in states. These states are added to them by
default, so you don’t need to use actions to trigger the states.
●

Normal (Default): This is the neutral state of a checkbox/radio button. By default, it’s how
a checkbox/radio button looks when it first appears.

●

Hover: This is how a checkbox/radio button looks when being hovered.

●

Pressed: This is how a checkbox/radio button looks when being clicked.

●

Disabled: This is the state you use when you want to disable a checkbox/radio button. A
disabled checkbox/radio button is visible but cannot respond to any user action.

●

Normal Checked/Hover Checked/Pressed Checked/Disabled Checked: These are the
states of the selected checkbox or radio button.

You can modify built-in states and create additional states if needed. For more details about
states, see Using Object States.

Making Checkboxes and Radio Buttons Work
To add event - actions, click the Properties pane > Interactivity > Events - Actions. Add
events and actions as you wish. Checkboxes/radio buttons can respond to five events.
●

On Check: Occur when a checkbox/radio button is marked.

●

On Uncheck: Occur when a checkbox/radio button isn’t marked.

●

On Timeout: Occur when users don’t respond within the specified time.

●

On Rollover: Occur when the mouse enters the boundary of the checkbox/radio button.

●

On Rollout: Occur when the mouse exits the boundary of the checkbox/radio button.

Formatting Checkboxes and Radio Buttons
Once a checkbox or a radio button is on a slide, you can move, scale, or customize it as you want.
Use commands and options in the Format tab or the Properties pane > Style & Effects.
In the Format tab, do the following:

●

Change Shape: Change the shape of checkboxes/radio buttons as you want.

●

Show Toggle Button: Uncheck/check this option if you want to hide/show the toggle
button of checkboxes/radio buttons. Besides, you can uncheck/check this option in the
Properties pane (Interactivity tab > General).
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●

Change styles: Use the drop-down gallery to select a ready-made style to customize
checkboxes/radio buttons.

●

Change colors: Initially, checkboxes/radio buttons use their default styles in which object
colors come from your theme colors. However, you can always use custom colors to
design checkboxes/radio buttons.

•

○

Fill: Define the background color of checkboxes/radio buttons.

○

Border: Define the color and style of the border of checkboxes/radio buttons. Choose
Width to change the border thickness.

○

Mark: Define the color of the check mark/radio dot when a checkbox/radio button is
checked.

Quick Style: Quickly set a ready-made style for the checkbox/radio button.

You can set a certain checkbox/radio button as the default style so that the same attributes will
be applied to all newly added checkboxes/radio buttons in the same project. To do that, right-click
on a checkbox/radio button > Set as Default Checkbox/Set as Default Radio Button, or set the
new styles for a checkbox/radio button object in the View tab > Object Settings.
In case you want the new default style to take effect on existing checkboxes/radio buttons in the
same project, right-click on a checkbox/radio button > Apply to All Checkbox Objects /Apply
to All Radio Button Objects > Style.

Slider
Slider is a brand-new feature in ActivePresenter 9. With a slider, you can select a specific value
or drag to define a range along the bar. This is perfect for displaying/selecting values in continuous
ranges. As a result, some of its applications are to display stages in a timeline, changing settings
such as volume and speed.

Inserting Sliders
You can easily find out the Slider button in the Insert tab. Or access the Home tab > Interactions
> Slider.
Selecting the Slider button turns the cursor into a crosshair. Draw sliders by clicking on any area
of the Canvas or dragging the mouse.

There are two parts in a default slider: Thumb (1) and Track (2). The thumb is a blue oval. Its
initial position depends on the initial value in the Properties pane. The track is a gray bar. Its
length depends on how long you draw it. When you drag the thumb along the track, the values
Interaction Objects > Slider
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get updated. This makes changes to the associated variable or fire the On Change and On
Changing event.
ActivePresenter allows you to set up a slider’s properties, style, work with sliders and add eventsactions to them.

Setting up Slider Properties
We can set up the values and properties for the slider. To do that, select the slider and navigate
to the Properties pane > Size & Properties tab > Slider section.

•
•
•
•
•

Min: Specify the minimum value and starting value of the slider (3).
Max: Specify the maximum value and ending value of the slider (5).
Step: Specify the size of each movement of the slider. As the slider thumb moves along
its track, this is its incremental value. The default value is 1.
Initial: Specify the starting position of the slider thumb (4). The range of the initial value is
from Min to Max and the formula is Initial = Min + n*Step (n is a whole number).
Variable: This is the variable associated with the slider. By default, its type is NUMBER.
To change the variable that’s controlled by a slider, click the drop-down arrow to select
one from the list. There are several available variables for a slider.

•
•

Add Variable
: This button is to add a new variable to the slider. Its type is
NUMBER as well. To remove the variable that you have created, navigate to the Home
tab > Variables > select the variable you want to remove > click .
Update Variable: This option offers two ways to show the changes when you interact
with the slider, namely While Dragging Slider and After Dragging Slider. The former
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updates the associated variables while you drag the slider, whereas the latter only
updates them when you stop dragging and release the mouse.
Learn more about variables at Using Variables.
Note: Except for apScoreSubstract, you cannot specify the initial point of the slider in other
default variables.

Working with the Slider States
Four built-in states are available for a slider. They are Normal (Default), Hover, Pressed, and
Disabled.

•
•
•
•

Normal (Default): This is the default state of a slider.
Hover: This is how a slider looks when being hovered.
Pressed: This is how a slider looks when it is pressed.
Disabled: This is the state that cannot respond to any user action.

For further information, refer to Using Object States.

Making Sliders Work
To interact with a slider, you need to add events - actions to it. To do that, select the slider then
navigate to the Properties pane > Interactivity tab > Events - Actions section.

A slider includes 5 default events, namely On Change, On Changing, On Timeout, On Rollover,
and On Rollout. Add as many actions to meet your needs.
•
•
•
•

On Change: Occur when you finish dragging the thumb or specifying a value on the track
and release the mouse.
On Changing: Occur during the time you drag the thumb along the track.
On Timeout: Occur when the time to do an action is over.
On Rollover: Occur when the mouse enters the boundary of the slider.
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On Rollout: Occur when the mouse exits the boundary of the slider.

Styling Sliders
To style a slider, select it then take advantage of commands and tools in the Format tab.

You can choose any style from the Slider Styles gallery, change the color and shape of the
thumb, track, and border of the slider. While tools in Style Tools help style the container layout
of the slider manually, styles in Quick Styles provide you with samples. Alternatively, navigate to
its Properties pane > Style & Effects tab > Fill/ Line/ Shadow/Opacity section.
You can set a certain slider as the default style so that the same attributes will be applied to all
newly added sliders in the same project. To do that, right-click on a slider > Set as Default Slider,
or set the new styles for a slider in the View tab > Object Settings.
In case you want the new default style to take effect to existing sliders in the same project, rightclick on a slider > Apply to All Slider Objects > Style.

Dropdown
When you have a long list of content to show in menus, consider using dropdowns. They are
helpful in both appearance and interaction. A dropdown can conserve screen space, which makes
the projects look well-arranged. Users can interact with the dropdown at their convenience.
Initially, it shows a single value or item. With a click, it will display all the values for users to choose
from. Depending on their purposes, dropdowns can be command menus, form filling, navigation
menus, attribute selections, and so on.
From version 9, ActivePresenter allows you to insert and work with dropdowns for more enhanced
projects.

Inserting Dropdown
To insert a dropdown, navigate to the Insert tab > Dropdown
tab > Interactions

. Alternatively, click the Home

> Dropdown.

As soon as you select the dropdown button, the cursor turns into a crosshair. Click anywhere on
the Canvas to insert a dropdown, or drag the mouse to draw one.
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A default inserted dropdown is a single-select list box that has 2 parts: textbox (1) and drop-down
arrow button (2). The container box has the text “--Select--” by default. It is also the hint item.
You can format, add items to the list, and add interactivities to a dropdown.

Adding Lists of Items to Dropdowns
To add items to the list, select the dropdown and navigate to the Properties pane > Interactivity
tab > Dropdown section.

Here you can see Hint Item, Item List, and Variable.
•

Hint Item: This is suggested item that allows you to click on it to reveal a dropdown list.
You can change the default “--Select--” text by deleting it and typing a new name.
• Item List: The list contains a range of commands and a table with 4 default columns.
You can use the commands below to edit the table.
• Add
: This button is to add new items to the list. Click it to add items as much as
you wish.
•

Remove : This button is to remove any items. To do that, select one or many
unwanted items and click the button.
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•

Edit
: This button is to edit the items in the list. Select the one you want to edit,
click the button and change its value. Alternatively, you can double-click any of them
to edit.

•

Move item up

or Move item down

in the list. Select the item and click

or

: These buttons are to rearrange the items
to move it up or down respectively.

The 4 default columns of the table are Index, Default, Item, and Correct.
•

•

•
•

●

Index: This column shows the number and order of items in the dropdown list. When
you delete the first item, the second item becomes the first one automatically. So, the
following items will change their order as well.
Default: This column displays radio buttons corresponding to the items. If you want
any item to be the hint item, select the button. Otherwise, the dropdown will show the
Hint Item.
Item: The column displays all items in the dropdown list. You can add more, edit,
change their order, or remove the unnecessary ones.
Correct: This column provides you with checkboxes corresponding to the items.
Selecting the checkboxes can set one or many items as the correct value.

Variable can be used sometimes when one item refers to a specific object. The green
plus button
is to add a new variable to the dropdown. Its type is TEXT. To remove the
variable that you have created, navigate to the Home tab > Variables > select the variable
you want to remove > click

.

Learn more about variables in Using Variables.

Setting Correct Values
To set the correct values for a dropdown, navigate to its Properties pane > Interactivity tab >
Dropdown section > Item List > Correct column > tick the corresponding checkbox(es) of the
correct items.
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If you want to remove any correct value, simply untick the checkbox.

Setting Score and Reporting
You can also set the score to the correct values. It can be done in Score & Reporting of the
Interactivity tab in the Properties pane.

This section provides you with many options:
•
•
•

Mode: This option offers you 2 choices: Graded and Survey. While the first one measures
learners' performance, the latter collects their feedback or information.
Report ID: This one is to track learners' results.
Points: This option sets points for correct answers. If the point is partial, the Points
column appears in the Item List. Double-click the column to edit the point for each answer.
Set the point by entering a new value or clicking the arrow drop up or down.

•

Attempts: This one sets the maximum attempts that learners can interact with the question.
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Timeout: It can set a limit time that only allows learners to respond to the question in the
given period.
Submit: This option offers the way you want learners to submit the answers automatically
(select Auto) or manually (select Manual).

Working with Dropdown States
In general, a default dropdown has two states: Normal (Default) and Disabled.

•
•

Normal (Default): This is the default state of a dropdown.
Disabled: This is the state that cannot respond to any user action.

Learn more at Using Object States.

Making Dropdowns Work
To make a dropdown work, navigate to its Properties pane > Interactivity tab > Events - Actions
section to add events-actions to it. A dropdown has six events by default, namely On Change,
On Correct, On Incorrect, On Timeout, On Rollover, and On Rollout. Add actions as you wish.
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On Change: Occur when selecting an item on the list.
On Correct: Occur when selecting the correct values.
On Incorrect: Occur when selecting the incorrect values.
On Timeout: Occur when users don’t respond within the specified time.
On Rollover: Occur when the mouse enters the boundary of the dropdown.
On Rollout: Occur when the mouse exits the boundary of the dropdown.

Formatting Dropdowns
Like many other interaction objects, dropdowns can be styled with ease in the Format tab.

In the Dropdown Styles gallery, you can choose a style in the built-in list for the dropdown. You
can also use tools in Dropdown Tools to style the dropdown. Choose a form in the Quick Style
section or use tools in Style Tools to customize the look of the container layout of the dropdown,
Alternatively, navigate to its Properties pane > Style & Effects tab > Fill/ Line/ Shadow/Opacity
section.
You can set a certain dropdown as the default style so that the same attributes will be applied to
all newly added dropdowns in the same project. To do that, right-click on a dropdown > Set as
Default Dropdown, or set the new styles for a dropdown in the View tab > Object Settings.
In case you want the new default style to take effect to exist dropdowns in the same project, rightclick on a dropdown > Apply to All Dropdown Objects > Style.

Animated Timer
An animated timer counts up the elapsed time or counts down the remaining time in a running
presentation. There are two types of animated timers: Timer and Progress. While a Timer shows
how much time has passed with a digital display, a Progress bar only gives a visual progression
of time.
You can trigger an action when a timer is completed or timed out. For example, when learners
don’t provide an answer within a given time and the timer finishes the countdown, a message
appears to tell them that there is no time left.
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Inserting Timers
To insert a timer, click the Insert tab > Animated Timer
> select either Timer (1) or Progress
(2). Alternatively, in the Home tab > Interactions
> Animated Timer .

To adjust a timer, click the Properties pane > Interactivity > Timer and do the following:

●

Format: Specify the time format of a timer (hh:mm:ss, hh:mm, mm:ss, or ss:ms). This
option is only available for Timer. It is not available for Progress.

●

Countdown: Change a count-up timer to a countdown one.

●

Match object duration: When you insert a timer into a slide, this checkbox is selected by
default. That means ActivePresenter will automatically adjust the duration of the timer so
that its duration is equal to that of the object which has the longest duration in the main
timeline.
To set a different duration, just clear the checkbox, then specify the duration as you wish.
Note that if the timer object is initially hidden and the checkbox is selected, the timer
duration is the same as the slide duration.

●

Start automatically: Make a timer starts as soon as a timer object starts showing in the
main timeline.

You can style a timer as a normal shape using the fill, line, or shadow properties.

Adding Events - Actions to Timers
To make timers interactive, add event - actions in the Properties pane > Interactivity tab >
Events - Actions. The On Timer Complete event is available to trigger an action when a timer
completes the count up or countdown. Besides, you can add more events like On Click, On
Rollover, On Rollout, etc.
You can also handle timers using three actions:
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●

Start Timer: Make the timer start counting, do nothing if it is running. If the timer has
finished, the action restarts it.

●

Pause Timer: Pause the timer but keep the current value, do nothing if it is paused.

●

Stop Timer: Stop the timer and reset its value.

Besides, it’s possible to use JavaScript API to work with timers. The supported functions are:
prez.object(‘TimerA’).startTimer();
prez.object(‘TimerA’).pauseTimer();
prez.object(‘TimerA’).stopTimer();

Questions
In ActivePresenter, questions can be used to assess learner performance (the Graded mode) or
collect information (the Survey mode). There are many types of interactive questions, which are:
•

True/False

•

Multiple Choice

•

Multiple Response

•

Fill in Text Entry

•

Fill in Text Entries

•

Fill in Blanks

•

Sequence

•

Drag-n-Drop

•

Hotspot

•

Essay

•

Select in Dropdown

•

Select in Dropdowns

•

Rating Scale (Likert)

For more details about questions, see Common Question Properties.
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Creating Quizzes
Common Question Properties
To create a question, open the Questions tab and click any of the thirteen question buttons.
Then, a new question slide will appear on the Canvas. The following section will give you more
details about the common components of a question slide.

Components of a Question Slide
A typical question slide in ActivePresenter is composed of three sections: the question title,
answer area, and submit button.

●

Question Title: Click to add a question title in this section.

●

Answer Area: Create and customize answer options for a question. The number of
answer options for each question type varies depending on its nature. For example, a
True/False question has only two answer options (True and False) while a Multiple Choice
question has four by default. For most types of questions, you can add more answer
options or delete them.

●

Submit Button: The Submit button is added to each question slide by default. It allows
learners to click on it to submit their answers. Open the Format tab or the Style & Effects
tab in the Properties pane to customize the Submit button in the way you want.

ActivePresenter also allows you to create your own custom-made buttons. To do that, click the
Insert tab > Button , or click the Home tab > Interactions
> Button . For more details,
see Button.
Note:
●

Feedback messages are also added to each question by default. To view and edit them,
click the View tab > Feedback Master .
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A question always comes with default events - actions that are ready to use. However,
you can delete them, edit them, or add new events - actions as you want. In addition, you
can use the Advanced Action feature to create and manage complex actions.
To open the Events – Actions section, do one of the following:
○

Select the answer area > Questions tab > Event

.

○

Select the answer area > Properties pane > Interactivity > Events - Actions.

After that, the Properties pane will show all necessary tools and properties allowing you to edit
and customize events and actions of a question.

Question Modes: Graded and Survey
A question can be used for assessing learner performance (the Graded mode) or collecting
information (the Survey mode). You can switch between these modes by selecting the answer
area > Properties pane > Interactivity > Score & Reporting > Mode > Graded/Survey.
The table below shows the differences between these two modes:
Mode

Graded

Survey

User validation

Correct/Incorrect/Incomplete

Complete/Incomplete

Score settings

Available

Not Available

Purpose

Assessing Performance

Gathering Information

On Correct
On Incorrect
Events

On Incomplete
On Timeout
On Change

On Complete
On Incomplete
On Timeout
On Change

Creating Quizzes
Quizzes are critical elements of a test. They allow you to test and track the performances of
learners, collect their information and opinions, and so much more.
In ActivePresenter, you can create quizzes with many types of interactive questions.

To create a question, open the Questions tab and click any question button. Or, you can click
the Home tab > Interactions
> select a question. After that, ActivePresenter will insert a new
question slide into your project.
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True/False
With a True/False question, learners have only two answer options to choose from: either True
or False.
To insert a True/False question, click the Questions tab > True/False . Alternatively, click the
Home tab > Interactions
> True/False . The question will appear on the Canvas as follows:

As mentioned above, each True/False question always has two answer options, therefore, you
cannot remove any or add more.
To change the question layout, select the answer area > navigate to the Properties pane > Size
& Properties > Container Layout. For more information, see Using Flex Layout and Using
Grid Layout.
To set a correct answer, double-click on a radio button that corresponds to the correct answer
option, or right-click the answer option > Set As Correct. You can edit the text of the default
answer options. For example, change from True/False to Yes/ No, Correct/ Incorrect, Right/
Wrong if needed.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a True/False question, you can set it as a default question to use
in the current project. To do that, right-click on the answer area > Set as Default True/False
Question. Alternatively, customizing this question type in the View tab > Object Settings >
Questions > True/False Question will apply changes to all newly inserted True/False questions
in the current project.

Multiple Choice
With a Multiple Choice question, learners can select only one correct answer option.
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To insert a Multiple Choice question, click the Questions tab > Multiple Choice . Alternatively,
click the Home tab > Interactions
> Multiple Choice . The question will appear on the
Canvas as follows:

To change the question layout, select the answer area > navigate to the Properties pane > Size
& Properties > Container Layout. For more information, see Using Flex Layout and Using
Grid Layout.
You can add more answer options to the question by selecting the answer area and clicking the
plus button:

To delete an answer option, just select it and press the DELETE key on your keyboard. If you
want to delete multiple answer options, hold down CTRL while clicking them, then press DELETE.
To set a correct answer, double-click on a radio button that corresponds to the correct answer
option, or right-click the answer option > Set As Correct. Remember that you can set only one
correct answer option for this question type.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set its properties.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
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After creating and customizing a Multiple Choice question, you can set it as a default question to
use in the current project. To do that, right-click on the answer area > Set as Default Multiple
Choice Question. Alternatively, customizing this question type in the View tab > Object Settings
> Questions > Multiple Choice Question will apply changes to all newly inserted Multiple Choice
questions in the current project.

Multiple Response
With a Multiple Response question, learners can select more than one correct answer option.
To insert a Multiple Response question, click the Questions tab > Multiple Response
.
Alternatively, click the Home tab > Interactions
> Multiple Response . The question will
appear on the Canvas as follows:

To change the question layout, select the answer area > navigate to the Properties pane > Size
& Properties > Container Layout. For more information, see Using Flex Layout and Using
Grid Layout.
You can add more answer options to the question by selecting the answer area and clicking the
plus button:

To delete an answer option, just select it and press the DELETE key on your keyboard. If you
want to delete multiple answer options, hold down CTRL while clicking them, then press DELETE.
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To set correct answers, double-click on all checkboxes that correspond to the correct answer
options, or right-click the answer options > Set As Correct. Unlike a Multiple Choice question,
you can set more than one correct answer option for a Multiple Response question.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Multiple Response question, you can set it as a default question
to use in the current project. To do that, right-click on the answer area > Set as Default Multiple
Response Question. Alternatively, customizing this question type in the View tab > Object
Settings > Questions > Multiple Response Question will apply changes to all newly inserted
Multiple Response questions in the current project.

Fill in Text Entry
A Fill in Text Entry question contains a single-line text box that allows learners to input text.
To insert a Fill in Text Entry question, click the Questions tab > Fill in Text Entry
.
Alternatively, click the Home tab > Interactions
> Fill in Text Entry . The question will
appear on the Canvas as follows:

As mentioned above, each Fill in Text Entry question always has only one single-line text box
therefore, you cannot remove it or add more.
To set correct answers for this question type, click the text box > navigate to the Properties pane
> Interactivity > General > Correct Values > click the Add Value button to add a correct answer
for the question. To know more details about it, see General Section.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
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Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.

Fill in Text Entries
A Fill in Text Entries question contains four default single-line text boxes that allow learners to
input text.
To insert a Fill in Text Entries question, click the Questions tab > Fill in Text Entries .
Alternatively, click the Home tab > Interactions
> Fill in Text Entries . The question will
appear on the Canvas as follows:

To change the question layout, select the answer area > navigate to the Properties pane > Size
& Properties > Container Layout. For more information, see Using Flex Layout and Using
Grid Layout.
A Fill in Text Entries question has four single-line text boxes by default. Each text box contains
an answer label and a text entry. You can add more text boxes by selecting the answer area and
clicking the plus button:

To delete a text box, select its answer label or its text entry, then press the DELETE key on your
keyboard. If you want to delete multiple text boxes, hold down CTRL while clicking them, then
press DELETE.
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Unlike a Fill in Text Entry question, a Fill in Text Entries question has more than one text box.
Therefore, you have to set correct answers for each text box separately. To do that, select each
text entry > navigate to the Properties pane > Interactivity > General > Correct Values > click
the Add Value button to add a correct answer for the text box. To know more details about it, see
General Section.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Fill in Text Entries question, you can set it as a default question
to use in the current project. To do that, right-click on the answer area > Set as Default Fill in
Text Entries Question. Alternatively, customizing this question type in the View tab > Object
Settings > Questions > Fill in Text Entries Question will apply changes to all newly inserted
Fill in Text Entries questions in the current project.

Fill in Blanks
A Fill in Blanks question allows learners to fill in multiple blanks in a paragraph.
To insert a Fill in Blanks question, click the Questions tab > Fill in Blanks . Alternatively, click
the Home tab > Interactions
> Fill in Blanks . The question will appear on the Canvas as
follows:

To work with the answer area of a Fill in Blanks question, firstly, you should insert text (either a
sentence or a paragraph) into it. Then, insert blanks into your text by doing either of the following:
●

Insert a new blank: Click anywhere in the text that you want to insert a blank > click the
plus button > select New Blank.
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To set a correct answer for a blank, simply type the correct answer into it. Alternatively,
select the blank, then go to the Properties pane > Interactivity > Score & Reporting >
Correct Values > Add Value.
●

Convert text into a blank: Select text (word, phrase, or sentence), right-click on it, and
choose Set Text As Blank. Alternatively, click the plus button then choose Set Text As
Blank. By doing this way, the selected text is automatically set as the correct answer for
the blank.

To delete a blank, simply select it and press DELETE on your keyboard. Or, right-click on it and
select Delete.
To change styles and effects for a blank, select it > Properties pane > Style and Effects >
Answer Style. Here, you can change the blank’s properties such as Border Color, Border
Width, Box Width, and Corner Radius.

Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Fill in Blanks question, you can set it as a default question to use
in the current project. To do that, right-click on the answer area > Set as Default Fill in Blanks
Question. Alternatively, customizing this question type in the View tab > Object Settings >
Questions > Fill in Blanks Question will apply changes to all newly inserted Fill in Blanks
questions in the current project.

Sequence
A sequence question contains at least two items that require learners to arrange them in the right
order.
To insert a sequence question, click the Questions tab > Sequence . Alternatively, click the
Home tab > Interactions
> Sequence . The question will appear on the Canvas as follows:
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By default, a Sequence question has five answer labels. You can add more answer labels to the
question by selecting the answer area and clicking the plus button:

Initially, each answer label is a shape with the default text inside. Click each of them to replace
the default text. Besides, you can customize these answer labels in the same way you do with
normal shapes in ActivePresenter.
To set the correct answer for a Sequence question, drag answer labels in their correct order.
However, before dragging, make sure the None mode is selected in the Container Layout section.
Otherwise, you cannot drag answer labels to desired positions. The order of answer labels you
set will be the correct answer for that question.
To delete an answer label, select it and press the DELETE key on your keyboard. If you want to
delete multiple of them, hold down CTRL while clicking them, then press DELETE.
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To change the question layout, select the answer area > navigate to the Properties pane > Size
& Properties > Container Layout. For more information, see Using Flex Layout and Using
Grid Layout.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Sequence question, you can set it as a default question to use
in the current project. To do that, right-click on the answer area > Set as Default Sequence
Question. Alternatively, customizing this question type in the View tab > Object Settings >
Questions > Sequence Question will apply changes to all newly inserted Sequence questions
in the current project.

Drag-n-Drop
Before creating a Drag-n-Drop question, you should take a look at drop area to understand what
drag sources and drop targets are. You can also have some basic concepts about drag and drop
to make the most out of a Drag-n-Drop question.
A Drag-n-Drop question is a type of question that includes multiple drag sources and drop targets
that require learners to match them correctly.
To insert a Drag-n-Drop question, click the Questions tab > Drag-n-Drop . Alternatively, click
the Home tab > Interactions
> Drag-n-Drop . The question will appear on the Canvas as
follows:

Both drag sources and drop targets are shapes with the default text and a clickable Image button
inside. Click the default text to replace it with the new text or click the Image button to quickly
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add an image. Besides, you can customize drag sources and drop targets in the same way you
do with normal shapes in ActivePresenter.
To insert more drag sources and drop targets, select the answer area, then click the plus button
that appears:

By default, a Drag-n-Drop question has two columns, one for drag sources and another for drop
targets. ActivePresenter allows you to change its position by dragging them to any area on a slide.
However, before doing that, make sure that the None mode is selected in the Container Layout
section of the Size & Properties tab. Otherwise, you cannot perform this action.
There are two ways to set the correct answer for a Drag-n-Drop question. Do either of the following:
●

Use the orange drag-drop connector to connect a drag source to its corresponding drop
target. This connector denotes that dropping a drag source to a drop target is a correct action.

●

Select each drop target > Properties pane > Interactivity > Drag-n-Drop > Accept List.
Then, the Accept List dialog appears. Select checkbox(es) that corresponds to correct
answer(s) in the Correct column.

To delete a drag source or drop target, simply select it and press the DELETE key on your
keyboard or right-click on it and select Delete. If you want to delete multiple of them, hold down
CTRL while clicking them, then press DELETE.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Drag-n-Drop question, you can set it as a default question to
use in the current project. To do that, right-click on the answer area > Set as Default Drag-nDrop Question. Alternatively, customizing this question type in the View tab > Object Settings
> Questions > Drag-n-Drop Question will apply changes to all newly inserted Drag-n-Drop
questions in the current project.
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Note: A drop target in a Drag-n-Drop question should accept only one drag source. In cases that
you want to create a quiz containing a drop target that accepts multiple drag sources, you should
use the drop area object.

Hotspot
A Hotspot question is an image-based question that allows learners to interact with an image. With
a Hotspot question, an image is presented to learners. Learners will give their answers by clicking
on one or more specific spots on that image. Hotspot questions are preferred to create simple
games such as finding differences between two pictures or finding hidden animals in a picture.
To insert a Hotspot question, click the Questions tab > Hotspot . Alternatively, click the Home
tab > Interactions
> Hotspot . The question will appear on the Canvas as follows:

Click the Image button

to insert an image.

To add hotspot(s) to that image, select the answer area, click the plus button > Oval/ Rectangle.
Then, click anywhere on the image to insert a hotspot. You can also drag it to any other desired
positions.
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Anytime you insert a hotspot into an image, it is set as a correct answer by default. However, you
can change it into an incorrect answer by navigating to the Properties pane > Interactivity >
General > deselect the Correct checkbox.
By default, in the Properties pane of the question > Interactivity > General > the Multiple
Response checkbox is checked, which means learners can give many answers by clicking on
many spots on an image. Each click they made is considered as an answer. However, in case
you want only the last click to be accepted as their answer, just deselect this checkbox.
To customize the default hotspot display, click on a hotspot > Properties pane > Style & Effects.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Hotspot question, you can set it as a default question to use in
the current project. To do that, right-click on the answer area > Set as Default Hotspot Question.
Alternatively, customizing this question type in the View tab > Object Settings > Questions >
Hotspot Question will apply changes to all newly inserted Hotspot questions in the current
project.

Essay
An Essay question contains a multiple-line text box that allows learners to input text.
To insert an essay question, click the Questions tab > Essay . Alternatively, click the Home
tab > Interactions
> Essay . The question will appear on the Canvas as follows:

By default, an Essay question is set in the Survey mode, which means the question is used to
gather the learner’s answers only. However, if you want to assess their performances, turn on the
Graded mode by selecting the text box > Properties pane > Interactivity > Score & Reporting
> Mode > Graded.
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Then, to set the correct answer list for an Essay question, select the text box > Properties pane
> Interactivity > General > Correct Values > Add Value.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.

Select in Dropdown
A Select in Dropdown question is also known as a dropdown question. It contains a dropdown
with a hidden list of options that allows users to select from. The dropdown menu is shown once
the user clicks on the dropdown arrow.
To insert a Select in Dropdown question, open the Home tab > Interactions
> Select in
Dropdown . Alternatively, open the Questions tab > Select in Dropdown . The question
will appear on the Canvas as follows:

Each Select in Dropdown question has only one dropdown. Therefore, you cannot remove it or
add more.
To add the list of answer options, select the dropdown > navigate to the Properties pane >
Interactivity > Dropdown > Item List > click the Add button .
You can remove one or multiple options in the Item List if you no longer need them. Select them
(hold CTRL while selecting multiple options), then click the Remove button .
By default, all options of the item list are hidden until users click the dropdown arrow. But, you
can set an item to be shown. To do that, select the dropdown > click its corresponding radio button
in the Default column (Properties pane > Interactivity > Dropdown).
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To set correct answers for this question type, select the dropdown > navigate to the Properties
pane > Interactivity > Dropdown > Item List > tick the checkbox of the correct values in the
Correct column.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.

Select in Dropdowns
A Select in Dropdowns question shares the same properties as a Select in Dropdown question,
but it has more than one dropdown.
To insert a Select in Dropdowns question, open the Home tab > Interactions
> Select in
Dropdowns
, or open the Questions tab > Select in Dropdowns
. After that, the new
question slide appears like that:

Creating Quizzes > Creating Quizzes

276

ActivePresenter User Manual

Version 9.0

To add the list of answer options, select each dropdown > navigate to the Properties pane >
Interactivity > Dropdown > Item List > click the Add button .
You can remove one or multiple options in the Item List if you no longer need them. Select them
(hold CTRL while selecting multiple options), then click the Remove button .
To change the container layout, select the answer area > Properties pane > Size & Properties tab >
Container Layout section > select None or Flex.

To add more dropdowns, select the answer area and click the Plus button:

To remove one or multiple dropdowns, select them, right-click > Delete, or press the Delete key
on the keyboard.
By default, all options of the dropdown lists are hidden until users click the dropdown arrows. But,
you can set an item to be shown. To do that, select a dropdown > click its corresponding radio
button in the Default column (Properties pane > Interactivity > Dropdown).
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Different from a Select in Dropdown question, a Select in Dropdowns question has more than one
dropdown. Therefore, you have to set the correct answer for each dropdown separately. To do
that, select a dropdown > navigate to the Properties pane > Interactivity tab > Dropdown >
Item List > tick the checkbox of the correct values in the Correct column.
Click the Properties pane > Interactivity > Score & Reporting to select the question mode and
set properties for it.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Select in Dropdowns question, you can set it as a default
question to use in the current project. To do that, right-click the answer area > Set as Default
Select in Dropdowns Question. Alternatively, customizing this question type in the View tab >
Object Settings > Questions > Select in Dropdowns Question will apply changes to all newly
inserted Select in Dropdowns questions in the current project.

Rating Scale (Likert)
A Rating Scale or Likert Scale question is very useful when making a survey. This type of question
allows you to gather feedback, opinions, or information effectively.
To insert a rating scale question, click the Questions tab > Rating Scale (Likert)
.
Alternatively, click the Home tab > Interactions
> Rating Scale (Likert) . The question will
appear on the Canvas as follows:
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By default, a Rating Scale (Likert) question has four answer labels. Each answer label includes
five radio buttons, which represent five rating scales. You can add more answer labels to the
question by selecting the answer area and clicking the plus button:

In addition, you can also add more radio buttons (rating scales) to the question or delete them.
To do that, select the answer area > Properties pane > Interactivity > Score & Reporting >
Rating Scale > select one number from the dropdown list.
To delete an answer label, select it and press the DELETE key on your keyboard or right-click on
it and select Delete. Then, that answer label and its corresponding radio buttons are deleted
simultaneously. If you want to delete multiple answer labels, hold down CTRL while clicking them,
then press DELETE.
Note that a Rating Scale (Likert) question is used to conduct a survey, it only has the Survey
mode. The Graded mode is not available for this question type.
Click the Properties pane > Interactivity > Events - Actions to have more settings for question
events and actions.
After creating and customizing a Rating Scale (Likert) question, you can set it as a default question
to use in the current project. To do that, right-click on the answer area > Set as Default Rating
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Scale (Likert) Question. Alternatively, customizing this question type in the View tab > Object
Settings > Questions > Rating Scale (Likert) Question will apply changes to all newly inserted
Rating Scale (Likert) questions in the current project.

Import Questions from File
Apart from 13 types of questions supported in the app, ActivePresenter allows you to directly
import questions from GIFT and CSV files. Creating GIFT and CSV format files and importing
questions from them are very useful when you need to add a large number of questions to your
project with a few clicks.
GIFT is an abbreviation of General Import Format Template. Meanwhile, CSV stands for CommaSeparated Values. Both of them are text files that allow writing various types of questions using
a simple text editor. For example, you can use Notepad or Microsoft Word to create GIFT files.
Meanwhile, Notepad or Microsoft Excel is useful to create CSV files.

Create GIFT Files
ActivePresenter allows you to import 6 types of questions from a GIFT file including Multiple
Choice, Fill in Text Entry, True/False, Essay, Drag-n-Drop, and Multiple Response questions. To
create a GIFT file, firstly, open a text editor (Microsoft Word or Notepad) to compose questions
following GIFT format. There is the generic syntax of GIFT format. You need to learn about the
syntax to write questions in GIFT format correctly.
In a simple form of GIFT format, a question comes first, then answers are put between (1) two
brackets {}. Use (2) an equal sign (=) to indicate a correct answer or (3) a tilde (~) to indicate an
incorrect answer.

To create a GIFT file, you first open a text editor such as Microsoft Word or Notepad. Then, start
writing different types of questions following GIFT format:
•
•
•

Multiple Choice: Use an equal sign (=) and a tilde (~) at the beginning of an answer option
to denote a correct answer and an incorrect answer, respectively.
Fill in Text Entry: Use an equal sign (=) or =%X% (X is percentage answer weight)
at the beginning of an answer option to denote a correct answer.
True/False: Input a T/TRUE between two curly brackets {T} to denote the statement is
correct. Input an F/FALSE between two curly brackets {F} to denote the statement is
incorrect.

•

Essay: Input two curly brackets {} to the answer section.

•

Drag-n-Drop: Must have at least 2 pairs of drag source and drop target. In the answer
section, use an equal sign (=) at the beginning of each answer option. Then, write a name
of the drag source (for example, rabbit) and write -> illustrating the arrow. After that, write
a name of the drop target (for example, carrot). Leave a space and continue to add other
similar drag source and drop target pairs.
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Multiple Response: Use a tilde (~) or ~%X% (X is percentage answer weight) at the
beginning of an answer option. An answer option is considered a correct aswer if 0 < X ≤
100. An answer option is considered an incorrect answer if X < 0 or just use a tilde (~) at
the beginning of it.

Refer to GIFT format if you want to learn more about writing different types of questions in GIFT
format.
After finishing composing questions, save the working document as a Text Document (*.txt) file
(with Unicode or UTF-8 encoding).

Create CSV Files
To create a CSV file, open a text editor (Microsoft Excel or Notepad). Then, start composing
questions following CSV format. Similar to GIFT format, CSV format has its distinct generic
syntax. Therefore, it’s necessary to know the syntax to write questions in CSV format correctly.
Here is the generic syntax for CSV format you need to follow:
Fields

Description
Use the following characters to indicate the question type you want to
create:

Question Type

•
•
•
•
•
•
•
•
•
•
•

TF - True/False
MC - Multiple Choice, Multiple Response
FIT - Fill in Text Entry
FITS - Fill in Text Entries
FIB - Fill in Blanks
SQ - Sequence
MAT - Drag-n-Drop
ES - Essay
SID - Select in Dropdown
SIDS - Select in Dropdowns
RS - Rating Scale (Likert)
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Points

Enter a number here to set points for a question.

Question Title

Input the title for a question.

Answer Options

Create answers options and/or define correct answers for a question.

Note: Bear in mind that the fields above must be created in the correct order: Question Type >
Points > Question Title > Answer Options. Otherwise, you cannot import questions from the file
into ActivePresenter.
Take a look at the following image to see how you can compose different types of questions using
Microsoft Excel:

Find the detailed instructions for each question type below:
●

True/False (TF): Use an asterisk (*) at the beginning of an answer option to denote a
correct answer.

●

Multiple Choice (MC): Use an asterisk (*) at the beginning of an answer option to denote
a correct answer.

●

Multiple Response (MC): As this question type has more than one correct answer,
append an asterisk (*) to all its correct answer options.

●

Fill in Text Entry (FIT): Input text or number into the first answer option column. Later,
ActivePresenter will convert this answer option into a text entry. The inputted text or
number will become the correct value of the text entry.

●

Fill in Text Entries (FITS): You can create this question type in the same way as the
previous one. The only difference is that it can have one or more text entries. Besides,
with each text entry, you can set more than one correct value for it. Note that each value
must be on a separate line.
For example, take a look at the Fill in Text Entries question in the image above. Its first
answer option column has two values: Product and Service. They are the correct values
of the first text entry. That means when learners type one of these two values, they are
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both accepted as the correct answer.
●

Fill in the Blank (FIB): In the question title column, let's add one or many pipes (|), which
will represent blanks. By doing so, you can create as many blanks as you want. Fill the
answer option columns with correct values for each blank correspondingly.

●

Drag-n-Drop (MAT): Separate each answer option and its match with a pipe (|). This
character denotes that this is a correct pair.

Note that if you want to display a pipe (|) as a normal character, put it between two percent
signs %%. If the pipe is put between two percent signs like this %|%, the system will display
it as a vertical bar, instead of recognizing it as a pipe at the beginning of an answer option in
Fill in the Blank or Drag-n-Drop questions.
●

Sequence (SQ): Enter text or number in each answer option column. The correct answer
to this question is the order of Answer Option 1 > Answer Option 2 > Answer Option 3 >
… > Answer Option n. Number of answers must be greater than or equal to 2.

●

Essay (ES): If you leave the answer option columns blank, Essays questions are set in
the Survey mode. On the other hand, if you fill answer options columns with text, the
questions will be set in the Graded mode. The inputted text in each answer option column
is considered the correct answer.

●

Select in Dropdown (SID): Each answer option is in one line but a separate column. Use
an asterisk (*) at the beginning of an answer option to denote a correct answer.

●

Select in Dropdowns (SIDS): Each dropdown is in a separate column. Note that each
answer option is on a separate line. Use an asterisk (*) at the beginning of an answer
option to denote a correct answer.

●

Rating Scale (RS): The first answer option column of this question type will function
differently. In detail, all inputted values in this column are considered rating scale values.
Number of values must be in the range of 2 – 10. For example, Poor, OK, Good, Excellent.
Keep in mind that each value must be on a separate line. Meanwhile, the inputted text or
number in the other columns will be recognized as answer labels. Let's say, Service,
Decoration, Food.

This is what a Rating Scale question looks like after you import a CSV file into ActivePresenter:
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After finishing composing questions, save the working document as a CSV UTF-8 (Comma
delimited) (*.csv) file.

Import Questions from GIFT or CSV Files
After creating GIFT or CSV files, follow these steps to import questions from the file into
ActivePresenter projects:
1. Open the Questions tab > click From File

.

2. Select a GIFT file (*.txt) or CSV file (*.csv) from your computer > Click Open.

By doing that, all questions from that file will be inserted into your project. Then, you can customize
properties (for example, question layout, question mode, correct answer, point and attempt, event
and action, etc.) for each question type as mentioned in the previous sections. Please refer to
each question type for more details if needed.

Randomizing Questions
While creating quizzes, you may want to randomize the order of questions displayed to learners.
ActivePresenter lets you do that using Slide Pools and Random Slide feature.
A slide pool contains a group of slides that don’t automatically appear directly in the output. To
make those slides randomly appear in the output, you need to use random slides. Random slides
help display slides linking to a specific slide pool by chance. You can choose to randomize all
slides in a pool or just its subset.
If you want to reuse slides in a pool, you just need to import that pool to another project.
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Creating Slide Pools
The Slide Pools pane is used to create and manage slide pools in a project. To open this pane,
click the View tab > Slide Pools. By default, ActivePresenter automatically adds Pool 1 without
any slide. You can add slides to this pool or create new pools as you wish.

To create a new slide pool, in the Slide Pools pane, do the following:
1. Click Add new pool

.

2. In the dialog that appears, enter a name for the new pool. Then, click OK to apply.

To manage slide pools, you can:
●

Change pool name

: Rename the current pool.

●

Delete a pool

●

Change pool color

●

Import slide pool from another project

●

More information about this pool : See the number of slides in the current pool and
the number of random slides linked to it.

: Remove the current pool and its slides.
: Change the current pool color.
: Import an existing pool from other projects.

Adding Slides to Slide Pools
There are two ways to add slides to a slide pool. First, create new slides directly in the Slide
Pools pane. Second, move existing slides from the Slides pane to a slide pool. In addition, you
can move slides from one pool to another if you wish.

Adding New Slides in Slide Pools
To add a totally new slide to a pool, you select a pool, then add new slides from the Home tab or
the Insert tab. Or, right-click on the Slide Pools pane > New Slide. In fact, creating new slides
in the Slide Pools pane is similar to creating new slides in your project.
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Moving Slides from the Slides Pane to a Pool
ActivePresenter allows you to move existing slides from the Slides pane to a pool. To do that, in
the Slides pane, select one or more slides and right-click on it/them > Move Slide To > select a
pool. As the selected slides are moved to the pool, they no longer appear in the Slides pane.

Moving Slides from one Pool to Another
In the Slide Pools pane, select a pool. Then, select one or more slides and right-click on it/them
> Move Slide To > select another pool. You can also copy slides from a pool and paste them into
another pool.

Moving Slides from Slide Pools to the Slides Pane
In the Slide Pools pane, select a pool. Then, select one or more slides and right-click on it/ them >
Move Slide To > Slides. You can also copy slides from a pool and paste them into the Slides pane.

Importing Slide Pools
You can reuse existing slide pools across projects. Do the following:
1. In the Slide Pools pane > Import slide pool from another project

.

2. Select a project file (*.approj) that contains slide pools you want to reuse.
The following window appears having two panes. The Pools pane shows all slide pools in the
selected project. The Slides pane shows all slides in each pool. To change the view mode, select
the Small or Large radio button.
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3. Select one or more checkboxes that correspond to slide pools you want to import.
4. Select an import option:
○

Append Pools: Import a pool as a new pool while keeping all previously created pools
in the current project.

○

Replace All Existing Pools: Import a pool as a new pool while removing all previously
created pools in the current project.

5. Click OK to apply changes.

Using Random Slides to Draw from Slide Pools
Random slides display slides that are randomly selected from a pool to which they are linked.
Let's take an example. A random slide is linked to a pool containing five slides. In the output, the
random slide will randomly display one of the five slides in the pool.
Compared with normal slides, random slides have some differences:
●

In the HTML5 output, random slides will be replaced by slides in the pool to which they
are linked.

●

You neither insert anything into random slides nor insert random slides into slide masters.
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Inserting Random Slides
To insert a random slide, click the Home tab or the Insert tab > New Slide > Random Slide .
Alternatively, access the Questions tab > Random Slide. Then, a random slide is inserted below
the current slide. A random slide whose background color is the color of the first pool in the list by
default.

If you no longer need a random slide, just remove it. Click it and press DELETE or right-click on
it > Delete.

Drawing Slides from Slide Pools
Random slides come in handy to draw slides randomly from a slide pool. You can choose to
display and randomize all slides in a pool or just its subset.
For example, a pool has five slides. To randomize all slides in that pool, insert five random slides
into your project. Otherwise, if you just want to randomize three out of five random slides in that
pool, only insert three random slides.
To draw slides from a slide pool, do the following:
1. In the Slides pane, select one or more random slides.
2. Click the Properties pane > Slide Properties > Linked Pool > select a pool.
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Note: Each slide pool is assigned a different color, so the linked random slide will display the
background color of the corresponding pool. Besides, it’s possible for you to change the color of a
slide pool. To do that, select a pool in Slide Pools > Change pool color > select the color you like.

When randomizing questions, it’s better to ensure each learner gets an equally difficult quiz. To do
that, set the difficulty level for each question. Then, sort questions based on their degree of difficulty
into separate pools. That way, you can have individual pools for each difficulty level with a certain
number of questions, such as 10 difficult questions, 10 moderate ones, and 10 easy ones.

Inserting Report Slides
At the end of a course or presentation, you can insert a report slide to summarize user
performance. A report slide allows learners to track and review all their interactions in a course.
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To add a report slide, click the Home tab or the Insert tab > New Slide > Report Slide .
Alternatively, in the Questions tab > Report Slide . Then, a report slide is inserted into your
project with the top text box, default parameters, and the Review Course button as follows:

You can show or hide the default parameters by selecting them, then navigate to the Properties
pane > Interactivity > Report Display. You can also add custom parameters using text captions
and variable references.
The Review Course button lets learners review a quiz in the review mode. For more details, see
the Reviewing Courses section below.
Note: To modify the look of the report slide, open the slide master view and adjust the report slide
layout. For more details, see Using Slide Masters.

Reviewing Courses
The Review Course button in a report slide lets users review the entire course. By clicking this
button, users enter the review mode where they can see correct and incorrect answers, correct
values, and the overall result of each interaction and slide.

Here’s how ActivePresenter creates and handles the review mode. At the beginning of a slide,
ActivePresenter checks if a course is in the review mode using the read-only apReviewMode
variable. If the course is in the review mode (the variable value is equal to true), ActivePresenter
will show all correct/incorrect responses for graded interactions on the review feedback layer.
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You can:
●

●

Change the parameters of the Show Responses action. By default, all graded
interactions are shown.

○

Variable: Use variable to show responses.

○

Interaction Object: Determine which object will show responses.

○

Correct/Incorrect Check Mark: Show correct/incorrect check marks next to
correct/incorrect answers.

○

Correct Values: Show correct values next to interaction objects. Available for mouse
clicks, key strokes, text boxes, fill in text entry, fill in text entries, and essay questions.

○

Results: Show the overall result of the graded interaction at the bottom of a slide. If
the slide has more than one graded interaction, all the results will overlap, so only the
result of the last graded interaction can be seen. However, you can determine which
result to be displayed as you wish. In common cases, there is only one graded
interaction on a slide, so its result is treated as the overall result of the slide.

Change the feedback layer to be displayed. By default, ActivePresenter displays the
review feedback layer. You can change this layer to any other feedback layer. Click the
Feedback combo box and select the layer you want.
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Open the feedback master view to modify the displayed feedback layer. For details, see
Using Feedback Master.
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Adding Interactivity
Adding Events - Actions
Events - Actions allows you to add various events to objects, slides, and the project and define
actions for events.
To open this section:
•

For objects, questions, and slides:

Select an interaction object/question/slide > Questions tab > Event

.

Alternatively, you can select the slide containing the question or interaction object > Properties
pane > Interactivity > Events - Actions.
•

For projects:

Click ActivePresenter > Project > Properties. In the Properties pane > Interactivity > Events
- Actions.
Below are seven tools allowing you to work with events, actions, and conditions in
ActivePresenter.

•
•
•
•
•
•

The Add
button (1): Selecting any object/question/slide or event/action entry in the
Events – Actions section of the Properties pane will enable this button. Then, click this
button to add events, actions or conditions depending on what you selected before.
The Delete
button (2): Selecting any event/action/condition entry in the Events –
Actions section of the Properties pane will enable this button. Then, click this button to
delete the event/action/condition you selected before.
The Edit Condition
button (3): Selecting any condition entry will enable this button to
edit the condition.
The Reset Event
button (4): Reset all events to the events as in the slide master layout.
The Move Action Up
(5) and Move Action Down
(6) buttons: Move an action’s
order in the list up or down, respectively.
The Advanced Action
button (7): Open the Advanced Action dialog.

The image below shows the sample Events - Actions of a slide:
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There are many types of events in ActivePresenter (On Click, On Correct, On Incorrect, On
Accept, On Rollover, etc.). They vary from question to question and object to object. Besides,
there are a wide variety of actions that an event can have.
The next parts will explain how to add and remove them in detail.
Since the structure of a given event, action, and condition does not change from object to object,
the next parts will describe how to add and remove an event/action/condition for a question as a
sample. You can do similarly for other types of objects.

Adding and Removing Events
Each question, object, or slide can have more than one event.
To add an event to a question/object/slide, select it > hover the mouse over the
question/object/slide title in the Properties pane > Interactivity tab > Events – Actions > Add
Event
> choose an event from the pop-up list.

Besides, to remove an event, click the event entry > Delete Event
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Adding and Removing Actions for Events
To add actions to an event, select the event > Add Action

.

Repeat these steps to add more actions if needed. Each event can have more than one action.
In that case, actions will be played in the order that you insert. To change the order of an action,
select it and click the Move Action Up button
or Move Action Down button
to bring an
action up or down one level respectively.

ActivePresenter will display the following action gallery:
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To change the action, simply click the Action entry (e.g. Continue Presentation) and select one
action from the action gallery.
To delete an action, click/hover the mouse over the action entry, and click the Delete Action
button .

Note: The object on the Canvas will gain the highlight when you click its name, event, action, or
condition from the drop-down list in the Events - Actions section. The highlight is a red line that
borders the object to let you know which object you are selecting.
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Adding and Removing Conditions for Actions
Each action can have specified conditions. This means the action can only be played if some
certain contexts are matched.
To add a condition to an action, select the action and click the Add Condition button

.

The dialog appears as follows:

After adjusting the Add Condition dialog, click the Add button to complete the process. Click Cancel
to cancel the condition and close the dialog. Click Add & Continue to add the condition and continue
adding other ones. After that, a Condition entry will be added right below the Action entry.
Note: The content of this dialog will vary differently. It depends on which type of objects you are
working with.
Parameter

Function

AND/OR

Use this to combine multiple conditions in an action.
AND
OR

List

Execute the action if all conditions are true.
Execute the action if there is at least one true condition.
The type of object to be compared in a condition.
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Compare a variable with a value or other variables.

Object State

Compare the current state of an object to a specified state of the object.

Radio Button
/Checkbox

Compare the current on/off state of an object to a specified on/off state of
the object. This is only available for Checkbox and Radio Button.

Slider
Dropdown
Attempt
Mouse
Key

Compare the value of a slider to a value.
Compare the value of a dropdown to a value.
Compare the number of actions that users have tried.
Compare the value of a mouse click event to a value. This is only available
for On Click event.
Compare the value of key stroke event to a value. This is only available in
the On Key Press event.

If

Specify the variable, shape to be compared.

Operator

The logical operator which is used to compare.

State

The state of the shape which the current state of the shape is compared
with.

Type

Select to compare a variable with a variable or a value.

Value

Set the value to compare the variable with.

To edit the condition that you’ve added, select the condition entry and click the Edit Condition
button . This opens the Edit Condition dialog which has the same structure and content as
the Add Condition one shown above.

To delete a condition, select the condition entry and click the Delete Condition button

.
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Copying Events, Actions and Conditions
ActivePresenter allows you to copy events, actions, and conditions easily. To do that, right-click
the event/action/condition entry > Copy . Then, right-click the destination object/event/action >
Paste
. You can also use the hotkeys to copy (CTRL+C) and paste (CTRL+V)
event/action/condition.
Besides, you can also duplicate an event/action/condition by right-clicking it and select Duplicate
(CTRL+D).

Events - Actions References
Event actions can be attached to both annotation and interaction objects. You can specify the
events (for example, “when the mouse rolls over this shape”), and what actions should be taken
in response to those events (for example, “display the hint message”).
In older versions of ActivePresenter, interactions are managed in the Event Editor dialog. From
version 7, this dialog no longer exists. Instead, you can set up and manage interactions in the
Properties pane > Interactivity > Events - Actions.

Events
Events are used to trigger actions - in other words, when an event is detected, one or more actions
are provided as a response.
Events available for objects, slides, and projects are explained as follows:
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Description
Occur when users click an object/a slide. Available for slides, mouse
clicks, buttons, drag sources, drop targets (not including drop areas),
animated timers, hotspot questions, shapes (including all message
types), images, text captions, containers, equations and videos.
Occur when users press a key or combination of keys. Available for slides
and key strokes. All keys except WINDOWS key are supported. You can
define actions for each key stroke value using conditional actions.
Note that there are different keyboards for different languages.

On Text Enter

Occur when users enter a text string. Available for text entry, fill in text
entry, essay question. You can define actions for each entered text value
using conditional actions.

On Check

Occur when users mark a checkbox or radio button. Available for
checkboxes and radio buttons only.

On Uncheck

Occur when users uncheck a checkbox or radio button. Available for
checkboxes and radio buttons only.

On Drag Start

Occur when a drag source is dragged from its location. Available for drag
sources only.

On Drag End

Occur when users release the mouse button (end the dragging) while
dragging a drag source. Available for drag sources only.

On Drag Out

Occur when you move a drag source out of a drop target/drop area after the
drag source was accepted. Available for drop areas and drop targets only.

On Drag Enter

Occur when a drag source enters (by hovering over) a drop area or drop
target. Available for drop areas and drop targets only.

On Drag Leave

Occur when a drag source leaves a drop area or drop target. Available
for drop areas and drop targets only.

On Accept

Occur when any accepted drag source is dropped on a drop area or
drop target. Available for drop areas and drop targets only.

On Reject

Occur when any rejected drag source is dropped on a drop area or drop
target. Available for drop areas and drop targets only.

On Timer Complete

Occur when a timer is completed or timed out. Available for timers only.

On Correct

Occur when users give a correct response. Available for all graded
interactions.
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On Incorrect

Occur when users give an incorrect response. Available for all graded
interactions.

On Complete

Occur when users answer a question or fill in a text box. Available only
when the mode of the question or text box is survey.
Occur when an answer is incomplete, for example:

On Incomplete

●

Users leave a field blank in a text entry object or in a question
containing a text entry (fill in text entry, fill in text entries, fill in blanks,
select in dropdown, select in dropdowns, and essay).

●

Users leave all checkboxes or radio buttons unchecked in case of
true/false, multiple choice, and multiple response.

●

Users leave all drop targets empty (contain no drag source) in dragn-drop question.

On Timeout

Occur when users don’t respond within a specified time.

On Rollover

Occur when the mouse rolls over the shape of an object (enters the
boundary of a shape). Available for mouse clicks, key strokes, text
entries, buttons, checkboxes, radio buttons, drag sources, drop areas,
drop targets, animated timers, text captions, shapes, (including all
message types), containers, equations, and images.

On Rollout

Occur when the mouse rolls out of the shape of an object (exits the
boundary of a shape). Available for mouse clicks, key strokes, text
entries, buttons, checkboxes, radio buttons, drag sources, drop areas,
drop targets, animated timers, text captions, shapes (including all
message types), containers, equations, and images.

On Swipe
Left/Right/Up/Down

Occur when users swipe across an object/a slide to the
left/right/top/bottom on the touch screen. Available for slides, buttons, drop
targets (not including drop areas), animated timers, text captions, shapes
(including all message types), containers, equations, and images.

On Load

Occur when a slide/project starts showing. Available for slides and
projects.

On Unload

Occur right before a slide completes. Available for slides only.

On Ended

Occur when an audio, a video, or a YouTube object completes playing.

On Change

Occur after you drag the thumb or specify a value on the track of a slider
object; when selecting an item in the list of a dropdown object; or when
the answer area of a question is changed. Available for sliders and
dropdowns, and questions.

On Changing

Occur at the same time when you are dragging the thumb of a slider.
Available for sliders only.
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Actions
Actions are always paired with events, that is, they occur in response to events. For example,
when you click a link in a slide, a new browser tab or window opens.
All actions are listed as follows:
Action

Description
Presentation
Depending on the current state of the presentation:
●

If the presentation is playing, this action doesn’t change anything.

●

If the presentation has been paused, this action will continue playing
the presentation from the time it stops.

You can pause a presentation in two ways:
●

Click the Properties pane > Interactivity > General > Pause
presentation to wait for user input for any interaction object. When
the object is played, the presentation will pause. You can choose
between pausing the presentation just before hiding the object or
pausing it after showing the object for a specific amount of time.

●

Execute the Pause Presentation action (see below).

Continue
Presentation

Half the presentation’s mainstream, thus making all the objects stop
playing against the time. Users can still interact with interaction objects.
Pause Presentation

End Presentation

The presentation is paused indefinitely until one of the following actions
is executed: Continue Presentation, End Presentation, Go to Slide, Go
to Slide at Index, Go Backward or Go Forward.
When this action happens, any further actions taken later that affect
learner results (such as submitting a quiz) will be blocked. The action
helps to notify an LMS that the lesson is completed or send the report to
the HTTP report address if you use LMS or HTTP report respectively.
Note that this action does not mean to close the browser.

Review
Presentation

Enter the review mode where users can see correct and incorrect
answers, correct values, and the overall result of each interaction and
slide.

Restart
Presentation

Reset the presentation to the original state and start from the beginning.
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Slide

Go to Slide

Go to a specific slide. The link is made to a specific slide, so if you
move that slide to a new position, the link will follow it and jump to the
new position. If the target slide is deleted, the link gets dissolved
automatically.

Go to Slide at Index

Go to a slide at a specific index. When you add, remove, or reorder
slides, the order of slides may change. Regardless of that, this action
will jump to the nth slide in the order.

Go Backward

Go backward by a specified number of slides. The target is not a
specific slide, instead the jump will land on any slide that is presently n
slides away from the current slide.

Go Forward

Go forward by a specified number of slides. The target is not a specific
slide, instead the jump will land on any slide that is presently n slides
away from the current slide.

Go to Last Visited
Slide

Go to the last slide that you have visited.
Object

Show Object

Show an initially hidden shape, image, audio, or video object. Objects
can be shown with animation and hidden automatically with animation
after an amount of time. If you want to allow users to manually hide the
object, execute the Hide Object action.
Subsequent actions can be blocked until this action is completed.
Otherwise, subsequent actions are executed right after the object is
displayed.

Hide Object

Hide any object which is displayed by the Show Object action before it
disappears automatically. Objects can be hidden with exit effects.

Toggle Visibility

Toggle between hide and show for the selected objects. For example,
click a button to show an object if it is hidden and hide an object if it is
shown. This creates a toggle effect.

Highlight Object

Highlight an object using an emphasis effect.

Change Object
State

Change the display state of a multi-state object.

Play Audio

Play an audio resource or built-in sound in your project. This action
should be used to play short audio. For long audio tracks, you’re
recommended to insert them into slides, make them initially hidden,
and execute the Show Object action. After that, use the Hide After
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option in the Show Object action to stop the audio automatically or
execute the Hide Object action to let users stop the audio manually.
In fact, the Play Audio action is similar to the Show Object non-blocking
action with audio objects, except it doesn’t require that an audio object
is inserted into a slide.
Clear whatever users entered in a specific interaction object, for example:

Clear User Input

Submit

●

Clear text in all text fields for text boxes and questions that contain
text boxes.

●

Uncheck checkboxes or radio buttons for questions.

●

Send dropped drag sources to their original positions.

●

Return the default item of dropdowns.

Send whatever users entered in a specific interaction object to the
presentation to evaluate.
Timeline

Start Timeline

Start the playback of the target timeline.

Pause Timeline

Pause the playback of the target timeline.

Continue Timeline

Resume the playback of the target timeline.

Click Sequence –
Go Forward

Complete animations in the current sequence if any, and run animations
in the next sequence.

Click Sequence –
Go Back

Complete animations in the current sequence if any, and run animations
in the previous sequence.
Feedback

Show Feedback
Layer

Show a feedback layer. You can choose to hide the feedback layer after
an amount of time.

Hide Feedback
Layer

Hide a feedback layer.

Show Responses

Show responses for all graded interactions. You can determine which
object will show responses as well as which types of responses to be
shown.
Miscellaneous

Adjust Variable

Change the value of a variable. You can assign a value (or another
variable value) to the target variable, toggle the value of true/false
variables, and do basic math with number variables.
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Start Timer

Make the timer start counting, do nothing if it is running. If the timer has
finished, the action restarts it.

Pause Timer

Pause the timer but keep the current value, do nothing if it is paused.

Stop Timer

Stop the timer and reset its value.
Launch the default email client program installed on user PC, and load
the previously configured contents in the mail (including recipient
address and subject line).

Send Email

Note that the email is not sent silently or automatically, instead users
must manually press the send button. Users can also modify the email
contents before sending.

Open Webpage

Open a specified URL. Choose to open it in the current, new, parent,
topmost, or named window.

Execute JavaScript

Execute a specified JavaScript. Write the script in the window that appears.

Advanced Actions

Execute an advanced action.

Setting Up Interactions
The following chart shows the events for each object type.
Objects

Events

Text
Caption
Equation
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On Ended

Shape

On Swipe

Container

On Rollover / Rollout

On Timeout

On Incomplete

On Complete

On Correct / Incorrect

On Timer Complete

On Accept / Reject

On Drag Enter/Leave/Out

On Drag Start / End

On Check/Uncheck

On Text Enter

On Key Press

On Change

On Changing

On Click

On Load / Unload

Slide
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Chart
Table
Image
Audio
Video
YouTube
3D Model
Mouse
Click
Key Stroke
Text Entry
Drag
Source
Drop Area
Drop Target
Button
Checkbox
Radio
Button
Slider
Dropdown
Animated
Timer
Question True/False
Question Multiple
Choice
Question Multiple
Response
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Question Essay
Question Fill in Text
Entry
Question Fill in Text
Entries
Question Fill in
Blanks
Question Sequence
Question Drag-nDrop
Question Hotspot
Question Select in
Dropdown
Question Select in
Dropdowns
Question Rating
Scale
(Likert)

Adding Advanced Actions
The Advanced Actions feature allows you to define complex actions and reuse them easily. An
advanced action can contain normal actions and parameters, which is divided into three
components: action name, parameters, and a list of actions. The action list can include both types
of actions that use and don’t use the parameters of the advanced action. You can reuse the
advanced actions in many places by changing or adjusting its parameters.
To create and use advanced actions, click the Properties pane > Interactivity > Events Actions > Advanced Actions .
Alternatively, click the Questions tab > Advanced Actions
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Then, the Advanced Actions dialog appears, allowing you to view and edit the parameters and
actions. Below is an advanced action that is used to toggle between the two states of a shape.

Note: You can click the button

to see which slides the advanced actions are currently used.

Take the following steps to create the advanced actions:

Creating New Advanced Actions
In the Action Name section, click the

button to create a new action.
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To rename an advanced action, select it from the Action Name list and click Rename Action .
Besides, to delete an action, select it and click Delete Action . To duplicate an action, select it
and click Duplicate Action .

Creating Parameters
The parameters you create here will be used as the references for the actions in the next part.
To create new parameters, in the Parameters section, click the Add button . Then, enter the
parameter name in the Name box and select the corresponding type from the Type list. For
example, if you are creating a parameter for a shape, the type will be Shape.

After adding a parameter, you can rename it by clicking the Edit button
parameter, select it and click Remove .

. Besides, to delete a

Adding Actions
Click Add
to select an action from the gallery. This gallery is the same as the one you have
when you add actions to events.
Then, you can hover the mouse over the newly added action entry and click Click to edit to edit
the action.

Then, the following dialog will appear:

First, click the Param box to enable selecting parameters from the list that you created before.

Adding Conditions to Actions
To add condition to advanced actions, select it and click Add Condition . This opens the Add
Condition dialog. This dialog is similar to the one you have when adding conditions to a normal
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action. However, it has the option to use parameter. Select this option and choose a
corresponding parameter.

In case there are more than one actions added, they will happen in the order that you add. To
change that order, click
and . Besides, to delete an action, select it and click Delete .

Adding Advanced Actions to Events
You can add advanced actions to events of an object the way you do with normal actions.
To do that, click the Properties pane > Interactivity > Events - Actions > select the event entry
> Add Action
> Advanced Action.
After that, on the Advanced Action entry, click Click to edit and select one advanced action from
the list. Then, in the dialog that appears, set the value for each parameter.
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Using Variables
Variables are a great way to collect, store, and retrieve dynamic information throughout a project.
They are also useful for creating conditional interactivity with conditional actions that only occur
when certain conditions are matched.
Variables can also be used in some actions. For example, you can add a Text variable to the
Show Object action. This is useful if you have many objects and would like to show one by one
by typing text into a text caption.
ActivePresenter provides three types of variables: true/false, text, and number. All come in two
categories: system and user-defined.
●

System variables come predefined. You cannot modify and delete them. Find system
variables in the Home tab > Variables
> System tab.

●

User-defined variables are project-specific variables created by users. You are free to
create, modify, and delete these variables.

A variable can fall into three types:
●

True/false variables (boolean variables) have only two possible values: true and false.
This true or false nature makes these variables a great way to keep track of things that
are right or wrong, on/off, clicked/not clicked, visited/not visited, and the like. True/false
variables enable you to make decisions, and thus have better control over your flow. For
example, you can use true/false variables for slide completion, that is, to track if learners
visit a slide and interact with its contents.

●

Text variables (string variables) hold text-based values (strings). They help store
information such as names, passwords, etc. For example, you can use text variables to
remember the learner’s name, then display it throughout the course to personalize your
training.

●

Number variables (real variables) hold numeric values. They store numeric information
such as scores, number of attempts/clicks, question counting, current slide number/index,
and any other numeric values. For example, you can use number variables for some
simple calculation functions such as addition and subtraction. Or, use these variables to
create a visible counter that counts either up or down to track the number of clicks.

Adding Interactivity > Using Variables

311

ActivePresenter User Manual

Version 9.0

Creating Variables
To create a new variable, do the following:
1. Click the Home tab > Variables to open the Variables dialog.

apScoreSubstract is a predefined User variable that is used to subtract scores when a learner
performs a wrong action.
2. In the User tab, click Add
in the bottom toolbar. This opens the Variable dialog where
you specify the variable name, type, initial value, and description (if any).
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○

Name: Specify a unique name for the variable. The name should be descriptive and
intuitive enough and associated with the data stored. For example, a variable storing
learner name would be called learnerName.

○

Type: Represent what kind of data is stored with the variable. Select from three types:
TRUE/FALSE, TEXT, and NUMBER.

○

Value: The data stored within a variable is called a value, and it can be one of multiple
types as mentioned above. Normally, when you add variables, you define the variable
names and types. For values, if you don’t assign initial values, the default values for
true/false, text, and number variables are true, empty string, and zero (0), respectively.

○

Description: Optionally, provide a description for the variable to state its use or purpose.

3. Click Add & Close to save the variable. The new variable will appear in the variable list in
the User tab.
4. Click Add & Continue to save the variable and continue adding another variable.

Adding References to Variables
Variables store data. Variable references retrieve and display the data stored in variables. You
can also use references to verify whether the variable is working correctly or not.
For example, you use a variable to get the learner's name, then use the name throughout the
course to personalize your training. On the welcome slide, just ask learners to type their names
in a field (text box) and store the input in a variable. Then, add references to that variable to
display the name in multiple slides in your course.

You can add a reference to any text captions, shapes, or other text-based objects. Do the following:
1. Click the text area of a text-based object to open the inline text editor.
2. Click the Home tab > Reference
to open the Variables dialog which contains all the
system and user variable in your project.
3. Select a variable. Both system and user variables are available to add references.
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4. Click OK to finish. Then, a variable reference appears in your text as a placeholder that
contains the variable name getting enclosed within two percent signs (%).
When you preview or publish the project to HTML5, ActivePresenter replaces the variable
names with the actual values of the variables they reference.
5. Optionally, adjust the formatting of the reference as normal.
Note: If you remember exactly a variable name, you can type the name and put it between the %
signs to reference that variable.

Using Actions to Adjust Variable Values
Variable values change depending on user input. For example, in the above example of the
learnerName variable, each time a learner types his name, the variable value will update with the
new entry.
Alternatively, you can use the Adjust Variable action to adjust variable values. Let’s say you want
to count the number of times that users click on the screen before they click the correct area. Do
the following:
1. Delete 2 feedback messages and add the Adjust Variable action to the On Incorrect
Event of a Mouse Click object.
2. Click Click to edit to open a dialog letting you change the variable.
3. Click the Variable combo box and choose a variable from the list. Or, click the Add
Variable button to create a new variable then select it. For example, you add a NUMBER
variable, name it incorrectClick and then set its default value to 0. After that, assign this
variable to the Adjust Variable action as follows:

4. Choose an operator from the Operator combo box. For example, the Assignment operator
assigns a value to the target variable. Meanwhile, the Add operator adds a value to the
target variable.
○

True/false variables: Assignment, Toggle.

○

Text variables: Assignment, Concatenate.
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Number variables: Assignment, Add, Subtract, Multiply, Divide. This means you can
do the math with number variables.

5. Specify the Value by which the operation is to be done. It can be a specific value (you
yourself specify it) or a value stored by another variable.
Note: So as not to limit the number of clicks, in the Interactivity tab of the Properties pane, you
have to select infinite for the attempts option in the Score & Reporting section of the Mouse
Click object.
You can add a reference to a shape to show the number of incorrect clicks by adding a shape,
then click the text area of the shape to open the inline text editor. In the Home tab, click Reference
and choose the variable you have created above. Click OK to finish.

Managing Variables
Duplicating Variables
To duplicate a user variable, in the Variables dialog > User tab, do the following:
1. Select the variable you want to duplicate.
2. Click Duplicate

in the bottom toolbar to make an exact copy of the variable.

3. In the user variable list, double-click the new variable to change its parameter.
4. Click Update to save changes.
5. Click OK to finish.

Removing Variables
You can delete only user variables. When you delete a variable, any references to this variable
and actions that involve it still remain. Thus, you need to modify or delete those references and
actions manually.
To delete a user variable, select it > Remove

in the bottom toolbar.

Editing Variables
You can edit the name, initial value, and description of a user variable at any time. The variable
type cannot be changed. If you rename a variable, all references to the variable and actions that
involve it will be updated automatically.
To edit a user variable, double-click it or select it > Edit
in the bottom toolbar. When you’re
done, click Update to save changes and click OK to finish.

Finding Variables
ActivePresenter makes it easy to find how many times and where a variable is used. You can
double-click the hyperlinked number in the Usage Count column for the variable you want to find.
Each time it is referenced by slide text or involved in an action will be counted. You can also select
the desired variable and click Usage
in the bottom toolbar.
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List of System Variables
All system variables are shown in the Home tab > Variables > System tab as in the figure below.
Besides the variable name, type, and default value, the list also shows the number of times each
variable is used.
Below is the list of system variables in ActivePresenter. Note that system variables have four
types in total, namely true/false, text, number, and command. Command variables are systemspecific variables used to control the player.
Name

Type

Description

apVersion

TEXT

Returns the version of the application.

apAuthor

TEXT

Returns the name of the project author.

apHomepage

TEXT

Returns the home page of the project.

apCopyright

TEXT

Returns the copyright information of the
project.

apProjectName

TEXT

Returns the project name.

apDescription

TEXT

Returns the project description.

apPlayMode

TEXT

Returns the current operation mode of
the presentation.

apCurrentSlideLabel

TEXT

Returns the current slide name.

apElapsedTime

TEXT

Returns the elapsed time in the format
hh:mm:ss since the presentation
started playing.

apElapsedTimeMs

NUMBER

apRemainingTime

TEXT

Returns the elapsed time in
milliseconds since the presentation
started playing.
Returns the remaining time in the
format hh:mm:ss.

apRemainingTimeMs

NUMBER

Returns the remaining time in
milliseconds.

apTotalSlides

NUMBER

Returns the total number of slides in the
project.

apTakenSlides

NUMBER

Returns the number of taken slides in
the project.
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apReviewMode

TRUE/FALSE

Returns true if presentation in review
mode.

apLastSessionIncomplete

TRUE/FALSE

Returns true if presentation is revisited
after an incomplete attempt.

apQuizScore

NUMBER

Returns the total score.

apQuizScorePercentage

NUMBER

Returns the total score as a
percentage.

apQuizMaxScore

NUMBER

Returns the highest score.

apQuizPassed
apQuizPassedBool

TEXT
TRUE/FALSE

Returns the result of the quiz as passed
or failed.
Returns the result of the quiz as true
(passed) or false (failed).

apQuizTotalInteractions

NUMBER

Returns the total number of interactions
in the project.

apQuizTakenInteractions

NUMBER

Returns the number of taken
interactions in the project.

apQuizUnTakenInteractions

NUMBER

Returns the number of unanswered
interactions in the project.

apQuizCorrectInteractions

NUMBER

Returns the number of correct
interactions in the project.

apQuizIncorrectInteractions

NUMBER

Returns the number of incorrect
interactions in the project.

apDetailedResult

TEXT

Returns the detailed report.

apDetailedResult2

TEXT

Returns the detailed report with correct
responses.

apCurrentTime

TEXT

Returns the current time in the format
hh:mm:ss.

apCurrentDay

NUMBER

Returns the day of the week. The range
is from 1 (Sunday) to 7 (Saturday).

apCurrentHour

TEXT

Returns the current hour in the 24-hour
format.

apCurrentMinutes

TEXT

Returns the current minutes in the
format mm.
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apCurrentMonth

TEXT

Returns the current month in the format
mm.

apCurrentYear

TEXT

Returns the current year in the format
yyyy.

apCurrentLocaleDate

TEXT

Returns the current date in the format
of the locale on the viewer's computer.

apProjectLocaleDate

TEXT

Returns the current date in the format
of the project language.

apDateMMDDYYYY

TEXT

Returns the current date in the format
mm/dd/yyyy.

apDateMMDDYY

TEXT

Returns the current date in the format
mm/dd/yy.

apDateDDMMYYYY

TEXT

Returns the current date in the format
dd/mm/yyyy.

apDateDDMMYY

TEXT

Returns the current date in the format
dd/mm/yy.

apDateYYYYMMDD

TEXT

Returns the current date in the format
yyyy/mm/dd.

apDateYYMMDD

TEXT

Returns the current date in the format
yy/mm/dd.

apCurrentSlideIndex

NUMBER

Gets or sets the current slide index,
starts from 1. Sets the value to a
number to go to the slide at that index
number.

apCurrentSlideProgress

NUMBER

Gets or sets the current progress of the
current slide in milliseconds. Sets the
value to a number to go to a specific
time of the current slide.

apPause

TRUE/FALSE

Sets or checks if the presentation is
paused. Sets the value to true to pause
the presentation.

apResume

TRUE/FALSE

Sets or checks if the presentation is
playing. Sets the value to true to
continue the presentation.

apProgress
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value to a number to go to a specific
time of the presentation.

apSpeed

NUMBER

Gets or sets the playback speed. The
range is from 50% to 200%.

apMute

TRUE/FALSE

Mutes or unmutes the audio. Sets the
value to true to mute the audio.

apVolume

NUMBER

Gets or sets the audio volume. The
range is from 0 (mute) to 100
(maximum).

apCCVisible

TRUE/FALSE

Shows or hides the closed caption.
Sets the value to true to show the
closed caption.

apToolbarVisible

TRUE/FALSE

Shows or hides the player toolbar. Sets
the value to true to show the toolbar.

apTOCVisible

TRUE/FALSE

Shows or hides the table of contents.
Sets the value to true to show the table
of contents.

apSidebarVisible

TRUE/FALSE

Shows or hides the side bar. Sets the
value true to show the side bar.

apCmdNextSlide

COMMAND

Sets the value to true to go to the next
slide.

apCmdPreviousSlide

COMMAND

Sets the value to true to go to the
previous slide.

apCmdFirstSlide

COMMAND

Sets the value to true to go to the first
slide.

apCmdLastSlide

COMMAND

Sets the value to true to go to the last
slide.

apCmdHistoryBack

COMMAND

Sets the value to true to go to the
previously visited slide in the navigation
history.

apCmdHistoryForward

COMMAND

Sets the value to true to go to the next
slide in the navigation history.

apCmdEnd

COMMAND

Sets the value to true to end the
presentation.
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apCmdRestart

COMMAND

Sets the value to true to restart the
presentation.

apCmdShowAbout

COMMAND

Sets the value to true to show the
information dialog.

Custom JavaScript in HTML5 Output
ActivePresenter allows retrieving elements of presentation in the HTML5 output by exposing the
JavaScript API. You can write custom script in the following area:
•
•

The Event - Actions section of a project. (ActivePresenter button > Project > Properties
> navigate to the Properties pane > Interactivity tab > Event - Actions section.)
The Execute JavaScript action in the Event - Actions section of the Properties pane.

You can access the presentation by using the object prez. The prez object has the following
methods:
Method

Description

object(name)

Gets the object in the current slide from name. If not found,
search control shows over multiple slides in the bottom layer,
then the top layer.

slideCount()

Returns the number of slides in the presentation.
Returns false if the index is out of range.

showSlideAt(index,
time)

●

index: Slide index, starts from 1.

●

time: Jumps to the specified timestamp (in milliseconds) in
the slide. Time can be omitted. If omitted, then time
equals 0.

Shows the slide with options.
Options is an object with the following properties:
•

showSlideAt(index,
options)

transition: customs slide transition type, it overwrites
transition set to slide when editing. Use any of the following
values. (You need to add AP.TransitionType. prefix
for accessing these values.)
o

NONE

o

CUT

o

FADE

o

PUSH

o

WIPE

o

ZOOM
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o

COVER

o

UNCOVER

o

REVEAL

o

FLY_THROUGH

•

duration: transition duration, in milliseconds.

•

direction: Use any of the following values. (You need to
add AP.EffectDirection. prefix for accessing these
values.)

•

o

BOTTOM

o

LEFT

o

RIGHT

o

TOP

o

BOTTOM_LEFT

o

BOTTOM_RIGHT

o

TOP_LEFT

slideTime: seeks to this time in slide, default 0

For example:
showSlideAt(2, {
transition: AP.TransitionType.PUSH,
duration: 500,
direction: AP.EffectDirection.LEFT
});
currentSlideIndex()

Returns the current slide index, starts from 1.

nextSlide()

Goes to the next slide. Ends the presentation and returns
false if the current slide is the last one.

nextSlide(options)

Goes to the next slide with options. Please refer to
showSlideAt(index, options) above to see the
properties of options.

previousSlide()

Goes to the previous slide. Returns false if the current slide
is the first one.

previousSlide(options)

Goes to the previous slide with options. Please refer to
showSlideAt(index, options) above to see the
properties of options.
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firstSlide()

Goes to the first slide. If the current slide is already the first
one, replays it from the beginning.

firstSlide(options)

Goes to the previous slide with options. Please refer to
showSlideAt(index, options) above to see the
properties of options.

lastSlide()

Goes to the last slide. If the current slide is already the last
one, replays it from the beginning.

lastSlide(options)

Goes to the last slide with options. Please refer to
showSlideAt(index, options) above to see the
properties of options.

historyBack()

Goes backward in slide navigation history.

historyBack(options)

Goes backward in slide navigation history with options. Please
refer to showSlideAt(index, options) above to see the
properties of options.

historyForward()

Goes forward in slide navigation history.

historyForward(options
)

Goes forward in slide navigation history with options. Please
refer to showSlideAt(index, options) above to see the
properties of options.

time()

Returns the current timestamp of the presentation in
milliseconds.

time(time)

Goes to the specified timestamp (in milliseconds) of the
presentation.

slideTime()

Returns the current timestamp of the current slide in
milliseconds.

slideTime(time)

Goes to the specified timestamp (in milliseconds) of the current
slide.

duration()

Returns the total duration (in milliseconds) of the presentation.

restart(slideIndex,
time)

Restarts the presentation from slide index (starts from 1), at
specified slide timestamp (in milliseconds). All previous results
are cleared.

end()

Ends the presentation.

startTimeline(name,
callback)

Starts the interactive timeline which has the specified name,
and executes the callback (if specified) when the timeline is
complete. Don't use this method for the main timeline.
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pauseTimeline(name,
paused)

Pauses or resumes the interactive timeline which has the
specified name. Don't use this method for the main timeline.

paused()

Returns true of the main timeline is paused, false
otherwise.

pause(paused)

Pauses or resumes the main timeline of the presentation.

speed()

Returns the current playback speed (normal speed value is 1).

speed(speed)

Sets the playback speed. Possible values are 0.5, 1, 1.5, 2.

volume()

Returns the current volume.

volume(volume)

Adjusts the volume of the player (volume value is from 0 to 1).

muted()

Returns true if the presentation is muted, false otherwise.

mute(muted)

Mutes or unmutes the presentation.

closedCaptionVisible()

Returns true if the closed caption is shown, false otherwise.

showClosedCaption(show
)

Shows the closed caption. If show equals true, then show the
closed caption, otherwise hide the closed caption.

tocVisible()

Returns true if the table of contents is shown, false
otherwise.

showToc(isShow)

Shows the table of contents if isShow equals true, otherwise
hide table of contents.

toolbarVisible()

Returns true if the player toolbar is shown, false otherwise.

showToolbar(show)

Shows the player toolbar. If show equals true, then show the
player toolbar, otherwise hide the player toolbar.

showAbout()

Shows the information dialog.

submit()

Submits all interactions in the current slide.

clear()

Clears all user input in the current slide.

interactionCount()

Returns the number of interactions.

takenInteractionCount(
)

Returns the number of taken interactions.

takenSlideCount()

Returns the number of taken slides in the project.
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score()

Returns the total score.

percentageScore()

Returns the score in percentages (0 - 100).

maxScore()

Returns the highest possible score of the presentation.

result()

Returns the result of the quiz as passed or failed (true equals
passed, and false equals failed).

reportData()

Returns the report object (see Report in JSON Format)
section for its properties).

elapsedTime()

Returns the elapsed time in milliseconds since the presentation
started playing.

remainingTime()

If in Tutorial, Practice, or Test mode and Total Max Time is
defined, returns the remaining time in milliseconds till the max
time expires. Otherwise, returns duration() - time().
Gets variable value.

variable(name)

●

name: The string name of the defined variable (“apVersion”,
“apAuthor”, etc.). e.g. to get the presentation’s version, you
can use script variable(“apVersion”).

Sets variable value.
variable(name, value)

●

name: The string name of the defined variable.

●

value: Value of variable, can be a string, number, or
boolean depending on the type of variable.

version()

Returns the version of the application.

author()

Returns the name of the project author.

homePage()

Returns the home page of the project.

copyright()

Returns the copyright information of the project.

name()

Returns the project name.

description()

Returns the project description.

playMode()

Returns the current operation mode of the presentation
('Demo', 'Tutorial', 'Practice' or 'Test').

runAction (name,
paramsData, e)

Runs advanced actions by JavaScript.
●

name: Advanced action name.
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●

paramsData: Json data of parameter in advanced action.

●

e: Event action.

Example:
A method called runAction allows you to run advanced actions by JavaScript. For instance, if
you want to change the state of an object named “Shape_1”, you first create a new state for
the shape. You name it “New State 1”, then create a new advanced action like this:

Then add an “Execute JavaScript” action to the On Click event of that object and write the
following code:
prez.runAction('changestate', {'state': ['Shape_1', 'New State 1'] },
e);
The Object object has the following methods. Note that for text box, both html and text method
set/get text box value as plain text.
Method
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name()

Returns the name of the object.

getTimerValue()

Gets the remaining time of the timer (in milliseconds).

getTimerDuration()

Gets the duration of the timer (in milliseconds).

setTimerValue(val)

Sets the value for the timer (in milliseconds).

visible()

Returns the object’s current visibility state. Note that child
object is actually visible if it is visible() and all its
ancestors are visible().

show()

Shows the object.
Shows the object with effect.
●

show(effectType,
duration, options)

effectType: Use any of the following values. (You need
to add AP.EffectType. prefix for accessing these
values.)
o

FADE_IN

o

FLY_IN

o

PEEK_IN

o

FLOAT_IN

o

WIPE_IN

o

ZOOM_IN

o

GROW_TURN_IN

o

SHAPE_IN

o

SWIVEL_IN

o

BOUNCE_IN

o

EXPAND_IN

o

SPINNER_IN

o

STRETCH_IN

o

COMPRESS_IN

●

duration: In milliseconds.

●

options: AP.EffectDirection or {
direction: AP.EffectDirection,
callback: Optional callback called when effect
completes, callback is bound to the object ('this' is the
object).

}
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AP.EffectDirection: Use any of the following values.
(You need to add AP.EffectDirection. prefix for
accessing these values.)

hide()

o

BOTTOM

o

LEFT

o

RIGHT

o

TOP

o

BOTTOM_LEFT

o

BOTTOM_RIGHT

o

TOP_LEFT

o

TOP_RIGHT

o

IN

o

OUT

o

CLOCKWISE

o

COUNTER_CLOCKWISE

Hides the object.
Hides the object with effect.
●

hide(effectType,
duration, options)

●

effectType: Use any of the following values. (You need
to add AP.EffectType. prefix for accessing these
values.)
o

FADE_OUT

o

FLY_OUT

o

PEEK_OUT

o

FLOAT_OUT

o

WIPE_OUT

o

ZOOM_OUT

o

GROW_TURN_OUT

o

SHAPE_OUT

o

SWIVEL_OUT

o

BOUNCE_OUT

o

CONTRACT_OUT

o

SPINNER_OUT

o

STRETCH_OUT

o

COLLAPSE_OUT

duration: In milliseconds
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●

options: AP.EffectDirection or {
direction: AP.EffectDirection,
callback: Optional callback called when effect
completes, callback is bound to the object ('this' is the
object)

}
See the values of AP.EffectDirection in the description
of the show function.
Animates the object.
●

animate(effectType,
duration, options)

effectType: Use any of the following values. (You need
to add AP.EffectType. prefix for accessing these values.)
o

PULSE

o

TEETER

o

SPIN

●

duration: In milliseconds.

●

options: AP.EffectDirection or {
direction: AP.EffectDirection,
callback: Optional callback called when effect
completes, callback is bound to the object ('this' is the
object).

}
See the values of AP.EffectDirection in the description
of the show function.
html()

html(htmlText)

Returns html text (all variables are replaced by their actual
values before returning).
Sets html text, returns this object.
●

text()

text(plainText)

htmlText: HTML string.

Returns plain text (all variables are replaced by their actual
values before returning).
Sets plain text, returns this object.
●

plainText: Plain text string.

cursor(strCursor)

Sets cursor for object, strCursor is CSS cursor (“busy”,
“crosshair”, “help”, etc.).

left()

Returns the left of the object in pixels.
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left(value)

Sets the left for the object. Value can be pixel number (e.g.
100), or string (e.g. '20%').

top()

Returns the top of the object in pixels.

top(value)

Sets the top for the object, value as left. Value can be pixel
number (e.g. 100), or string (e.g. '20%').

right()

Returns the right of the object in pixels.

right(value)

Sets the right for the object, value as left. Value can be pixel
number (e.g. 100), or string (e.g. '20%').

bottom()

Returns the bottom of the object in pixels.

bottom(value)

Sets the bottom for the object, value as left. Value can be
pixel number (e.g. 100), or string (e.g. '20%').

width()

Returns the width of the object in pixels.

width(w)

Sets the width for the object, value as left. Value can be pixel
number (e.g. 100), or string (e.g. '20%').

height()

Returns the height of the object in pixels.

height(h)

Sets the height for the object, value as left. Value can be pixel
number (e.g. 100), or string (e.g. '20%').

size()

Returns the size of the object in pixels {width, height}.

size(w, h)

Sets the size for the object. w, h can be pixel number (e.g.
100), or string (e.g. '20%').

state()

Returns the name of the current state.

state(stateName)

Changes object state to the state named stateName
Changes fill color of object.

fillSolid(color)

●

rotate()

Returns the current rotation in degrees.

rotate(degree)

Rotates the object, value is number in degrees.

rotateBy(deltaDegree)

Rotates the object by an additional delta in degrees. E.g., if
currently the object rotates by 30 degrees, rotateBy(40)
will make the object rotate by 70 degrees.
●

color: CSS color (e.g. 'red', '#FF0000', 'rgb(255, 0, 0)',
'rgba(255, 0, 0, 0.5)'.

deltaDegree: Number in degree.
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Returns the current translate transform {translateX,
translateY}.
Uses translate transform to move the object from its original
position by an amount of translateX, translateY along
X, Y axis, respectively.
●

translateX, translate are numbers in pixels. Note
that object position returned by left(), top(),
right(), bottom() doesn't change.

Uses translate transform to move the object from its current
position by an amount of deltaX, deltaY along X, Y axis,
respectively.
●

deltaX, deltaY are numbers in pixels. Note that object
position returned by left(), top(), right(),
bottom() doesn't change.

scale()

Returns the current scale {scaleX, scaleY}.

scale(scaleX, scaleY)

Scales object. If scaleY is left out then scaleY equals
scaleX.
●

scaleX, scaleY: Scale value along x, y axis.

scaleBy(multiplierX,
multiplierY)

Scales object by multiple values. If multiplierY is left out,
then multiplierY equals multiplierX. E.g., if current
scale is 2, scaleBy(3) means that scale is 2 x 3 = 6.

transform()

Returns the current transform {translateX,
translateY, scaleX, scaleY, rotate}.
Transforms object by matrix values.

transform(translateX,
translateY, rotate,
scaleX, scaleY)

●

translateX, translate are numbers in pixels. Note
that object position return by left(), top(), right(), bottom()
doesn't change.

●

degree: Number in degree.

●

scaleX, scaleY: Scale value along x, y axis.

disabled()

Returns true if the object is disabled, false otherwise.

disable(disabled)

Disables or enables object. Disabled object can't receive
events. Disabled buttons, radio buttons, and checkboxes
show disabled state.
●

disabled: If true, disables object. Otherwise, enables
object.
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submit()

Submits the interaction object.

clear()

Clears the user input.

score()

Returns the object score.

attempts()

Returns the current attempts.

maxAttempts()

Returns the maximum allowed attempts.
Returns the media player associated with the object. The
media player has the following methods:
nativePlayer(): Returns an HTMLMediaElement if
the object is an audio or video, returns a YT.Player object if
the object is a YouTube object.
state(): Returns either 'playing' or 'stopped'
depending on object animation state. For the actual player
state, you need to get from the native player.

mediaPlayer()

pause(time): Pauses the media at specified time (in
milliseconds). If time is not specified, the media is paused at
the current position.
play(time): Plays the media at specified time
(milliseconds). If time is not specified, the media is played
from the current position.
position(): Returns the current playback position in
milliseconds.
seek(time): Seeks to specified time (in milliseconds)
volume(vol): Sets the volume for media object, the
value is in the range [0..1]
muted(muted): Mutes or unmutes the media object.

The Player object (AtomiAP) is a global object which has the following methods:
Method

Description
Returns the new presentation object or null if browser isn't
supported.

open(prezUrl,
containerId, options)

●

prezUrl: The URL of the presentation.

●

containerId: The ID of the presentation’s container.

●

options: Can be omitted. Available options are
playMode: 'Demo', 'Tutorial', 'Practice', or 'Test', etc.
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Closes the presentation object.

close(prez)

●

prez: The presentation to close.

Finds the presentation object from container id.

find(containerId)

●

containerId: The ID of the presentation’s container.

Example:
If you want to set text for an object which has the name “object1”, you can add an “Execute
JavaScript” action and write below code:
var obj = prez.object("object1");
if (obj) {
obj.text(“the text you want to set”);
}

Note: When you need to access the Player object inside a project, you should use the AP object
(which has the same scope as prez) instead of AtomiAP.
Differences between version 6 and version 7, version 8, version 9 APIs:
Object

Prez

Slide

Version 6

Version 7, 8, and 9

Prez: presentation object.

prez: presentation object.

ShowSlide(index)

showSlideAt(index)

ShowNextSlide()

nextSlide()

ShowPreviousSlide()

previousSlide()

ShowPreviousVisitedSlide()

historyBack()

ShowNextVisitedSlide()

historyForward()

GetSlide()

currentSlide()

GetObject(objectName)

object(objectName)

GetObject(objectName)

Access from prez object instead

SetText(htmlText)

html(htmlText)
●

Object

GetText(plaintext)

plaintext equal true:

text()
●

plaintext equal false:

html()
Show(show)

●

show equal true:
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show()
●

show equal false:
hide()

IsShown()

visible()

Using two functions to replace:
GetPosition()

●

top()

●

left()

Using two functions to replace:
SetPosition(x, y)

●

top(x)

●

left(y)
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Exporting Projects
ActivePresenter allows you to export the presentation to many different formats, as described below:
Format

Description

Images

Export slides as images that can be used for purposes related to the
presentation/training course. Each slide will be exported as an image.

Video

Export the presentation to a video. Use the video format when the
interaction with audience isn’t required.

PDF Document

Export slides as images and embed them in the PDF format.

Microsoft Word

Export slides to shapes, text, and images, and insert them in a *.doc/docx
file. After that, this file can be edited further in Microsoft Word (or
LibreOffice Writer).

Microsoft Excel

Export slides to shapes, text, and images, and insert them in an *.xls/xlsx
file. After that, this file can be edited further in Microsoft PowerPoint (or
LibreOffice Calc).

Microsoft
PowerPoint

Convert slides into PowerPoint slides. After that, this file can be edited
further in Microsoft PowerPoint (or LibreOffice Impress).

HTML5

Export the presentation to a set of files (HTML, CSS, JavaScript, etc.)
using the HTML5 standard so it can run on most modern browsers (Google
Chrome, Mozilla Firefox, Safari), and on various devices and platforms
(Windows, macOS, Linux, iOS, Android).

SCORM

Export your project to SCORM package (SCORM 1.2 or SCORM 2004) for
uploading to LMS.

Experience API

Export your project to Experience API package for uploading to LMS.

LMS

Publish your course with SCORM 2004 format directly to a learning
management system (LMS) where you can track your quiz takers’ results.

Exporting to Images
When you choose to export a project to images, each slide of the project will be exported as an
image, which is great for creating brochures, handouts, and posters for the training.
To export the project to images, click the Export tab > Images
display the following dialog:

Exporting Projects > Exporting to Images
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Option

Description
Rendering Options

Include Closed
Caption

Export images along with closed captions (if any).

Include Cursor Path

Export images along with cursor path (if any).

Embed in HTML
SlideShow

The slides will be exported and embedded in HTML SlideShow.

Include Objects
Started by Event

Export images along with objects that are triggered by events.

Only Export Active
Window Area

The exported images only include the active window area and slide
objects that are selected to export.
Image

Format

Select either PNG or JPEG. JPEG compression is lossy while PNG is
lossless. PNG retains crystal clear quality, but it doesn’t compress well
with pictures (very big file size) and its decoding (when viewing) is
slower than JPEG’s.
Thus, JPEG is best suited for pictures while PNG is best suited for
computer-generated images (screenshots, drawings, etc.).
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Size

Image size is relative to the slide size.

Optimization Level

Applicable to the PNG format only. This option specifies a relative
compression level (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it
takes to export.

Quality

Applicable to the JPEG format only. Use this opiton to adjust the quality
of images in a range of 1 - 100%.
Output

Location

Specify the location where the exported images will be saved.

Exporting to Videos
This feature allows you to convert your project to one of the most common video formats such as
MP4, AVI, WMV, WEBM, and MKV with all the animations, closed captions, and audio files you
have inserted in. You can save the video on your computer or share it with others.
To export the project to a video, click the Export tab > Video
allowing you to specify export options.

Exporting Projects > Exporting to Videos

. The following dialog will appear,
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General Tab

Option

Description
Rendering Options

Include Zoom-n-Pan

The exported video will include the zoom-n-pan effect that you have
inserted in the project.

Include Cursor Path

The exported video will include the cursor path that you have inserted
in the project.

Export Audio

Selected by default. Clear this checkbox if you want to remove audio
from the output.

Selected Slides

The project will export the selected slides to video.
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Export Closed
Captions as Soft
Subtitles

Select to export closed captions as two separate subtitle files (*.srt and
*.vtt).

Export Closed
Caption as Hard
Subtitles

Select to hard-code closed captions in the video. Any video player which
can play the video can also display CC. However, the attributes of the
subtitles cannot be changed at the play time.

Embed in HTML

The project will be exported and embedded in an HTML file. This allows
viewing the video by using browsers. However, not every browser can
display these formats. You can check the supported browsers for HTML5
video formats at HTML5 video - Wikipedia. The MP4 (AAC, H.264)
format is widely supported than others.
Video

Video Size (%)

Video size is relative to the slide size. If you change the video size, it
will be scaled using bicubic interpolation.

Width

The width of exported video. When you specify the video size or height,
the width will be automatically calculated based on the original size of
project. Note that the aspect ratio cannot be changed.

Height

The height of exported video. When you specify the video size or width,
the height will be automatically calculated based on the original size of
project. Note that the aspect ratio cannot be changed.

Frame Rate

Set between 1 and 60 fps (frames per second).

Quality

Select in the range [1,100]. The higher number, the better quality and
larger file size. Applicable to all formats except MKV (FSV1, PCM 16-bit)
format.
Audio

Channels

Select either Stereo or Mono.

Sample Rate

Select from 11025, 22050, 44100, and 48000 Hz. The higher the sample
rate, the better the audio quality.

Quality

Select in the range [1,100]. The higher number, the better quality and
larger file size. Applicable to MP4 (H.264, AAC), MP4 (HEVC, AAC),
WEBM (VP8, Vorbis), and WEBM (VP9, Vorbis) formats.

Bit Rate

Select from 64, 96, 128, 192, 256, 320 Kbps. The higher the bit, the
better the audio quality and larger file size. Applicable to AVI (MPEG-4,
WMA2) and WMV (WMV2, WMA2) formats.
Output

Exporting Projects > Exporting to Videos
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Select from MP4, WEBM, MKV, AVI, and WMV. The following video
and audio codecs are used for each container format:

Format

Output File

●

MP4: H.264, AAC

●

MP4: HEVC, ACC (On Windows, this option is only available for
systems that have AMD or NVIDIA graphics cards but not all
models of graphics cards are supported.)

●

WEBM: VP8, Vorbis

●

WEBM: VP9, Vorbis

●

MKV: FSV1, PCM 16-bit (this format uses lossless audio and video
codecs so it can be used for further editing in other programs
without quality loss)

●

AVI: MPEG-4, WMA2

●

WMV: WMV2, WMA2

Specify the file path and name of the exported video.

Advanced Tab
This tab allows you to set the thumbnail for the exported video when you choose to embed it in
HTML. The following video formats are supported to embed in HTML: MP4 (H.264, AAC), MP4
(HEVC, AAC), WEBM (VP8, Vorbis), and WEBM (VP9, Vorbis).
Option

Description

None

The exported video doesn’t have any thumbnail.

Select a slide image
from project

Select one slide from the project to set as a thumbnail for the exported
video.

Select an image
from file

Select one image from your computer to set as a thumbnail for the
exported video.

From version 9, ActivePresenter allows you to export one or multiple selected slides to video. To
do that, you right-click a slide on the Canvas or in the Slides pane > Save Slide As Video/Save
Selected Slides As Video. After that, you can adjust the output options in the Export To Video
dialog.

Exporting to PDF Documents
When exporting a project to PDF document, ActivePresenter will export slides as images and
embed into PDF files afterward. For this reason, you cannot edit slide objects anymore.
To export the project to Adobe PDF Document, click the Export tab > PDF Document
dialog that appears, there are three tabs which are described in detail in the next parts.

. In the
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General Tab

Option

Description
Rendering Options

Include Objects
Started by Event

The exported file will include objects which are started by events.

Create Bookmarks

Bookmarks are created from slide names and each bookmark is
linked to a corresponding slide image. In other words,
ActivePresenter creates bookmark links to each slide.

Hide Correct Answers
in Questions

The exported file will not show correct answers in questions.

Only Export Active
Window Area

The exported area only includes the active window area and slide
objects which are selected to export.

Include Main Page

The exported file will include a page which has a brief description of
a project such as project name and author.
Layout

Exporting Projects > Exporting to PDF Documents
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Slides Per Page

Specify the number of slides in one page: one (single slide per
page), two (two slides per page (top, bottom)), or contiguous (the
slides are written contiguously in a page until there isn’t enough
space, then it will be moved to the next page).

Page Orientation

Choose from landscape and portrait. The page size is fixed (A4).
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides.

Description

Export slide description and specify which side of the slide to place it
(top, left, right, or bottom). Select None to disable this option.
Image

Format

Select either PNG or JPEG. JPEG compression is lossy while PNG
is lossless. PNG retains crystal clear quality, but it doesn’t compress
well with pictures (very big file size) and its decoding (when viewing)
is slower than JPEG’s.
Thus, JPEG is best suited for pictures while PNG is best suited for
computer-generated images (screenshots, drawings, etc.).

Optimization Level

Applicable to the PNG format only. This option specifies a relative
compression level (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it
takes to export.

Quality

Applicable to the JPEG format only. Use this option to adjust the
quality of images in a range of 1 – 100%.
Output

Output File

Specify the file path and name of the exported document.

Advanced Tab
Option

Description

Description: PDF document-related options.
Title

Title of the PDF document. When you open the PDF in a viewer, the
title appears in the windows bar (or in the tab in the case of a tabbed
PDF reader).

Subject

Subject of the document. This is one of PDF document properties
which can be seen in Document Properties in any PDF viewer.

Keywords

Keywords defined in the PDF document.

Protection: Security password for opening the PDF document.

Exporting Projects > Exporting to PDF Documents
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Opening Password

You can set a password for opening this PDF document.

Confirm Password

Enter the password again manually (no copy-paste from the previous
field).

Slide Name: The name of the slide which is entered in the Properties pane > Slide
Properties > General > Name.
Font Size

Font size of the slide name.

Line Spacing

Space between lines of the slide name.

Text Color

Text color of the slide name.

Slide Description: The description of the slide which is entered in the Properties pane >
Slide Properties > General > Description.
Font size

Font size of the slide description.

Line Spacing

Space between lines of the slide description.

Text Color

Text Color of the slide description.

Exporting to Microsoft Word Documents
Exporting projects to Microsoft Word Documents allows you to convert slides into Word pages.
Please be noted that only static objects should be converted using this feature as it will remove
all the effects, for example, transform a video into an image.
To export the project to Word Document, click the Export tab > Microsoft Word

.

Note: When you export the project to document formats (Microsoft Excel, Microsoft Word, and
Microsoft PowerPoint), the slide name and slide description are included in the output with the
default text style (font, size, color, etc.). However, if you format the text before exporting,
ActivePresenter will export them with the customizations you made.

Exporting Projects > Exporting to Microsoft Word Documents
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Option

Description
Rendering Options

Include Objects
Started by Event

The exported file will include objects which are started by events.

Create Table of
Contents

Add a table of contents to the document with hyperlinks to slides.

Only Export Active
Window Area

The exported area only includes the active window area and slide
objects which are selected to export.

Include Main Page

The exported file will include a page which has a brief description of a
project such as project name and author.
Layout

Slides Per Page

Specify the number of slides in one page: one (single slide per page),
two (two slides per page (top, bottom)), or contiguous (the slides are
written contiguously in a page until there isn’t enough space, then it will
be moved to the next page).

Exporting Projects > Exporting to Microsoft Word Documents
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Page Orientation

Choose from landscape and portrait. The page size is fixed (A4).
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides.

Description

Export slide description and specify which side of the slide to place it
(top, left, right, or bottom). Select None to disable this option.

Use Template
Layout

Use the layout specified in the template. See Creating Custom Word
Template to learn more about how to create a custom layout.
Image

Format

Select either PNG or JPEG. JPEG compression is lossy while PNG is
lossless. PNG retains crystal clear quality, but it doesn’t compress well
with pictures (very big file size) and its decoding (when viewing) is
slower than JPEG’s.
Thus, JPEG is best suited for pictures while PNG is best suited for
computer-generated images (screenshots, drawings, etc.).

Optimization Level

Applicable to the PNG format only. This option specifies a relative
compression level (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it
takes to export.

Quality

Applicable to the JPEG format only. Use this option to adjust the quality
of images in a range of 1 – 100%.
Output

Template

Specify the location of the template file.

Output File

Specify the file path and name of the exported document.

Creating Custom Word Template
When exporting to MS Word Document, you can create your own Word template and let
ActivePresenter use it to create the output document.
To create a custom layout template, you must have Word 2003 (Word XP) or a higher version
installed on your computer. The steps are as follows:
Step 1. Create a Word Template.
You will use the 3 following tags to place contents in a Word document including slide name, slide
description, and slide image.
●

$SlideName1

●

$SlideDescription1

●

$SlideImage1

For slide name and slide description, you can type $SlideName1 and $SlideDescription1
anywhere you want to place them in the template.
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For slide image, it’s a little different. This is used to specify the location of the slide content (slide
background, shapes, captions, text, etc.). You need to insert a Word Drawing Canvas and set its
Alternative Text to $SlideImage1 as follows:
Insert > Shapes > New Drawing Canvas > right-click it and choose Format Drawing Canvas.
In the Layout & Properties tab > Type $SlideImage1 into the Alt Text section.
Step 2. Style contents.
To set styles (font name, font size, color, etc.) for Slide Name, Slide Description, you cannot set
text properties directly to the tags. You need to open the Styles pane and add new styles and
name to them as: SlideName and SlideDescription. ActivePresenter will automatically use these
styles when writing Slide Name and Slide Description text.
Step 3. Save the word template you have created above as a template (.dotx).
Step 4. Export your project to Word (Export tab > Microsoft Word).
Step 5. In the dialog appearing, check Use Template Layout in the Layout section and open the
template path in the Output section.
Step 6. Click OK to start exporting your project to Microsoft Word using the template you created.
After exporting, you can also change these styles easily by opening exported document and
changing appropriate styles.

Exporting to Microsoft Excel Worksheets
This feature allows you to export slides to shapes, text, and images, and insert them in an
*.xls/xlsx file. After that, this file can be edited further in Microsoft PowerPoint (or LibreOffice Calc).
To export the project to Excel Worksheet, click the Export tab > Microsoft Excel
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Option

Description
Rendering Options

Include Objects
Started by Event

The exported file will include objects which are started by events.

Only Export Active
Window Area

The exported area only includes the active window area and slide
objects which are selected to export.
Layout

Slides Per Page

Specify the number of slides in one page: one (single slide per page),
two (two slides per page (top, bottom)), or contiguous (the slides are
written contiguously in a page until there isn’t enough space, then it
will be moved to the next page).

Page Orientation

Choose from landscape and portrait. The page size is fixed (A4).
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides.

Description

Export slide description and specify which side of the slide to place it
(top, left, right, or bottom). Select None to disable this option.
Image
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Select either PNG or JPEG. JPEG compression is lossy while PNG is
lossless. PNG retains crystal clear quality, but it doesn’t compress well
with pictures (very big file size) and its decoding (when viewing) is
slower than JPEG’s.
Thus, JPEG is best suited for pictures while PNG is best suited for
computer-generated images (screenshots, drawings, etc.).

Optimization Level

Quality

Applicable to the PNG format only. This option specifies a relative
compression level (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it
takes to export.
Applicable to the JPEG format only. Use this option to adjust the
quality of images in a range of 1 – 100%.
Output

Template

Specify the location of the template file.

Output File

Specify the file path and name of the exported document.

Exporting to Microsoft PowerPoint Presentations
Using this feature, you are allowed to convert ActivePresenter slides into PowerPoint slides. After
that, this file can be edited further in Microsoft PowerPoint (or LibreOffice Impress). After
converting, charts, tables, 3D models will be converted into images.
To export the project to PowerPoint Presentation, access the Export tab > Microsoft PowerPoint
.
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Option

Description
Rendering Options

Include Objects
Started by Event

The exported file will include objects which are started by events.

Only Export Active
Window Area

The exported area only includes the active window area and slide
objects which are selected to export.
Layout

Show Slide Name

Display the slide name.

Show Slide
Description

Render the slide description.

Full Screen

Open the presentation in full screen initially.
Image

Format

Select either PNG or JPEG. JPEG compression is lossy while PNG is
lossless. PNG retains crystal clear quality, but it doesn’t compress well
with pictures (very big file size) and its decoding (when viewing) is
slower than JPEG’s.
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Thus, JPEG is best suited for pictures while PNG is best suited for
computer-generated images (screenshots, drawings, etc.).

Optimization Level

Applicable to the PNG format only. This option specifies a relative
compression level (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it
takes to export.

Quality

Applicable to the JPEG format only. Use this option to adjust the
quality of images in a range of 1 – 100%.
Output

Template

Specify the location of the template file.

Output File

Specify the file path and name of the exported document.

Exporting to HTML5
The HTML5 output uses the HTML5 standards that allow learners to view and interact with the
content on the World Wide Web. Export your project to HTML5 once you have done editing it.
To export the project to HTML5, access the Export tab > HTML5
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General Tab

Option

Description
Operation Modes

Modes

Select which operation modes (Demonstration, Tutorial, Practice, and
Test) to be exported and available to users.

Generate Index
Page

Generate the HTML index page which contains the entry to open all the
selected modes.

Generate Zip

Export the project and compress it as a zip file automatically.
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Applicable to the Tutorial, Practice, and Test mode. Set a time limit (in
minutes) on an entire project. This is the total amount of time required for
users to complete the project.
Determine the overall pass/fail result of users when they take a test.
Choose between the following options: percent of correct answers,
points gained, number of correct answers, and number of slides viewed.

Pass Condition

Due to SCORM specifications, take the following notes when the
SCORM option is selected:
●

In SCORM 1.2, the raw score submitted to LMS is a normalized
value in the range [0, 100].

●

In SCORM 2004, the raw score submitted to LMS is a normalized
value in the range [0, 100] if the first condition (percent of correct
answers) is chosen. Otherwise, it is an absolute value.
Content

The following options are applicable to slide background images, audio, and text. Regarding
multi-state objects, the object state will be retained when users move between slides. For
example, users finish one slide with a button in the Pressed state and move to the next slide.
When they go back to this slide, the button is still in the Pressed state.
Include WebM &
Ogg

Allow viewing HTML5 content on browsers that don’t support MP4 and
MP3 but support WebM and Ogg.

Enable Visual Focus
Indicator

Display an outline around the object having focus.

Disable [Click or
Tap to Unmute]
Notification

Some browsers don’t allow content containing audio that plays
automatically without user interaction. In that case, the HTML5 player
will mute audio to enable autoplay.
The player will display a message to notify users to click to unmute
audio. Select this checkbox to hide the message.

Embed Fonts

Embed fonts that are used in content into output using CSS3 Web Fonts
Specification. This makes the content look consistent across platforms
and devices. Click the Details button to select the fonts to embed.

JPEG Quality (%)

Applicable to JPEG format only. This option specifies the quality of the
images that are exported to JPEG format. The higher the quality, the
larger the output file size.

PNG Optimization

Applicable to PNG format only. This option specifies the relative
compression levels (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it takes
to export.
Images at 100% JPEG Quality and None PNG Optimization have no
loss, which means images will not be recompressed. You can also
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change these specifications for each image by right-clicking the image in
the Resources pane then choosing Recompress.
Audio Quality (%)

Specify the quality of audio in the output. The higher value, the higher
the audio quality and the larger the output file size.

Video Quality (%)

Specify quality for videos in the output. The higher value, the higher the
video quality and the larger the output file size.
Output

Location

Specify the location where the output will be saved.

Click the Setting button to open the following dialog and specify further output options:

●

Project ID: An identifier for each project. This will be used to identify different projects if
multiple projects are embedded within the same page.

●

Player: Location for storing HTML5 player script and CSS files.

●

Project Resources: Location for storing project images, audio, and video

●

Index Resources: Location for storing index page images.

●

File Name Prefix: File names of project-related files such as resources and project CSS and
JavaScript files will begin with this prefix. This option may be used in the scenario that the
system needs to put files of multiple projects into one folder.

●

Restore Defaults: Discard all changes and go back to the default settings.

Operation Modes
ActivePresenter allows you to run interactive presentations in four operation modes:
Demonstration, Tutorial, Practice, and Test. These modes are useful when you create HTML5
content such as interactive software simulations and quizzes.
● Demonstration: In this mode, the task will be shown as a demonstration for learners. Learners
are not supposed to interact with the content but only to view it.
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● Tutorial: This mode allows learners to try the steps with hint messages and annotations
provided to each one.
● Practice and Test: Learners have a chance to try the task themselves to see how well they
understand it. There will be no hint message or annotation in these modes. The only difference
between these two modes is that interactions (Mouse Click, Key Stroke, and Drop Area) will only
appear in the Practice mode if learners perform the steps incorrectly.
Overall, the Demonstration mode is most different from the others. In this mode, the content will
be shown as a demonstration, hence, learners will not be able to interact with it. The content is
just paused or resumed if they click it. Meanwhile, in the other modes (Tutorial, Practice, and
Test), learners can interact with the content.
In ActivePresenter, the Show In Mode section is set reasonably in most cases. For example,
cursor paths only appear in the Demonstration mode by default. If you want to change these
modes, you can change the default Show in Mode options of each object in the Properties pane.
The table below shows the difference between the four operation modes:
Function

Demonstration
Mode

Tutorial
Mode

Practice
Mode

Test
Mode

The simulation automatically runs
based on the time you have set
for objects and slides.
The presentation jumps to the
next slide when the current slide
comes to the end.
If the toolbar is available, users
can control the presentation such
as navigate to a certain slide,
pause/resume the simulation.
The simulation supports
interactive capability through
mouse and keyboard.
ActivePresenter assesses user
response and executes
associated actions which you
have defined before.
It has options to create a report of
user results and send them to a
specified HTTP address.
The simulation displays interactive
hidden objects when users fail to
execute associated actions in a
predefined time.

N/A

The authors can limit the
maximum time in which users are
allowed to complete the test.
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To preview the content in one of four operation modes, click the drop-down arrow on the HTML5
Preview button. Then select one mode out of the two available categories: Preview Project and
Preview Current Slide. After that, the content will be previewed in a browser with selected
HTML5 Settings. Depend on each preview mode, learners can interact with the Player including
the Table of Content (TOC) and the toolbar which holds many navigation buttons.

Reporting Tab
Navigate to the Reporting tab of the Export To HTML5 dialog. This reporting tab helps you to
track user activities. These methods are useful when you use some alternatives to deliver and
track your course, such as Google Sheets. The report is in either XML or JSON (JavaScript Object
Notation) format.

Option

Description
Choose between the following options:

Method

●

No Report: Do not send the report.

●

HTTP: Send a report through the HTTP request.

Format

Choose between XML and JSON (JavaScript Object Notation).

HTTP Address

This is the HTTP address of a server-side script that will process the
report data (the data is in either XML or JSON format).
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Content of Report
The report can be formatted in various ways but the content generally consists of the following:
Property

Description

Name

Presentation name (also the project name).

Description

Presentation description (also the project description).

Date

The local time (based on the user computer date and time setting) when
the report is created.

UserID

Identity of the user who takes the practice or test. When the user logs in
to take the test, the server-side script should store a cookie whose name
is "userid". If no "userid" cookie is found, the user will be prompted to
input his/her identity before sending the report.

TotalTime

Duration in seconds in which users take the practice or test.

SlideCount

The number of slides in the presentation.

TakenSlide

The number of slides that the user has taken.

TotalInteraction

The number of interactions in the presentation.

TakenInteraction

The number of interactions that the user has taken.

Correct

The number of interactions that users perform correctly without any help.

Score

Score (marks) users gain through the practice or test, only correct action
gains points.

MaxScore

The maximum score that users can gain in the Practice or Test (by
taking correctly all slides).

Percent

Score over MaxScore in percentages (Score/MaxScore*100).
The practice or test assessment is based on the pass condition.

Result

●

For human-readable: Passed or failed

●

For computer: True or false

Users pass the Practice or Test if their results are greater than or equal
to the minimum required result. The result can be points that users gain
and are displayed in percentages or the number of correct answers.
Details

Detail result for each slide and interaction is called the interaction data
record.

The Details section of the report data contains an array of the interaction data record. Each
interaction data record contains the following information:
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Description

SlideIndex

The index of the slide which contains the interaction (starting from 1).

ReportID

The ReportID of the interaction.

Attempts

The number of actions that users have tried.

Score

Score gained when users interact with interactions.

MaxScore

The maximum score that users can get when interacting with interactions.
A string shows in the output language of the presentation. It can be one of
the following values:

Result

●

Correct

●

Incorrect

●

Incomplete

●

(Empty)

Type of the interaction represented in the output language of the
presentation. There are the following interaction types:

Type

●

Mouse Click

●

Key Stroke

●

Text Entry

●

Drop Area

●

Dropdown

●

True/False

●

Multiple Choice

●

Multiple Response

●

Fill in Text Entry

●

Fill in Text Entries

●

Fill in Blanks

●

Sequence

●

Drag-n-Drop

●

Hotspot

●

Essay

●

Select in Dropdown

●

Select in Dropdowns
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Rating Scale (Likert)

Users’ responses.
Some examples for each interaction type:
●

●

●

Mouse Click:
○

Left-click

○

Click outside

○

Right-click

○

Left double-click

Key Stroke:
○

A

○

Ctrl+A

○

Ctrl+Shift+Alt+A

Text Entry:
○

●

Drop Area:
○

●

LearnerResponse

Answer1_report_id[.]text_value1[,]Answer2_report_id[.]text_value2
[,]Answer3_report_id[.]text_value3

Fill in Blanks:
○

●

This is a sample text

Fill in Text Entries:
○

●

Answer1_report_id[,]Answer2_report_id

Fill in Text Entry:
○

●

Answer1_report_id

Multiple Response:
○

●

Answer1_report_id

Multiple Choice:
○

●

This is a sample text

True/False:
○

●

Drop_area_report_id[.]Draggable_report_id

Dropdown:
○

●

This is a sample text

Answer1_report_id[.]text_value1[,]Answer2_report_id[.]text_value2
[,]Answer3_report_id[.]text_value3

Sequence:
○

Answer1_report_id[,]Answer2_report_id[,]Answer3_report_id[,]Ans
wer4_report_id
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Drag-n-Drop:
○

●

Answer1_report_id[.]text_value1[,]Answer2_report_id[.]text_value2
[,]Answer3_report_id[.]text_value3

Rating Scale (Likert):
○

CorrectResponses

This is a sample text

Select in Dropdowns:
○

●

This is a sample text

Select in Dropdown:
○

●

Answer1_report_id[.](% position)[,]Answer2_report_id[.](% position)

Essay:
○

●

Droppable1_report_id[.]Draggable1_report_id[,]Droppable2_report
_id[.]Draggable2_report_id[,]

Hotspot:
○

●
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Answer1_report_id[.]0[,]Answer2_report_id[.]5

An array of correct responses. The format of a correct response is similar
to the format of a learner response.

Report in XML Format
The report is formatted in XML (Extensible Markup Language) format. Here is an example:
<?xml version="1.0" encoding="UTF-8"?>
<Content>
<Report>
<Name>Quiz Sample</Name>
<Description></Description>
<Date>Tue, 10 May 2016 04:15:58 GMT</Date>
<UserID>apteam</UserID>
<TotalTime>96</TotalTime>
<SlideCount>2</SlideCount>
<TakenSlide>2</TakenSlide>
<TotalInteraction>2</TotalInteraction>
<TakenInteraction>2</TakenInteraction>
<Correct>2</Correct>
<Score>2</Score>
<MaxScore>2</MaxScore>
<Percent>100</Percent>
<Result>Passed</Result>
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<Details>
<Interaction>
<SlideIndex>1</SlideIndex>
<ReportID>MouseClick1</ReportID>
<Attempts>2</Attempts>
<Score>1</Score>
<MaxScore>1</MaxScore>
<Result>Correct</Result>
<Type>Mouse Click</Type>
<Answers>Left click</Answers>
<LearnerResponse>Left click</LearnerResponse>
<CorrectResponses>
<CorrectResponse>Left click</CorrectResponse>
</CorrectResponses>
</Interaction>
<Interaction>
<SlideIndex>2</SlideIndex>
<ReportID>KeyStroke1</ReportID>
<Attempts>1</Attempts>
<Points>1</Points>
<MaxPoints>1</MaxPoints>
<Result>Correct</Result>
<Type>Key Stroke</Type>
<Answers>Space</Answers>
<LearnerResponse>Space</LearnerResponse>
<CorrectResponses>
<CorrectResponse>Space</CorrectResponse>
</CorrectResponses>
</Interaction>
</Details>
</Report>
</Content>

Report in JSON Format
The report is formatted in JSON (JavaScript Object Notation) format. Here is an example:
{
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"Name": "Quiz Sample",
"Description": "",
"Date": "Tue, 10 May 2016 04:32:36 GMT",
"UserID": "apteam",
"TotalTime": 79,
"SlideCount": 2,
"TakenSlide": 2,
"TotalInteraction": 2,
"TakenInteraction": 2,
"Correct": 2,
"Score": 2,
"MaxScore": 2,
"Percent": 100,
"Result": true,
"Details": [
{
"SlideIndex": 1,
"ReportID": "Question_5",
"Attempts": 1,
"Score": 1,
"MaxScore": 1,
"Result": "Correct",
"Type": "Fill Multiple Blank",
"Answers": "1.quick, 2.jumps, 3.dog",
"LearnerResponse": "1[.]quick[,]2[.]jumps[,]3[.]dog",
"CorrectResponses": [
"1[.]quick[,]2[.]jumps[,]3[.]dog"
]
},
{
"SlideIndex": 2,
"ReportID": "Question_6",
"Attempts": 1,
"Points": 1,
"MaxPoints": 1,
"Result": "Correct",
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"Type": "Sequence",
"Answers": "1, 2, 3, 4, 5, 6, 7",
"LearnerResponse": "1[,]2[,]3[,]4[,]5[,]6[,]7",
"CorrectResponses": [
"1[,]2[,]3[,]4[,]5[,]6[,]7"
]
}
]
}

Transmission of Report
When the report is sent via the HTTP protocol, the POST method will be used. The key is “report”
and the value is the report content with the format specified when exporting to HTML5
presentation.
The server-side script at the HTTP address must handle and process the report. For example,
suppose that the HTTP address is
"http://atomisystems.com/reportreceiver.php".
The following is a trivial sample code in reportreceiver.php file to receive and process report:
<?php
if (isset($_POST["report"]))
{
//read report data
$report = $_POST["report"];
//process report, e.g. append to a text file here
$report_file = fopen("report.txt", "a");
if($report_file)
{
fwrite($report_file, $report);
//separate this report from others
fwrite($report_file,"\n\n---------\n\n");
fclose($report_file);
}
}
?>

In case you want to send the report data to a Google Sheets document or an email, refer to this
tutorial for more details.
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Exporting to SCORM
Apart from Export To HTML5, you can also export your project to a SCORM package to publish
your course to any LMS that supports this standard.
To export the project to SCORM, access the Export tab > SCORM

.

General Tab
The General tab of the Export To SCORM dialog is the same as that of the Export To HTML5
dialog. The only difference is that it does not have the Generate Index Page option.

eLearning Tab
Navigate to the eLearning tab of the Export To SCORM dialog.
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The SCORM Options section allows you to package the content to one of the following standards
for uploading to LMS: SCORM 1.2 or SCORM 2004.
ActivePresenter stores the value of a variable in suspend data on the LMS. The LMS will resume
from the point where users left, allowing you to restore variables when users relaunched the
course on the LMS.
Option

Description
SCORM 1.2 and SCORM 2004

Identifier

Specify a name used by the LMS to identify different manifests (this value
is generated automatically by ActivePresenter but you can change it if
needed).

Version

Specify a version that can be used to differentiate manifests with the same
identifier.
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Organization Title

Specify a title for the organization to which this item belongs. Although
ActivePresenter automatically generates this value from the project name,
you can change it if needed.

Item Title

The title of your project is displayed to users viewing the project using an
LMS. Although ActivePresenter automatically generates this value from
the project name, you can still change it if needed.

Report the score in
percentage

Normalize the score in the range 1-100 instead of an absolute value. This
option is only available in SCORM 2004. The score in SCORM 1.2 is
always normalized.

Export each
operation mode to a
separated package

Export each operation mode to a separated package instead of exporting
all operation modes to one package with multiple organizations.

Additional Report
Besides SCORM reporting, you can use additional methods to track user activities. These
methods are useful when you use some alternatives to deliver and track your course, such as
Google Sheets. The report is in either XML or JSON (JavaScript Object Notation) format. In fact,
you can use both SCORM reporting and these additional methods at the same time if you need.
To enable additional reporting, in the Export To SCORM dialog, switch to the eLearning tab >
Additional Report > Method. For more information, you can refer to the Reporting tab of the
Export to HTML5 section.

Exporting to Experience API
Another LMS standard that you can choose to export your project to is Experience API. You can
then publish your xAPI package to any LMS that supports this standard.
To export the project to Experience API, access the Export tab > Experience API

.

General Tab
The General tab of the Export To Experience API dialog is the same as that of the Export To
HTML5 dialog. The only difference is that it does not have the Generate Index Page option.
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eLearning Tab
Navigate to the eLearning tab of the Export To Experience API dialog.
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The Experience API Options section allows you to package the content to the Experience API
standard for uploading to LMS.
ActivePresenter stores the value of a variable in suspend data on the LMS. The LMS will resume
from the point where users left, allowing you to restore variables when users relaunched the
course on the LMS.
Option

Description
Experience API (xAPI)

Identifier

Specify a name used by the LMS to identify different manifests. This value
is generated automatically by ActivePresenter but you can change it if
needed.

Title

The title of your project is displayed to users viewing the project using an
LMS. ActivePresenter automatically generates this value from the project
name but you can change it if needed.
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The description of your project is displayed to users viewing the project
using an LMS. ActivePresenter automatically generates this value from
the project description but you can change it if needed.

Additional Report
Besides API reporting, you can use additional methods to track user activities. These methods
are useful when you use some alternatives to deliver and track your course, such as Google
Sheets. The report is in either XML or JSON (JavaScript Object Notation) format. In fact, you can
use both API reporting and these additional methods at the same time if you need.
To enable additional reporting, in the Export To Experience API dialog, switch to the eLearning
tab > Additional Report > Method. For more information, you can refer to the Reporting tab of
the Export to HTML5 section.

Publish to LMS
With the Publish to LMS option, you can upload your course directly to ActivePresenter Online
(https://activepresenter.online/). This is a learning management system that allows educators
to publish and share online courses with a focus on interaction and the ability to track the quiz
takers’ results.
To publish a project to LMS, click the Export tab > Publish LMS

.

LMS Tab
LMS Tab allows you to set information and publish the course with SCORM 2004 standards
directly to the LMS site where learners can access and interact with the course content. You need
to sign up for an account to publish it on this site.
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Once you have signed in for the ActivePresenter Online site, a dialog with course details will
appear like this:
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Description
Course Info

Action

Select one option (New course, Update lesson in existing course,
Add lesson to existing course) to publish your course.

Course Category

Choose one subject that your course will be categorized from the list.

Course Full Name

Put in the full name of your course here. It is displayed at the top of
each course page and in the list of courses.

Course Short Name

Put in the short name of your course here. It is displayed in the
navigation and the subject line of course email messages.
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Topic

Type the topic of your course.

Lesson Name

Type the lesson name.

Make this course
accessible to
everyone

Tick this checkbox to allow everyone to access the course without
logging in. If the checkbox is not selected, only learners that are
enrolling in or invited to the course can access it.

Options Tab

Option

Description
Operation Modes

Modes

Select which operation modes (Demonstration, Tutorial, Practice, and
Test) to be exported and available to users.
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Applicable to the Tutorial, Practice, and Test mode. Set a time limit (in
minutes) on an entire project. This is the total amount of time required for
users to complete the project.
Determine the overall pass/fail result of users when they take a test.
Choose between the following options: Percent of correct answers,
Points gained, Number of correct answers, and Number of slides
viewed.

Pass Condition

Due to SCORM specifications, take the following notes when the
SCORM option is selected:
●

In SCORM 1.2, the raw score submitted to LMS is a normalized
value in the range [0, 100].

●

In SCORM 2004, the raw score submitted to LMS is a normalized
value in the range [0, 100] if the first condition (Percent of correct
answers) is chosen. Otherwise, it is an absolute value.
Content

The following options are applicable to slide background images, audio, and text. Regarding
multi-state objects, the object state will be retained when users move between slides. For
example, users finish one slide with a button in the Pressed state and move to the next slide.
When they go back to this slide, the button is still in the Pressed state.
Include WebM &
Ogg

Allow viewing HTML5 content on browsers that don’t support MP4 and
MP3 but support WebM and Ogg.

Enable Visual Focus
Indicator

Display an outline around the object having focus.

Disable [Click or
Tap to Unmute]
Notification

Some browsers don’t allow content containing audio that plays
automatically without user interaction. In that case, the HTML5 player
will mute audio to enable autoplay.
The player will display a message to notify users to click to unmute
audio. Select this checkbox to hide the message.

Embed Fonts

Embed fonts that are used in content into output using CSS3 Web Fonts
Specification. This makes the content look consistent across platforms
and devices. Click the Details button to select the fonts to embed.

JPEG Quality (%)

Applicable to JPEG format only. This option specifies the quality of the
images that are exported to JPEG format. The higher the quality, the
larger the output file size.

PNG Optimization

Applicable to PNG format only. This option specifies the relative
compression levels (none, low, normal, high, ultra). The higher the
compression level, the smaller the output file size, and the longer it takes
to export.
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Images at 100% JPEG Quality and None PNG Optimization have no
loss, which means images will not be recompressed. You can also
change these specifications for each image by right-clicking the image in
the Resources pane then choosing Recompress.
Audio Quality (%)

Specify the quality of audio in the output. The higher value, the higher
the audio quality and the larger the output file size.

Video Quality (%)

Specify quality for videos in the output. The higher value, the higher the
video quality and the larger the output file size.

After specifying the course information, click OK to finish. Then, the course will be uploaded
directly to ActivePresenter Online and the following dialog appears letting you View Course or
View Lesson.

View Course: If you click this button, it will take you to the page where the course is located.
This page shows general information such as course title, and course content. You can further
edit the course if needed.
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View Lesson: When selecting this button, you will see a course lesson with Info and Reports
tabs. You can also try taking the course or customize it the way you want.
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Player Settings
The Player Settings window allows you to set various options for the HTML5 output of the project
created by ActivePresenter. To open it, go to the Export tab > Player Settings and the player
settings window will show up like the image below:

The window includes the settings (1) with a lot of options around the player, the preview Canvas
(2) lets you know what the changes look like, the top bar (3) with the project name and a resource
menu, the side bar (4), and the toolbar (5) that holds many navigation buttons.
You can make the player look the way you want by toggling its components, modifying each one,
changing colors and fonts, etc. All changes you make will be reflected in the preview pane on the
right side of the window.
Note: The videos and audio may not be available in this preview window because of the reduction
in preparation time. This means ActivePresenter may not get the videos or audio data to preview
them, which helps reduce the preparation time remarkably.

General Settings
General
is the first tab in the Player Settings window. This tab allows you to choose and
customize the skin, add information about the author, and change many general and color
parameters for the player.

a. Customizing the Skin
ActivePresenter provides you with several skins to define the layout of the player. Each skin
comes with a variety of presets for you to choose from and make changes if you want. In addition,
you can create your own custom preset and reuse it across projects.
Do the following:
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●

Choose skins: Click the Skin combo box and choose the desired skin from the list.

●

Choose presets: Click the Preset combo box and choose the desired preset from the list.

●

Modify presets: Select a preset, then go to the Parameters pane > Color Parameters
tab
to modify any color parameter you want.

●

Create new presets: After modifying a built-in preset, click the Save button
Preset combo box to save your custom preset for later use.

●

Remove custom presets: Select a custom preset from the Preset drop-down list >
Remove . You cannot remove built-in presets.

next to the

b. Adding Author Information

You can display information about the author in the side bar of the player (General tab >
Parameters pane > General Parameters
> Side Bar). All the information, including the
author's name, description, and image, will be displayed at the top of the side bar, above the table
of contents (if any).
Do the following:

●

Add author names: Enter the name of the author in the Name text box.

●

Add author descriptions: Enter the description of the author in the Description text box.

●

Add author images: Choose an image from your project
or your computer
the author's image. If you no longer need an author image, remove it by clicking

to be
.

c. Changing General Parameters
You can customize the parameters for each operation mode separately or all the modes at once.
Choose the operation mode you want by clicking the Operation Mode combo box.
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Later, if you want to go back to the original settings, click the Restore Defaults button

.

1. Content section allows you to customize the common properties of the player.

Option
Border Width

Description
Specify the border (in pixels) for the content and the side bar. When
creating a responsive project, its default value is 0.
Decide how the content will be displayed in the output.
●

Actual Size: Display the content in the actual size. Users can use
the scroll bars to view the portions of the content that extend
beyond the player.

●

AutoFit: Automatically scale the content without changing the
proportion to fit it into the player.

Display Mode

Decide how the player will fit the size of the content and the window.
Player Size

Navigation

●

Fit to Content: The player will wrap to fit the content size.

●

Fit to Window: The player will fit the container or browser window. If
the content is smaller than the window, more space will be added
to the gap between the player and the content.

Specify the navigation behavior for the presentation using the toolbar
and the TOC.
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●

None: Disable the content navigation so that users cannot navigate
through the slides.

●

Backward Only: Allow users to navigate through the viewed slides.

●

Free: Allow users to navigate freely through the slides.

Font

Specify the font for the player elements, such as presentation title,
author information, and table of contents.

Font Size

Specify the player font size.

Auto Hide Player Bar

This option allows you to hide the Player Bar automatically when you
view a project on small screen devices.

2. Side Bar displays the information of the author and the table of contents.

Option

Description

Position

Specify the position of the side bar on either the left or right side of the
content. Select None if you don’t want to display the side bar.

Width

The width of the side bar in pixels.

Author Information

Display the name and description of the author in the side bar.

Author Image

Display the image of the author in the side bar.

Author Video

Display the video of the author in the side bar.

3. Top Bar at the top of the player displays the presentation title.
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Description
Show the top bar of the player. The top bar can display the presentation
title and the Resources menu button.

Show Top Bar

4. Table of Contents (TOC) shows the content structure of the presentation and allows users to
navigate through the presentation.

Option

Description
Select the display style for the table of contents.
●

None: Hide the table of contents.

●

Overlay: Allow users to use the TOC button in the toolbar to open the
TOC in an overlay.

●

Side Bar: Display the table of contents on the side bar. Users can use
the TOC button in the toolbar to show/hide the TOC.

Style
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Show Duration

Show slide duration in the TOC.

Show Thumbnails

Show slide thumbnails in the TOC.

Show State Icons

Show state icons in TOC entries to indicate the state of slides. The current
slide is marked with an arrow while the viewed slide is marked with a
checkmark.

Initially Expand
Entries

Expand all levels of the TOC from the beginning. Users can use the arrow
icon next to an entry to expand/collapse its subentries.

Auto Scroll to
Current Entry

Automatically scroll the TOC to the entry associated with the current slide.
This ensures the entry of the current slide is always visible to users
without having to manually scroll the TOC.

5. Toolbar gives users many tools to control the player.

Option

Description

Show Toolbar

Show the toolbar at the bottom of the player.

Restart Button

Show the Restart Presentation button which allows users to reset the
presentation to the original state and start from the beginning.

Exit Button

Show the Exit button which allows users to exit the presentation.

First Slide Button

Show the First Slide button which allows users to jump to the first slide
in the presentation.

Previous Slide
Button

Show the Previous Slide button which allows users to go to the previous
slide.

Play Button

Show the Play/Pause button which allows users to play/pause the
presentation.

Speed Button

Show the Playback Speed button which allows users to change the
playback speed of the presentation.

Next Slide Button

Show the Next Slide button which allows users to go to the next slide in
the presentation.
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Last Slide Button

Show the Last Slide button which allows users to jump to the last slide in
the presentation.

Progress Bar

Show the progress bar which allows users to navigate through the
presentation when navigation is enabled.

Volume Bar

Show the volume bar which allows users to change the sound volume.

Volume Button

Show the Mute/Unmute Audio button which allows users to toggle the
sound.

CC Button

Show the Show/Hide Closed Caption button which allows users to
toggle the CC.

Display Mode
Button

Show the Display Mode button which allows users to change the display
mode (actual size, autofit, full screen).

Information Button

Show the Information button which allows users to view the information
of the presentation, such as title, author name, copyright, and home
page.

TOC Button

Show the Show/Hide Table of Contents button which allows users to
toggle the TOC when the TOC is enabled.

Side Bar Button

Show the Show/Hide Side Bar button which allows users to toggle the
side bar when the side bar is enabled.

Resources Button

Show the Resources menu button in the top bar which allows users to
access external content attached to the presentation.

Slide Markers

Show slide markers indicating the duration of slides in the progress bar.

Playback Position

Show the current playback position in the presentation in the toolbar.

Total Duration

Show the total duration of the presentation in the toolbar.

d. Changing Color Parameters
To change the colors of the player, you can customize the color parameters for each operation
mode separately or for all the modes at once. Choose the operation mode you want by clicking
the Operation Mode combo box. Later, if you want to go back to the original settings, click the
Restore Defaults button .
You can also customize the color parameters and save the settings as a custom preset.
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Description

Content

Specify the colors for the background of the border and the page.

Side Bar

Specify the colors for the background and the text in the side bar.

Table of Contents

Specify the colors for the background and the text in the TOC. You can
specify different colors for the background of

Toolbar

Specify the colors for the background and the text in the toolbar.

Button

Specify the colors for the buttons in the toolbar and the top bar.

Slider

Specify the colors for the progress bar and the volume bar in the
toolbar.

Menu

Specify the colors for the background and the text in the menus that
appear when users interact with buttons and controls in the toolbar.

Resources Pane

Specify the colors for the background and the text in the Resources
pane.

Table of Contents
An informative table of contents (TOC) is essential for your presentation as it can give a visual
overview of the whole presentation and help users easily navigate while viewing. At run time, the
TOC entry associated with the current slide will be highlighted. You can also choose to mark it
with an arrow to indicate that the corresponding slide is playing. Meanwhile, a checkmark can be
shown in an entry to indicate that the corresponding slide has been viewed completely. During
editing, you can enable navigation so that users can click a TOC entry to jump to the
corresponding slide.
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By default, ActivePresenter generates the TOC and shows it in the side bar of the player. When
viewing the output, users can show or hide the side bar to toggle the TOC. The Show/Hide Side
Bar button is enabled by default and appears at the bottom-right corner of the player toolbar.

Besides showing the TOC in the side bar, you can enable the Show/Hide Table of Contents
button in the player toolbar and use it to open the TOC in an overlay.
To organize the TOC, you can change the hierarchy of entries, create new entries, delete or hide
entries you don’t want. Note that the reorganization in the TOC doesn’t affect the order of the slides.
Access the Table of Contents tab and do one or more of the following to reorganize the TOC:
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●

Add entries: Click the

button to add a new entry right above the selected entry.

●

Remove entries: Click the

●

Hide entries: Clear the status box to hide an entry. Click the
button to show or hide all
entries. Note that hiding a TOC entry doesn’t remove a slide from the project.

●

Move entries one sublevel up/down: Click the
button to make an entry one sublevel
down or the
button to make an entry one sublevel up.

●

Move entries up/down: Click the
button to move an entry before the previous or the
button to move an entry after the next entry. You can also move an entry by dragging
it to a new location.

●

Adjust TOC heading style: Click the

●

Reset TOC to default: Click the
button to go back to the default TOC. In case you
reorganize slides after creating the TOC, your changes will not be automatically updated.
Just click this button to reflect any changes.

button to remove a custom entry.

button and select a style.

Preloader
By default, ActivePresenter documents preload necessary resources before showing the first
slide. To show the loading progress, a loading indicator that contains a spinner and a percentage
sign appears in the center of the screen. The loading indicator also appears afterward if buffering
takes longer than usual.
To customize the preloader, access the Preloader in the Player Settings window. The loading
indicator has six editable properties. To adjust their values, you can drag the handle on the slider,
scroll the mouse wheel, or enter a new value. All changes you make are immediately reflected in
the preview pane. After customizing, if you want to discard all changes, click Restore Defaults
to go back to the default settings.
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●

Diameter: Set the diameter of the loading indicator.

●

Density: Set the number of shapes drawn on the loading indicator.

●

Range: Set the amount of the modified shapes in percentages. Specifically, it sets what
range of the shapes should be scaled and/or faded. The shapes that are out of this range
will be scaled and/or faded with a minimum amount only. If the range is 0.1, every shape
out of the range will be scaled and/or faded to 10% of the original values. The visually
acceptable range value should be between 0.4 and 1.5. The default value is 1.0.

●

Speed: Set the speed of the loading indicator animation. This value tells the loading
indicator how many shapes to skip by each tick.

●

Color: Set the color of the loading indicator in RGB.

●

Shape: Set the type of loading indicator shapes, namely oval, spiral, square, rectangle,
and rounded rectangle.

Resources
You can add external content to the presentations in the Resources tab. It allows learners to
access reference materials or find out more helpful information. They can access the printable
transcript or downloadable copy of the course content.
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●

Click the

button to add the resource from an URL, a project, or your computer.

●

Click the

button to replace the content that you added.

●

Click the

button to delete the selected content from the resources.

●

Click the

and

button to change the order of the content.

Player Language
ActivePresenter provides the readily translated text for the output (name of elements in the toolbar
and messages) for all supported languages through the Player Language editor. If you want to
modify the translation or add support for your language, access the Player Language tab in the
Player Settings window.
The editor provides the following properties:
●

Project Language: Display the language of the open project. You can change the project
language in the Project Properties dialog.

●

Name: Display the text in the current user interface language of ActivePresenter so you
can know their original meanings.

●

Value: Display the text in the language which is set in the Project Language section (if it
is supported). You can modify the text in this column by double-clicking each row and
typing in it.

●

Reset: Restore the original translation of the text.

HTML5 Preview
To preview the HTML5 output before actually exporting, click the HTML5 Preview button
in
the Home or Export tab. Two preview categories are available: Preview Project and Preview
Current Slide. Previewing the current slide takes you only to the currently selected slide.
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Meanwhile, previewing the project allows you to preview the whole project so that you can review
all slides, from the first to the last slide. Each category provides four operation modes
(Demonstration, Tutorial, Practice, and Test) to choose from.

By default, when you click the HTML5 Preview button, the entire project will be previewed in
Tutorial mode. This button then archives the latest previewing mode for future use. For example,
if you click the HTML5 Preview button after having previewed the content in Demonstration mode,
it then will show in Demonstration mode. You can also see which mode the content is previewed
through the URL address.
Note: You can click the HTML5 Preview icon on the Status bar to preview the entire project.
Alternatively, press F5 on the keyboard.
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Miscellaneous
Editing Project Properties
To view the project properties, click the ActivePresenter button > Project > Properties. When
no slide is selected, the Project Properties pane will be shown in the Properties pane. Then, if
you want to enter the slide editing mode, just select a slide in the Slides pane.
The Project Properties pane allows you to do the following operations:
●

Edit the project name and description, the author’s name, copyright, and home page
information, the project language, and the size of slides.

●

View the project related information such as the total number of slides, the total run time
for the presentation, the project location, the project file size, the date on which the project
was created and last modified, the version that the project is created.

●

Add the On Load event.
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Project Properties Tab
This tab gives you generic information and settings of the currently editing project. They are global
settings that affect all slides in your project.
●

Project Name: Change the name of the project.

●

Description: Describe the project.

●

Author: Set the name of the author for the project.

●

Copyright: Add the copyright information for the project.

●

Home Page: Add the home page information for the project.
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●

Language: Specify the language of the editing project. ActivePresenter will use the
corresponding translation of the selected language to display in the output (name of
elements of toolbar and messages in HTML5) if the language is supported in
ActivePresenter. For other languages, you can still modify the text in output by using
Player Language Editor.

●

Slide Size: The size of the project slides. Click the Change Size button to change the
current project’s slide size. Note that this option is only available in non-responsive
project.

●

Number of Slides: The total number of slides in your project.

●

Total Duration: The total duration of all slides in your project.

●

Location: The location of the project on the computer.

●

File Size: The size of the project.

●

Created: The time that the project was first created.

●

Modified: The time that the project was last edited.

●

File Format Version: The format version of the project.

Interactivity Tab
This tab allows adding events – actions to your project.

The On Load event allow adding all action types that are available in ActivePresenter. The added
actions will be triggered automatically when the first slide (or the last visited slide in the case of
restoring from LMS) starts showing.

Making Project Accessible
ActivePresenter allows you to make your project accessible to people with disabilities. This means
you can edit your project so that users with disabilities can perceive, understand, navigate, and
interact with the project outputs. The HTML5 output can be viewed in various ways that don’t
depend on a single sense or ability. For example, users can navigate with a keyboard, not with a
mouse only. Also, audio content should be accompanied with closed captions for hearing impaired
users, text descriptions should be provided for visual content so that screen readers can read out
loud for visually impaired users.
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Tips for Creating Accessible Projects
To create accessible projects, you should always use more than one means (e.g. text, visuals,
and sounds) to convey information.
●

For users with visual impairments, add text descriptions or audio equivalents for visual
objects. For example, provide an accessible text description for a video so that you can
send the information to users through the screen reader. For objects that contain text such
as shapes, text captions, you should enable the Auto Label property, the screen reader
will read the text when this object is displayed. If you choose to attach audio to the object,
don't forget to remove all accessibility text, otherwise, the voice from the screen reader
will interfere with the attached sound.

●

For users with hearing impairment, add text equivalents for audio objects. For example,
when delivering narrative audio, it is important to provide captions at the same time. You
can use closed captions or any other type of objects that can display text, and remember
to synchronize the text with the audio by using the Timeline pane.

●

For users with either visual or hearing impairment, ensure that users can interact with the
output using the keyboard. For example, enable the Focusable property for mouse click
objects so that users can use the TAB key to navigate between objects, and the ENTER
or SPACE BAR key to activate it. You can also provide a key stroke object that acts as
a hotkey for each mouse click object.

●

Enable Accessibility features when exporting to output formats that support accessibility.

Customizing Accessibility Text for Slides
In ActivePresenter, you can add accessibility text describing each slide for screen readers to read
aloud when the slide is displayed. Screen readers and accessibility text are useful for people with
visual impairments.

By default, ActivePresenter uses slide name as slide accessibility text. To provide different text
for screen readers, do the following:
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1. Select the slide that you want to change accessibility text.
2. Navigate to the Properties pane > Slide Properties tab > expand the Accessibility section.
3. Clear the Auto Label checkbox, the Accessibility Text box is now enabled. Type text
that describes the slide.
4. When the slide appears, screen readers will read aloud the accessibility text in the text
box. If you don’t want screen readers to read anything, leave this text box blank.

Customizing Accessibility Text for Objects
ActivePresenter supports accessibility text for each object in a slide. By default, accessibility text
is generated automatically from the text that the object displays, or the object name if it doesn’t
contain any text. Therefore, the default accessibility text is usually useless for objects that don’t
contain text, such as videos and images.
In that case, you should customize the accessibility text to provide sufficient information about the
object by following the steps below:
1. Select the object that you want to change accessibility text.
2. Navigate to the Properties pane > Size & Properties tab > Accessibility section.
3. Clear the Auto Label checkbox, the Accessibility Text box is now enabled. Type the
description of the object in the text box.
4. When the object appears, screen readers will read aloud this accessibility text. If you don’t
want screen readers to read anything, leave this text box blank.

Localizing Projects
Localization is the process of adapting a project for use in a specific country, a region with a
particular language, culture, and desired local look and feel. If you are creating a demonstration
or simulation of a certain application that supports multiple languages, you may need to localize
your project for each language. With ActivePresenter, you can do it easily thanks to the slide
background replacement and the text translation features.

Localizing Process
Before doing localization, make sure that you have finished editing the original project (usually in
English).
To localize your project, do the following:
1. Export text in your project to XLIFF format.
2. Translate text in the exported XLIFF file using any tool that supports XLIFF 1.2 (e.g.
Swordfish Translation Editor).
3. Replace the original slide backgrounds with the new ones that are captured in the new
language.
4. Import the translated XLIFF file into the project of which slide backgrounds have been
replaced in step 3.
5. Test the localized version of your project, make sure that all screenshot images are
replaced, and all texts are properly translated and displayed.
The next sections will describe each step in detail.
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Exporting to XLIFF
XLIFF (XML Localization Interchange File Format) is an XML-based format created to standardize
the way localizable data are passed between tools during the localization process.
To export text in your project to XLIFF format, do the following:
1. Click the ActivePresenter button > Project > Localize > Export To XLIFF.
2. In the dialog that appears, select the types of text which you want to export for the
translation.

3. Select the Use TMX 1.4b standard compatible tags (<bpt>, <ept>, <ph>) text box if
your translation tool doesn’t support <g> and <x/> tag.
4. Enter the output location and file name in the Output File text box.
5. Click OK to start exporting to XLIFF.

Replacing Slide Backgrounds
You should not localize directly in your original project but a copied version of the project. This
section will describe the steps of copying projects and replacing slides.
Step 1. Create a copy of the original project for the new language.
1. Copy the project file in File Explorer, or use the ActivePresenter button > Save As…. If
you copy it in File Explorer, make sure it isn’t opening in ActivePresenter. The project
copied from an open project may be corrupted.
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2. Give the copied project a meaningful name. It is recommended that the project name has
language code suffice, for example, Skype_es.approj. You can also create a folder for the
new language and place the copied project there.
Step 2. Capture a new project for the new language.
1. Change language preferences and settings for the captured application to display the new
language, if needed.
2. Use the same project size (width x height) as the size of the original project.
3. Name the new captured project a meaningful name. For example, you can name it
Skype_es_captured.approj.
Step 3. Open the Slide Background Replacer window to replace slide backgrounds in the
project copied in step 1 with new ones captured in step 2, or by slides of the new captured project.
1. Open the project copied in step 1 (Skype_es.approj).
2. Click the ActivePresenter button > Project > Localize, and do one of the following:
○

Select Replace Backgrounds of All Slides to replace all slides backgrounds with
slides of the new captured project. Selecting this option will launch the blue rectangle
and the Replace Slide Backgrounds dialog so that you can capture the new project.

○

Select Replace Backgrounds of Selected Slides to replace some selected slide
backgrounds with slides of the new captured project. Selecting this option will launch
the blue rectangle and the Replace Slide Backgrounds dialog so that you can
capture the new project.

○

Select Replace Backgrounds of All Slides From Project and browse the new
project captured in step 2 (Skype_es_captured.approj) to replace all slide
backgrounds of the current project.

○

Select Replace Backgrounds of Selected Slides From Project and browse the new
project captured in step 2 (Skype_es_captured.approj) to replace some selected slide
backgrounds of the current project.

Step 4. In the Slide Background Replacer window, arrange new slides on the right in the same
order as the current slides on the left.
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To move a slide, drag and drop it to the new position. You can only drag slides on the
same side (left or right) to change their positions.
To copy/cut/paste/delete a slide, right-click it and choose one of the options in the pop-up
dialog. To delete a slide, you can also click it and press the DELETE key on the keyboard.

●

If a certain slide is required in the new language but not available in the original language,
select it and click the Copy To Left button . This moves the selected slide from right to
left.

●

If you don’t want to change a certain slide on the left (e.g. the introduction slide), select it
and click the New Placeholder button . This inserts a placeholder slide into the right.

●

If you aren’t sure whether a new slide of the new project (on the right) is redundant or not,
move it to the bottom instead of deleting it. To do that, select the slide and click the down
arrow button .

●

To reverse your last action, click the Undo last action button
or press CTRL + Z. To
reverse your last Undo, click the Redo last action
or press CTRL + Y.

●

Click the Larger Size button
to zoom in, the Smaller Size button
the AutoFit Size
button to fit the slide to the screen.

●

If you want to scroll each slide side separately, click the Disable Synchronous Scrolling
button .

to zoom out, or

Step 5. Click the OK button in the Slide Background Replacer window to replace slide
backgrounds.
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Importing from XLIFF
After translating text and replacing slide backgrounds, you need to import the XLIFF file back to
the project in which slide backgrounds are replaced. ActivePresenter will replace the current text
in your project with the corresponding text in the translated XLIFF file.
●

Open the project that has been replaced with slide backgrounds.

●

Click the ActivePresenter button > Project > Localize > Import From XLIFF > browse
the translated XLIFF file.

●

Verify the imported text on each slide, adjust the object position and size if necessary.

Active Window
When creating a video demo or simulation to demonstrate how to work with an application or
software (e.g. Microsoft), you want to capture only a specified window sometimes (e.g. a
confirmation dialog). ActivePresenter can automatically detect the area that you want to capture
and save the information to captured slides through the active window feature.
To view the active window, do one of the following:
●

Access the View tab > View Active Window

.

●

Right-click the slide on the Canvas > View Active Window.

The following figure shows an active window area (in the red dashed border) in a captured slide:
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In certain circumstances, the active window area detected while capturing doesn’t fit the
dialog/window. You can modify this area by opening the View tab > Edit Active Window
, or
right-clicking the slide on the Canvas and selecting Edit Active Window.
This enables the Edit Active Window Area tool. Then, you can resize the active window by
dragging the red dashed border.
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ActivePresenter Windows
Canvas
The Canvas in the center of the workspace displays all slide contents. It can also be called the
working window.
●

With a blank project, the Canvas displays the blank slide.

●

With a project includes many slides, the Canvas show the content of the selected slide.

●

With a recorded project, the Canvas displays the recorded videos/slides along with all
annotations added.

●

With a created project, the Canvas shows the slide with all of its contents (quizzes, shapes,
images, videos, etc.).

Zooming Canvas
While editing the project, you may need to zoom in and zoom out the Canvas to make editing
more easily. Regardless of how much you are zooming in/out of the Canvas, when you preview
the slide, the content automatically fits the Canvas. This allows you to view the content of the
entire slide. When the preview is completed, ActivePresenter goes back to the previous zoom
scale.
This feature saves you tons of time
With this feature, you don’t have to click the Zoom Fit
content, which saves you a lot of time in project editing.

button each time you preview the

To zoom in/out the Canvas, do one of the following:
●

Drag the Zoom slider at the bottom-right corner of the application window.
Drag it to the right or left to zoom in or zoom out the Canvas respectively.

●

Access the View tab > Zoom
> select a preset zoom level from the Zoom dialog that
appears, or enter a value in the Percent spin box.

●

Place the mouse inside the Canvas area > hold down CTRL while scrolling the mouse
wheel up or down to zoom in or zoom out of the Canvas respectively.

To automatically fit the Canvas zoom level, do one of the following:
●

Click the Zoom Fit button

next to the Zoom slider.

●

Click the View tab > Zoom Fit

.

This automatically adjusts the zoom level to fit the space of the Canvas.
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Timeline Pane
Timeline Overview
A timeline defines how multiple objects in a slide show or hide against time. By default, each slide
has a Main Timeline which is run automatically when entering the slide. You can add more timelines
to a slide. ActivePresenter now lets you create a Click Sequence timeline and many interactive
timelines as you want. These timelines perform specific tasks depending on user needs.
If you are working on a video project, you just need to work with the Main Timeline. While working
with an interactive presentation, you may need to use interactive timelines. To control and animate
objects sequentially by clicking the mouse or pressing the keyboard, a Click Sequence timeline
is what you need.
In case you don’t see the Timeline pane is under the Canvas, it may be closed somehow. To
open it again, access the View tab > Timeline .
The Timeline pane is used to manage timelines and edit each timeline. You can do the following
tasks in the Timeline pane:
●

Edit audio/video objects (split, join, change volume/speed, insert time, etc.).

●

Edit the object timing and animations.

●

Play slides and record your commentary in real-time.

●

Preview slides.

●

Add, remove, or rename timelines.

Managing Timelines
In ActivePresenter, you can create and manage multiple timelines simultaneously with the
Multiple Timelines feature. You can add or remove timelines when needed.
●

Select a timeline: Click the Main Timeline drop-down arrow, and select one of the existing
timelines.

●

Add a Click Sequence timeline: Click the Main Timeline drop-down arrow, and select
Add Click Sequence.

●

Add an interactive timeline: Click the Main Timeline drop-down arrow, and select Add
Timeline. The new timeline will be created with an auto-generated name (Timeline N).
The newly created timeline will be automatically chosen for editing. You can add more
than one timeline.

●

Remove a timeline: Click the Main Timeline drop-down arrow, and select the timeline that
you want to remove. Then click Remove Timeline. You cannot remove the Main Timeline.
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Rename a timeline: Click the Main Timeline drop-down arrow, and select the timeline that
you want to rename. Then, click Rename Timeline. Enter a new name in the pop-up
dialog and click OK. You cannot rename the main timeline and the Click Sequence one.

Using Multiple Timelines
To use multiple timelines, do the following:
1. Add timelines.
2. Rename added timelines to a more meaningful name.
3. Add animations to objects. To add animations to objects in the selected timelines, select
the object from the Canvas or Selection pane. Then, click the Animations tab and select
entrance, exit, emphasis, and motion path effects from the effect galleries.
4. Use events - actions to start/pause/continue the added timelines.

Using Click Sequence Timeline
In the Click Sequence timeline, you can decide to start an animation when clicking the mouse, or
coordinate it with other effects on the slide. Note that the Click Sequence timeline depends on the
Main Timeline duration. If the Main Timeline duration is short, the Click Sequence timeline will not
have enough time to work. So, expand the Main Timeline duration as long as you want.
Alternatively, can deselect the Auto Advance checkbox in the Properties pane before creating
this slide.
To create and work with a Click Sequence timeline, do the following:
1. Add a Click Sequence timeline.
2. Add animations to objects (Animations tab > select entrance, exit, emphasis, and
motion path effects from the effect galleries).
3. Specify the type of animations’ start time.
•

Start On Click

•

Start With Previous
effect.

: Start the object animation when you click the slide.
: Start the object animation at the same time as the previous

For example, the order of objects’ appearance in the above image is Shape 1 > Shape 2 > Shape
3 and Shape 4, respectively. Each object has a different delay time based on its start time.
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After the 1st click, Shape 1 starts immediately.
After the 2nd click, Shape 2 appears at 03:00 since it has a 3-second delay.
After the 3rd click, Shape 3 and Shape 4 appear. Shape 4 is set up with Start with
Previous, so it will appear along with Shape 3. However, Shape 3 has a one-second
delay before showing. And Shape 4 appears later than Shape 3 three seconds. In
other words, Shape 4 will appear at 04:00.

4. Customize object animations.
•

•

•

Set up the delay time. Do either of the following:
o

Hover the mouse over the effect time bar until the mouse turns into a four-way
arrow, and drag the bar along the timeline ruler.

o

Double-click or right-click its time bar > Effect Settings > enter a new value to
the Start Time spin box of the pop-up dialog.

Modify animations’ duration. Do either of the following:
o

Hover the mouse over the end point of the effect time bar until the mouse turns
into a double-headed arrow. Next, drag it horizontally to extend or reduce its
duration.

o

Double-click or right-click its time bar > Effect Settings > enter a new value to
the Duration spin box of the pop-up dialog.

Change the effects’ order. Do either of the following:
o

Click the Move Effect Up/Move Effect Down icons in the Timeline.

o

Right-click effects, and select the Move Effect Up/Move Effect Down
commands in the context menu.

o

Press the hotkeys CTRL+PAGEUP/CTRL+PAGEDOWN.

5. Add events – actions to further manipulate with animation effects.
• Click Sequence - Go Forward action allows you to:
o

Start the animation when the action is executed.

o

Complete current animation immediately (if any).

o

Run the next Start On Click animation and all subsequent Start With Previous
animations.

o

Move to the next slide if the current slide doesn’t have the next animation and
current animations are completed.

Tip: Click the mouse or press the right/down arrow keys to execute the action.
•

Click Sequence - Go Back action allows you to:
o

Reset animations if they are running (Seek to start of these animations).

o

Go back and stop at the previous Start On Click animations.

o

Go back to the previous slide if there is no previous action.

Tip: Press the left/up arrow keys to execute the action.
Note: If you create a Click Sequence timeline in the master layout of the Slide Master, all the
custom layouts will inherit this timeline.
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Object Time Bars
The time bar of an object represents its existence along the time axis. It is only available in the
main timeline.

As indicated in the image above, Shape_3 will appear in the first second after the slide starts to
play. Then, it will disappear at the 4 second, which means its duration is 3 seconds. The length
of the object's time bar represents its duration.
th

The animation effects of Shape_3 are displayed by the green and red bars placed inside the
object time bar. The green bar's length indicates the duration of the entrance effect while the red
bar’s length indicates the duration of the exit effect.

Objects Initially Hidden
We can set the initial state of an object as hidden, so it can only be shown by an action or an
interactive timeline. The initially hidden object is represented in the timeline as follows:

You cannot change the time bar of the initially hidden object. To change the initially hidden state,
just right-click the object > select Initially Hidden. You can also change this option in the
Properties pane > Size & Properties tab > Timing section > tick the Initially Hidden checkbox.
By default, some types of messages such as Correct Messages, and Incorrect Messages are
initially hidden objects.

Changing Object Name, Timing and Duration
ActivePresenter hasn’t supported changing the object’s name directly in the Timeline pane. To
rename objects, you can navigate to the Properties pane or the Selection pane.
The timing and duration of an object are easy to adjust by using its time bar. The left-side edge
of the time bar is the start point, and the right-side edge of the time bar is the end point of the
object.
●

Changing the start time of objects: Hover the mouse over the start point of the object
time bar until the mouse pointer turns into a double-headed arrow, and drag it horizontally
to change its start time.
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●

Changing the end time of objects: Hover the mouse over the end point of the object
time bar until the mouse pointer turns into a double-headed arrow, and drag it horizontally
to change its end time.

●

Moving objects in the timeline: Hover the mouse over the object time bar until the mouse
pointer turns into a four-way arrow, drag the bar horizontally, and drop it wherever you
want.

You can move multiple objects as well as change their start/end points simultaneously by
selecting multiple of them, then moving them together. To select multiple objects, hold down
CTRL or SHIFT while clicking object time bars or clicking object names in the timeline.
To select contiguous objects, click the first object, then hold down SHIFT while clicking the last
object, all the objects between these two objects will be selected.

Putting Multiple Objects in a Line
Each line in the timeline can contain multiple object time bars which are displayed sequentially.
Thanks to that, you can easily organize and track their timing and duration.
The time bar of object in a line has the successive z-order. This means the object time bar on the
left has a smaller z-order in comparison with the one on the right. You cannot swap the z-order
between two object time bar in a line without changing their start time.

To move an object time bar along its current line, select it, then drag it sideways and drop it to the
desired position.
If the object time bar is between two other objects’ time bars, you can only move it within the
available space between these two other ones, or move it to the space outside the two other ones.
If the object time bar is placed at the end of the line, and the duration of it is greater than the
available duration, the slide duration will be automatically extended to the right to contain it.
To move an object time bar to a new line, do one of the following:
●

Select the object time bar and drag it upward or downward to the new line. You can only
drop the object time bar in the line which has enough available space between two object
time bars for it. You can move multiple objects time bar together sideways, but you cannot
move them up/down simultaneously to the new line.

●

When there are at least two object time bars in a line: right-click the object time bar >
Move Up/Down into a New Line. In this case, ActivePresenter will create a new line
containing the object time bar.
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Inserting Objects Using Playhead
Note that the following description doesn’t apply for cursor path, closed caption, and zoom-n-pan.
When you place the Playhead at a position in the timeline, the object will be inserted right at the
Playhead position. And the object start time is the current time of the Playhead. For example,
you place the Playhead at 0:01 in the timeline then, you insert an object. So, that object will be
inserted at 0:01, and its start time is 0:01.
If there are any existing object time bar in a line and the duration of the newly inserted object time
bar is smaller than the line duration, the new object time bar will be placed before existing object
time bar in the same line. See the below image for easy understanding:

If there are any existing object time bar in a line, and the duration of the newly inserted object
time bar is larger than the line duration, the new object time bar will be placed in the new line and
above existing object time bars in the timeline, as long as the new line doesn’t contain any object
time bar that is overlapped in time with it. See the below image for easy understanding:

When you insert an object time bar in the timeline without the Playhead, the start time of the
object time bar is set to 0, and its duration is stretched to the end point of the slide. The newly
added object time bar will also be placed above existing object time bars in the slide. See the
below image for easy understanding:
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Timeline Snapping
With the snap mode in ActivePresenter, you can align different objects more easily and precisely
in the timeline. When the snap mode is on, as soon as a moving “snappable” element comes in
the vicinity of another “snappable” element, it will make a tiny jump to match the timestamp of the
other element.
The snap mode applies to the following elements:
●

In ruler area: Playhead, start marker, and end marker of the range.

●

In the time bars of objects: Starting and ending edge, all markers inside the object time
bar.

●

Others: Start and end point of the slide.

To turn the snap mode on, click the View tab > Timeline Snapping

.

Below are some notes when using the snap mode:
●

The “other element” may be anywhere in the timeline: Right from the ruler to the lowest
object's time bar. The vertical separation between the elements doesn’t matter at all.

●

You may not be dragging the “snappable” element itself. For example, when we drag a
time bar of an object, all “snappable” elements in the bar are moving simultaneously. Any
of these elements can snap to another snappable element.

●

You can temporarily disable the snap mode by pressing ALT when dragging the element.

When a snapping takes place, ActivePresenter shows an orange vertical line to draw your
attention. This helps you to synchronize the dragged elements precisely with other elements in
the timeline. Now it is up to you whether to drop the dragged element there or keep dragging.

Timeline Toolbar and Productivity Tips
Icon

Command

Hotkey

Function

Add Click
Sequence
Timeline

Add a Click Sequence timeline.

Add Timeline

Add an interactive timeline. Additional
timelines are triggered using actions.
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Remove Timeline

Remove the current timeline. You cannot
remove the main timeline.

Rename Timeline

Rename the current timeline. You cannot
rename the main timeline and the Click
Sequence timeline.

Single Slide/All
Slides

View the current slide or all slides in your
project. The All Slides mode shows all slides
in the timeline, which is useful to see the
objects that span across multiple slides.
Switch the control to play, pause, or resume
the preview, starting from the Playhead
position. You can also right-click the Canvas
> Play Preview. At the end of the preview,
the Playhead returns to the start marker of
the range.

Preview

SPACE BAR

In addition, click the arrow next to the button
and choose the following options:
●

Preview All: Preview all slides in your
project, from the first to the last.

●

Preview from Current Slide: Preview
from the current position of the Playhead
to the last slide.

●

Preview Selected Slides: Preview
multiple slides that you have selected.

Stop

Stop the preview if the timeline is playing.
Otherwise, clicking this button clears the
selected range.

Record Narration

Record audio while playing the slide
simultaneously. To stop recording, click the
Stop button .

CTRL+SHIFT+R

Fit the entire slide duration into the available
pane width.

Zoom Fit Timeline
Zoom Out Timeline

CTRL+MOUSE
DOWN

Reduce the time scale of the timeline.

Zoom In Timeline

CTRL+MOUSE
UP

Expand the time scale to see more details.

Cut Range

CTRL+SHIFT+X

Cut the selected range and place it on the
clipboard.
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Copy Range

CTRL+SHIFT+C

Copy the selected range and put it on the
clipboard.

Delete Range

CTRL+DELETE

Delete the selected range.

Crop to Range

SHIFT+DELETE

Delete everything outside the selected range.

Insert Time

Insert a period of silence/ freeze frame into
the selected audio/video at the Playhead
position. This function can be applied to other
objects in ActivePresenter.

Split Audio/Video
Objects

Split the selected audio/video at the
Playhead position.

Join Audio/Video
Objects

Join the selected audio/video objects.

Change Playback
Speed

Speed up or slow down the selected range of
the audio/video.

Insert Blur Area

Insert a blur area into the selected video.

Adjust Volume

Adjust the relative volume of the selected
range of the audio/video.

Audio Fade In

Add a volume fade-in effect to the selected
audio.

Audio Fade Out

Add a volume fade-out effect to the selected
audio.

Audio Noise
Reduction

Reduce background noise from the selected
audio.

Audio
Normalization

Normalize audio throughout a project for
consistent volume across all slides.

Insert Caption

Insert a closed caption (CC) into a slide.

Split Slide

Split the slide at the Playhead position.

Go to Previous
Keyframe

In editing blur effects, go to the previous
keyframe.
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Add/Remove
Keyframe

In editing blur effects, add or remove a
keyframe.

Go to Next
Keyframe

In editing blur effects, go to the next
keyframe.

Below are hotkeys you can use to speed up your work in the timeline. Only some of them are
customizable using the Preferences dialog > Hotkeys tab.
Hotkey

Function

HOME

Move the Playhead to the beginning of the timeline.

END

Move the Playhead to the end of the timeline.

SPACE BAR

Play or pause the Playhead at any timestamp in the Timeline pane.

LEFT ARROW

If there are no selected objects, move the Playhead to the left.
Otherwise, move the selected objects to the left.

CTRL+LEFT ARROW

Same as above, but 10 times faster (the CTRL key is x10
accelerator).

RIGHT ARROW

If there are no selected objects, move the Playhead to the right.
Otherwise, move the selected objects to the right.

CTRL+RIGHT ARROW

Same as above, but 10 times faster (the CTRL key is x10
accelerator).

[

Move the Playhead to the start marker of the selected range.

]

Move the Playhead to the end marker of the selected range.

SHIFT+[

Set the start marker of the selected range at the Playhead
position.

SHIFT+]

Set the end marker of the selected range at the Playhead
position.

SHIFT+LEFT ARROW

If there are no selected objects, move the start point of the range
to the left, increase the duration of the selected range.
Otherwise, if an object is selected, reduce the duration of the
selected object.

CTRL+SHIFT+LEFT
ARROW

Same as above, but 10 times faster (the CTRL key is x10
accelerator).

SHIFT+RIGHT ARROW

If there are no selected objects, move the end point of the range
to the right, increase the duration of the selected range.
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selected object.

CTRL+SHIFT+RIGHT
ARROW

Same as above, but 10 times faster (the CTRL key is x10
accelerator).

CTRL+MOUSE UP/DOWN

Scroll the timeline horizontally.

CTRL+SHIFT+X

Cut the selected range and place it on the clipboard.
(customizable)

CTRL+SHIFT+C

Copy the selected range and put it on the clipboard.
(customizable)

CTRL+DELETE

Delete the selected range. (customizable)

SHIFT+DELETE

Delete everything outside the selected range. (customizable)

CTRL+SHIFT+R

Record audio while playing the slide simultaneously.
(customizable)
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Properties Pane
As its name implies, the Properties pane lets you view and customize the properties of selected
slides or objects. If you close this pane accidentally, click Properties
it on again.

in the View tab to toggle

There are many tabs in the Properties pane: Project Properties, Slide Properties, Style &
Effects, Size & Properties, Interactivity, Audio, Media, Chart, Table, and 3D Model.
By default, when you create a new project or open an existing one, its first slide is selected. Thus,
you will see three tabs (Slide Properties, Size & Properties, and Interactivity) in this pane:

As you select different types of objects, the related tabs will appear. For example, if selected
objects are shapes, images, buttons, etc., the Slide Properties tab will no longer exist. Instead,
the Style & Effects tab will appear. You will also see the Audio tab at the end:

In another case, if you select a video object, you will see the presence of the Media tab. Similarly,
the 3D Model tab will only be available when 3D model objects are selected.
Each tab can contain multiple sections. Each section displays many properties which are related
to each other. You can freely expand or collapse any section by clicking the section title. Keep in
mind that it's possible to change the properties of multiple objects or slides simultaneously. To do
that, you need to select all of them before customizing their properties.

Project Properties Tab
To make this tab appear, click the ActivePresenter button > Projects > Properties. It allows you
to change the general information of the project. Refer to the Project Properties tab to learn more.
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Slide Properties Tab
The Slide Properties tab will only appear when you select one or many slides in your projects.
This tab provides you with 5 sections (General, Layout Height, Background Fill, Background
Image, and Accessibility) to change the slide properties.

General Section
This section allows you to view and edit the general information of the selected slide.
Default
Value

Property

Name

The current
order of the
selected slide
in the project.
For example,
Slide 1

Description

Duration

Auto
Advance

Blank

3000 ms

Ticked

Function
This property displays the title of the selected slide. It will serve
as a table of contents (TOC) entry in HTML5 and document
outputs. It also appears as a brief description at the top-left of
each slide in document outputs.
The slide name comes in handy when planning navigational
jumps among slides.
It shows your notes or comments for this slide. When exporting
the project to document formats (PDF, MS Word, Excel,
PowerPoint), you can choose whether to include the slide
description. Besides, you can specify its position (Top, Left,
Right, Bottom) in all slides of that project.
This spin box allows you to change the duration of the selected
slide in HH:mm:ss.SSS. You can also drag the slide time bar
along the timeline to adjust this value.
Keep in mind that if any object in the slide ends beyond this time
limit, ActivePresenter automatically extends the slide's duration
to display that object in HTML5 and video outputs.
This checkbox is ticked by default. That means the presentation
automatically jumps to the next slide when the current slide
completes. If you untick it, consider using events - actions to
advance slides.
Note: This option is independent of the Pause presentation to
wait for user input option.

Layout Height Section
This section is only available for responsive projects. Refer to Changing Slide Height to learn
more about this section’s properties.

Background Fill Section
This section allows you to fill the slide background with a color or image.
Property

ActivePresenter Windows > Properties Pane

Function

410

ActivePresenter User Manual

Version 9.0

No Fill

The selected slides are not filled with any specific color or image.
Thus, their background becomes transparent.

Solid Fill

This option is selected by default. It lets you fill the slide
background with a single color.

Gradient Fill

Fill the background of the slides with a color gradient.

Image Fill

Fill the background of the slides with an image.

Hide Background Objects

Hide the background objects originating from the slide master.

Apply to All

Apply the changes you’ve made to all slides in your project.

Reset Background

Restore the original slide background.

Background Image Section
Apart from the Image Fill option above, ActivePresenter features the Background Image section
to fill the selected slides with an image. This section offers some properties (Left, Top, Width,
Height) that the Image Fill option lacks. These properties help customize the size and the position
of the background image relative to the slide:

●

Click the
button to select a background image from the current project. Alternatively,
click the
button to import a background image from your computer. Click the
button
if you want to delete the background image.

●

By default, the newly imported image will be stretched to fit the slide size. However, feel
free to customize its position and size in pixels. In the case of responsive projects, the
unit of these properties can be either pixel (px) or percentage (%):
o

Left: Adjust the X position of the background image from the top-left corner.

o

Top: Adjust the Y position of the background image from the top-left corner.

o

Width: Change the width of the background image.

o

Height: Change the height of the background image.

o

Align Horizontal Center: This checkbox is only available in responsive projects. When
you tick this checkbox, the background image will be aligned to the horizontal center of
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the slide. The Left spin box is disabled. That means you cannot adjust its X position
anymore. You can only adjust the Y position by changing the value in the Top spin box.
o

Align Vertical Center: This checkbox is only available in responsive projects. The
background image will be aligned to the vertical center of the slide. The Top spin box
is disabled. That means you cannot adjust its Y position anymore. You can only adjust
the X position by changing the value in the Left spin box.

●

Restore Original Size: Revert to the original size of the imported image.

●

Fit To Background: The imported image will fit into the background size.

Accessibility Section
This section comes in handy when you want to create accessible projects for users with visual
impairments.
Property

Function

Auto Label

This checkbox is ticked by default. That means the accessibility text will be
generated automatically from the slide name.

Accessibility
Text

If you clear the Auto Label checkbox, this property is enabled. Input text that
describes the selected slide in the text box. Later, screen readers will read
aloud that text when the slide is displayed. If you don’t want to provide any
information about this slide, leave this text box blank. For detailed instructions,
refer to Customizing Accessibility Text for Slides.

Style & Effects Tab
When you select objects in a slide, the Style & Effects tab will appear in place of the Slide
Properties tab. Yet, this tab is not available for all types of objects such as audio, videos,
YouTube videos, or web objects. It has four sections (Fill, Line, Shadow, and Opacity) to help
you customize the properties of the selected objects.

Fill Section
This section has four options similar to those in the Background Fill section of the Slide
Properties tab. It lets you customize the background of the selected objects. In detail, you can fill
them with any color or image.
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a. No Fill
The background of the selected objects becomes transparent.

b. Solid Fill
It is the default option. It fills the selected objects with a single color. Do as follows:
1. Click the color picker and select a color.
2. Drag the Opacity slider to adjust its value. You can also enter a number (0-255) in the Opacity
spin box. Or, click the up/down arrow buttons to increase/decrease the value respectively.

c. Gradient Fill
A gradient is a smooth transition from one color to another or from one shade to another shade
of the same color. The Gradient Fill option in ActivePresenter lets you fill the selected objects
with a graduated blend of two or more colors or tints of the same color.
When you tick this option, its related properties will appear as in the image below:
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At first, choose one gradient style, either Linear or Radial, from the Type drop-down list (1).
●

Linear: Shades vary in a straight direction.

●

Radial: Shades are in concentric circles.

Both of them require at least two color stops. A color stop, also known as a gradient stop, is the
starting point of new color and the ending point of the current color. By default, either the Linear
or Radial gradient style has two predefined color stops (3). The first one is black and the second
is white. The selected color stop has a blue border (Color Stop 1). The gradient strip in between
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shows a live sample and lets you make changes to it in a visual manner. You can click any color
stop to select it and drag it along the strip. To add more stops, click anywhere in the strip, the new
one will be added at the point that you click. Alternatively, click the Add button
to get the same
result. To delete any unwanted stop, select it and click the Remove button .
After that, you can customize the properties of the selected color stop:
•
•
•

Position: If you want to move the selected stop into a precise position, enter a specific
value (0-100%) in this spin box. You can also drag it along the strip.
Color: To apply a color to the selected stop, click the color picker to choose the color you
want.
Opacity: Adjust the transparency for each color stop from 0 to 255. The minimum value
indicates full transparency. The maximum value indicates full color.

Feel free to customize the Transform properties (2) to make colors blend into each other as you wish.
You can drag the corresponding slider. Alternatively, enter a specific number in the corresponding
spin box. You can also click the up or down arrow button to increase or decrease the value:
●

Angle: This property is only enabled if you select the Linear gradient type. Color
transitions in linear gradients occur along a straight line determined by an angle. Linear
gradients can be defined as horizontal, vertical, or angular. This value is measured in
degree (0-360o). Its default value is 0. That means the color transition happens from left
to right, starting with black and finishing with white.

When you increase this value, the gradient will rotate clockwise. On the contrary, if you
decrease the value, the gradient will rotate counterclockwise.
Take a look at the image above. If you change the angle from 0 to 90 degrees, the direction
of the color transition changes from horizontal to vertical. In detail, the transition starts at
the top and finishes at the bottom.
●

Offset X (%): This property is used to change the position of the gradient along the Xaxis. Its value ranges from -100 to 100%. Its default value is 0. When you increase or
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decrease this value, the gradient will move to the right or the left correspondingly. As a
result, the color of the object will change accordingly.
●

Offset Y (%): The Offset Y is available when you choose the Radial style. It lets you
change the position of the gradient along the Y-axis. Its value ranges from -100 to 100%,
and the default value is 0. When you increase or decrease this value, the gradient will
move upwards or downwards. The color of the object, therefore, will change accordingly.

●

Scale X (%): This property allows you to change the gradient horizontal scale (10-250%).
Its default value is 100. When you increase or decrease this value, the horizontal radius
of the radial gradient or the width of the linear gradient will be increased or decreased
correspondingly.

●

Scale Y (%): This property is only enabled for the Radial type. It lets you customize the
gradient vertical scale (10- 250%). Its default value is 100. Increasing or decreasing this
value will expand or shrink the vertical radius correspondingly.

d. Image Fill
This option allows you to fill the selected objects with an image. You can choose an image either
from the current project or your file system (1):

Apart from that, you can customize how the objects will be filled (2):
●

Tile: The image will be replicated in the x- and y-axis to fill up the space. If the image is
larger than the object, it will be clipped.

●

Stretch: The image will be stretched in height and/or width to fill up the available space.
If the image is larger than the object, it will be rescaled to fit the available space.

Line Section
The first two options that you can see in this section are No Line and Solid Line. When you insert
a new object into your current project, initially, it has no line. That means the first option is ticked
by default. To create a solid line for the object, select the second option. It will let you customize
many line properties:
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●

Width: This property allows you to change the width of the line in the range of 0-500 (in
pixel). Enter a value in the Width spin box. Or, click the up/down arrow to increase or
decrease the value.

●

Cap Type: This property only matters in an open curve, where you can see the end of a
line. You can let its end have either a round or square cap type.

●

o

Round: The end of the line is capped with a rounded shape.

o

Square: The end of the line is capped with a square shape.

Join Type: You can change the type of the join where two lines intersect with each other.
o

Round: The corners where two lines connect are rounded.

o

Bevel: The corners where two lines connect are cut off at a 45-degree angle.

o

Miter: The corners where two lines connect are squared off.
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Dash Pattern: This option lets you change the line pattern. Select either of the four types:
o

Solid: The border is the solid line.

o

Dot: The line is formed by dots.

o

Dash: The line is created by dashes.

o

Dot Dash: The line is formed by dots and dashes.

Arrow Type and Size: These properties are only available for Line and Arrow.
o

Begin Arrow Type/ End Arrow Type: You can choose from six built-in options, including
No Arrow, Arrow, Open Arrow, Stealth Arrow, Diamond Arrow, and Oval Arrow.

o

Begin Arrow Size/ End Arrow Size: There are nine built-in sizes for you to select,
from Size 1 to Size 9.

●

Color: It allows you to change the color of the line.

●

Opacity: You can drag the slider or enter a number (0-255) in the spin box to adjust the
transparency of the line. The zero value indicates full transparency. Meanwhile, the
maximum value display full color.
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Shadow Section
Initially, a newly inserted object has no shadow because the first option in this section is ticked by
default. If you want to add shadow effects to it, select Custom Shadow. Then, feel free to
customize other properties:

●

Presets: This option provides you with eight default shadow effects, namely, Top Left,
Top, Top Right, Bottom Left, Bottom, Bottom Right, Right, and Left.

●

Blur Radius: Set the blur radius of the shadow in pixel unit (0-50). The larger the value,
the fuzzier the shadow. The smaller the value, the sharper the shadow.

●

Angle: Enter a number (0-3600) in the spin box. Changing this value will lead to the change
of the shadow position.

●

Distance: Set the distance from the shadow to the shape in the range of 0-300 pixels.

●

Color: Change the color of the shadow.

●

Opacity: Adjust the transparency of the shadow (0-255). The zero value indicates full
transparency. Meanwhile, the maximum value displays full color.

Opacity Section
The Opacity option exists in all the above sections. It lets you customize the transparency of each
separate property of the object like fill, line, and shadow. For example, the Opacity option in the
Fill section helps you adjust the transparency of the object color, either solid or gradient color.
However, if you fill the object with an image, this option is unavailable. Let’s take another example.
What if you want to adjust the transparency of text captions? In those cases, the Opacity section
will come in handy. It lets you adjust the transparency of the whole selected object:
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By default, the Full Opacity option is enabled. Select the Custom Opacity option if you want to
customize this property. Then, feel free to adjust the value by dragging the slider or specifying a
value in the spin box. If the value is 0, the whole selected object becomes transparent. Increasing
this value will make it more apparent.

Size & Properties Tab
Unlike the other ones, the Size & Properties tab is available for all object types. However, below
are 6 popular sections that you will frequently work with:
•
•
•
•
•
•

Timing Section
Transform Section
Container Layout Section
Text Box Section
Show in Mode Section
Accessibility Section

Timing Section
This section defines when and how the selected object starts/stops displaying in the presentation.
●

Start Time: Normally, when you insert a new object (without Playhead), its start time is
also the slide’s start time (0:00.000). There are two ways to adjust this value. First, you
can change it in the Start Time spin box. Alternately, you can drag the left edge of its time
bar in the timeline.
If you do not want the object to appear at the beginning of the slide, you can set another
value right from start. Just place the Playhead at the desired timestamp in the timeline.
Then, insert a new object. The timestamp where the Playhead is located is the start time
of that object.

●

Duration: The total time the object is present on the slide. This option is not set by default.
That means the object appears until the end of the slide. You can adjust this value by
deselecting the Show to the End of Slide checkbox. As a result, the Duration spin box
is enabled and lets you change the value. Keep in mind that another way to change the
object duration is to drag its time bar in the timeline.

●

Initially Hidden: If you select this option, the selected objects will not appear in the
presentation until they are called by an event. See Initially Hidden Objects for more
information.

●

Show to the End of Slide: This checkbox is selected by default. That means the object
will appear until the end of the slide. Click to untick this checkbox. Or, dragging the object
time bar will clear it automatically.
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Transform Section
This section defines the size and position of the frame that is used to define the object.
●

Left: Left edge of the frame.

●

Top: Top edge of the frame.

●

Width: Width of the frame.

●

Height: Height of the frame.

●

Rotation: Rotate the object by a specified degree in slide coordinates. The rotation center
is the center point of the frame that is used to define the shape.

●

Lock Aspect Ratio: Keep the ratio between the width and the height of the frame
unchanged when resizing the frame.

●

Exclude from Container Layout: Define whether an object can be excluded from the
container layout or not. The container layout can be flex or grid layout.

●

Restore Original Size: Restore the initial size of Image and Video objects.

Container Layout Section
The Container Layout section only displays when you select:

•
•
•

A slide;
A group of objects;
An answer area of a question (except for Fill in Text Entry, Fill in Blanks, Essay, and Select
in Dropdown). In this case, the answer area is considered as a group of text box objects.

There are three modes for choosing:
•
•
•

None: Allow you to freely change the position/ size of any object.
Flex: Align objects in a horizontal or vertical direction. You can change the position/ size
for each object separately. See Customize Flex Child in Flex Container to know more.
Grid: The objects’ position is fixed. You cannot change the position/ size for each object
separately. You can only change the position/ size for the whole grid container.

Text Box Section
This section defines the minimum margin between the frame and the text inside it.
●

Left Margin: Minimum margin on the left side.

●

Right Margin: Minimum margin on the right side.

●

Top Margin: Minimum margin on the top side.

●

Bottom Margin: Minimum margin on the bottom side.

Show in Mode Section
As you may know, ActivePresenter allows you to run interactive presentations in four operation
modes, including Demonstration, Tutorial, Practice, and Test. The Show in Mode section
allows you to show or hide the selected slides or objects in different modes. You just need to
select or deselect the corresponding checkboxes.
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Accessibility Section
This section features some properties that make the objects accessible to users with disabilities
when viewing the project output.
●

Text Selection: Allow users to select the text of the object in the HTML5 output.

●

Auto Label: Generate accessibility text automatically from the text that the object displays,
or from the object name if it doesn’t contain any text. If you clear this checkbox, the
Accessibility Text text box will appear. Type text in this box. When the slide is shown,
screen readers will read aloud the accessibility text in the text box. If you don’t want screen
readers to read anything, leave this text box blank.

Other Sections
Apart from the six sections above, depending on the selected object type, you will see the other
sections:
•
•
•
•
•
•
•
•
•
•
•
•

Gesture Effects Section: Appear when the selected object is a gesture effect. It allows
you to change the type, color, and opacity of gesture effects.
Image Section: Appear when the selected object is an image. It lets replace the current
image with the new one.
Crop Section: Appear when the selected object is an image or a video. It features some
properties to help you crop an image or a video.
YouTube Section: Appear when the selected object is a YouTube object. It allows you to
change the object name, edit the link, specify playback options, adjust the start time and
the end time of the YouTube video.
Web Object Section: Appear when the selected object is a web object. In this section,
you can change the name, edit the address, specify the scrolling and scaling behaviors of
web objects.
3D Model: Appear when the selected object is a 3D model. It lets you change the 3D
model source. In addition, with animated 3D models, you can customize other properties
such as scenes, duration, and playback options.
Slider Section: Appear when the selected object is a slider. It helps you to adjust the
slider values including min, max, initial, and step. Plus, you can use variables to make the
slider work as you wish.
Cursor Section: Appear when the selected object is a cursor. In this section, you can
change the cursor image, apply a style to all cursor objects, adjust timing and click point.
Cursor Path Section: Appear when the selected object is a cursor. If you want to change
the cursor effects (click sound, click effect, size, color, opacity), this section will come in
handy.
Position & Zoom Scale Section: Appear when the selected object is a zoom-n-pan. As
its name implies, it lets you change the position and size of a zoom-n-pan object.
General Section: Appear when the selected object is a closed caption. In this section,
feel free to add multiple languages for closed captions.
Caption Section: Appear when the selected object is a closed caption. Refer to this
section to adjust its timing and convert closed captions to speech.

Interactivity Tab
The Interactivity tab has five sections (General, Dropdown, Score & Reporting, Drag-n-Drop,
Events – Actions). It supports you in creating interactive projects.
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General Section
The General section lets you customize the common properties of the slides or objects. Depending
on the different object types that you select, you will see some or all of the properties below:
●

Name: Show the current name of the selected object. You can type text here to rename
it. When an object is renamed, its name will also change in the Timeline pane and the
Selection pane.

●

Cursor: Change the cursor shape when viewers hover the mouse over an object. You can
let the cursor display in the default shape or change it to other ones. You can also set the
cursor image of your own by selecting an image from the current project or your computer.
Select None if you don’t want to show the cursor.

●

Tab Order: Allow specifying the tab order for objects. It is the order in which users move
from one object to another by using the TAB key. There are four options to choose from:
○

Focusable Only: Only selected objects can receive focus. However, the TAB key
cannot be used.

○

Auto: Objects will be automatically ordered. When the TAB key is pressed, objects
will be selected randomly.

○

Specific Value: Define a specific order for an object. When the TAB key is pressed,
objects will be selected in the order you’ve set.

○

None: Select this if you don’t want to give objects in any tab order.

●

State View: Click to open the Object States pane.

●

Retain State: If this box is checked, the object will retain its last state when users revisit
the slide (in HTML5 output). If it is unchecked, the object will reset to its normal state.

●

Show Toggle Button: For the objects that contain toggle buttons like radio buttons or
checkboxes, you can choose to show or hide them. Clearing this option will make the
toggle buttons invisible to users.

●

Pause presentation to wait for user input: If this checkbox is selected, all the objects
stop playing. The presentation resumes when one of the defined actions is executed.

●

Just before hiding object: Pause the presentation before the selected object disappears.
In case this checkbox is deselected, you can decide to pause the presentation after
showing the object for n second.

●

Correct Values: Allow setting the correct answer list for:
o
o
o
o
o
o

Fill in Text Entry Question
Fill in Text Entries Question
Essay Question (applied for the Graded mode only)
Text Entry object
Mouse Click object
Key Stroke object

Click the Add Value button and type text in the box, click the mouse button, or press a
key or a combination of keys to define the correct value. Keep doing that until you have
the desired list of correct answers. When you want to delete any value in the answer list,
click the Remove button .
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Dropdown Section
This section appears when the selected object is a dropdown. It allows you to create and manage
the item list. See Adding Lists of Items to Dropdown for more information.

Score & Reporting Section
This section only appears when you select interactive objects or the answer area of questions.
●

Mode: Except for the Rating Scale (Likert), the other question types let you select between
the Graded or Survey mode.

●

Report ID: This checkbox is selected by default with a unique reference number. You can
change this number as you wish. Note that only text that contains alphanumeric characters
(A-Z, a-z, 0-9) and underscore (_) is allowed (maximum length = 250 characters).

●

Shuffle Answers: Allow shuffling answer options of a question. This property only
appears when you are working with certain types of questions: True/ False, Multiple
Choice, Multiple Response, and Drag-n-Drop.

●

Points: Allow learners to get a predefined point if they give a correct answer to a question.
Enter a specific number in the spin box or choose one from the Points list. If you select
Partial, it lets you assign points to each answer option of a question. Just select each
answer option. Then, navigate to the Properties pane > Interactivity tab > Score &
Reporting section > Points > enter a number in the spin box. Thanks to that, learners
can get scores depending on the number of correct values they select. This also applies
for interactions objects.

●

Attempts: Set the maximum number of attempts that users could make. If exceeding the
predefined number, users could not interact with objects anymore. If you select Infinite,
there is no limit to the number of attempts that users could make.

●

Timeout (ms): Let you specify the time limit. If this checkbox is selected, when the timeout
occurs, objects will be disabled.

●

Password Field: When this checkbox is selected, entered characters will be displayed as
asterisks. It is only available for Text Entry, Fill in Text Entry, and Fill in Text Entries
questions.

●

Case Sensitive: Uppercase and lowercase letters are treated differently if this option is
selected. It is only available for Text Entry, Fill in Text Entry, Fill in Text Entries, and
Fill in Blanks questions.

●

Submit: Select the method to submit entered/selected text. This option is only available
for Text Entry, Dropdown, Fill in Text Entry, and Select in Dropdown questions.

●

Variable: Select the variable which is associated with the text box. The value of the
variable will be updated following the content in the text box.

Drag-n-Drop Section
This section helps you to convert normal objects to drag sources or drop targets. By default, the
None mode is selected.
If you select Drag Source, the following properties will be enabled:
•

Effect: Set the effect for a drag source:
o None: No effect happens when learners drag a drag source.
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o Zoom: The drag source will be zoomed in when learners drag it.
o Highlight: The drag source will be highlighted when learners drag it.
Revert: Selecting this checkbox means that a drag source will be sent back to its original
position if:
o Learners drop it outside a drop area.
o Learners drag a wrong drag source into a drop area.

If you select Drop Target, refer to Setting Correct Values and Setting Other Properties to
know how to adjust available properties. Besides, drop targets also have the following properties:
Accepts: Specify the number of drag sources that can be accepted by a drop target. The default
value is Infinite. Yet, it’s possible to use the finite value from 1 to 10. In this case, you can define
what happens when users reach maximum acceptance:
●

Reject: The drop target doesn’t accept the new dropped object. The dropped object is
sent back to its original position, and the On Reject event is triggered.

●

Replace the Last: The last dropped object is sent back to its original position, and the
new dropped object is accepted. Of course, the On Accept event is triggered in this case.

Events - Actions Section
The Events – Actions section helps you make your content more interactive. For example,
clicking on an object to play an audio, hovering the mouse over it to highlight another objects, or
dragging it to a new position. An event is used to trigger actions. In other words, when an event
happens, one or more actions are triggered in response to that event.
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For detailed steps to create events – actions, refer to this section.

Audio Tab
The Audio tab is used to attach sound to objects such as shapes, text captions, etc. The sound
plays when the object starts showing. In general, this tab has the same structure and functions
as those of the Audio section in the Media tab, except the Playback Options section.
To view this contextual tab, select an object > Properties pane > Audio tab
sections including General, Recording, Text to Speech.
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General
In this part, you can attach an available audio file to an object. To do that, click
button to select
audio from the current project. Or, click
button to import an audio file from your computer. Click
button to delete the unwanted audio. After that, you will see the name of the audio file in the
Source box and its duration. There are also playback buttons to play or stop playing the audio.

Recording
This part lets you record your own audio track and attach it to an object.
To record the sound, do the following:
1. Select a device from the Input Device drop-down list.
2. Click the Record button

to start recording.

3. Click the Volume control button
4. Click the Stop button

to adjust the recording volume.

to finish the recording.

Note: You can calibrate the input volume of the microphone before starting the recording to
make sure that the sound level is strong enough. To do this, click Calibrate Input… and scale
the input volume in the dialog that appears.

Text To Speech
This part provides you with an alternative source of sound, which is text-to-speech. By default,
the Use Object Text checkbox is selected. That means ActivePresenter copies the text of the
object into this box. However, it also allows you to edit the text directly. When you make changes
to the text in this box, the Use Object Text checkbox is automatically clear:

1. Select an available voice from the Voice drop-down list or click More Voices…
2. If you want to enhance your output speech with SSML tags, select the SSML checkbox to use
SSML-supported voices.
3. Click Speak to listen to the voice and click Stop to stop listening.
4. To adjust the TTS settings, click the Settings button. The following dialog will appear:
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Adjust the voice, speed, and volume, and click Speak to listen to the voice.

•
•
•
5.

If the results are not OK, change the parameters and try again. Repeat the cycle until
you are satisfied.
If your settings are not good enough, click Reset and start over.
When you are satisfied, click OK to close the dialog.

Click Generate to perform the conversion.

When you attach audio to an object, the object duration can be shorter than the audio duration.
In that case, ActivePresenter will open a dialog to ask whether you want to extend the object
duration to match the new audio:

You can also make further adjustments in the Preferences dialog to always extend the object
duration so that it can match the audio duration. Click the ActivePresenter button > Preferences
> Miscellaneous > select Yes in the Extend object duration to match the duration of
generated audio section > click OK.

Media Tab
The Media tab is only displayed if you select a media file (video/audio) in your project. If you
select a video file, the Media tab will show the Video section. On the other hand, when you select
an audio file, the Audio section will be shown.
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Audio Section
a. General
This part shows the name and source of the audio file and its duration. It also contains playback
buttons to control the audio playing.
●

Click
to select audio from the current project or click
computer.

●

Click the Remove button

to import an audio file from your

to delete the audio from the object.

b. Recording
This part allows you to record your own audio track. Refer to the Recording for more detailed steps.

c. Text To Speech
This part features the same properties as the Text to Speech section of the Audio tab.

d. Playback Options
This section provides options to control how the audio is played. These options are available only
for audio objects, not for the audio files attached to other objects types.
●

Loop: Make the audio start playing again when playback is finished. When the Playhead
reaches the end of the audio, it will return to the start point and continue playing. This
feature is especially helpful for adding background music to a project.

●

Autoplay: Make the audio play automatically when the slide loads and the Playhead
reaches the start point of the audio time bar.

●

Show Media Controls: Display a media players bar for the audio in the HTML5 output,
which allows users to control the playback.

●

Background Music: Make the audio file play as the Background Music for the
presentation. That means the audio continues playing when the presentation is paused to
wait for user input.

Video Section
a. Video
●

●

General: Show the name and source of the video file and its duration:
○

Click
to import a video from the current project or click
your computer.

○

Click the Remove

to import a video from

button to delete a video from the object.

Playback Options: Allow you to define the playing mode of the video:
○

Loop: Make the video replay continuously. When the Playhead reaches the end of
the video, it will return to the start point and continue playing.

○

Autoplay: Make the video play automatically when the slide loads and the Playhead
reaches the start point of the video time bar.

○

Show Media Controls: Display a media players bar for the video in HTML5 output,
which allows users to control the playback.
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HTML5 Closed Caption: Allow you to embed/attach subtitle files into a video for
displaying in the HTML5 output.

b. Cursor Effects
This section is used to change the cursor effects for the recorded videos.

c. Green Screen Effect
This section allows you to apply the green screen effect for videos.

d. Blur Effect
This section is activated only if your video has a blur effect.

Chart Tab
This newly added tab in ActivePresenter 9 only appears when a chart is selected. This tab has
only one section – the Style section. However, keep in mind that its properties may vary
depending on each chart type. To learn how to work with these properties of different charts, refer
to Customizing Chart Styles.

Table Tab
Similar to the Chart tab, the Table tab is available only when a table is selected. This tab has five
sections (Style Options, Shading, Table Background, Border, and Cell Size) with many
options to customize the properties of tables. Take a look at Modifying Tables, Columns, Rows,
and Cells for detailed information.

3D Model Tab
This is also a newly added tab in ActivePresenter 9. The tab has three sections including 3D
Model, Model Rotation and Camera to help you customize 3D models. To learn how to adjust
each property in this tab, please refer to Customizing 3D Models.
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Resources Pane
This pane contains all the resources that are available in the current project. If the Resources
pane doesn’t appear when you open your project, click the View tab > Resources . It has three
tabs placed respectively at the bottom:
•

Images: Contain all image resources in the current project.

●

Audio & Video: Contain all audio and video resources in the current project.

●

Other Resources: Contain other resources in the current project.

There are some different ways in which resources get into a project, being shown in the
Resources pane:
●

●

Resources added by users:
○

Audio files by inserting, recording narration, or using Text to Speech.

○

Video files by inserting or recording.

○

Image files by inserting or capturing.

○

Other resources by using a hyperlink or the Resources menu in the player, inserting
3D models.

Logical resources created by certain operations: Audio/video splitting, audio/video
range editing, slide splitting.

Images Tab
The Images tab has the Toolbar and Preview section. The Toolbar section contains buttons for
managing image resources:
Button

Function
Select to view images either as thumbnails or items.
Add an image from the computer (or LAN, etc.).
Select the unused images in the current project.
Remove the unused image(s) in the current project.
Export an image to a file.
Launch the image editor and load the image in it.
This button triggers the Image Resource Properties dialog.
You can also double-click the image thumbnail (or item) to open this dialog.
Toggle the Slide Background’s visibility in the Images tab.
Toggle the Object Background’s visibility in the Images tab.
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Toggle the Cursor’s visibility in the Images tab.
The Preview section shows images either as thumbnails or items. The currently selected images
have dark blue borders. You can directly drag any resources from here into the Canvas for use.

Audio & Video Tab
The Audio & Video tab also has the Toolbar and Preview section. The Toolbar section contains
icons to manage the audio and video resources. The buttons work as follows:
Button

Function
Select to view audio/videos either as thumbnails or as items.
Add an audio/video clip from the computer (or LAN, etc.).
Select the unused audio track(s)/video(s) in the current project.
Remove the unused audio track(s)/video(s) in the current project.
Export (save) the media as a file.
This button triggers the Audio/Video Resource Properties dialog.
Double-click an item to get the same result.
Toggle the Audio’s visibility in the Audio & Video tab.
Toggle the Video’s visibility in the Audio & Video tab.

The Preview section shows audio/videos either as thumbnails or as items. The currently selected
resource has a dark blue border. You can drag any resources from here into the Canvas for use.

Other Resources Tab
The Other Resources tab also has the Toolbar and Preview section. The Toolbar section
contains icons to manage the resources. The buttons work as follows:
Button

Function
Select to view resources either as thumbnails or as items.
Add a resource from the computer (or LAN, etc.).
Select the unused resources in the current project.
Remove the unused resource(s) in the current project.
Export (save) the media as a file.
This button triggers the Rename dialog. Double-click an item to get the same result.
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Toggle the other resources’ visibility in the Other Resources tab.
Toggle the 3D model’s visibility in the Other Resources tab.
The Preview section shows the resources. The currently selected resource has a dark blue border.
The commands such as inserting a resource into slide, importing/exporting a resource, removing,
selecting unused items, and opening the resource properties can also be found from the context
menu. Just right-click a resource and select the desired command.

Resource Properties Dialog
Image Resource Properties Dialog
You can open this dialog by double-clicking an image item in the Images tab of the Resources
pane. Alternatively, you can click the Properties button in the Resources pane.
This dialog has only one tab which is the General tab:

•
•
•

Name: Show the name of the image. You can rename it without affecting any functionality.
Type: This section lets you select the type of image. You can tag it as Slide background,
Object background, and/or Cursor.
Cursor Hotspot: This section is enabled when the Cursor checkbox is selected. It defines
the cursor hotspot for the Cursor resource type.

Audio Resource Properties Dialog
You can open this dialog by double-clicking an audio item in the Audio & Video tab of the
Resources pane. Alternatively, you can click the Properties button in the Resources pane.
The dialog has two tabs including General and Details:
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The General tab provides you with general information about the audio such as its name,
duration, format, and data size. You can rename the audio as you wish. It also lets you
preview the audio.
In the Details tab, you can find more detailed information about the audio including sample
rate, bit rate, and channels.

Video Resource Properties Dialog
You can open this dialog by double-clicking a video item in the Audio & Video tab of the
Resources pane. Alternatively, you can click the Properties button in the Resources pane.
It also has two tabs which are General and Details:

•
•

The General tab contains general information about the video such as video name,
duration, format, and data size. You can rename the video if needed. You can use the Play
button
or Stop Playing button
to preview or stop previewing the video respectively.
The Details tab displays more detailed information about the video including:
o Audio sample rate, bit rate, channels.
o Video frame rate, bit rate, size.
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Selection Pane
The Selection pane shows all the objects in a selected slide by their stack order (z-order). The
pane is hidden by default. To show it, in the View tab, click the Selection button
.

You can do the following tasks in the Selection pane:
1. Select objects: When a slide has many overlapping objects, it can be tricky to select them for
editing on the Canvas. To make it simple, click a line in this pane to select the desired object.
Hold down CTRL while clicking each line to select multiple objects. It is also possible to
select a range of objects. To do that, click the first object of the range. Then, hold
down SHIFT while clicking the last object. All the objects between the first and the last will
also be selected.
Select one or multiple lines, then, right-click them, you can use one of the following
operations: Cut, Copy, Duplicate, Delete, Select All, Bring to Front, Bring Forward,
Send to Back, Send Backward, Lock, Lock Size and Position, and Hide.
2. Rename objects in the Selection pane: Double-click a line in the Selection pane and type
a new name. Giving objects unique names can be helpful when you are adjusting their
timing values in the timeline or writing a custom script that refers to the object by name.
3. Turn visibility state on or off: The Visibility button
controls whether to display the object
on the Canvas. Click it to toggle the object state. An eye-slash
means the object
becomes invisible. The best use of this control is to hide an object to edit the overlapped
object easier.
Note that this control is applicable only during editing; not during playback. It also doesn’t
affect the output when exporting. The objects which are hidden by this command still
display normally in the exported materials.
The Master Visibility button

in the first line toggles the visibility of all the objects at once.

4. Lock or unlock objects: The Lock button

controls whether you can edit the object. Click
this button to lock or unlock objects. A closed lock
means that the object is “locked”.
You cannot select it by using any pane and you cannot edit it.
The Master Lock button

in the first line toggles the lock status of all the objects at once.

5. The Expand/Collapse button
is available for a group of objects. It controls whether to
display sub-objects. You can press RIGHT ARROW or LEFT ARROW to get the same result.
6. You can press the UP ARROW or DOWN ARROW to navigate between objects in the
Selection pane.
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7. You can drag and drop objects to change their z-order in the Selection pane.

Calibrate Audio Input Dialog
The Calibrate Audio Input dialog allows you to select an appropriate level of input volume for
recording audio.

There are three ways to open this dialog:
•
•
•

When you record screen: In the Record Screen as a Video Project or Record Interactive
Simulation Project dialog > click the Settings button > select Calibrate Audio Input…
When you record narration: In the Recording Options dialog > click Calibrate Input…
In the Properties pane of an audio object > Media tab > Recording section > click
Calibrate Input…

You can calibrate audio in two different modes:

Manual Calibration
●

Keep the microphone in its normal position.

●

Click the

●

At the same time, move the slider to the right and increase the gain till the LED bar on the
right shows yellow bars intermittently. If the bar starts showing red LEDs, move the slider
a bit to the left (otherwise the voice will be clipped).

●

When you are satisfied with the audio level, click the

●

Now, click the
button to play your recorded voice. If the sound has any defects (e.g.
breathing noise), take care of the problem and repeat steps 1-4. Or you can use the Audio
Noise Reduction feature in ActivePresenter.

button and speak something into your microphone.

button to stop the calibration.

Automatic Calibration
●

Click the Auto Calibrate button and use the microphone normally.
The Auto Calibrate button turns into the Stop Calibration button which you can click
when you want to stop the calibration.

•

Continue speaking so that ActivePresenter can automatically optimize the gain.
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After a few seconds, the button reverts to the Auto Calibrate button. This indicates that the
calibration is over.
Regardless of the calibration method, the volume adjustment is accepted only when the OK
button is clicked. If you click the Cancel button, the new value will be discarded and the old value
still is applied.

Recording Settings Dialog
When you record a screen as a video or software simulation, ActivePresenter provides the
Recording Settings for Video and Recording Settings for Software Simulation dialog
correspondingly so that you can have settings for the audio/video/webcam quality and storage size.
Both dialogs have three tabs: Audio & Video, Cursor, and Hotkeys tab. However, the
Recording Settings for Software Simulation dialog has one more tab - the Annotation tab.

Audio & Video Tab
This tab contains three main sections:
•
•
•
•

Video Settings
Audio Settings
Advance Screenshot Capture (only for the Recording Settings for Software
Simulation dialog)
Webcam Settings (only for the Recording Settings for Video dialog). Webcam settings
are mentioned separately.
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Video Settings Section
●

Video Codec: ActivePresenter offers two options:
o
o

●

H.264/MPEG-4 AVC (lossy): If you select the H.264 codec, ActivePresenter
down-samples the video data, resulting in the reduction of file size but at the cost
of irreversible loss of video detail.
Flash Screen Video (lossless): When this option is selected, ActivePresenter
uses the lossless algorithm in encoding to preserve the quality.

Frame Rate: You can set the value in the range of 1 and 60. A higher frame rate can
increase the size of the recorded video. It may also overload simpler computers because
the computer not only has to run all the applications but also captures those screens in
real-time. In the worst case, you will see dropped frames in the captured video.
On the other hand, a lower frame record will appear jerky. This particularly happens with
the rates which are lower than 15 frames/s. Besides, you may miss capturing some lowduration events (something that just flashes on screen and vanishes).
The most commonly used range is 20-30 frames/s.
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●

Quality: When you select H.264/MPEG-4 AVC, ActivePresenter allows you to set this
value in the range of 1 and 100. The higher the number you select, the better the video
quality and the larger the file size.

●

Use Direct3D for recording screen: ActivePresenter may record screen with a very high
frame rate without overloading.

Audio Settings Section
●

Audio Codec: ActivePresenter offers three audio codecs including:
o
o
o

16-bit PCM (lossless): When this codec is selected, ActivePresenter uses the
lossless algorithm in encoding to preserve the quality.
AAC (lossy)
Vorbis (lossy)

When you select AAC or Vorbis codec, ActivePresenter uses the lossy algorithm in
encoding, resulting in the reduction of the file size and the irreversible loss of audio
quality.
●

Sample Rate: The incoming analog sound is initially converted to digital form and stored
in the disk. This digital sound isn’t a replica of the original, sometimes fidelity is lost. The
fidelity of the digital sound depends on the Sample Rate and Bit Rate. This means that
the higher the sampling and bit rate, the better the fidelity. However, higher fidelity also
increases the file size, which means more data needs to be stored.

●

Channels: Choose from Mono or Stereo channels. Unless you are opting for a studiorecorded soundtrack, the Mono channel is sufficient. (During playback, the sound card
feeds the same sound in left and right channels). Stereo recording needs to double the
storage size as compared to Mono.

●

Quality: ActivePresenter allows you to select a quality level between 1 (min) and 100 (max).
The higher the number you select, the better the audio quality and the larger the file size.
This option is only available if the ACC or Vorbis audio codec is selected. The reason for
that is ActivePresenter encodes the ACC or Vorbis audio in constant quality mode.

Advance Screenshot Capture
From ActivePresenter version 8, this section is placed at the bottom of the Recording Settings
for Software Simulation dialog. By default, its duration is 500ms. This means, half of a second
before you click a button, ActivePresenter will take a screenshot. You can change the value in
the range of 0 and 3000. Directly enter a specific number in the spin box. Or, just click the up or
down arrow to change the duration as you want.

Cursor Tab
The properties in the Cursor tab apply to both the cursor in recorded videos and the cursor of the
cursor path object. The Cursor tab contains the following sections:
•
•
•
•

Cursor Settings
Cursor Path
Cursor Effects
Automatic Panning
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Cursor Settings Section
●

Record Mouse Cursor: Commonly, you want to record the cursors in a software
demonstration video, so this option is selected by default. If you don’t want cursors to
appear in the recorded result, clear this checkbox.

●

Exclude Layered Windows While Recording to Reduce Cursor Flickering: When
recording screen as videos or creating software simulations, some layered windows may
appear on the screen. In that case, ActivePresenter will exclude those windows that you
don’t want to record.

Cursor Path Section
●

Real Movement: The mouse movements on the screen will be recorded truthfully.

●

Simplified - Straight: The mouse movements on the screen will be recorded and saved
as straight.

●

Simplified – Curved: The mouse movements on the screen will be recorded and saved
as curved lines.
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Note that this section is only available in recording software simulations.

Cursor Effects Section
●

On: The mouse movements on the screen have full effects.

●

Off: The mouse movements on the screen have no effects. This option is selected by default.

●

Theme Settings: The mouse movements on the screen have effects depending on the
custom theme.

Automatic Panning Section
●

Make Capture Window Follow Mouse Cursor: When this option is selected, the blue
rectangle follows the mouse pointer around the screen. As long as the pointer is within the
blue rectangle, the frame doesn’t move. But when the mouse pointer crosses any side of
the frame, the frame starts following it.

●

Panning Speed: Set the speed (in pixels/s) at which the frame will start following the
mouse pointer. Note that very high speeds are unsettling for users, because the small blue
rectangle presents a blinkered view, to begin with, and at high pan speeds, users won’t
realize which area of the screen you are at.

Annotation Tab
This tab controls the annotations and interactions that are automatically added during the
capturing. (These are distinct from the annotations and interactions added during the editing of
the captured project.)
Note that the Annotation tab is only activated when you record software simulations. When you
record a video, this tab is deactivated.
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The Annotation tab has two main sections, one for the mouse and the other for the keyboard.
Both have identical options as follows:
Annotation: Introduce an annotation (mouse/key) that is about to occur or to guide learners on
how to operate. Annotation is usually used for demonstrating and training.
Correct Message/Incorrect Message/Hover Message: Correct, Incorrect, and Hover
messages are feedback objects. ActivePresenter presentations can provide feedback on user
actions when they interact with the HTML5 (in Tutorial, Practice, or Test mode; but not in
Demonstration mode).
●

The Correct message is displayed if the users’ action is correct.

●

The Incorrect message is displayed if the users’ action is incorrect.

●

The Hover message is displayed when users hover the mouse over the interaction object
(e.g., mouse click, key stroke).

Place Annotation inside Active Window Area: Let you place all the annotations that are
automatically added during the capture inside the active window area.
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Hotkeys Tab
The Hotkeys tab lets you set the keyboard hotkeys for various functions.
The image below shows the Hotkeys tab when you record Software Simulations. If you record
screen as a video, this tab doesn’t have four last options: Manual Capture, Capture For Next
Slide, Start Full Motion Recording, and Stop Full Motion Recording.

Select Use Hotkeys to enable all the options below. Otherwise, clear it if you want to disable all
of them.
To change any hotkey, just click inside the box corresponding to it, and press the new combination
of keys on your keyboard. The new combination doesn’t take effect until you click the Save button.
The Capture For Next Slide function is similar to the Manual Capture function except the
captured screenshot will be used as background for the next steps. This function may be useful
in some circumstances, for example when you want to capture a button in the normal state, not
in the hover state.
The Restore Defaults button at the bottom brings back all the default values. This is useful if you
have experimented with the controls far too much and want to start over.
To know more in detail about hotkeys and how to customize them, see Hotkeys Tab.
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Webcam Settings Dialog
Format Settings

You can change the following settings:
●

Color Space: Select the type of color space that the device supports.

●

Frame Rate: Change the recording frame rate for the webcam. A higher value will make
the motion in the video smoother but larger file size.

●

Output Size: The dimension of recorded video.
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Menus, Toolbars and Hotkeys
ActivePresenter Main Menu
ActivePresenter main menu appears when you click the ActivePresenter button at the top-left
corner of the application window. This menu is similar to the File menu, commonly seen in the
top-left corner of Microsoft Office programs.
The main menu provides access to all common file operations, configuration settings, and a list
of recently opened projects.

Icon

Command

Hotkey

Function

Blank Project

Create a new project using the blank theme.

Record Screen as
Video

Record the screen as a new video project.

Record Interactive
Simulation

Record an interactive simulation as a new project.

Responsive Project

Create a new responsive project.

Import PowerPoint

Create a new project from a PowerPoint
presentation.

Open Project...

CTRL+O

Open an existing project on your computer.

Save

CTRL+S

Save the current project.

Save As...

Save the current project under a new name and
different types.

Close

Close the current project.

Project > Properties

Open the Project Properties to view and edit
general information about the current project.

Project > Convert to
(Non-)Responsive
Project…

Convert from a non-responsive project to a
responsive one or vice versa.

Project > Shrink…

Make a project compact.
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Project > Batch
Operations > Insert
Objects…

Insert an object type into multiple slides at once.

Project > Batch
Operations > Delete
Objects…

Remove an object type from multiple slides at
once.

Project > Batch
Operations >
Convert Closed
Captions to Audio

Convert closed captions to audio in specified
slides or all slides in your project.

Project > Batch
Operations >
Generate Slide
Name From First
Shape

Find the first shape in the slide and use its text for
the slide name.

Project > Localize

Localize a project to another language.

Recent Projects

Open a list of recently opened projects.

Preferences

View and edit the global settings.

Start Page

Open the Start Page.

Exit

Close the application.
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Quick Access Toolbar
The Quick Access Toolbar includes a set of commands which are independent of the tabbed
toolbar. This toolbar gives quick access to commonly used features like saving and opening. Note
that you cannot move or add commands to the Quick Access Toolbar.
Icon

Command

Hotkey

Create Blank Project

Function
Create a new blank project.

Open Existing
Project

CTRL+O

Open an existing project.

Save Changes

CTRL+S

Save the current project.

Undo Last Action

CTRL+Z

Reverse the last action. Click the Undo last
action button.

Redo Last Action

CTRL+Y

Restore the last “undo” action. Click the
Redo last action button.
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Home Tab
The Home tab is the first tab in the tabbed toolbar. It is selected by default whenever you launch
the application. This tab contains all common tools for inserting slides, formatting text, organizing
objects, etc.
Icon

Command

Hotkey

Function

Cut

CTRL+X

Remove the selected items and place them
on the clipboard.

Copy

CTRL+C

Copy the selected items and place them on
the clipboard.

CTRL+V

Paste the contents of the clipboard at the
current location. Adapt the copied contents to
match the destination theme.

Paste > Use
Destination Theme
(default)

Paste the contents of the clipboard at the
current location. Keep the original theme
format of the copied contents.

Paste > Keep Source
Formatting
Duplicate

CTRL+D

Duplicate the selected object(s).

Format Painter

Apply the format of the selected object or
slide to other(s).

New Slide

Insert a new slide into a project. Click the
arrow to select a slide.

Layout

Change the layout of the current slide. Click
the arrow to show the layout gallery.

Reset

Reset the position, size and format of the
slide placeholders to their default settings

Record Screen >
Record Screen as
Video

Record the screen as a new video slide.

Record Screen >
Record Interactive
Simulation

Record an interactive simulation as new
slides.

Font Name

Change the font of the selected text or objects.

Font Size

Change the font size of the selected text or
objects.
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Increase Font Size

CTRL+]

Increase the font size of the selected text or
objects.

Decrease Font Size

CTRL+[

Decrease the font size of the selected text or
objects.
Return the selected text or the text in the
selected objects to its default formatting.

Remove Format
Bold

CTRL+B

Make the selected text or the text in the
selected objects bold.

Italic

CTRL+I

Make the selected text or the text in the
selected objects italic.

Underline

CTRL+U

Underline the selected text or the text in the
selected objects.

CTRL+SHIFT
+S

Strike through the selected text or the text in
the selected object.

Strikethrough
Text Color

Change the text color of the selected text or
objects.

Highlight Color

Highlight the selected text or the text in the
selected object.

Subscript

Format the selected text as a subscript.

Superscript

Format the selected text as a superscript.

Insert Symbol

Insert a symbol into the selected text.

Insert Hyperlink

Insert a hyperlink into the selected text. You
can also link to a project resource (appears in
the Resources pane) or a file from your
computer. When you add a link to an external
file, that file will be attached to the course
player automatically.

Remove Hyperlink

Remove the hyperlink added to the selected
text.

Numbering

Add numbering to the selected text.
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Bullets

Add bullets to the selected text.

Decrease Indent

Make the selected text closer to the margin.

Increase Indent

Make the selected text farther away from the
margin.

Line Spacing

Adjust the amount of space between each
line in a paragraph.

Align Text Left

CTRL+L

Align the selected text or the text in the
selected objects left.

Align Text Center

CTRL+E

Align the selected text or the text in the
selected object center.

Align Text Right

CTRL+R

Align the selected text or the text in the
selected objects right.

Justify

CTRL+J

Justify the selected text or the text in the
selected objects.

Text Vertical Align

Align the selected text vertically.

Text Vertical Align >
Align Text Top

Align the selected text to the top of the
object.

Text Vertical Align >
Align Text Middle

Align the selected text to the middle of the
object.

Text Vertical Align >
Align Text Bottom

Align the selected text to the bottom of the
object.

Container

Insert preset layouts into a slide. Insert
groups of objects with grid/flex layout.

Shapes

Insert a shape into a slide. Click the arrow to
select a shape type.

Interactions

Insert an interaction object into a slide. Click
the arrow to select an interaction object type.

Equation

Insert an equation into a slide.

Arrange > Order

Change the order of the selected objects to
the front or back of others.
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Arrange > Group

Group the selected objects to create a new
group object.

Arrange > Align

Align the selected objects.

Quick Style

Quickly set the style (fill, line, shadow, and
text) of the selected objects.

Fill

Change the fill style of the selected objects.

Line

Change the line style of selected objects.

Variables

Create a variable.

Reference

Add a reference to a variable.

Find

CTRL+F

Find text.

Replace

CTRL+H

Find and replace text.

HTML5 Preview
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Insert Tab
In ActivePresenter, the Insert tab is the second tab in the tabbed toolbar. It allows you to insert
new slides together with all of the annotations, media, interactions, and misc objects.
Icon

Command

Function

New Slide

Insert a new slide into a project. Click the arrow to select a slide.

Container

Insert preset layouts into a slide. Insert groups of objects with
flex/grid layout.

Shapes

Insert a shape into a slide.

Text Caption

Insert a text caption to explain the content.

Spotlight

Insert a spotlight into a slide.

Equation

Insert an equation into a slide.

Icons

Insert an icon into a slide.

Gesture Effects

Insert a gesture effect into a slide.

Footer

Insert a footer into a slide.

Chart

Insert a chart into a slide.

Table

Insert a table into a slide.

Image

Insert an image into a slide.

Screenshot

Take a screenshot of windows, objects, the full screen, or an
application or region.

Audio

Insert audio from your computer or create an empty audio
object for recording or text to speech.

Video

Insert a video from your computer or by recording a webcam.
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YouTube

Insert a YouTube video into a slide.

Web Object

Insert a web object into a slide.

3D Model

Insert a 3D model into a slide.

Mouse Click

Insert a mouse click into a slide.

Key Stroke

Insert a key stroke into a slide.

Text Entry

Insert a text entry into a slide.

Drop Area

Insert a drop area into a slide.

Button

Insert a button into a slide.

Checkbox

Insert a checkbox into a slide.

Radio Button

Insert a radio button into a slide.

Slider

Insert a slider into a slide.

Dropdown

Insert a dropdown into a slide.

Animated Timer

Insert an animated timer into a slide.

Cursor Path

Insert a cursor path into a slide.

Zoom-n-Pan

Insert a zoom-n-pan into a slide.

Closed Caption

Insert a closed caption (CC).
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Questions Tab
The Questions tab allows you to insert all interaction objects and questions into slides.
Icon

Command

Function

True/False

Insert a true/false question.

Multiple Choice

Insert a multiple choice question.

Multiple Response

Insert a multiple response question.

Fill in Text Entry

Insert a fill in text entry question.

Fill in Text Entries

Insert a fill in text entries question.

Fill in Blanks

Insert a fill in blanks question.

Sequence

Insert a sequence question.

Drag-n-Drop

Insert a drag-n-drop question.

Hotspot

Insert a hotspot question.

Essay

Insert an essay question.

Select in Dropdown

Insert a select in dropdown question.

Select in Dropdowns

Insert a select in dropdowns question.

Rating Scale (Likert)

Insert a rating scale question.

Menus, Toolbars and Hotkeys > Questions Tab
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From File

Insert a question from a GIFT file (*.txt) and CSV file (*.csv).

Random Slide

Insert a random slide.

Event

Open the Properties pane > Events - Actions section to add
and manage actions.

Advanced Actions

Manage advanced actions.

Message

Insert a feedback message.

Report Slide

Insert a report slide.

Menus, Toolbars and Hotkeys > Questions Tab

455

ActivePresenter User Manual

Version 9.0

Design Tab
The Design tab allows you to apply a theme or color scheme, or format the slide background.
Icon

Command

Function

Themes gallery

Apply a theme to a project.

Colors

Change the color of the current theme.

Fonts

Change the font of the current theme.

Background Styles

Change the background style of the current theme.

Slide Size

Change the size of the slides in your project.

Transitions Tab
The Transitions tab contains a gallery of all slide transition effects. Use this tab to set up how a
slide appears.
Icon

Command

Function

Transition Gallery

Apply a transition effect to a slide.

Effect Options

Choose a variant of the transition.

Effect Duration

Specify the length of the transition.

Slide Duration

Specify the length of the slide.

Auto Advance

Jump to the next slide automatically when a slide completes.
If you disable this feature, use actions to advance slides.

Animations Tab
The Animations tab contains all animation effects that can be applied to objects.
Icon

Command

Function

Effect Gallery

Apply an animation effect (entrance/exit/emphasis/motion path)
to an object.

Effect Options

Choose a variant of the animation.

Start Time

Specify the time when the animation starts playing.

Menus, Toolbars and Hotkeys > Design Tab
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Duration

Specify the length of the animation.

Add Animation

Apply an additional emphasis/motion path to an object in the
main timeline, or apply effects of all types to an object in the
interactive timelines and Click Sequence timeline.

Menus, Toolbars and Hotkeys > Animations Tab
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Export Tab
The Export tab lets you export a project to many different output formats.
Icon

Command

Function

Images

Export slides as individual images.

Video

Export a project as a video.

PDF Document

Export a project as a PDF file.

Microsoft Word

Export a project as a Microsoft Word file.

Microsoft Excel

Export a project as a Microsoft Excel file.

Microsoft
PowerPoint

Export a project as a Microsoft PowerPoint file.

HTML5

Export a project as HTML5.

SCORM

Export a project as a SCORM package.

Experience API

Export a project as an Experience API package.

Publish LMS

Export a project and publish it to LMS.

Player Settings

Customize the HTML5 player.

HTML5 Preview

Preview a project in the browser.

Menus, Toolbars and Hotkeys > Export Tab
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View Tab
The View tab allows you to show or hide panes and toggle some useful features when working
on a project.
Icon

Command

Function

Slides View

Show slides view.

Slides in Column

Show slide thumbnails in the Slides pane in column.

Slides in Grid

Show slide thumbnails in the Slides pane in grid.

Slides in Titles

Show slide titles in the Slides pane.

Slide Master

Open the slide master view.

Feedback Master

Open the feedback master view.

Object Settings

Open the object settings view allowing setting default objects or
resetting default settings.

Timeline

Show/hide the Timeline pane.

Resources

Show/hide the Resources pane.

Properties

Show/hide the Properties pane.

Slides

Show/hide the Slides pane.

Selection

Show/hide the Selection pane.

Slide Pools

Show/hide the Slide Pools pane.

Object States

Show/hide the Object States pane.

Object Templates

Show/hide the Object Templates pane.

Menus, Toolbars and Hotkeys > View Tab
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Reset Pane Layout

Go back to the original window layout.

Gridlines

Show/hide gridlines on the Canvas.

Guides

Show/hide drawing guides on the Canvas.

Smart Guides

Enable/disable snap behavior on the Canvas.

Drag-n-Drop

Show/hide the markers that indicate drag sources, drop areas,
and drop targets along with the connection between them.

Tab Order

Show the tab order value of objects on the Canvas.

Timeline Snapping

Enable/disable snap behavior in the timeline.

Cursor Snapping

Make cursor paths move continuously between slides.

Container
Snapping

Enable/disable snap behavior in the container.

Fit on Preview

Fit the slide into the available Canvas area during the preview.

View Active
Window

Show/hide the active window area.

Edit Active
Window

Enable/disable editing the active window area.

Zoom

Set the zoom level of the Canvas.

Zoom Fit

Fit the slide into the available Canvas area.

Language

Set the GUI language.

UI Theme

Select the light theme or dark theme for the project.

Menus, Toolbars and Hotkeys > View Tab
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Help Tab
The Help tab provides access to the documentation, homepage, user community, and the current
version. It also helps activate or deactivate ActivePresenter and check for updates. Remember
that most of these commands are available on the Start Page.
Icon

Command

Function

User Manual

Launch the Help file.

Product Homepage

Launch the default browser to access the ActivePresenter
homepage.

Support Center

Launch the default browser to access the user forum/FAQ.

Activate Product

Enter the license information to activate ActivePresenter.

Deactivate Product

Deactivate ActivePresenter on your computer.

Check Updates

Check for available updates.

About

Provide information about the current version.

Format Tab
The Format tab is a contextual tab that appears when an object is selected. Use this tab to format
and organize objects.
Icon

Command

Function

Change Shape

Change the shape of the selected objects.

Quick Styles Gallery

Apply a built-in style to the selected objects.

Fill

Change the fill style of the selected objects.

Line

Change the line style of selected objects.

Shadow

Change the shadow style of the selected objects.

Menus, Toolbars and Hotkeys > Help Tab
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Order

Change the z-order of the selected objects.

Group

Group the selected objects to create a new group object.

Align

Align the selected objects.

Rotate

Rotate the selected objects.

Crop

Crop the selected images or videos on Canvas. This option is
only available when you select an image or video object.

Scenes

Change the animation scene of a 3D model.

Reset 3D Model

Reset the properties of a 3D model to the initial values.

Show Toggle Button

Hide/show the toggle button of checkboxes/radio buttons.

Checkbox/ Radio/
Slider/ Dropdown
Styles Gallery

Apply a built-in style to the selected checkboxes/ radio buttons/
sliders/ dropdowns.

Checkbox/ Radio/
Slider/ Dropdown
Border

Change the color and style of the border of checkboxes/radio
buttons/sliders/dropdowns.

Checkbox/ Radio Fill

Change the background color of checkboxes/radio buttons.

Checkbox/ Radio
Mark

Change the color of the check mark/radio dot when a
checkbox/radio button is checked.

Slider Track

Change the background color of slider tracks.

Slider
Thumb/Progress

Change the background color of slider thumbs and progresses.

Background

Change the background color of dropdowns.

Arrow Background

Change the background color of arrows.

Arrow

Change the color of dropdown arrows.

Quick Style

Change the style of checkbox/radio button/slider/dropdown
objects.

Menus, Toolbars and Hotkeys > Format Tab
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Table Tools Tab
The Table Tools tab is a contextual tab that appears when a table object is selected. Use this
tab to style a table.
Icon

Command

Function

Select Table

Select the entire table. Before that, click any cell in a table to
enable the Table group of the Table Tools tab.

Select Row

Select a row in a table.

Select Column

Select a column in a table.

Delete Rows

Delete selected rows.

Delete Columns

Delete selected columns.

Insert Above

Insert a row above the selected cell.

Insert Below

Insert a row below the selected cell.

Insert Left

Insert a column to the left of the selected cell.

Insert Right

Insert a column to the right of the selected cell.

Merge Cells

Combine two or more cells in the same row or column into a
single cell.

Split Cells

Divide a table cell into more cells.

Table Styles gallery

Apply a built-in style to the selected table.

Equation Tab
The Formula tab is a contextual tab that appears when you edit an equation. Use this tab to edit
and write equations.
Icon

Command

Menus, Toolbars and Hotkeys > Table Tools Tab
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Equation

Insert a built-in equation.

Symbols gallery

Insert a math-related symbol.

Structures gallery

Insert a structure.

Menus, Toolbars and Hotkeys > Equation Tab
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Drawing Tab
The Drawing tab is a contextual tab that appears when you edit (background) images (right-click
an image > Edit (Background) Image). This tab contains many basic photo editing.
Icon

Command

Function

Paste

Paste the contents of the clipboard at the current location.

Cut

Remove the selection and place it on the clipboard.

Copy

Copy the selection and place it on the clipboard.

Duplicate

Duplicate the selection.

Select Rectangle

Select a rectangle area by drawing on the Canvas.

Crop

Crop the image so that it contains only the selection.
Scale an image.

Scale Image

●

Image size: Specify the target width and height.

●

Lock ratio: Maintain the aspect ratio of the image.

●

Reset: Bring back the original size value.

●

Interpolation: Specify the algorithm used to scale an image
(Box, Bilinear, Bicubic, 4th order b-spline, Catmull-Rom
spline, and Lanczos3).

Box algorithm is the simplest one and usually gives the lowest
quality. Lanczos3 is an advanced algorithm with the best
quality and is commonly used in a popular image editor.
Menus, Toolbars and Hotkeys > Drawing Tab
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However, choosing the most suitable algorithm depends on the
image content, so you can use the try-and-error tactic to
choose the most suitable one.

Insert Image

Insert an image from your computer.

Auto Shape

Select a shape.

Rotate Right 90o

Rotate an image 90o to the right.

Rotate Left 90o

Rotate an image 90o to the left.

Flip Horizontal

Flip an image horizontally.

Flip Vertical

Flip an image vertically.

Antialias

Enable antialiasing to draw anti-aliased lines, smooth the
edges of objects.

Line

Draw a line.

Polygon

Draw a polygon. When you click at various spots, those points
are added to the current polygon. A double-click ends the
spline-creation mode.

Spline

Draw a spline. As you click at various spots, those points are
added to the current spline. A double-click ends the splinecreation mode.

Pencil

Draw freehand with a pencil.

Air Brush

Create spray with a color.

Eraser

Make an area on the image transparent.

Flood Fill

Fill the same contiguous colored area with the current fill color.

Text

Create rich text by using the text editor.

Menus, Toolbars and Hotkeys > Drawing Tab
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Blur

Blur the selected area.

Blur Radius

Specify the blur radius. The larger the radius, the more blurred
the image.

Pen Color

Select a pen color for painting or drawing.

Pen Opacity

Set the opacity level for a pen (0 means fully transparent, 255
means fully opaque).

Pick Pen Color

After selecting this tool, click any area on the image and the
pen tool will assume that color (hue and saturation) and
opacity.

Fill Color

Set the color filled inside a shape.

Fill Opacity

Set the opacity level for fill (0 means fully transparent, 255
means fully opaque).

Pick Fill Color

After selecting this tool, click any area on the image and the fill
color tool will assume that color (hue and saturation) and
opacity.

Line Width

Set the width of the outline of a shape or the pencil tool.

Line Style

Set the type of an outline of a shape or the pencil tool.

Zoom

Set the zoom level of the Canvas.

Zoom Fit

Adjust the zoom level automatically to fit the Canvas to the
available space.

Menus, Toolbars and Hotkeys > Drawing Tab
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Slide Master Tab
The Slide Master tab appears when you open the slide master view (View tab > Slide Master).
It contains commands for editing slide masters.
Icon

Command

Function

Insert Slide Master

Add a new slide master to a project.

Insert Layout

Insert a custom layout into a slide master.

Delete

Delete a custom layout.

Rename

Rename a layout.

Preserve

Preserve a slide master so that it won’t be deleted even if not
used.

Master Layout

Choose what to include in the master layout.

Insert Placeholder

Insert a placeholder into a custom layout.

Title

Show/hide the title placeholder on a custom layout.

Footers

Show/hide the footer placeholders on a custom layout.

Themes

Apply a theme to a slide master.

Colors

Change the color of the current theme.

Fonts

Change the font of the current theme.

Background Styles

Change the background style of the current theme.

Slide Size

Change the size of the layouts.

Close Master View

Exit the slide master view and go back to editing slides.

Menus, Toolbars and Hotkeys > Slide Master Tab
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Feedback Master Tab
The Feedback Master tab appears when you open the feedback master view (View tab >
Feedback Master). It contains commands for editing feedback masters.
Icon

Command

Function

Insert Layer

Add a new feedback layer to a feedback master.

Delete

Delete a feedback layer.

Rename

Rename a master layout or feedback layer.

Title

Include the title placeholder in a master layout or feedback
layer.

Text

Include the text placeholder in a master layout or feedback
layer.

Button

Include the button placeholder in a master layout or feedback layer.

Colors

Change the color of a master layout.

Fonts

Change the font of a master layout.

Background Styles

Change the background style of a master layout or feedback layer.

Close Master View

Exit the feedback master view and go back to editing slides.

Object Settings Tab
The Object Settings tab appears when you open the object settings view (View tab > Object
Settings). It contains commands for editing default objects. This tab contains many object types,
namely Shapes, Gesture Effect, Mouse Click, Key Stroke, Text Entry, Drop Area, Button,
Checkbox, Radio Button, Slider, Dropdown, Timers, Cursor Path, and Questions. You can select
object types and customize them the way you want. All changes will apply to the default settings
of all newly inserted objects of that type in the current project.
Icon

Command

Function

Reset Object
Settings

Reset the initial settings of a specific object.

Reset All Object
Settings

Reset the initial settings of all objects.

Close Settings View

Exit the settings view and go back to editing slides.

Menus, Toolbars and Hotkeys > Feedback Master Tab
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Customizing ActivePresenter
Customizing Language
By default, the display language in ActivePresenter is set to English (United States). If you prefer
another language, click the View tab > Language > select another language. Your change will
be applied the next time you open the application.
Another way to customize the display language is to use the Preferences dialog. Do the following:
1. Click the ActivePresenter button > Preferences.
2. In the dialog, click the General tab > Program section > select a language.
3. Click Apply to submit changes. Your change will be applied the next time you open the
application.

Customizing User Interface
ActivePresenter saves the project settings when you close a project. The next time you open the
application, the settings of the last saved project will be applied to the new one. After customizing,
if you want to go back to the original window layout, just click the View tab > Reset Pane Layout
. Your change will be applied the next time you open the application.

Showing and Hiding Toolbar and Panes
You can collapse the tabbed toolbar by clicking the Hide/Show Toolbar button (double arrow) at
the top-right corner of the application window. To show or hide panes, click the View tab and
select the pane you want. In this tab, you can also:
●

Change the slide view mode in the Slides pane (column, grid, titles).

●

Open the slide master view and feedback master view to work on slide masters and
feedback masters, respectively.

●

Change the zoom level of the Canvas.

Changing Pane Position
You can drag panes, except the Timeline pane, from their current positions by dragging their title
bars. Alternatively, click the Floating button at the top-right corner of a pane to undock it. After
undocking a pane, you have two options:
●

Make the pane free-floating by dragging it to an area that isn’t a drop zone. The floating pane
allows you to position it anywhere on the screen, even outside the application window.

●

Dock the pane in the highlighted drop zones that appear on the screen. Just drag and
bring the pane to the edge of the window and release the mouse button over a drop zone.
The pane will be docked into place.

Changing Pane Size
Changing pane size is useful when you want to make your work area larger by reducing the pane
size, or when you want to view more of the information that appears in a pane by increasing its size.

Customizing ActivePresenter > Customizing Language
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●

To resize a docked pane, move the pointer over the left or right edge of the pane (for
vertical panes) or the top edge of the pane (for horizontal panes). When the pointer turns
into a resize pointer, drag the boundary to resize the pane to the dimensions you want.

●

To resize a floating pane, hover over any edge or corner of the pane until the pointer turns
into a resize pointer, then drag the boundary until the pane reaches the width/height you
want.

Customizing Preferences
Use the Preferences dialog to set how you want ActivePresenter to operate. To open the dialog,
click the ActivePresenter button > Preferences. The dialog has six tabs, each serves a different
area. Select the relevant tab to change the relevant settings.
Tab

Category

General

General options apply to the entire application.

Auto Annotation Text

Handle how annotation text is auto-generated while capturing.

Hotkeys

Set hotkeys for various operations.

Toolbar

Customize the tabbed toolbar.

Script Editor

Features and colors in the JavaScript Function form.

Miscellaneous

Options that don’t fit anywhere in the above tabs.

Customizing ActivePresenter > Customizing Preferences
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General Tab

Control

Function
Program

Display Language

Set the display language of the application.

Display Theme

Set the display theme of the application

Max Recently Used
Projects

Set how many recently opened projects would be listed. Set to 0
to disable this control. Note that a large number isn’t useful.
Instead, cultivate the habit of storing the project files in a
hierarchical folder system so that you can retrieve a project fast.
Clear List: Select to forget the actual list of recently opened projects.

Customizing ActivePresenter > Customizing Preferences
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Project

Backup Project Every n
Minutes

Set how frequently to back up (save) the project. In rare cases
when ActivePresenter crashes, it allows you to recover the last
opened project from the latest back-ups. Set to 0 to disable this
control.
Note that these aren’t permanent back-ups. Back-ups are
automatically removed when a project is closed.

Project Language

Set the default project language.

Project Location

Set the default folder path where all new projects will be saved.
You are allowed to change this folder each time you save a new
project.

Template Location

Set the default folder path where all custom templates will be
saved.

Default Project Size

Set the default project size. To change the size, enter a new
value or choose from the Preset Size list.

Responsive Layout

Check the box to use Flex Box when creating a new responsive
project.

Restore Defaults

Go back to the original settings.

Auto Annotation Text Tab
This tab defines the auto-annotation text that is automatically added when you record interactive
simulations.

Customizing ActivePresenter > Customizing Preferences
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ActivePresenter can automatically generate the text for annotations based on what you are
interacting with while capturing. For example, when you type your user name into a log-in screen,
ActivePresenter can create a callout that says “Type [XXX] into User Name text box”.
You can easily customize how annotation text is generated while capturing. There are three
parameters available to specify dynamic content. Each parameter has the form {$XXX}, in which
XXX is the parameter name:
{$name}

Name of the item with which you are interacting while capturing. For example, when
you enter your name on a log-in screen, the text box may have a name like “User
Name”.

{$type}

Type of the item with which you are interacting while capturing. The item types are
provided by the Operating System. For example, you are typing in a text box, then
the item type is “text box”. If you are clicking a button, then the item type is “button”.

Customizing ActivePresenter > Customizing Preferences
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What you are entering while capturing. If you are pressing a key, the value is the
key that you’ve pressed. If you are entering text into a text box, then the value is the
text you’ve entered.

Note that the Prefix Modifiers checkbox is selected by default to allow using modifier keys
(SHIFT, CTRL, and ALT) in mouse clicks and key strokes.

Hotkeys Tab
The Hotkeys tab shows all hotkeys in ActivePresenter. You can assign hotkeys to commands or
remove any hotkeys you don’t want.

Customizing ActivePresenter > Customizing Preferences
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All the major commands are grouped functionally in a hierarchical tree. The tree consists of nodes;
each node contains a group of related commands. To expand any node to list the commands or
other items that it contains, click the button to its left. Any currently used hotkeys are shown in
the Current hotkey box on the right side of the dialog.

Assigning Hotkeys
1. Select a command or item that you want to assign a hotkey.
2. Click inside the New hotkey box, then press the combination of keys you want to assign.
3. Look at the Currently assigned to box to see if the combination of keys is already
assigned to a command or item. If the combination is already in use, press a different
combination.
4. Click the Add button to assign the new hotkey.
5. Click Apply to submit changes.
For example, select the Save command in the tree view, then press CTRL+A in the New hotkey
box. The combination is automatically captured and displayed. You are informed that the
combination is currently used by the Select All command.
Now you have two options: Either try another hotkey (and repeat the cycle), or press the Add
button to reassign the CTRL+A hotkey to the Save command. If you choose the second option,
this hotkey will no longer be assigned to the Select All command.

Removing Hotkeys
1. Select command or item that you want to remove a hotkey.
2. Click the Remove button.
3. Click Apply to submit changes.
To go back to the default settings, click the Restore Defaults button.

Toolbar Tab
You can customize the tabbed toolbar to improve the performance of editing. In this tab, the box
to the left contains all the commands which are organized in groups. The box to the right is the
structure of the current toolbar.

Customizing ActivePresenter > Customizing Preferences
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Note: You cannot reorder the default commands, hide their names, or rename them. Besides, if
your experiments go haywire, you can always go back to the default settings by clicking the
Restore Defaults button. All your customization will be removed.

Reordering Tabs, Groups and Commands
You can change the order of all the tabs/groups/commands but not the default commands.
1. In the right box, select the tab/group/command that you want to move.
2. Click Move Up

or Move Down

until you get the order you want.

3. Click Apply to save and see your changes.

Customizing ActivePresenter > Customizing Preferences
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Removing Tabs, Groups and Commands
1. In the right box, select the group (both default and custom) or tab/command (custom only)
that you want to remove.
2. Click the Remove button to exclude them from view.
3. Click Apply to save and see your changes.
To remove the default tabs or groups/commands like the Home or Slide tab, clear the relevant
checkbox in the right box. Note that you cannot hide contextual tabs such as Format and
Drawing.

Adding Tabs and Groups Back to the Toolbar
After removing a tab/group from view, you can still add it back to the tabbed toolbar by:
1. In the left box, select the tab that you want to bring back. In case you want to recover a
group, you must select a tab in the right box to place it.
2. Click the Add button to retrieve the selected tab/group.
3. Change the tab/group order if needed.
4. Click Apply to save and see your changes.

Creating Custom Tabs and Groups
You can add new tabs to the tabbed toolbar and add new groups to both default and custom tabs.
Regarding commands, you can only add commands to custom groups. The custom tabs and groups
have the word (Custom) after their names, but this word doesn’t appear in the tabbed toolbar.
To create custom tabs/groups, do the following (skip unnecessary steps, if any):
1. In the right box, select the tab to which you want to add a new group. In case you want to
create a tab, the new tab with being inserted below all other tabs or the selected one.
2. Click New Tab… or New Group… to create a new tab or group, respectively.
3. In the dialog, enter a name for the new tab/group and click OK.
4. For custom groups, select Hide Command Labels to hide the labels while showing the
icons in a smaller size.
5. In the main dialog, click Apply to save and see your changes.
After creating a custom group, you need to add commands to it. Use the Add button to add
commands from the left box.

Renaming Tabs, Groups and Commands
You can rename both default and custom tabs and groups, but for commands, you can only
rename the ones added to custom groups. For those included in default groups, you cannot
rename them.

Script Editor Tab
Use this tab to customize coding preferences. The tab has three parts. The Color box to the left
lets you change syntax highlighting preferences. The View box in the center lists some code view
options. The Preview box to the right allows you to preview the coding content.

Customizing ActivePresenter > Customizing Preferences
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To customize syntax highlighting preferences, click the color rectangle next to each element and
change the color. All changes you make are immediately reflected in the preview editor on the
right side.
Below are the code view options:
●

Line Number: Display line numbers along the side of the code.

●

View White Space: Display dots in place of white space.

●

Auto Insert (), {}, []: Selected by default. This option automatically inserts matching
closing brackets to the code.

You can always go back to the default settings by clicking the Restore Defaults button. All your
customization will be removed.

Miscellaneous Tab
This tab is a “catch-all” tab. It contains application options that could not be placed in other tabs.

Customizing ActivePresenter > Customizing Preferences
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Control

Function
Automatic Updates

Automatically Check for
Updates

Selected by default. ActivePresenter periodically checks for
updates when it starts.

Connection Settings

Set connection settings to use a proxy (no proxy, use system
settings (default), manual configuration. Check with your admin
and set the value.
Log Settings

Customizing ActivePresenter > Customizing Preferences
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Enable Logging

Selected by default. If you disable this option, no logs will be
kept.

Log UI Level

Select the log level to show. Only log messages with the
severity level higher or equal to the selected level are
displayed. The other logs are written to the log file silently.

Verbose Mode

In verbose mode, more details are captured. This is better for
troubleshooting.

Log Level

View Log

There are five levels: fatal error (most severe level), error,
warning, message, status, and information. If you select any
level, the log will be kept of that level and higher levels (if any).
For example, selecting Warning keeps a log of the top three
types of problems, but selecting Fatal Error keeps a log of fatal
errors only.
Show the log file. The log file is automatically cleared and
started over when its size reaches 2 MB.
Confirmation Settings

Warning none-ANSI path
when export

Selected by default. When you export your project, some
outputs cannot be opened or run properly if the file name
contains non-ANSI characters. This option specifies whether
you should be asked in such cases or not.

Show language confirmation
when importing XLIFF

Selected by default. When you import from XLIFF, chances are
that the target language is unspecified or invalid. A language
confirmation will appear letting you select a target language to
continue.

Extend object duration to
match the duration of
generated audio

Select any of the choices to determine how ActivePresenter
performs when converting text to speech: Should it display
the dialog so that you can make further changes to the TTS
settings before converting?
Save external resource

Link resources with file size
greater than n MB

When an external file is added to a project, ActivePresenter
creates a copy of the file and stores it in that project (to ensure
that even if you rename, move, or delete the original file, the
inserted item will not be affected).
If the original file is large, storing it directly in the project will
consume more disk space than necessary, which severely
reduces the performance and prone to errors that might corrupt
the project.
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In that case, ActivePresenter doesn’t store the original file
directly in the project. Instead, it maintains a copy of the original
file and creates a link in the project which points to the copy.
This parameter defines the threshold above which
ActivePresenter creates a link to the resource instead of storing
the original file directly in your project.

Video Encoder

Select the encoder for encoding with H.264 and HEVC video
codecs.

Always use software
decoders for decoding video

Select this option if the program has problems when rendering
video objects

Use software rendering
instead of GPU rendering
(take effect from the next run)

Improve performance for some computers which have a strong
CPU but a weak GPU.

Use Direct3D for recording
screen

Clear this checkbox if you cannot capture the screen due to
graphics driver-related issues.

Use JPEG color range (full
range) when exporting video

Select to fix the “white color turns grey” issue when viewing
output videos on some systems.
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